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What’s New in PCS Axis?

The following information identifies improvements available in version 1.8 of the PCS Axis 
software. For more information, view or download a copy of the PCS Axis 1.8 Release 
Notes. 

• Telluric Compensation: This is an optional feature set that provides support for 
compensating facility and close interval inspections with telluric current effects. 
Stationary data logger (SDL) files used in compensation runs are managed in 
Stationary Survey Maintenance. PCS Axis features enhanced for Telluric 
Compensation include the CPDM and ISM modules, Bridge Import, Field 
Computer, and Reports/Graphs. 

NOTE: Customers with an existing PCS Axis license who want to use the optional 
Telluric Compensation feature will need a new PCS Axis license. Contact PCS 
Technical Services for more information. 

• System Options:

• Default Telluric Threshold:  This option only displays when running PCS Axis 
with a telluric-enabled license. The Default Telluric Threshold is in a range of 
0.010 volts but can be changed to meet your business needs. PCS Axis 
calculates a baseline average for survey measurements in an SDL data set. If 
any survey measurement in the data set is above or below the baseline 
average by 0.010 volts, this indicates the data set exhibits telluric current 
effects. 

• Show Detail Inspection Entry Grid: This option controls the display of CPDM 
Test Point Detail mini-grids. When using the optional Telluric Compensation 
feature, this option is enabled by default and cannot be disabled. 

• CPDM Test Point Detail mini-grids: Information and Inspection mini-grids 
display by default when using the optional Telluric Compensation feature and 
cannot be disabled. 
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IMPORTANT: To prevent adding duplicate subfacility records in the system, it is 
important to enter a unique subfacility name when adding multiple subfacility 
records for a test point record in the Test Point Information grid. Enter a unique 
subfacility name in the Name field of the Test Point Detail Information mini-grid. 
Do not use the default name for this field or leave it empty (blank). For more 
information, refer to Linking Multiple Subfacilities to a Parent Test Point 
Facility (page 313). 

• Job Service Viewer:

• Current Jobs: When a job is in a Waiting or Validated state, clicking the 
Suspended button suspends processing of the selected job. Other jobs in the 
queue continue to process. Clicking the Suspended button for a suspended 
job resumes processing. 

• Job History / Detail Log: Option labeled ReSend in the Detail Log for an 
Email Notification report allows you to resend the report. 

• Field Computer: 

• Dynamic Picklist User-Defined Fields (UDFs): Can now be included in 
prompts sent to the Allegro Field computer. 

• Mini-grid Fields: ON/OFF subfacility fields in the Test Point Detail Inspection 
mini-grid can now be included in prompts sent to the Allegro Field Computer. 
The following criteria must first be met to include ON/OFF subfacilities in 
Allegro prompts:

• Subfacilities must be set up as Currently Active in the Test Point Detail 
Information mini-grid.

• The parent facility of ON/OFF subfactilities must also be included in 
prompts sent to the Allegro. Parent facilities include any of the following 
PCS fields: AC P/S and AC IRF; Casing P/S and Casing IRF; Foreign P/S and 
Foreign IRF; Insulator P/S and Insulator IRF; or Structure P/S and Structure 
IRF. 

• Field Computer Receive: Pipeline Series and ROW can be applied to close 
interval (CI) survey readings received from the Allegro Field Computer. 

• Edit ISM Data / Survey Maintenance: Enhancements in Survey Maintenance 
allow you to select an existing facility when modifying a range of station numbers 
using Shift and Rubber Band. 

• Field and UDF Customizations: Optional property setting labeled Show Time 
In Milliseconds allows you to set date/time fields with millisecond resolution. The 
property setting applies to date/time fields in Bridge, Field Computer, Reports, and 
data entry grids. 
2 What’s New in PCS Axis?
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About PCS Axis Help

Information in this section identifies features available in PCS Axis Help. Topics include 
those in the following list:

• Using PCS Axis Help

• Language Translation (page 5)

• User Discussion System (page 7)

• Document Conventions (page 10)

Using PCS Axis Help
PCS Axis Help provides information for setting up and using the PCS Axis software. To view 
online help, click the  help button in any PCS Axis window to view a contextual help 
topic. Or click Help > Help in the main menu to open PCS Axis Help. You can also view 
PCS Axis Help using the following web address: http://www.pcsaxishelp.aiworldwide.com/
reverb/index.html. 

Viewing PCS Axis Help requires an internet browser software such as Internet Explorer®, 
Firefox®, Chrome®, or Safari®. Other notable features of online help include those in the 
following list: 

• Table of contents navigation. 

• Breadcrumb “you are here” navigation.
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• Search with support for Boolean search operators AND and OR. 

Setting search keywords in quotations marks returns exact search results. For 
example, typing “grid layout” (with quotation marks) returns search results for all 
occurrences of grid layout. 

IMPORTANT: If you use Internet Explorer 9 (IE9) to view PCS Axis Help, the 
Compatibility View setting in IE9 may need to be set in order to view help topics 
without problems. To set Compatibility View, click the  broken page icon in the 
address bar of the internet browser. Or, click Tools > Compatibility View to 
enable the setting. 

• Integrated language translation using Google Translate. 

• Integrated user discussion system using Disqus®. 

Clicking the  PDF button in the main toolbar displays a PDF of the current help topic in 
a new window (Figure 1-1). Click the  save button to download a copy of the PDF to 
your computer. Use Adobe® Reader® to view or print the PDF. If you need to install Adobe 
Reader on your computer, a free copy of the software is available for download on the 
Adobe website at http://get.adobe.com/reader/. 

Figure 1-1.  PCS Axis Help

Click to open a PDF
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Language Translation
Clicking the  globe button in the toolbar of PCS Axis Help displays the Google 
Translate bar (Figure 1-2). To translate the current help topic in your language: 

• Click the down arrow in View this page in to open the language selection panel. 
Select a language and then click Translate. 

NOTE: For more information about Google Translate, visit the web address 
https://support.google.com/translate/. 

Figure 1-2.  Google Translate

Click to open Google Translate bar

Google Translate bar
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Contributing an Alternative Translation
If you would like to contribute an alternative translation to Google for one or more words 
(Figure 1-3):

1 Hover the mouse cursor over a translated word to change the cursor to a text 
select cursor  . When a popup window opens click Contribute a better 
translation. 

2 Click a translation to view a list of alternatives. Select or enter an alternative 
translation, then click Use. 

3 Click Contribute to submit the alternative translation to Google. 

Figure 1-3.  Google Translate

Contribute an alternative translation
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User Discussion System
PCS Axis Help provides an integrated discussion system. The discussion system is 
developed and hosted by Disqus®, a company that specializes in online community 
development. Using the discussion system allows PCS Axis customers to submit 
comments, questions, and other types of feedback to PCS Technical Services via online 
help. PCS Technical Services moderates the discussion system providing answers to 
questions and replies to comments. See the section entitled Commenting Guidelines 
(page 9) for more information about posting comments in PCS Axis Help. 

To add a comment in PCS Axis Help, follow these steps:

1 Display a help topic in PCS Axis Help that you want to provide a comment. 

2 In the comment panel of the selected help topic, type a comment in the text box 
Start the discussion (Figure 1-4, page 8). 

Continue with step 3 to post the comment as a Guest or step 4 (page 8) to post 
with your Disqus login credentials. 

3 To post a comment as a Guest, follow these steps:

a Click the Name text box to display fields requiring data entry (Figure 1-4, 
page 8). 

b Type your name in the Name text box and your email address in the Email 
field. 

c Click the check box I’d rather post as guest. Then click  to submit your 
comment to PCS Technical Services. 
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Figure 1-4.  Posting a Comment as a Guest

4 To post a comment using your Disqus login credentials: 

a In the comment panel, click Login and select Disqus in the menu that opens.

b Provide login credentials for your Disqus account when the Sign in to Disqus 
dialog box opens (Figure 1-5). 

c In the comment panel of the help topic, click  to submit your comment to 
PCS Technical Services. 

Figure 1-5.  Disqus Login

Comment Panel
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Commenting Guidelines
The discussion system in PCS Axis Help allows you to submit comments, questions, and 
other types of feedback about PCS Axis to PCS Technical Services. If you need help with 
using PCS Axis or have a suggestion for a new feature, you can submit a comment using 
the discussion system. 

The discussion system requires that you use a valid email address when submitting a 
comment. This also allows PCS Technical Services the ability to follow-up with any 
questions, comments, or feedback you may have. 

Before a comment is posted in PCS Axis Help, it is first submitted to PCS Technical Services 
for moderation purposes. If the comment is considered to be inappropriate or off-topic, it 
is not posted in PCS Axis Help. 

When submitting a comment, follow these guidelines: 

• Provide a valid email address. 

The discussion system does not allow you to submit a comment anonymously. You 
can however submit a comment as a “guest” using a valid email address. 

• Be respectful of others.

The discussion system is great way to share product knowledge with other PCS 
Axis users. Be respectful when replying to another user’s comments or questions. 

• Avoid using profanity. 

A comment with profanity will not be accepted or will be edited during moderation 
by PCS Technical Services before the comment is posted in PCS Axis Help. 
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Document Conventions
Typographical conventions used in this manual include those described in the following 
table (Table 1-1). 

Table 1-1.  Document Conventions

Convention Description Example

Italic text Denotes named items for 
easy identification, such as 
the name of a software 
feature, title, or product. 

Open the Define Routes 
window. 

Bold text Denotes named items in 
the software for easy 
identification that require 
user input, such as a 
clickable button or a field 
requiring user input as 
noted in a procedure. 

Click Data Entry > 
Define Routes to open 
the Define Routes 
window.

Arrow brackets <> Denotes placeholder text 
inside arrow brackets, such 
as <module> to indicate 
the name of a module in a 
procedure that applies to 
any module. 

Click Data Entry > Edit 
<module> Data to open 
the data entry grid. 

Right arrow bracket >  
(right chevron >)

Denotes a streamlined task 
with a series of sequential 
actions performed by the 
user, such as a procedure 
for opening menus and 
submenus. 

Click Data Entry > Edit 
CPDM Data means to 
click Data Entry in the 
main menu, then click the 
menu option Edit CPDM 
Data. 

Plus sign + Indicates a combination of 
key presses, such as 
CTRL+S. 

CTRL+S means to press 
and hold the CTRL key 
while pressing the S key. 

Internal cross references Refers to a related section 
in the current document 
with a page number. 
Clicking the page number 
displays the referenced 
item. 

See Setting Security 
Options (page 50) for 
more information. 
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Getting Started

Information in this manual explains how to set up and use American Innovations’ Pipeline 
Compliance System Axis® software (PCS Axis®). The information is intended for users of 
the software and the PCS Axis system administrator.

Topics in this chapter include those in the following list: 

• Starting PCS Axis (page 14)

• Activating Bridge Import for Operation (page 15)

• Activating Telluric Compensation (page 17)

• System Overview (page 18)

• Modules and Related Options (page 19)

• System Requirements (page 21)

• Viewing Information About PCS Axis (page 24)

• Technical Support (page 25)
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Starting PCS Axis
Information in this section explains how to start the PCS Axis software. The Windows user 
name and password of the person currently logged in to the computer is used to start the 
software and log in to the database. If PCS Axis is set up with the security option Requires 
Windows Password, a password is required to log in to the database. See Setting Options 
(page 35) for more information. 

Complete the following steps:

1 If present, double-click the PCS Axis desktop shortcut  to start the software. Or, 
click the Windows Start button , then click PCS Axis. 

2 If the Login window opens, type your Windows password in the Password field 
and then click the login button  to start the software (Figure 2-1). 

Figure 2-1.  Login
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Activating Bridge Import for Operation
If your company purchased the optional Bridge add-on for importing raw data from a 
third-party application, running a Basic Bridge import for the first time requires you to 
activate Bridge using the license file provided by American Innovations (AI). A Bridge 
license is required only for those operations that use the Basic Bridge function to import 
data. 

Operations using the Bullhorn Bridge function to import data do not require a Bridge 
license. Likewise, using Bridge to export data from PCS Axis also does not require a Bridge 
license. 

The Bridge license becomes part of the PCS Axis database during the activation process. 
This allows a single license to apply to all PCS Axis users in your company, including 
remote clients (subscribers) in a client/server network who use a subscription. If the Bridge 
license is activated after a subscription has been created or used, the subscription will 
need to run the Synchronize Now or Resynchronize command to have the Bridge license 
applied to the subscription. For more information about how to synchronize a 
subscription, see Synchronizing a Subscription (page 739). 

NOTE: You can maintain all PCS Axis licenses for your organization in the same shared 
folder location. PCS Axis will request the file and location the first time each user opens 
the PCS Axis application. The Bridge activation key is assigned only once for the PCS Axis 
database; once it is assigned it functions for all users. If you are unable to locate your 
Bridge license file, contact PCS Technical services for assistance at 
pcstechservices@aiworldwide.com. 

To activate Bridge import for operation, follow these steps:

1 Start PCS Axis if the software is not running.

2 Click Tools > Job Service Viewer to open the Job Service Console window 
(Figure 2-2, page 16)
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Figure 2-2.  Job Service Console

3 Click Activate Bridge Import License. When the Activation Key dialog box 
opens, navigate to the license file and select it (Figure 2-3). 

4 Click Open to open the license file and return to the Job Service Console window. 

Figure 2-3.  Activation Key
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5 Verify Running displays in the Status field and Valid displays in the License field 
(Figure 2-4). If these messages are not currently displayed, please contact PCS 
Technical Services for assistance at pcstechservices@aiworldwide.com. 

Figure 2-4.  Valid Bridge License

Activating Telluric Compensation
If your company purchased the optional Telluric Compensation feature, it becomes 
operational after activating your PCS Axis license during the software installation process. 

Customers with an existing PCS Axis license who want to use Telluric Compensation will 
need a new PCS Axis license and software upgrade. For more information about upgrading 
your PCS Axis license, contact PCS Technical Services (page 25). 

NOTE: You can maintain all PCS Axis licenses for your organization in the same shared 
folder location. PCS Axis will request the file and location the first time a user opens the 
PCS Axis application. If you are unable to locate the license file, contact PCS Technical 
Services for assistance at pcstechservices@aiworldwide.com.
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System Overview
PCS Axis is a database application used worldwide by distribution and transmission 
companies to manage pipeline compliance and integrity data. The application uses a SQL 
server database to store and manage data for one or more modules (Figure 2-5). All 
modules share a common interface that allows users to easily work with data regardless of 
which module they use. Modules are based on common industry practices and various 
Department of Transportation (DOT) regulations. These include DOT 192 titled 
Transportation of Natural Gas and Other Gas by Pipeline: Minimum Federal 
Standards Safety and DOT 195 titled Transportation of Hazardous Liquids by Pipeline. 

The PCS Axis database is fully ODBC compliant allowing for integration with other 
databases, such as GIS (geographic information system) and ERP (enterprise resource 
planning) databases. 

Figure 2-5.  PCS Axis System Overview
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Modules and Related Options
PCS Axis modules are purchased either separately or as a package. Modules and related 
options, such as Bridge Import and Telluric Compensation, become operational after 
entering the software activation key provided by American Innovations (AI). A description 
of PCS Axis modules and their related options is provided in the next table (Table 2-1). 

Table 2-1.  PCS Axis Modules and Related Options 

Modules/Related Options Description

Cathodic Protection Data 
Manager (CPDM)

CPDM manages cathodic protection (CP) data for 
facility types such as test points, rectifiers, foreign 
bonds, galvanic anodes, and tanks. Distribution 
and transmission companies use this module to 
manage and track corrosion data as well as other 
types of corrosion-related data. 

Indirect Survey Manager (ISM) ISM manages and analyzes survey data for above 
ground continuous surveys (also referred to as 
indirect surveys). You can enter survey readings 
manually or use the Allegro Field PC or PCS Axis 
Bridge to transfer survey readings in ISM. The 
types of continuous surveys supported in ISM 
include: Close Interval Survey (CIS), AC Close 
Interval Survey (AC CIS), DC Voltage Gradient 
(DCVG), AC Voltage Gradient (ACVG), AC Current 
Attenuation (ACCA), Soil Resistivity, and Pearson. 

Atmospheric Corrosion 
Manager (ACM)

ACM manages atmospheric corrosion data as 
required by US DOT 192 and 195 regulations.

Valve Manager (VM) VM manages valve inspection and repair data. The 
module provides compliance scheduling, data 
management, and reporting of valve information.

Internal Corrosion Manager 
(ICM)

ICM tracks internal corrosion data in compliance 
with US DOT 192 and 195 regulations. ICM 
supports facility types such as inhibitor injectors, 
coupons, samples, and probes.

Leak Survey Manager (LSM) LSM manages and provides compliance 
scheduling for leak surveys, classifies leaks and 
repair data, and supports follow-up activities.
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Custom Module Management 
(CMM)

CMM is an optional module available for purchase 
that becomes operational after activating your 
PCS Axis license. PCS Axis supports up to ten (10) 
user defined modules with each module 
supporting up to ten (10) user defined facility 
types. Features and functionality available in the 
various modules distributed with PCS Axis are also 
available in CMM. These include routes, schedules, 
reports/graphs, user defined fields (UDFs), 
themes, and so on. 

Bridge Import An optional feature available for purchase that 
requires a Bridge activation key for use. This 
feature allows you to transfer data between PCS 

Axis and an external system, such Bullhorn® Asset 
Tracker (BAT™) or a GIS or work management 
system.

Telluric Compensation An optional feature available for purchase that 
becomes operational after applying your PCS Axis 
license. This feature provides support for telluric 
current compensation of survey readings and 
management of stationary survey data used in 
telluric compensation. PCS Axis enhancements for 
telluric compensation include CPDM, ISM, 
Stationary Survey Maintenance, Field Computer, 
and Reports/Graphs. 

Table 2-1.  PCS Axis Modules and Related Options (continued)

Modules/Related Options Description
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System Requirements
The following information identifies system requirements for running PCS Axis in a client/
server network. 

See Table 2-2 for local client computer requirements; Table 2-3 (page 22) for subscriber 
computer requirements (remote client); and Table 2-4 (page 23) for server and database 
requirements. 

Table 2-2.  Local Client Computer Requirements (Client/Server Network)

Properties Minimum Recommended

Processor Intel Core i5 or faster Intel Core i7 or faster

Processor Speed 1.4 GHz or faster 2.0 GHz or faster

RAM 4 GB 8 GB

Operating System Windows 7 32-bit or 64-bit, 
Service Pack 1 (SP1)

Windows 7 64-bit, Service 
Pack 1 (SP1)

Available Disk Space 10 GB 100 GB

Resolution 1280x1024 1920x1080

Microsoft .NET 
Framework

Version 4.5 (see note) Version 4.5 (see note)

NOTES:

• Microsoft .NET Framework : If the target computer does not have Microsoft .NET 
Framework v4.5 installed, the PCS Axis installation automatically installs it. This 
feature requires an active Internet connection to complete the installation of .NET 
Framework v4.5. 

• PCS Axis Installation: Only the PCS Axis application installs on the computer of 
local clients in a client/server network. See Table 2-4 (page 23) for information 
about the PCS Axis database and job service installation on the central database 
server. 
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Table 2-3.  Subscriber Computer Requirements (Client/Server Network)

Properties Minimum

Processor Intel Core i7 or faster

Processor Speed 2.0 GHz or faster

RAM 8 GB

Operating System Windows 7 64-bit, SP1

Available Disk Space 100 GB

Resolution 1920x1080

Microsoft .NET Framework Version 4.5 (see note)

Microsoft SQL Server Express, 
64-bit version

Microsoft SQL Server Express 2008 R2 
SP2, 64-bit version (see note) 

NOTES:

• Microsoft .NET Framework : If the target computer does not have Microsoft 
.NET Framework v4.5 installed, the PCS Axis installation automatically installs 
it. This feature requires an active Internet connection to complete the 
installation of .NET Framework v4.5.

• Microsoft SQL Server Express 2008 R2 SP2: Must be installed on the 
computer of a subscriber (remote client) with a subscription database. The 
installation provides the database engine required to run PCS Axis as a 
subscriber. SQL Server Express 2008 R2 SP2 supports a maximum database 
size of 10 GB. 

IMPORTANT: To prevent conflicts from occurring when running PCS Axis, 
the correct version of SQL Server Express 2008 R2 must be installed on the 
subscriber's computer (remote client). The 64-bit version of SQL Server 
Express 2008 R2 must be installed when running the 64-bit version of 
Windows 7. For more information, see the installation document entitled 
PCS Axis Client/Server New Installation with Replication. 
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Table 2-4.  Central Database Server Requirements (Client/Server Network)

Properties Minimum Recommended

Processor Intel Itanium or faster Intel Xeon or faster

Processor Speed 1.4 GHz or faster 2.0 GHz or faster

RAM 16 GB 32 GB (see note)

Operating System Windows Server 2008 R2 Windows Server 2008 R2

Relational Database 
Software

SQL Server 2008 R2 SQL Server 2008 R2

Available Disk Space 200 GB (see note) 400 GB (see note)

Resolution 1280x1024 1920x1080

NOTES:

• Larger databases may require more RAM for optimum performance. 

• Consult with your company’s IT personnel or DBA to determine where database 
backups will be created. 

• The PCS Axis database installs on the central database server. If selected in Setup 
Wizard during the installation, the PCS Axis application and job service can also 
install on the central database server. For local client and subscriber computer 
requirements, see Table 2-2 (page 21). 
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Viewing Information About PCS Axis
To view information for the current database connection, as well as the software version of 
PCS Axis, click Help > About PCS Axis. The About dialog box displays the current 
database connection in the Connection field. The Version field identifies the current 
database and software version (Figure 2-6). 

To copy information to the Windows clipboard, click Copy To Clipboard. The information 
stores in the Windows clipboard until you paste the information elsewhere, such as in a 
Microsoft® Word or Windows® Notepad file, or an email message. Use this feature when 
contacting PCS Technical Services for support with PCS Axis. 

Figure 2-6.  About PCS Axis
24 Getting Started



PCS Axis User and Administrator Guide
Technical Support
If you need assistance with PCS Axis, have a feature request or bug to report, or have a 
comment or suggestion about this document, your feedback would be appreciated. If you 
have a training need for your organization or would like to know more about upcoming 
training classes, use the following information to contact PCS Technical Services: 

Support Email: pcstechservices@aiworldwide.com

Support Telephone: 1-800-229-3404, select 1, then press 2

American Innovations: http://www.aiworldwide.com
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Notes
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Setting Up PCS Axis

PCS Axis modules share a common interface and many similar functions. Information in 
this chapter explains how to set up features common to all PCS Axis modules. 

If you are unable to access a PCS Axis menu or perform a particular function, check with 
your system administrator to verify your PCS Axis user account is set up with an 
appropriate user role in User Management (page 175). 

Topics in this section include those in the following list:

• Preparing to Set Up PCS Axis (page 28)

• Understanding a Typical PCS Axis Workflow (page 30)

• Understanding the System Hierarchy (page 31)

• Setting the System Hierarchy (page 32)

• Setting Up PCS Axis (page 34)

• Working with Custom Security Roles (page 55)

• Working with Pipeline Series (page 112)

• Working with a User Defined Module (page 119)
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Preparing to Set Up PCS Axis
After installing PCS Axis, consider the following questions before you begin setting up PCS 
Axis for operation. Answers to these questions determine how you set up PCS Axis to fit 
your company's business needs. 

Table 3-1.  Preparing to Set Up PCS Axis 

Question Description

How is your company’s 
pipeline system organized?

Pipeline companies organize their distribution or 
transmission pipeline system using certain terms to 
describe how the system is organized. For example, 
terms such as Right-of-way (ROW), Pipeline Segment, 
Section, Section Map, District, County, Region, or State 
may be used. 

Setting up PCS Axis for operation requires that you 
define a pipeline system hierarchy. PCS Axis supports 
up to five (5) hierarchy levels and can be organized 
and named in the same manner as your company’s 
pipeline system. 

How does your company 
identify inspection points on 
a pipeline? 

A location name and location format must be set up 
for inspection points on a pipeline before users begin 
entering survey data in PCS Axis. Once this information 
has been established, it is recommended that you do 
not change it in order to maintain data integrity. 

When you first install PCS Axis, default settings for 
location name and location format are Milepost and 
Station Number respectively. However you can 
change both of these to match your company’s 
method for identifying inspection points on a pipeline. 

What is your company’s 
policy for scheduling 
surveys? 

Default settings in PCS Axis for survey schedules and 
grace periods are based on current regulations. You 
can however edit these default settings to match your 
company's survey policies instead. 

For example, the grace period for surveying long lines 
is three months. However your company’s policy may 
be less than three months. When setting up PCS Axis 
survey schedules, enter your company’s grace period 
to ensure surveys are scheduled correctly. 
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Does your company want to 
use PCS Axis security 
features? 

The User Management feature in PCS Axis controls 
system security using a role based method. Each PCS 
Axis user is assigned a user role. Users with SysAdmin 
security permissions have full control of the hierarchy 
and all system features. Users with User or Read Only 
security permissions have limited control. 

For a list of user role permissions assigned to the User 
and Read Only user roles, see Appendix C (page 791). 

Will your company need 
unique data recorded in PCS 
Axis? 

Although PCS Axis provides many fields for entering 
data, you can create what is called a User-Defined 
Field (UDF) when a PCS Axis field does not exist. Your 
company’s data collection forms are a good place to 
gather data for a UDF you may want to create. 

For example, if test points are identified by map 
numbers, create a UDF to be used for data entry of test 
point map numbers. 

Will PCS Axis themes need to 
be customized to fit your 
company’s business needs? 

PCS Axis uses themes for many operations, such as 
themes for data entry grids, sorting methods, filtering 
data, and field computer prompts. The PCS Axis 
software installation includes several installed themes 
ready for use. 

You can modify PCS Axis installed themes and also add 
new themes to include only those features that fit your 
business needs. For example, you might want to 
include specific data fields for entering and viewing a 
particular type of survey data. 

Do you want to set up 
picklists that allow users to 
choose from a list of 
acceptable choices when 
entering survey data? 

When a data entry field is limited to certain data, 
consider creating a picklist that includes only those 
items for selection, such as repair codes, priority levels, 
or status conditions. 

For example, you may want to create a picklist with 
items for selection that identify insulator status as 
good, missing, and shorted. Picklists are helpful in 
reducing data entry errors by allowing users to select 
an item from a list of approved choices instead of 
entering data manually. 

Table 3-1.  Preparing to Set Up PCS Axis (continued)

Question Description
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Understanding a Typical PCS Axis Workflow
A typical workflow for working in PCS Axis is shown in the next figure (Figure 3-1). Some 
operations are required and only occur once when setting up PCS Axis, such as setting up 
system Options and Edit ROW Detail identified in the following figure. Others may occur 
more often as needed by PCS Axis users with appropriate security permissions, such as 
adding or moving pipeline segments in the hierarchy; adding survey folders; customizing 
themes and reports; or creating routes and schedules for facility survey inspections. 

Figure 3-1.  Typical PCS Axis Workflow

1 Set Up PCS Axis

Edit System Options1.
(Company Name, Hierarchy Levels, & 
User Location Name are required.)

Edit ROW Detail3.

Edit Survey Folders4.

Edit User Management5.

(User Location Format is required.)

Edit ROWs2.
(Add, move, & rename pipeline segments 
in Select ROWs as needed.)

Create Custom Security Roles
(optional)

Edit Themes

Edit Field & UDF Customizations

Edit Routes & Schedules

Edit Themes Management & 
Facility Types Management

(Includes Field Captions, UDFs, 
Picklists, etc., as needed.)

2 Customize Features

3

Manual Data Entry

Bridge, Bridge with Bullhorn 
Integration (optional)

Transfer from Allegro Field PC 
(optional)

Survey data via:

Enter Survey Data

4

Reports

Graphs

Set up and run:

Set Up/Run Reports
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Understanding the System Hierarchy
Before you begin entering data in PCS Axis, you first need to establish the system 
hierarchy and enter your company’s name. The hierarchy determines how PCS Axis 
organizes data. The company name displays at the top of all reports and graphs. 

You can create a hierarchy that reflects how your company categorizes its pipeline system. 
For example, you may want to create a hierarchy based on one or more of the following 
criteria: division, district, county, region, system, right-of-way (ROW), or section map. 

PCS Axis supports a hierarchy structure with up to five (5) levels. The top hierarchy level 
includes either your company’s name or other type of descriptor. The following figure 
shows a hierarchy structure with three (3) hierarchy levels (Figure 3-2). The names of 
hierarchy folders as well as ROW Code and ROW name support up to 100 characters. 

IMPORTANT: After entering data in the database, it is recommended that you do not 
change the hierarchy structure. 

Figure 3-2.  Example of Hierarchy Structure

1 Company Name 

Level 3 Hierarchy (Region)2

Level 2 Hierarchy (System)3

Level 1 Hierarchy (Pipeline)4

1
2

4
3
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Setting the System Hierarchy
The following procedure explains how to set up PCS Axis with the following required 
system settings: your company’s name; the number of levels in the system hierarchy; and a 
name for inspection points on a pipeline. 

NOTE: Another required setting is needed later after adding pipeline records in the 
system hierarchy. The required setting labeled User Location Format in Edit ROW Details 
must be completed for each pipeline record to identify how inspection points are located 
on a pipeline. For more information see Understanding Default Location Formats 
(page 134). 

To create the system hierarchy, follow these steps:

1 Click Tools > Options > General to open the General options page (Figure 3-3). 

2 Type the name of your company in the field Company Name. 

3 Identify how your company refers to inspection points on a pipeline. For example, 
type Milepost, Station Number, Reference Reading, or other type of descriptor in 
the field User Location Name. 

NOTE: See Understanding Public and Private Property Settings (page 34) for a 
description of the Private check box and Public caption. 

Figure 3-3.  Company Name and User Location Name
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4 Click the Hierarchy tab to open hierarchy options page (Figure 3-4).

5 Click the check box Hide Parallel Lines if you want to hide features in PCS Axis 
that allow you to create and display parallel lines in the hierarchy. 

NOTE: When Hide Parallel Lines is enabled, parallel lines are hidden in Select 
ROWs and in the Add New Node dialog box. Distribution companies with no 
parallel lines typically use this setting. PCS Axis identifies parallel lines using the 
fields Pipe, Pipeline Code, and Pipeline Name. For a description of these fields 
refer to System Field Descriptions on page 753. 

6 Identify how many levels to include in the hierarchy. Click the down arrow in the 
Levels field and select the number of hierarchy levels in the selection list.  

7 Identify how pipelines are referred to in the system. For example, type ROW or 
Segment in the Level 1 field. 

8 Type a description for each additional level in the hierarchy using the fields labeled 
Level 2 through Level 5 as required. 

9 Click  Save and then continue with the next section Setting Up PCS Axis 
(page 34) to continue setting up PCS Axis for operation. 

Figure 3-4.  Hierarchy Levels
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Setting Up PCS Axis
PCS Axis provides several property settings that allow you to customize the software 
according to your company’s business needs. Other settings effect the functionality of 
certain PCS Axis features. Information in this section explains how to set each of these 
property settings. Topics include those in the following list: 

• Understanding Public and Private Property Settings

• Setting Options (page 35)

• Working with Custom Security Roles (page 55)

• Setting Properties in Field and UDF Customizations (page 61)

• Using an Application Scheme (page 111)

• Choosing a Printer for PCS Axis (page 111)

Understanding Public and Private Property Settings
Some property settings in Options include a Public caption or a Private check box 
(Figure 3-5). Property settings with a Public caption are system-specified and cannot be 
altered. Property settings with a Public caption apply globally to all users. 

Property settings with a Private check box can be changed. When the Private check box is 
enabled, the currently logged in user can change the property setting. Changes are 
“private” and only apply to the logged in user who makes a change to the setting. If the 
Private check box is disabled for a property setting, the property setting made by the 
SysAdmin applies globally to all users and users cannot change the setting. 

Figure 3-5.  Options Public and Private Property Settings 
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Setting Options
PCS Axis uses property settings in Options to perform many functions across all modules, 
such as arranging data, performing calculations, generating reports, and allowing user-
access to certain features. Required settings include Hierarchy levels, Company Name, 
User Location Name, and Criteria. If optional add-ons have been purchased, such as 
Bridge or Bridge with Bullhorn integration, setting properties for these features are also 
required. 

Information in this section explains how to set properties in Options. The information is 
intended for users with SysAdmin user permissions. Topics in this section include those in 
the following list:

• Setting Bullhorn Options (page 36)

• Setting Criteria Options (page 37)

• Setting Editing Options (page 39)

• Setting Email Notification Options (page 41)

• Setting Field Computer Options (page 44)

• Setting General Options (page 45)

• Setting Hierarchy Options (page 48)

• Setting Report Options (page 48)

• Setting Security Options (page 50)

• Setting Synchronization Options (page 52)

• Disabling Synchronization (page 54)
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Setting Bullhorn Options
If you plan to use Bridge to transfer data from your account on Bullhorn® Asset Tracker 
(BAT™), complete the following steps to set Bullhorn property settings in Options:

1 Click Tools > Options > Bullhorn tab to open the Bullhorn options page 
(Figure 3-6). 

NOTE: You can also display the Bullhorn options page by clicking the  arrow 
above the navigation panel and then selecting Bullhorn in the selection list that 
opens. 

2 Type http://www.bullhornsys.com/BATAPI/BATAPI.svc/extract in the field 
Extract Endpoint Url. 

3 Type http://www.bullhornsys.com/BATAPI/BATAPI.svc/mapping in the field 
Mapping Endpoint Url. 

4 Click  Save to save changes. 

NOTE:  Property settings with a Public caption refer to system-specified settings 
that apply globally to all users and can only be changed by the SysAdmin. For more 
information see Understanding Public and Private Property Settings (page 34). 

Figure 3-6.  Bullhorn Options
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Setting Criteria Options
The following procedure explains how to set Criteria properties. For information about 
public and private property settings, refer to Understanding Public and Private 
Property Settings (page 34). 

Complete the following steps:

1 If the Options window is not open, click Tools > Options to open the window. 
Then click the Criteria tab to open the Criteria options page (Figure 3-7 
(page 38)). 

2 If your PCS Axis license includes the optional Telluric Compensation feature, the 
field labeled Default Telluric Threshold is present in the Criteria page. 

The default threshold used to identify telluric effects in an SDL (stationary data 
logger) data set is 0.010 volts. If you want to change the default threshold, type a 
value in volts in the field Default Telluric Threshold.

PCS Axis calculates a baseline average for survey measurements in an SDL data set. 
If any survey measurement in the data set is above or below the baseline average 
by 0.010 volts, this indicates the data set exhibits telluric current effects. 

NOTE: For information about how to upgrade a PCS Axis license to include 
Telluric Compensation, contact Technical Support (page 25). 

3 Identify the isolation criteria for casing inspections. Type a value in the field Casing 
Criteria Minimum Difference Between P/S and C/S to set the minimum 
difference allowed between pipe-to-soil (P/S) and casing pipe-to-soil (C/S) 
readings before the casing is considered shorted. The default setting is 100 mV. 

NOTE: PCS Axis displays a warning message when the minimum difference does 
not meet the casing criteria for an inspection reading entered in the data entry 
grid. Similarly, an entry is added in the Field Computer Log when inspection 
readings transferred from the Allegro do not meet casing criteria. 
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4 Identify the number of days after an inspection reading is taken, that a native pipe-
to-soil (P/S) reading is taken. Type the number of days in the field Days To Look 
Forward From Inspection For Native P/S. 

NOTE: The number of days effects the system calculation for the fields Effective 
Native P/S and Effective Native Date in data entry grids. Native P/S is a potential 
reading taken prior to any current placed on the pipeline. It is also referred to as a 
depolarized or static potential reading. 

5 Click  Save to save changes. 

Figure 3-7.  Criteria Options
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Setting Editing Options
Complete the following steps in the Editing page of Options to set property settings that 
apply when entering data in data entry grids: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Editing tab to open the Editing options page (Figure 3-8). 

Figure 3-8.  Editing Options

3 Review the information in Table 3-2 and then set options as needed in the 
following manner. When you finish, click  Save to save changes. 

• To enable an option, click the option’s check box to place a check mark inside 
the check box. Clicking the check box again removes the check mark and 
disables the option. 

• For options with a Private check box, enable or disable the check box based 
on your company’s requirements. 

When the Private check box is enabled, the currently logged in user can 
change the property setting. Changes are “private” and only apply to the 
logged in user who makes a change to the setting. If the Private check box is 
disabled for a property setting, the property setting made by the SysAdmin 
applies globally to all users and users cannot change the setting. 
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Table 3-2.  Editing Options 

Option Description

Date Carry Forward 
Enabled Option

Use the last entered survey date as the survey date for the 
next record when working in an Inspection grid or form.

Technician Carry 
Forward Enabled 
Option

Technician Carry 
Forward Method 
Option

When entering inspection data in the Inspection grid, 
automatically enter a person’s name in the Technician 
field using one of the following methods: 

• Last Technician: Use the name of the last person 
entered in the Technician field. 

• Security: Use the name of the person currently 
logged into PCS Axis. 

Timestamp Readings 
Enabled Option

Add today’s date as the inspection date when entering 
readings in the Inspection grid. 

Show Detail Inspection 
Entry Grid

Display the CPDM Test Point Inspection Detail mini-
grid. Enabling this option allows you to work with test 
points that have multiple potential readings, such as a 
test point with multiple readings for Structure P/S, 
Casing P/S, or On/Off Pair user defined fields (UDFs). 

NOTE: This system option is not present when using the 
optional PCS Axis Telluric Compensation feature. The 
mini-grid displays by default and cannot be disabled. 

Show Grid Tooltips 
Option

Display a field description when the user hovers the 
mouse over a data entry field. 

Warn When Below 
Protection Criteria 
Enabled Option

Display a warning message when a user enters an 
inspection reading that is below the protection criteria 
value specified in the Test Point Protection Criteria field 
of the facility Information grid. 

Require Remarks When 
Range Or Criteria Is 
Violated Option

Display a message prompting the user to edit the 
inspection reading or enter a description in the 
Inspection Remarks field when the entered reading is 
out of range or does not meet the criteria limit specified 
in Options (Tools > Options > Criteria). 

Warn Before Permanent 
History Record 
Changed Option

Display a warning message to the user before changes 
are made to a permanent history record. AI recommends 
this option be enabled if your company plans to maintain 
history records. 

Warn When Outside 
Established Range 
Values Enabled Option

Display a warning message when a user enters an 
inspection reading that is out of range or under criteria. 
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Setting Email Notification Options
Complete the following steps to set property settings that apply when sending email 
reports to recipients using the Email Notification feature: 

1 If the Options window is not open, click Tools > Options to open the 
window. Then click the Email Notification tab (Figure 3-9). 

Figure 3-9.  Email Notification Options

NOTE:  Property settings with a Public caption refer to system-specified settings 
that apply globally to all users and can only be changed by the SysAdmin. For more 
information see Understanding Public and Private Property Settings (page 34). 

2 Type the host name of the SMTP email server your company uses to send email in 
the field Email Smtp Host Name. 

NOTE: SMTP is an acronym for Simple Mail Transfer Protocol. It is a data 
transmission format used to send email. 

3 Type a user name in the field Email Smtp User Name that is associated with the 
email address you plan to use for sending email notifications. 

4 Type a password in the field Email Smtp Password that is associated with the 
user name and email address you plan to use for sending email notifications. 
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5 In the field Email From, type the email address you plan to use for sending email 
notifications. 

6 If the email server supports SSL protocol, click the check box Email Enable Ssl to 
place a check mark inside the check box. 

When an email server supports SSL (secure socket layer) protocol, the email server 
transmits information in an encrypted form for security purposes. If needed, 
contact your IT System Administrator to determine if your company’s email server 
supports SSL.

NOTE: When Email Enable Ssl is disabled (empty check box) and the email server 
supports SSL protocol, recipients will not receive PCS Axis email notifications. PCS 
Axis also adds an entry in the log of Job Service Viewer to identify email 
notification failures (Tool > Job Service Viewer > Job History > Log). 

7 Use the check box Disable Email Service to stop or start sending email 
notifications to all email recipients. 

To stop sending email notifications to all recipients, click the check box to place a 
check mark inside the check box. To begin sending email notifications again, clear 
the check mark by clicking the check box. For more information, refer to Stopping 
Delivery of Email Notifications (page 554). 

8 Enter a default time to send email notifications in the field Email Default Time. 
Use 12-hour time format to indicate the hour, minute, and AM/PM setting (HH:MM 
AM/PM). The default time is used when an email report is not set up with a delivery 
time in the Email Reports tab of Email Notification (Tools > Email Notification > 
Reports tab). 

IMPORTANT: When setting a default time to send email notifications, choose a 
time that does not impact other network services or computer resources. 

9 In the field Email Log Retention In Days, enter the number of days to store a 
copy of the email log in the database. Entries in the email log are purged from the 
log after the specified number of days. 

IMPORTANT: Storing the email log in the database increases the size of the 
database. PCS Axis adds an entry in the log each time an email is sent. The log also 
includes email recipient information; email delivery mode and frequency; hierarchy 
assignments; and email report attachments in Adobe® PDF format. 
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10 In the field Email Max Attachment Size In Mb, enter a value in megabytes (MB) 
that identifies the maximum size allowed by the email server for attachments in an 
email. Because some email servers are set up to process emails no larger than 10 
MB in size, it may be necessary to contact your IT department for this information 
to ensure email recipients receive email notifications. 

11 Click  Save to save changes. 
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Setting Field Computer Options
If your company plans to use the Allegro Field PC with PCS Axis, complete the following 
steps to set up Field Computer options:

1 If the Options window is not open, click Tools > Options to open the 
window. Then click the Field Computer tab (Figure 3-10). 

2 To only use the Allegro digital voltmeter to record voltage readings, enable the 
option Require Voltage Readings By Voltmeter. Enabling this option prevents 
manual data entry of voltage readings on the Allegro. 

3 Enable or disable the Private check box based on your company’s requirements. 

When the Private check box is enabled, the currently logged in user can change 
the property setting. Changes are “private” and only apply to the logged in user 
who makes a change to the setting. If the Private check box is disabled for a 
property setting, the property setting made by the SysAdmin applies globally to all 
users and users cannot change the setting.

4 Click  Save to save changes. 

Figure 3-10.  Field Computer Options
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Setting General Options
To set property settings in the General page of Options, follow these steps: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the General tab to open the General options page (Figure 3-11). 

Figure 3-11.  General Options

3 Review the information in Table 3-3 (page  46) and then set options as needed in 
the following manner. When you finish, click  Save to save changes. 

• To enable an option, click the option’s check box to place a check mark inside 
the check box. Clicking the check box again removes the check mark and 
disables the option. 

• For options with a Private check box, enable or disable the check box based 
on your company’s requirements. 

When the Private check box is enabled, the currently logged in user can 
change the property setting. Changes are “private” and only apply to the 
logged in user who makes a change to the setting. If the Private check box is 
disabled for a property setting, the property setting made by the SysAdmin 
applies globally to all users and users cannot change the setting.

The Public caption indicates the property setting applies globally to all users.
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Table 3-3.  General Options 

Option Description

Disable Attached 
Document Preview

Applies to documents that have previously been 
attached to a record in a data grid. When the option is 
enabled, users are unable to preview an attached 
document in the Preview Attached Documents 
window. When the option is disabled, users can open an 
attached document for editing or viewing purposes if 
the file type of the attached document is associated with 
a default software program on their local computer. See 
Viewing an Attached Document (page 153) for related 
information. 

Include Unit Of Measure 
In All Captions

Include the unit of measure in the description of column 
headings and field captions, such as Structure P/S 
(Volts).

Company Name Provide your company's name. It appears at the top level 
of the PCS Axis system hierarchy and in the header of all 
reports.

Metric Milepost Delimiter Choose Period, Comma, or Plus in the selection list to 
identify the delimiter used in the formatting of metric 
mileposts, such as 1.234AB (Period), 1,234AB (Comma), 
or 1+234AB (Plus). Values before the metric delimiter 
indicate kilometers. Values after the metric delimiter 
indicate meters. For example, milepost number 1.234AB 
indicates 1 kilometer (km) and 234 meters (m). 
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Survey Status Behavior Selections for Survey Status Behavior effect the 
inspection field labeled Surveyed, which is a PCS Axis 
calculated field. 

The Survey Status Behavior option you select identifies 
which conditions must be met in order for PCS Axis to 
determine the facility survey status. When conditions are 
met, PCS Axis places a check mark in the Surveyed check 
box to indicate the facility has been inspected and a 
survey reading has been recorded.   

Review the following information and then choose an 
option in the Survey Status Behavior selection list:   

Any: The Inspection grid must include at least one 
inspection field with a survey reading before PCS Axis 
considers the facility has been surveyed. 

All: All fields related to the inspection field must be 
populated before PCS Axis considers the facility has 
been surveyed. Related fields include the Activate field 
for the inspection field in the Information grid; a survey 
reading in the inspection field of the Inspection grid; 
and Yes in the property setting for the field labeled 
System-Inspection Surveyed in Field and UDF 
Customizations. 

Use Date Only Only display the date instead of date and time for date 
fields such as Inspection Date in the Inspection grid 
and Repair Found Date in the Maintenance grid. 

User Location Name Identify the name your company uses to refer to 
inspection points on a pipeline. For example, type 
Milepost, Station Number, or other type of descriptor 
in the field User Location Name. 

Table 3-3.  General Options (continued)

Option Description
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Setting Hierarchy Options
Hierarchy options determine how PCS Axis organizes data in the system. For information 
about how to set up the PCS Axis system hierarchy, refer to the previous sections 
Understanding the System Hierarchy (page 31) and Setting the System Hierarchy 
(page 32). 

Setting Report Options
Complete the following steps in the Reports page of Options to set property settings: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Reports tab to open the Reports option page (Figure 3-12, page 49). 

3 If you want to change the default setting used as the caption below the signature 
line in a Columnar report (Surveyor), type a name in the field Signature Line 
Caption. 

Disable Link Attachments Disable Link Attachments is a system option that 
applies when attaching a document to a record in a data 
grid (Tools > Options > General). When the option is 
enabled, a document can be embedded but not linked 
to a record. A copy of an embedded document stores in 
the PCS Axis database and can be accessed by all PCS 
Axis users. A linked document stores on the local 
computer of the user who linked the document and can 
only be accessed by that user. 

If your company prefers that users embed documents 
instead of linking to documents, enable the option by 
clicking the check box. A check mark inside the check 
box indicates the option is enabled. For more 
information, refer to Attaching a Document to a Grid 
Record (page 317). 

Table 3-3.  General Options (continued)

Option Description
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4 Enable or disable the Private check box based on your company’s requirements. 

When the Private check box is enabled, the currently logged in user can change 
the property setting. Changes are “private” and only apply to the logged in user 
who makes a change to the setting. If the Private check box is disabled for a 
property setting, the property setting made by the SysAdmin applies globally to all 
users and users cannot change the setting. For more information see 
Understanding Public and Private Property Settings (page 34). 

5 Click  Save to save changes. 

Figure 3-12.  Reports
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Setting Security Options
Complete the following steps in the Security page of Options to set property settings: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Security tab to open the Security options page (Figure 3-13). 

Figure 3-13.  Security Options

3 Review the information in Table 3-4 (page  51) and then set options as needed in 
the following manner. When you finish, click  Save to save changes. 

• To enable an option, click the option’s check box to place a check mark inside 
the check box. Clicking the check box again removes the check mark and 
disables the option. 

NOTE: The Public caption indicates the property setting applies globally to all 
users. For more information see Understanding Public and Private Property 
Settings (page 34). 
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Table 3-4.  Security Options 

Option Description

Use Hierarchical Security Enable this option if you plan to set up hierarchy rights 
in User Management for users with User and Read 
Only security permissions. 

Hierarchical security allows you to assign users access 
rights to certain hierarchy folders in the Select ROWs 
window. When a user does not have access rights to a 
hierarchy folder, PCS Axis does not display the folder in 
the Select ROWs window.

Requires Windows 
Password

If you want users to enter their Windows password when 
logging in to PCS Axis, click the option Requires 
Windows Password. When this option is disabled, the 
system automatically logs in users with their Windows 
login credentials (user name and password 
combination).
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Setting Synchronization Options
The following procedure explains how to set property settings for Synchronization in 
system Options. If you want to disable Synchronization, see Disabling Synchronization 
(page 54).

Complete the following steps: 

1 Click Tools > Options > Synchronization to open the synchronization 
property settings window (Figure 3-14). 

Figure 3-14.  Synchronization

2 Review the following information and then set options as needed. When you finish, 
click  Save to save changes. 

• Default Subscription Database Name: This property setting identifies the 
default name applied to all subscription databases when setting up 
subscribers in Configure Subscription (Tools > Configure Subscription). If 
you want to use a different default name, type a name in this field. 

NOTE: You also have the option to use a different name than the default when 
setting up each subscription database. See Configuring a Subscription 
(page 737) for more information if needed. 
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• Subscription Expiration Warning Threshold: This property setting 
applies to all subscription databases that have not synchronized with the 
publication database within the publication retention period. 

The warning threshold is the number of days before a subscription expires that 
a warning message displays indicating the subscriber must synchronize their 
subscription database. The default value is 10 days. To change the default 
setting, type a value in this field. 

IMPORTANT: Publication retention period is also referred to as subscription 
expiration period. A subscription becomes expired (obsolete) when the 
subscriber does not synchronize their subscription database with the 
publication database within the publication retention period. An expired 
subscription must be re-initialized at the publisher (network server with 
publication database).  
 
The publication retention period is set in the field Subscription expiration in 
the General page when using SQL Server Management Studio (SSMS). See 
Confirming Share Folder Access (page 732) for more information.

• Synchronization User Group Name: This property setting identifies your 
company’s domain name and the name of the local domain user group set up 
for PCS Axis on the central database server. If needed, contact your company’s 
IT System Administrator for this information. When entering the 
Synchronization User Group Name, format the information as shown in the 
following example: 

Example: Domain Name\User Group Name 

• Disabling Synchronization: See the section titled Disabling Synchronization. 
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Disabling Synchronization
If your company does not plan to use Synchronization, you have the option to disable the 
feature. When disabled, the Synchronization menu command is not included in the Tools 
menu, which prevents creating the publication and subscription databases. You can 
however activate Synchronization at anytime if your company decides later to use the 
feature. 

NOTE:  Property settings with a Public caption refer to system-specified settings that 
apply globally to all users and can only be changed by the SysAdmin. For more 
information see Understanding Public and Private Property Settings (page 34). 

To disable Synchronization, follow these steps:

1 Click Tools > Options > Synchronization to open the synchronization property 
settings window (Figure 3-15). 

2 Click the check box Disable Synchronization to place a check mark inside the 
check box. Then click  Save. 

The Synchronization menu command is no longer available in the Tools menu. If 
you decide later to activate Synchronization, clear the check mark by clicking the 
Disable Synchronization check box. 

Figure 3-15.  Disable Synchronization
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Working with Custom Security Roles
Custom security roles are an optional feature in PCS Axis. Using the feature allows you to 
grant or deny user access to one or more PCS Axis menus and menu commands. 

A custom security role is a named set of permissions based on your company’s business 
requirements. You create a custom security role using a Parent Role as a template and 
then modify permissions in the custom security role as needed. A Parent Role is a PCS 
Axis installed security role with predefined permissions that cannot be modified, such as 
the SysAdmin, User, and Read Only security roles. After creating a custom security role 
you are then ready to assign it to a PCS Axis user set up in User Management (page 175). 

Information in this section explains how to use Security Role Management to add and 
edit a custom security role. Topics include those in the following list: 

• Adding a Custom Security Role (page 56)

• Using Copy to Add a Custom Security Role (page 57)

• Editing a Custom Security Role (page 58)

• Deleting a Custom Security Role (page 59)

• Assigning a Custom Security Role to a User (page 60)
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Adding a Custom Security Role
Complete the following steps to add a custom security role:

1 Click Tools > Security Role Management to open the Security Role 
Management window (Figure 3-16). 

Figure 3-16.  Security Role Management

2 Click  Add to open the Add Security Role dialog box (Figure 3-17). 

Figure 3-17.  Add Security Role

3 Select a Parent Role to use as a template to create the custom security role. Click 
the down arrow in the Parent Role field and select a PCS Axis installed security 
role in the selection list, such as User or SysAdmin. 

4 Type a name for the custom security role in the Name field and a description in 
the Description field. 
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5 Click  OK to save changes and return to Security Role Management. 
Information about the custom security role display in the fields Parent Role, Role, 
and Description. 

6 Repeat steps 2 through 5 as needed to add additional custom security roles. Then 
continue with the next section to edit permissions in a custom security role 
(page 58). 

Using Copy to Add a Custom Security Role
When you want to add a custom security role with permissions that are slightly different 
than those in an existing customer security role, use the Copy command to copy 
permissions from the existing custom security role. 

To add a custom security role using the Copy command, follow these steps: 

1 If the Security Role Management window is not open, click Tools > Security 
Role Management (Figure 3-16, page 56). 

2 Click  Copy to open the Copy Security Role dialog box (Figure 3-18). 

3 Complete the following steps to select the existing custom security role you want 
to copy permissions:

a Click the down arrow in the Parent Role field and select the parent role 
associated with the existing custom security role. 

b Click the down arrow in the Role field and select the existing custom security 
role with permissions you want to copy to the new custom security role. 

4 Type a name for the new custom security role in the Name field. Then click  OK 
to save changes and return to the Security Role Management window. 

5 Repeat steps 2 through 4 as needed to add additional custom security roles. Then 
continue with the next section to edit permissions in a custom security role 
(page 58). 

Figure 3-18.  Copy Security Role
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Editing a Custom Security Role
To edit permissions in a custom security role, follow these steps:

1 If the Security Role Management window is not open, click Tools > Security 
Role Management. 

2 Click the down arrow in the Role field and select a custom security role in the 
selection list. Then click  Edit to begin editing permissions (Figure 3-19, 
page 59). 

NOTE: If the custom security role is not visible in the selection list, click the down 
arrow in the Parent Role field and select either User or SysAdmin, then select the 
custom security role in the Role field. 

3 Use the following methods to edit permissions for the custom security role. 

NOTE: You can toggle permissions on and off for all items in the window. Click 
 All to grant access to all items or  None to deny access to all items. 

a To grant access to a menu or menu command listed in the Display Name 
column, click the adjacent check box to place a check mark inside the check 
box . 

b To deny access to a menu or menu command listed in the Display Name 
column, click the adjacent check box to remove the check mark inside the 
check box . 

c Repeat step 3 as needed for each menu and menu command listed in the 
Display Name column. 

4 Click  Save to save changes. 

To assign a custom security role to a user previously set up in User Management, 
see Assigning a Custom Security Role to a User (page 60).
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Figure 3-19.  Security Role Management

Deleting a Custom Security Role
To delete a custom security role, follow these steps:

1 If the Security Role Management window is not open, click Tools > Security 
Role Management (Figure 3-16, page 56). 

2 Click the down arrow in the Parent Role field and select the parent role associated 
with the custom security role you want to delete. 

3 Click the down arrow in the Role field and select the custom security role you want 
to delete. 

4 Click  Delete. When the Confirm Delete message displays, click  Yes to 
delete the custom security role or  No to cancel the operation (Figure 3-20). 

Figure 3-20.  Confirm Delete
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Assigning a Custom Security Role to a User
The following information explains how to assign a custom security role to a user set up in 
User Management. For more information about User Management, see Setting Up User 
Management (page 175). 

Complete the following steps:

1 Click Tools > User Management to open the User Management window 
(Figure 3-21). 

2 Select a user record in the grid. 

3 Complete the following steps in the Role group box on the left side of the window:

a Click the Parent Role field and select the parent role associated with the 
custom security role you want to assign to the user record. 

b Click the Role field and select the custom security role you want to assign to 
the user record. 

4 Click  Save to save changes

Figure 3-21.  User Management
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Setting Properties in Field and UDF Customizations
Use Field and UDF Customizations to modify property settings for certain PCS Axis 
installed fields and add one or more user-defined fields (UDFs) when PCS Axis does not 
provide a field for data entry. 

Information in this section explains how to use the most common features of Field and 
UDF Customizations. Topics include those in the following list: 

• Navigating Field and UDF Customizations

• Editing a PCS Axis Installed Layout Theme (page 62)

• Adding a Layout Theme Addition (page 65)

• Renaming Field Captions on page 67

• Setting Up Range Checking for Inspection Fields on page 70

• Adding User Defined Fields on page 72

Navigating Field and UDF Customizations
The selection tree in the Properties panel of Field and UDF Customizations includes 
three main categories labeled Facility Surveys, Continuous Surveys, and ROW and 
Pipeline. Each of these categories includes related items for selection. For example, items 
for selection in Facility Surveys are based on module and data grid. Items for selection in 
Continuous Surveys are based on data grid and the various continuous survey types. 

Selecting an item in the selection tree displays a list of related fields and property settings 
in the adjacent grid. The grid layout includes columns, rows and cells similar to a 
spreadsheet. Grid columns at top of the grid identify the names of the various properties 
you can set up for a field. Each grid row contains property settings for a specific field, such 
as Casing Status shown in the following figure (Figure 3-22, page 62). When a property 
setting is shaded gray or includes the label N/A (not applicable), this indicates the setting 
cannot be modified. 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to view 
more of the grid. Clicking the bar again expands the panel. 
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Figure 3-22.  Field and UDF Customizations

Editing a PCS Axis Installed Layout Theme
A layout theme is a named set of fields that are present in the grid when working in Field 
and UDF Customizations. Two types of layout themes are available for use. They include 
installed and addition layout themes. An installed layout theme is one that has been 
installed during the PCS Axis software installation, such as [PCS] All Fields. A layout theme 
addition is one that you create.

The procedure in this section explains how to complete the following tasks to edit a PCS 
Axis installed layout theme: 

• add and remove fields in an installed layout theme

• revert an installed layout theme

• save changes as a new baseline installed layout theme
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To edit a PCS Axis installed layout theme, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-23). 

Figure 3-23.  Field and UDF Customizations

2 Click  Customize to open the Column Selections dialog box (Figure 3-24). 

3 Click the down arrow in Select Layout Theme and select a theme in the selection 
list, such as  [PCS] All Fields. 

NOTE: By default all fields are included in the  [PCS] All Fields layout theme. If 
you want to clear all fields listed in the right pane and subsequently remove them 
from the layout theme, click  Toggle Select. Clicking the button again moves all 
fields to the right pane and adds them in the layout theme. 

4 To remove one or more fields in the layout theme, complete one of the following 
steps (Figure 3-24, page 64): 

a Select a field in the right pane and then click the bottom arrow button  to 
move the field to the left pane. 

b Double-click a field in the right pane to move it to the left pane. 
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NOTE: The grid layout theme includes all fields listed in the right pane of the 
Column Selections dialog box. 

Figure 3-24.  Column Selections

5 Click  Save to save changes. 

6 To revert an installed theme and restore settings prior to editing:

• Click  Revert, then click Yes when the Confirm Revert message displays. 

7 To save current changes as new baseline settings, click  New Baseline. 
When future changes are made and then reverted, PCS Axis restores the 
theme with baseline settings.
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Adding a Layout Theme Addition
Information in this section describes how to add a new grid layout theme in Field and 
Customizations. Adding a layout theme allows you to choose which fields to include in 
the grid and then save the new layout as a theme for later use. 

To add a grid layout theme, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25). 

Figure 3-25.  Field and UDF Customizations

2 Click  Customize to open the Column Selections dialog box (Figure 3-26). 

Figure 3-26.  Column Selections
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3 Click  Add to open the New Layout Theme dialog box (Figure 3-27). 

Figure 3-27.  New Layout Theme

4 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it.

5 Select a layout theme with fields you want to copy to the new layout theme. Click 
the down arrow in Copy Fields From Theme and select a theme in the selection 
list. 

6 Click  Save to save changes and return to the Column Selections dialog box. 

7 If you want to clear all fields listed in the right pane of the dialog box and 
subsequently remove them from the grid, click  Toggle Select. Clicking the 
button again moves all fields to the right pane and adds them in the grid. 

8 Choose which fields to include in the layout theme. Select a field in the left pane 
and then click the top arrow button  to move the field to the right pane. Repeat 
this step as needed (Figure 3-28, page 67). 

9 If you want to remove a field in the layout theme, select a field in the right pane 
and then click the bottom arrow button  to move the field to the left pane. 
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NOTE: The grid layout theme includes all fields listed in the right pane of the 
Column Selections dialog box. 

10 Click  Save to save changes and return to the Field and UDF Customizations 
grid. 

Figure 3-28.  Column Selections

Renaming Field Captions
You can rename many of the original PCS Axis field captions with a caption that is more 
familiar to users in your company. The following procedure explains how to rename field 
captions. The information is intended for users with SysAdmin user permissions. 

Complete the following steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 
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3 Select an item in the Properties panel to display related fields and property 
settings in the grid. 

For example, double-click Facility Surveys > Common to All Facilities > ROW 
and Pipeline. The grid displays related fields and property settings for ROW and 
Pipeline (Figure 3-29). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-29.  Field and UDF Customizations

4 To rename an original field caption listed in the Original Caption grid column:

• Type a name in the adjacent field listed in the Caption grid column. 

For example, to rename Milepost, type a new description in the adjacent field, 
such as Station. Bold text indicates a user-modified field as shown in Figure 3-
30, page 69. 
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Figure 3-30.  Field and UDF Customizations

Returning a Field Caption to its Original Name
To return a field caption to its original name, follow these steps:

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations (Figure 3-25, page 65). 

2 Select an item in the Properties panel with the field caption you want to return to 
its original name. 

3 Highlight the name in the Caption field and then press the Delete key on the 
computer keyboard. 

NOTE: If the cursor is still in the Caption field after typing a a new name, you can 
also press Ctrl+Z to undo changes and display the original field caption. 
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Setting Up Range Checking for Inspection Fields
Range checking is the acceptable range of values allowed for data entry in an inspection 
field. 

Setting up range checking allows PCS Axis to alert the user when an incorrect value has 
been entered in an inspection field. For example, if the acceptable range of values is in a 
range of -10 to 0 and the user enters a value that is outside this range, a warning message 
displays allowing the user to correct the invalid entry. Data entry errors are less likely to 
occur when inspection fields are set up with range checking. 

Settings apply system-wide when range checking is set up for an inspection field in Field 
and UDF Customizations. You can also set up range checking at the facility level using 
the minimum/maximum fields available in the Information and Inspections data entry 
grid. Range checking at the facility level overrides range checking at the system level. 

Complete the following steps to set up range checking for an inspection field: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the inspection field you want 
to set up for range checking. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection. The grid displays related fields and property settings for the Test 
Point Inspection data entry grid (Figure 3-31, page 71). 

4 Select the inspection field you want to set up for range checking. For example, 
select Casing P/S as shown in the following figure (Figure 3-31, page 71). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-31.  Field and UDF Customizations

5 Locate the grid columns labeled System–Default Minimum Range and 
System–Default Maximum Range. 

6 Type a minimum range value in the field labeled System–Default Minimum 
Range for the selected inspection field. 

7 Type a maximum range in the field labeled System–Default Maximum Range 
field for the selected inspection field. 

8 If you want to set up another inspection field with range checking, repeat steps 
3 through 7. When you finish, click the  close icon to close the Field and UDF 
Customizations window. 
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Adding User Defined Fields
A user defined field (UDF) is a field you create when PCS Axis does not provide a field for 
data entry. The types of UDFs available for use include those in the following list: 

• Normal: Set up a normal UDF when you want to add any of the following types of 
fields: character, numeric, date, logical, memo, or date/time field.

• Calculated: Set up a calculated UDF when you want PCS Axis to perform 
calculations based on expressions you set up for the UDF. 

• Milepost: Set up a milepost UDF when you want to assign a different milepost 
format to one or more facility types on a pipeline. 

• Standard Picklist: Set up a Standard Picklist UDF when you want to limit data 
entry to a list of valid choices in a selection list. (A Standard Picklist in PCS Axis is 
similar to a validation table in PCS 7.)

• Dynamic Picklist: Set up a Dynamic Picklist with a drop-down list of data items 
that change based on a data item selected in another picklist. This type of picklist 
uses a cascading parent/child relationship allowing you to set up more than five (5) 
levels of interdependent picklists. 

• On/Off Pair : Set up a custom pair of on/off fields when PCS Axis does not 
provide a pair of installed on/off fields for recording inspection readings in a 
data grid or form. This UDF is available for both facility and continuous surveys. 

• Summation: Set up a Summation UDF when you want PCS Axis to perform an 
aggregation for a selected Information, Inspection, or Maintenance field. This 
UDF type supports aggregation on a user-selected target field using any one of the 
following operators: Average, Count, Latest, Maximum, Minimum, and Sum. You 
can also include one or more user-defined filters in the set up of the UDF to further 
filter the results of aggregated data. Summation UDF is a Permanent Information 
field available for use in data grids, forms, reports, and as a filter in scheduling. 

Topics in this section include those in the following list:

• Adding a Normal User Defined Field (page 73)

• Adding a Calculated User Defined Field (page 75)

• Adding a Milepost User Defined Field (page 78)

• Adding a Standard Picklist User Defined Field (page 80)

• Setting Up a Data Entry Field as a Standard Picklist (page 84)

• Adding a Dynamic Picklist User Defined Field (page 89)

• Editing a Picklist (Standard or Dynamic) (page 99)

• Adding an On/Off Pair User Defined Field (page 101)

• Working with a Summation User Defined Field (page 104)
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Adding a Normal User Defined Field
To add a Normal user defined field (UDF), follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. For example, double-click Facility Surveys > CPDM > Test Point > 
Test Point Inspection to display a grid with fields and property settings related 
to the Test Point Inspection data entry grid (Figure 3-32). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-32.  Field and UDF Customizations
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4 Click  Normal in the toolbar to open the Add Normal Field dialog box 
(Figure 3-33). 

5 Type a unique name for the UDF in the Caption field. 

Figure 3-33.  Add Normal Field

6 Choose the type of field you want to add. Click the down arrow in the Data Type 
field and select one of the following options:

• Character : Supports characters such as A, B, and C. This data type can be 
used for both character and numeric data. If you plan to use mixed data, such 
as a number and a character or dash, define the data type as a character. If you 
plan to create a picklist for the UDF, use the Character data type. For more 
information about picklists, see Adding a Standard Picklist User Defined 
Field (page 80). 

• Numeric: Supports values such as 1, 2, and 3 and numeric values using the 
following format: 999.999 and –99.999. 

• Date: Supports a date format using MM/DD/YYYY (month, day, year), such as 
11/12/2012. 

• Logical: Supports a yes/no selection in the form of a check box to enable or 
disable an option in the data entry grid.

• Memo: Supports more than 255 characters and carriage returns.

• DateTime: Supports a date and time format using HH:MM:SS (hours, 
minutes, seconds) and MM/DD/YYYY (month, day, year). Such as 11:15:45, 12/
11/2012. 

• Integer : Supports a positive or negative whole number, or zero. Such as -2, 4, 
123, and 3,245. 
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7 If you selected the Character or Numeric data type earlier, set the length of the 
field by typing the number of characters required for the UDF in the Width field. 

Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 

8 If you selected the Numeric data type earlier, set the number of decimal places 
required for the UDF by typing a value in the Decimals field. 

9 If you selected the Numeric data type earlier and want to set up range checking 
for the UDF, click the Range Checking option and then type a minimum and 
maximum value in the respective fields. 

NOTE: Range checking is the acceptable range of values allowed for data entry in 
a field. Setting up range checking allows PCS Axis to alert the user when an 
incorrect value has been entered. 

10 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see Working 
with Themes and Filter Groups (page 295) for information about how to add 
fields in a data entry grid. 

Adding a Calculated User Defined Field
The procedure in this section includes an example that describes how to define an 
expression for a user defined field (UDF) labeled Shorted P/S. In the example, if 
Casing P/S is below protection criteria (less than or more negative than –0.8495), PCS 
Axis enables Shorted P/S for data entry in the grid. The field is not enabled for data 
entry when Casing P/S meets protection criteria. 

NOTE: An expression is a logical statement with specific conditions that must be met 
before PCS Axis enables the field for data entry. Logical statements are either “true” or 
“false” based on the conditions defined in the expression for the UDF.

To add a Calculated UDF, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 
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2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. For example, double-click Facility Surveys > CPDM > Test Point > 
Test Point Inspection to display a grid with fields and property settings related 
to the Test Point Inspection data entry grid (Figure 3-34). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-34.  Field and UDF Customizations
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4 Click  Calculated in the toolbar to open the Add Calculated Expression 
dialog box. If you want to work with the expression editor in advanced mode, 
click  Switch To Advanced Mode (Figure 3-35).

Figure 3-35.  Add Calculated Expression (Advanced Mode)

5 Type a unique name for the UDF in the Caption field. Then click the down arrow in 
the Data Type field and select a data type in the selection list, such as Numeric. 

6 If you selected the Character or Numeric data type earlier, set the length of the 
field by typing the number of characters required for the UDF in the Width field. 
Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 

7 If you selected the Numeric data type earlier, set the number of decimal places 
required for the UDF by typing a value in the Decimals field. 

8 Click a toggle button  to open a field category, such as Test Point Inspection 
Fields shown in Figure 3-34, page 76. Double-click a field in the list of fields to add 
it in the Expression field. Define the UDF using the operator and functions buttons. 

NOTE: Hovering the mouse over a function or operation button displays a 
description below the folder tree. 

9 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. The UDF is now available for adding in a data entry grid. 
If needed, see Working with Themes and Filter Groups (page 295) for 
information about how to add fields in a data entry grid. 
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Adding a Milepost User Defined Field
Set up a Milepost user defined field (UDF) when you want to assign a different milepost 
format to a facility type on a pipeline. For example, if coupons require a different milepost 
format than other facility types on a pipeline, set up a milepost UDF and then assign the 
UDF at the facility type level in the Facility Location ID Formats mini-grid of Edit ROW 
Detail (Data Entry > Edit ROW Detail). 

To add a Milepost UDF, follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. 

For example, double-click Facility Surveys > Common to All Facilities > ROW 
and Pipeline to display a grid with fields and property settings related to the Edit 
ROW Detail grid (Figure 3-36, page 79). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-36.  Field and UDF Customizations

4 Click  Milepost in the toolbar to open the Add Milepost Field dialog box 
(Figure 3-37). 

5 Type a unique name for the UDF in the Caption field. 

6 Click the down arrow in the Milepost Formats field and select a milepost format 
in the selection list. 

7 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

The UDF is now available for selection in the Facility Location ID Formats mini-
grid of Edit ROW Detail. If needed, see Working with Pipeline Records 
(page 127) for more information. 

Figure 3-37.  Add Milepost Field
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Adding a Standard Picklist User Defined Field
A Standard Picklist is a list of acceptable choices for a field in a data entry grid that a user 
selects from when entering data. This feature improves data consistency and accuracy by 
allowing users to select from a list of predefined choices instead entering data manually. 

A Standard Picklist contains a list of valid items for selection, a description of each item, 
and a value assigned to each item that determines the sorting order of items in the list. 

NOTE: A Standard Picklist in PCS Axis is similar to a validation table in PCS 7.x. 

To add a Standard Picklist user defined field (UDF), follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid (Figure 3-38, page 81). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-38.  Field and UDF Customizations

4 Click  Picklist in the toolbar to open the Select Picklist Type dialog box 
(Figure 3-39). 

5 Click Standard and then click  OK to close the Select Picklist Type dialog box. 

Figure 3-39.  Select Picklist Type

6 When the Add Picklist Field dialog box opens, type a unique name for the UDF in 
the Caption field (Figure 3-40, page 82). 

7 Set the length of the field by typing the number of characters required for the UDF 
in the Width field. 

Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 
Setting Up PCS Axis 81



PCS Axis User and Administrator Guide
Figure 3-40.  Add Picklist Field

8 Choose an option for displaying the UDF in data entry grids. Click the down arrow 
in the field Cell Style and select one of the following options in the selection list:

• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the 
picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

9 Choose an option for displaying items in the picklist. Click the down arrow in the 
field Dropdown Style and select one of the following options in the selection list:

• Show Value: Displays only the assigned value of items in the picklist. 

• Show Description: Displays only the description of items in the picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the picklist. 
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10 Select an option for sorting items in the picklist. Click the down arrow in the field 
Validation Order and select one of the following options in the selection list:

• Value: Sorts items numerically based on values assigned to items in the 
picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

11 If you want the UDF to support multiple selections in the picklist, click the check 
box Allow Multiple Selections. 

12 If you want the UDF to allow data entry of other data in addition to picklist items 
for selection, click the check box Allow Other Entry. 

13 To add picklist items for selection, follow these steps:

a Click the message Click here to add new row to add an empty row of fields 
for data entry (Figure 3-40, page 82).

b Type a value in the Value field to associate a code number with the picklist 
item. They type a description for the picklist item in the Description field. 

c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 

d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for the picklist item. 

e Repeat steps “c” and “d” as needed until all picklist items have been added. 
When you finish, click  Save to close the dialog box and return to the Field 
and UDF Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see 
Working with Themes and Filter Groups (page 295) for information about 
how to add fields in a data entry grid. 
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Setting Up a Data Entry Field as a Standard Picklist 
A Standard Picklist is a list of acceptable choices for a field in a data entry grid that a user 
selects from when entering data. This feature improves data consistency and accuracy by 
allowing users to select from a list of predefined choices instead entering data manually. 

For example, setting up a picklist with valid repair codes or status conditions allows users 
to choose from a list of valid items instead of typing information to describe the repair 
status or condition of a facility test station or pipeline. 

A Standard Picklist contains a list of valid items for selection, a description of each item, 
and a value assigned to each item that determines the sorting order of items in the list. 

NOTE: A Standard Picklist in PCS Axis is similar to a validation table in PCS. 

To set up a data entry field as a Standard Picklist, follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry field you want 
to set up as a Standard Picklist. 

For example, double-click Facility Surveys > Common to All Facilities > 
Maintenance to display a grid with fields and property settings related to all 
Maintenance data entry grids (Figure 3-41). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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4 Using the horizontal scroll bar near the bottom of the grid, display the grid column 
labeled Grids–Picklist Definition. Then select the data entry field you want to set 
up as a Standard Picklist. For example, select Repair Priority as shown in the 
following example. 

Figure 3-41.  Field and UDF Customizations

5 Convert the selected data entry field to a Standard Picklist field. Click the edit 
icon  in the Grids-Picklist Definition field for the data entry field selected 
earlier, such as Repair Priority (Figure 3-41, page 85). 

When a data entry grid includes existing data for the data entry field you convert 
to a Standard Picklist, PCS Axis displays a message to notify you of the number of 
affected records. You can either click Yes in the message to continue converting the 
field to a Standard Picklist or No to cancel the operation. Selecting Yes allows PCS 
Axis to use existing data as valid items for selection in the Standard Picklist. Using 
the merge button  allows you to edit these selection items as needed (Figure 3-
42). 

If you decide later you want to convert the Standard Picklist to a normal data 
entry field, click the revert button  and then click Yes when a confirmation 
message displays. PCS Axis then re-populates affected fields in the data entry grids 
with unaltered data that was available prior to the field conversion. 
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Figure 3-42.  Field and UDF Customizations

6 Click the edit icon  again for the data entry field converted earlier to a Standard 
Picklist to open the Edit Picklist Field dialog box (Figure 3-43). 

Figure 3-43.  Edit Picklist Field

7 Choose an option for displaying the UDF in data entry grids. Click the down arrow 
in the field Cell Style and select one of the following options in the selection list:

• Show Value: Displays the assigned value of the selected item in the Standard 
Picklist. 

• Show Description: Displays the description of the selected item in the 
Standard Picklist.
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• Show Value And Description: Displays the assigned value and description of 
the selected item in the Standard Picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the Standard Picklist. 

8 Choose an option for displaying items in the Standard Picklist. Click the down 
arrow in the field Dropdown Style and select one of the following options in the 
selection list:

• Show Value: Displays only the assigned value of items in the Standard 
Picklist. 

• Show Description: Displays only the description of items in the Standard 
Picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the Standard Picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the Standard Picklist. 

9 Select an option for sorting items in the Standard Picklist. Click the down arrow in 
the field Validation Order and select one of the following options in the selection 
list:

• Value: Sorts items numerically based on values assigned to items in the 
Standard Picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the Standard Picklist.

• Defined: Sorts items based on the order of items listed in the Edit Picklist 
Field dialog box. 

10 To add items for selection in the Standard Picklist, follow these steps:

a Click the message Click here to add new row to add an empty row of fields 
for data entry (Figure 3-43, page 86).

b Type a value in the Value field to associate a code number with the picklist 
item. Then type a description for the picklist item in the adjacent Description 
field. 

c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 
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d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for the picklist item. 

e Repeat steps “c” and “d” as needed until all picklist items have been added. 
When you finish, click  Save to close the dialog box and return to the Field 
and UDF Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see 
Working with Themes and Filter Groups (page 295) for information about 
how to add fields in a data entry grid. 

For information about how to edit a picklist refer to Editing a Picklist 
(Standard or Dynamic) (page 99). 
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Adding a Dynamic Picklist User Defined Field
Information in this section explains how to add and edit a Dynamic Picklist user defined 
field (UDF). The information is intended for the PCS Axis SysAdmin or a user with 
SysAdmin user permissions. 

A Dynamic Picklist UDF is a dynamic drop-down list with data items that change based 
on a data item selected in another picklist. This dependency uses a cascading parent/child 
relationship. For example, selecting a data item in the drop-down list of picklist A (parent) 
determines which data items are available for selection in the drop-down list of picklist B 
(child). 

Dynamic Picklists are helpful to users when entering data in a data grid or form. It allows 
for easier and more accurate data entry. 

Building a Dynamic Picklist allows you to control the data entered in a field by limiting 
the choices to those in a pre-defined list. For example, instead of a user typing a lengthy 
description for sub-station locations throughout the country, you might want to build a 
Dynamic Picklist with a parent picklist named My Sub-Station Type that includes three 
associated child picklists labeled My Sub-Station State, My Sub-Station County, and 
finally My Sub-Station City. Each of these are dependent upon the other and form the 
Dynamic Picklist. 

Building a Dynamic Picklist is a 2-part process. You begin with creating the initial parent 
picklist as a Standard Picklist and then add and map one or more child Dynamic 
Picklists. Once this process is complete, you can then add the parent and child picklists in 
data entry grids/forms, reports, and prompts sent to the Allegro Field Computer. 

Topics in this section explain how to add and edit a Dynamic Picklist. They include those 
in the following list: 

• Adding the Initial Parent Picklist (page 90)

• Adding a Child Picklist and Mapping Data Items (page 94)

As an example to demonstrate how to build a Dynamic Picklist, information in this section 
uses a 2-level Dynamic Picklist with My Pipeline State as the initial parent picklist and My 
Pipeline County as the associated child picklist. Although Dynamic Picklists support an 
unlimited number of child picklists, the example uses one for clarity purposes. The process 
for adding multiple child picklists is the same as adding one child picklist.
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Adding the Initial Parent Picklist
Complete the following steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-44). 

2 If you want to select a grid layout theme:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want 
to add a Dynamic Picklist UDF. For example, double-click Facility Surveys > 
CPDM > Test Point > Test Point Inspection to display a grid with fields and 
property settings related to the Test Point Inspection data entry grid (Figure 3-
44). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-44.  Field and UDF Customizations
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4 Click  Picklist in the toolbar of the Field and UDF Customizations window 
to open the Select Picklist Type dialog box (Figure 3-45). 

5 Click Standard and then click  OK to close the dialog box.

Figure 3-45.  Select Picklist Type

6 When the dialog box Add Picklist Field opens, set properties for the parent picklist 
in the following manner (Figure 3-46): 

a Type a unique name for the parent picklist in the Caption field. 

b Indicate the number of characters to allow in the name of the parent picklist. 
Type a value in the Width field or use the up/down arrows to select a value. 
Clicking the up arrow increases the value; clicking the down arrow decreases 
the value. 

Figure 3-46.  Add Picklist Field
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7 Choose an option for displaying the parent picklist in data entry grids. Click the 
down arrow in the field Cell Style and select one of the following options in the 
selection list:

• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the 
picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

8 Choose an option for displaying items in the parent picklist. Click the down arrow 
in the field Dropdown Style and select one of the following options in the 
selection list:

• Show Value: Displays only the assigned value of items in the parent picklist. 

• Show Description: Displays only the description of items in the parent 
picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the parent picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the parent picklist. 

9 Select an option for sorting items in the parent picklist. Click the down arrow in the 
field Validation Order and select one of the following options in the selection list:

• Value: Sorts items numerically based on values assigned to items in the parent 
picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the parent picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

NOTE: Do not enable the options Allow Multiple Selections and Allow Other 
Entry for the parent picklist. These options do not apply to Dynamic Picklists. 
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10 Complete the following steps to add data items for selection in the drop-down list 
of the parent picklist. 

The figure below shows an example of two data items labeled OK-1 Oklahoma 
and TX-1 Texas as items for selection in the parent picklist My Pipeline States 
(Figure 3-47). These data items are set up later as child picklists in the section 
Adding a Child Picklist and Mapping Data Items (page 94). 

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item (child picklist). Type one or 
more letters, numbers, or a combination of both in the Value field. Then type 
a description for the data item (child picklist) in the Description field. 

c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 

d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for another data item (child picklist). 

e Repeat steps “c” and “d” as needed until all data items (child picklists) have 
been added. When you finish, click  Save to close the dialog box and return 
to the Field and UDF Customizations window. 

PCS Axis adds the parent picklist in the list of other fields in the Field and UDF 
Customizations window. 

11 Continue with the next section Adding a Child Picklist and Mapping Data Items 
(page 94). 

Figure 3-47.  Add Picklist Field
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Adding a Child Picklist and Mapping Data Items
Complete the following steps to add a child picklist and then map data items in the child 
picklist to data items in a parent picklist: 

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations to open the window (Figure 3-44, page 90). 

2 Select an item in the Properties panel that includes the initial parent picklist added 
earlier. (See Adding the Initial Parent Picklist on page 90.)

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid.

3 Click  Picklist in the toolbar of the Field and UDF Customizations window 
to open the Select Picklist Type dialog box (Figure 3-48). 

4 Click Dynamic in the Select Picklist Type dialog box. Then click the down arrow in 
the adjacent field and select the parent picklist you want to associate with the child 
picklist. Click  OK to close the dialog box.

Figure 3-48.  Select Picklist Type

5 When the dialog box Add Picklist Field opens, set properties and add data items 
for the child picklist in the following manner (Figure 3-49, page 95): 

a Type a unique name for the child picklist in the Caption field. 

b Indicate the number of characters to allow in the name of the child picklist. 
Type a value in the Width field or use the up/down arrows to select a value. 
Clicking the up arrow increases the value; clicking the down arrow decreases 
the value. 
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Figure 3-49.  Add Picklist Field

6 Choose an option for displaying the child picklist in data entry grids. Click the 
down arrow in the field Cell Style and select one of the following options in the 
selection list:

• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the 
picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

7 Choose an option for displaying data items in the child picklist. Click the down 
arrow in the field Dropdown Style and select one of the following options:

• Show Value: Displays only the assigned value of items in the child picklist. 

• Show Description: Displays only the description of items in the child picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the child picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the child picklist. 
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8 Select an option for sorting data items in the child picklist. Click the down arrow in 
the field Validation Order and select one of the following options:

• Value: Sorts items numerically based on values assigned to items in the child 
picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the child picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

NOTE: The options Allow Multiple Selections and Allow Other Entry are 
unavailable for selection when adding a child picklist. 

9 Complete the following steps to add data items in the child picklist and then map 
these data items to data items in the associated parent picklist. Data items you add 
become selections in the drop-down list of the child picklist.

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 

The example below shows a data item labeled TX-1 Travis as an item for 
selection in the child picklist labeled My Pipeline County (Figure 3-50). 

Figure 3-50.  Add Picklist Field
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c Click the  parent picklist button to open the dialog box labeled Select 
Parent Picklist Values (Figure 3-51). 

Figure 3-51.  Select Parent Picklist Values

d Map a data item in the parent picklist to the currently selected data item in the 
child picklist. A list of data items related to the parent picklist display in the left 
pane of the dialog box (Figure 3-52). 

• Double-click a data item in the left pane of the dialog box to move the 
data item to the right pane. 

You can also map data items by clicking a data item’s check box and then 
clicking the  right arrow button. A  check mark beside a data item 
indicates that data item is mapped. 

If you want to unmap a data item, double-click the data item in the right 
pane of the dialog box to move it back to the left pane. Or, select the data 
item in the right pane and then click the  left arrow button. 

Figure 3-52.  Select Parent Picklist Values
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e Click  Save to save settings and close the dialog box. 

10 To add another data item in the child picklist, follow these steps (Figure 3-53): 

a Press Enter on the computer keyboard to add another empty row of fields for 
data entry in the dialog box Add Picklist Field. 

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 

The example below shows a data item labeled OK-2 Marshall as data item for 
selection in the child picklist labeled My Pipeline County (Figure 3-50). 

Figure 3-53.  Add Picklist Field

c Click the  parent picklist button to open the dialog box labeled Select 
Parent Picklist Values (Figure 3-51, page 97). 

d Map a data item in the parent picklist to the currently selected data item in the 
child picklist (Figure 3-52, page 97). Click  Save when you finish to save 
settings and close the dialog box. 

e To add additional data items in the child picklist, repeat step 10 "a" through 
"d". When you finish adding and mapping all data items in the child picklist, 
click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

The process for adding a Dynamic Picklist UDF is now complete. You can add 
the Dynamic Picklist (parent and child picklist fields) in the layout theme of a 
data grid, form, or report, as well as in a prompt theme for prompts sent to the 
Allegro Field Computer. Refer to Working with Themes and Filter Groups 
(page 295) for information. For information about editing a picklist, refer to 
Editing a Picklist (Standard or Dynamic) on page 99. 
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Editing a Picklist (Standard or Dynamic) 
Information in this section explains how to edit or delete a Standard or Dynamic Picklist 
user defined field (UDF) in Field and UDF Customizations. 

Complete the following steps:

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations to open the window (Figure 3-44, page 90). 

2 Select an item in the Properties panel that includes the picklist you want to edit or 
delete. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid.

3 Select the picklist UDF you want to work with in the grid of the Field and UDF 
Customizations window. 

4 If you want to delete the picklist UDF, click  Delete in the toolbar of the Field 
and UDF Customizations window. Then click  Yes when the Confirm Delete 
message displays. 

5 If you want to add or remove data items in a picklist UDF, navigate to the grid 
column labeled Grids - Pick List Definition and click the  edit icon to open the 
Edit Picklist Field dialog box (Figure 3-54). 

Figure 3-54.  Edit Picklist Field
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6 To delete a data item in the picklist UDF, select the data item and then click 
 Delete. When a Delete message displays, click  Yes to delete the data 

item or  No to cancel the operation. 

7 To add a data item in the picklist UDF, follow these steps:

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 

c If you are adding a data item in a child Dynamic Picklist, complete the 
following steps: 

1) Click the  parent picklist button to open the dialog box Select Parent 
Picklist Values (Figure 3-51, page 97). 

2) Map a data item in the associated parent picklist to the new data item in 
the child picklist in the following manner. A list of data items related to the 
parent picklist display in the left pane of the dialog box (Figure 3-52, 
page 97). 

• Double-click a data item in the left pane of the dialog box to move the 
data item to the right pane. 

You can also map data items by clicking a data item’s check box and 
then clicking the  right arrow button. A  check mark beside a data 
item indicates that data item is mapped. 

If you want to unmap a data item, double-click the data item in the 
right pane of the dialog box to move it back to the left pane. Or, select 
the data item in the right pane and then click the  left arrow button. 

d To add another data item, press Enter on the computer keyboard and then 
repeat step 7 "a" through "c". 

8 Click  Save to save settings and close the dialog box. 
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Adding an On/Off Pair User Defined Field
PCS Axis provides several pairs of installed on/off fields for recording inspection 
readings in a data grid or form, such as AC P/S and AC IRF; Casing P/S and Casing 
IRF; Foreign P/S and Foreign IRF; Insulator P/S and Insulator IRF; and Structure P/S 
and Structure IRF. 

If PCS Axis does not provide an installed pair of on/off fields you can use to record 
inspection readings for a facility or continuous survey, create a custom On/Off Pair user 
defined field (UDF). Information in the following procedure explains how to use Field and 
UDF Customizations to add an On/Off Pair UDF. 

NOTE: Editing an On/Off Pair UDF is not currently supported. This feature will be 
available in a future release of PCS Axis to allow changing or deleting an On/Off Pair UDF. 

The current version of PCS Axis does not support editing an On/Off Pair user defined 
field. 

Complete the following steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Double-click Facility Surveys or Continuous Surveys in the Properties panel to 
open the selected folder. Then select the Inspection data grid you want to set up 
an On/Off Pair UDF. 

For example, to set up an On/Off Pair UDF for the Test Point Inspection data grid, 
double-click Facility Surveys > CPDM > Test Point. Then click Test Point 
Inspection (Figure 3-55, page 102). Likewise, to set up an On/Off Pair UDF for 
the Edit ISM Data grid, double-click Continuous Surveys > CIS Surveys. Then 
click Surveys. 
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NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-55.  Field and UDF Customizations

4 Click  On/Off Pair in the toolbar to open the Add On/Off Pair Fields dialog 
box (Figure 3-56). 

Figure 3-56.  Add On/Off Pair Fields
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5 Type a unique name in the fields On Field Caption and Off Field Caption. 

6 Click the down arrow in Data Type and select Numeric or Integer. 

A Numeric data type is a positive or negative value with decimal precision, such as 
1.123 and –1.123. An Integer data type is a positive or negative whole number, 
such as 5 and –5. 

7 If you selected the Numeric data type earlier in step 6 (page 103), set the length of 
the field using the Width and Decimal fields (Figure 3-56, page 102). 

Clicking the up arrow in Width or Decimal fields increases the value; clicking the 
down arrow decreases the value. 

8 If you want PCS Axis to apply Range Checking to the On reading in the On/Off 
Pair, complete the following steps. 

NOTE: Range checking is the acceptable range of values allowed for data entry in 
an inspection field.  
 
Setting up range checking allows PCS Axis to alert the user when an incorrect value 
has been entered in an inspection field. For example, if the acceptable range of 
values is in a range of -10 to 0 and the user enters a value that is outside this range, 
a warning displays allowing the user to correct the invalid entry. Data entry errors 
are less likely to occur when using Range Checking. For more information, see 
Setting Up Range Checking for Inspection Fields (page 70). 

a Click the check box On Range Checking. 

b Type a minimum range value in the On Minimum field. 

c Type a maximum range value in the On Maximum field. 

9 If you want PCS Axis to apply Range Checking to the Off reading in the On/Off 
Pair, complete the following steps: 

a Click the check box Off Range Checking. 

b Type a minimum range value in the Off Minimum field. 

c Type a maximum range value in the Off Maximum field. 

10 The On/Off Pair UDF is now available for adding in a data entry grid. If needed, 
see Working with Themes and Filter Groups (page 295) for information about 
how to add fields in a data grid or form. 
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Working with a Summation User Defined Field
A Summation user defined field (UDF) is a Permanent Information field available for 
use in a data grid, form, report, or as a filter in scheduling. It is a simple yet powerful 
UDF that provides useful information when analyzing pipeline data. 

The function of a Summation UDF is to aggregate data for a target field using one of the 
following operators: Average, Count, Latest, Maximum, Minimum, and Sum. As an 
option, you can also include one or more filters that run either before or after the data 
aggregation. 

EXAMPLE:  Set up a Summation UDF using Structure P/S as the target field and Average 
as the operator. Include a Calculated UDF as a filter in the Summation UDF that is set up 
to find the variance between the actual and average Structure P/S reading for test points. 
The expression for the Calculated UDF is ABS([My Summation Name] – [Structure P/S]). 
Add the Summation and Calculated UDFs in the Test Point Inspection data grid to view 
the results of the data aggregation. For more information about working with a 
Calculated UDF, refer to Adding a Calculated User Defined Field (page 75). 

Information in this section explains how to work with a Summation user defined field. 
Topics include those in the following list:

• Adding a Summation User Defined Field

• Editing a Summation User Defined Field (page 109)

Adding a Summation User Defined Field
Complete the following steps to add a Summation UDF: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-28, 
page 67).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 
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3 Double-click Facility Surveys > Common to All Facilities in the Properties 
panel. Then click Permanent Information to display a grid with fields and 
property settings common to all facilities (Figure 3-57). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-57.  Field and UDF Customizations

4 Click  Summation in the toolbar to open the Add Summation Field dialog 
box (Figure 3-58, page 106). 
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Figure 3-58.  Add Summation Field

5 Type a unique name for the Summation UDF in the Caption field. 

6 Select a target field in the list of fields in the selection panel. For example, click the 
 expand arrow for Test Point Inspection Fields, then double-click Structure P/S. 

A  green check mark indicates a selection (Figure 3-59, page 107). 

7 Select an Operator option. For example, Average is selected in the following 
figure (Figure 3-59, page 107). 

The Summation expression displays in the top right-hand corner of the dialog box, 
such as Average: Structure P/S shown in the following example. 

8 Click  Save to save settings. 

9 If you want to add an optional AND filter group to the Summation UDF, continue 
with step 10 (page 107). To add an optional OR filter group, continue with step 11 
(page 108). Otherwise, continue with step 12 (page 109) to close the Add 
Summation Field dialog box. 
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Figure 3-59.  Summation Target Field

10 If you want to include one or more optional AND filters in the Summation UDF, 
complete the following steps. Data results produce a subset of records that meet 
all filter conditions included in the filter group. 

a Click the  Filters button to open the Filters panel. 

b Click  New ‘And’ Group to open the filter properties group box (Figure 3-
60, page 108). 

c Type a name for the filter group in the field Filter Group Caption. 

d Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

e If you want to set up additional filter criteria, click  Add to display an 
additional set of filter selection fields. Select a PCS Axis field, operator, and 
one or more filter conditions to set up filter criteria. 

f Repeat steps "b" through "e" as needed. When you finish, click the  Filters 
button to close the Filters panel. Then continue with step 12 (page 109). 
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Figure 3-60.  New ‘And’ Filter

11 If you want to include one or more optional OR filters in the Summation UDF, 
complete the following steps. Data results produce a subset of records that meet 
any filter condition(s) included in the filter group. 

a Click the  Filters button to open the Filters panel. 

b Click  New ‘Or” Group to open the filter properties group box 
(Figure 3-61). 

c Type a name for the filter group in the field Include records that match any 
of these conditions. 

d Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

e If you want to set up additional filter criteria, click  Add to display an 
additional set of filter selection fields. Select a PCS Axis field, operator, and 
one or more filter conditions to set up filter criteria. 

f Repeat steps "b" through "e" as needed (page 108). When you finish, click the 
 Filters button to close the Filters panel. Then continue with the next step . 
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12 Click  Save and then the close button  to close the Add Summation Field 
dialog box. 

Figure 3-61.  New ‘Or’ Filter

Editing a Summation User Defined Field
When you want to edit a Summation UDF previously added in PCS Axis, follow these 
steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-25, page 65). 

2 Double-click Facility Surveys > Common to All Facilities in the Properties 
panel. Then click Permanent Information to display a grid with fields and 
property settings common to all facilities (Figure 3-57, page 105). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

3 Select the Summation UDF you want to edit in the grid of the Field and UDF 
Customizations window. Then navigate to the grid column labeled System-
User Defined Summation Definition and click the … ellipsis button 
Figure 3-62). 
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Figure 3-62.  System-User Defined Derivation Definition

4 When the dialog box Edit Summation Field opens, change UDF settings as 
needed, such as selecting a different target field in the list of fields in the selection 
panel or a different Operator option (Figure 3-63). 

5 If the Summation UDF includes filter settings you want to change, click the 
 Filters button to open the Filters panel and make changes as needed. 

Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions.
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6 Click  Save to save settings and return to the Field and UDF Customizations 
window. 

Figure 3-63.  Edit Summation

Using an Application Scheme
An application scheme is a group of named property settings that change the overall 
appearance of the PCS Axis interface. Currently PCS Axis only provides a default 
application scheme which cannot be customized (Tools > Application Schemes). Future 
software enhancements will allow you to create application schemes for customizing the 
PCS Axis interface, such as choosing a different color scheme. 

Choosing a Printer for PCS Axis
PCS Axis uses your computer’s default printer to print reports and graphs. If a color printer 
is available, you may want to print graphs on a color printer. If you need to add or set up a 
local or network printer, contact your company’s network administrator or IT department 
for assistance. 
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Working with Pipeline Series
Information in this section explains how to work with Pipeline Series. Topics include those 
in the following list: 

• About Pipeline Series

• Adding and Applying Pipeline Series (page 113)

About Pipeline Series
When a discontinuity occurs in a pipeline, use Pipeline Series to adjust facility numbers on 
the pipeline. A discontinuity typically occurs when an extension is added to the pipeline; 
the pipeline is re-routed; or when a company designates two pipelines as parallel lines. 
Instead of physically renumbering pipeline location numbers on-site, Pipeline Series 
allows you to shift pipeline numbering in PCS Axis using Relative Milepost locations. 

A Pipeline Series is an ordered list of milepost locations with a starting milepost and an 
ending milepost that serve as connectors to preceding and subsequent Pipeline Series. 
All Pipeline Series snapped end to end map the pipeline. Multiple connected Pipeline 
Series form a Pipeline Series chain. 

Additional characteristics of Pipeline Series include those in the following list:

• All facilities on the pipeline must be assigned to a Pipeline Series when a Pipeline 
Series is used with a segment of the same pipeline. An entire pipeline can be made 
up of several Pipeline Series. 

The starting milepost of a Pipeline Series corresponds to the starting milepost for 
a segment of the pipeline. The ending milepost of the Pipeline Series corresponds 
to the ending milepost for the same segment of pipeline. Each Pipeline Series 
joins together, end-to-end, to make up the entire pipeline. Pipeline Series defines 
each segment and is then used to calculate the Relative Milepost. 

• A pipeline with several different numbering schemes can be converted into a 
sequential line using a Pipeline Series for each segment of the pipeline. This 
allows you to graph the entire distance of the pipeline using the Relative Milepost.

• Pipeline Series supports negative milepost locations. This helps identify milepost 
locations that are in an opposite direction of other milepost locations in a series. 

• Red facility records in a data entry grid identify milepost numbers that require a 
Pipeline Series be applied to the record. 
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Adding and Applying Pipeline Series
The procedure in this section describes how to add a Pipeline Series definition and then 
apply it to effected milepost numbers in a facility data entry grid. The example in the 
procedure adds a pipeline extension with negative milepost locations as shown in the 
following example (Figure 3-64). 

Figure 3-64.  Example of an Extended Pipeline with Mileposts Set in Reverse Order
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NOTE:  In the example above, PCS Axis calculates relative milepost 40+00 
as the end of Series A and the beginning of Series B. 
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To add and apply a Pipeline Series, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 3-65). 
Select one or more pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

Figure 3-65.  Select ROWs

2 Select the PCS Axis module you want to work with, such as the CPDM module. Click 
Modules > Cathodic Protection Data Manager (CPDM). 

3 Click Data Entry > Pipeline Series to open the Pipeline Series window 
(Figure 3-66). 

Figure 3-66.  Pipeline Series
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4 Click  Add and then select the ROW Code and Pipe you want to work with in 
the dialog box that opens (Figure 3-67). 

Figure 3-67.  Select Right Of Way Code And Pipeline

5 Click  Save to display required field(s) for data entry. Required fields are 
identified with the  icon, such as Series Number, Start Milepost, and End 
Milepost in the next figure (Figure 3-68). 

6 Type a unique identifier for the Pipeline Series in the Series Number field. This 
field accepts up to 10 alphanumeric characters including spaces and special 
characters, such as a hyphen (–) or pound sign (#). 

7 Set the Pipeline Series start and end milepost numbers. Type the starting milepost 
in the Start Milepost field and the ending milepost in the End Milepost field. 

The starting milepost of the Pipeline Series corresponds to the starting milepost 
for a segment of the pipeline. The ending milepost of the Pipeline Series 
corresponds to the ending milepost for the same segment of pipeline. 

Figure 3-68.  Add Record
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8 Click  Save to close the dialog box and add the record in the Pipeline Series 
grid. 

9 If you want to add a description or other type of information for the Pipeline Series, 
type the information in the Description field. This field supports up to 30 
alphanumeric characters. 

10 If you want to add another Series, complete the following steps to create a pipeline 
Series chain (Figure 3-69): 

a Repeat steps 4-9 to add another Series. 

b Click the down arrow in the Previous Series field and select the Series that 
precedes the currently selected series. 

c Repeat step 10 to add additional Series in the chain as needed. 

NOTE: PCS Axis uses the preceding Series of each Series in a chain to calculate the 
Relative Milepost. All Series in a chain except the first Series require that you 
identify the Previous Series (Figure 3-69). 

The following example illustrates a pipeline Series chain with two Series in the 
chain (Figure 3-69). Series A was added for the original pipeline segment with a 
start and end milepost of 0+00 and 40+00 respectively. Series B was added for a 
pipeline extension. Because the mileposts are in reverse order in Series B, the 
Pipeline Series is set up with a start and end milepost of –38+00 and 0+00 
respectively. Also see Figure 3-67 (page 115) for an illustration of a pipeline Series 
chain with calculated Relative Mileposts. 
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Figure 3-69.  Pipeline Series

11 Click the  close button to close the Pipeline Series window. 

When a message similar to the following example displays, click  OK to apply 
pipeline Series to effected mileposts (Figure 3-70). 

The following message displays to notify you of the facilities that need to have 
pipeline Series applied in the facility data entry grid. Red facility records in the data 
entry grid identify milepost numbers that require a pipeline Series applied to the 
record. 

Figure 3-70.  Pipeline Series Message
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The remaining steps explain how to apply pipeline Series to effected mileposts in a 
data entry grid. 

12 Open the data entry grid with the mileposts you want to apply pipeline Series, 
such as the Test Point Inspection data grid shown in the next example (Figure 3-
71, page 118). 

NOTE: Red facility records in the data grid identify milepost numbers that require 
a Pipeline Series applied to the record. 

13 Select the Series field for a facility record in the grid to display a drop-down arrow. 
Click the arrow and select a pipeline Series in the selection list. Repeat this step for 
each effected facility record in the data grid. 

Figure 3-71.  Pipeline Series

14 Click  Refresh to update data in the grid. 

PCS Axis automatically calculates the Relative Milepost for each facility record 
assigned a pipeline Series in the data entry grid. In the following example, PCS Axis 
calculates relative milepost 40+00 as the end of Series A and the beginning of 
Series B. (Figure 3-72). 
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Figure 3-72.  Relative Milepost

Working with a User Defined Module
If you need to manage compliance data for facility types not included in PCS Axis, use 
Custom Module Management (CMM) to add a user defined module. For example, adding 
a user defined module with user defined facility types allows you to manage compliance 
data for major components associated with a cathodic protection electrical system or a gas 
odorization system. 

IMPORTANT: PCS Axis supports up to ten (10) user defined modules with each module 
supporting up to ten (10) user defined facility types. 

CMM is an optional add-on feature that requires an activation key for operation. If your 
company has purchased the CMM module, use the information in this section to set up a 
user defined module with user defined facility types. Topics in this section include those in 
the following list:

• Understanding a User Defined Module (page 120)

• Adding a User Defined Module (page 121)

• Deleting a User Defined Module (page 125)
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Understanding a User Defined Module
A user defined module (UDM) provides the same features and functions as a system 
installed module. It is available for use throughout PCS Axis, such as the Modules, Data 
Entry, and Reports/Graphs menus; Field and UDF Customizations, Bridge, and Email 
Notification. 

Likewise, the following features provided with a system installed module are also provided 
with a user defined module: Information, Inspection, and Maintenance data entry grids; 
layout, sorting, and filter themes; reports and graphs; and optional routes, schedules, and 
scheduling types for user defined facility types. 

The process for adding a user defined module includes the following tasks (Figure 3-73):

• Add a user defined module with user defined facility type(s) in Custom Module 
Management (Modules > Custom Module Management).

• Add one or more user defined fields (UDFs) as needed to be used throughout the 

• system, such as data entry grids, reports, and graphs (Tools > Field and UDF 
Customizations). 

• Set up data entry grids (Data Entry > Edit <module> Data); reports and graphs 
(Reports/Graphs); scheduling (Data Entry > Edit Schedule Settings and Define 
Schedules); and routes (Data Entry > Define Routes). 
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Figure 3-73.  Workflow for Adding a User Defined Module

Adding a User Defined Module
Information in this section explains how to add a user defined module with one or more 
user defined facility types. A user defined module supports up to six (6) user defined 
facility types. 

Complete the following steps: 

1 Click File > Select ROWs to open the Select ROWs window. Select one or more 
pipeline segments and then click  Save to close the window (Figure 3-74). 

Figure 3-74.  Select ROWs

Set properties in CMM (Modules > Custom 
Module Management)

Add User Defined Module(s)

Add User Defined Facility Type(s)

Set Option for Schedules and Routes

1 Add User Defined Module

Set properties as needed for the following 
system features:

Add User Defined Fields
(Tools > Field and UDF Customizations)

Set Up Data Entry Grids with Layout, 
Sorting, and Filter Themes

(Data Entry > Edit <module> Data) 

Set Up Reports/Graphs with Layout, 
Sorting, and Filter Themes

(Reports/Graphs)

Set Up Scheduling and/or Routes

(Data Entry > Edit Schedule Settings & 
Define Schedules; Define Routes)

2 Set Up System Features
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2 Open CMM and add a user defined module. Click Modules > Custom Module 
Management >  Add Module (Figure 3-75). 

PCS Axis adds a group of fields for the new user defined module. Fields with an 
error icon  indicate a required data entry field. 

Figure 3-75.  Custom Module Management

3 To set Name, Acronym, and Color properties for the user defined module, follow 
these steps (Figure 3-76): 

a Type a name in the Name field. The field accepts up to 50 alphanumeric 
characters including spaces and special characters. 

NOTE: Clicking the  toggle button in the  information bar displays 
information related to required property settings. 

b Type an acronym in the Acronym field. This field accepts up to four (4) alpha 
characters. It does not support numeric or special characters. 

c Click the down arrow in the Color field and select a color in the color palette. 

The following example shows a user defined module with the following 
property settings: module name is My CP Electrical System, module acronym 
is MCPE, and module color is Aquamarine. 
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Figure 3-76.  Custom Module Management

4 To set properties for one or more user defined facility types, complete the 
following steps (Figure 3-77):

a Type a name in the Name field. The field accepts up to 30 alphanumeric 
characters including spaces and special characters. The name you provide 
appears in data entry grids, reports and graphs, scheduling, routes, and so on. 

b Type a longer name for the user defined facility in the Long Name field. This 
field accepts up to 40 alphanumeric characters including spaces and special 
characters. 

c Type an acronym for the user defined field in the Short Name field. The field 
accepts up to four (4) alpha characters. It does not support numeric or special 
characters. 

d If you want the facility type available for selection when setting up a schedule, 
click the check box Is Schedulable. Likewise, click the check box Is Routable 
to have the facility type available for selection when setting up a route. 

The following example shows a user defined module with user defined facility 
types labeled Electric Meters, Transformers, Power Poles, and Circuit 
Breakers (Figure 3-77). 
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Figure 3-77.  Custom Module Management

e To add another user defined facility type, repeat steps "a" through "d". You can 
add up to six (6) user defined facility types for each user defined module. 

f Click  Save. 

NOTE: Clicking the  close icon in the group box of user defined facility types 
closes the group box. Use this feature when you only want to view property 
settings of user defined modules. To re-open the group box, click the  open icon. 

5 Click  to close the Custom Module Management window. 

6 Set up the following system features as needed:

a Add fields related to the user defined module in Fields and UDF 
Customizations > Facility Surveys. Refer to Setting Properties in Field and 
UDF Customizations (page 61).

b Set up data entry grid Layouts, Sorts, and Filters. Refer to Working with 
Themes and Filter Groups (page 295). 

c Set up reports and graphs. Refer to Using Reports and Graphs (page 667).

d Set up scheduling and routes. Refer to Using a Schedule (page 415) and 
Using a Route (page 349). 
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Deleting a User Defined Module
Deleting a user defined module also deletes all user defined facility types, reports, graphs, 
schedules, routes, and facility data associated with the module. 

To delete a user defined module, follow these steps:

1 Click File > Select ROWs to open the Select ROWs window. Select one or more 
pipeline segments and then click  Save to close the window (Figure 3-74, 
page 121). 

2 Open CMM. Click Modules > Custom Module Management. 

3 Click the  delete button for the user defined module you want to delete 
(Figure 3-78). 

4 When the warning message Confirm module delete opens, click  Delete to 
delete the module or  Cancel to cancel the operation. 

5 Click  to close the Custom Module Management window. 

Figure 3-78.  Custom Module Management
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Notes
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Working with Pipeline Records

This chapter explains how to work with folders and pipelines in the system hierarchy tree. 
The information is intended for users with SysAdmin user permissions unless noted 
otherwise. 

Topics in chapter include those in the following list:

• Adding a Folder in the Hierarchy (page 128)

• Adding a Pipeline in the Hierarchy (page 129)

• Moving and Renaming a Pipeline (page 132)

• Deleting a Pipeline (page 133)

• Understanding Default Location Formats (page 134)

• Selecting a Default Location Format (page 137)

• Adding a Pipeline Information Record (page 139)

• Adding a Pipeline Maintenance Record (page 142)

• Attaching a Document to a Pipeline Record (page 146)

• Working with Themes and Filter Groups (page 155)

• Filtering Data in a Grid (page 171)
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Adding a Folder in the Hierarchy
The hierarchy is an organizational structure of one or more folders. Folders are organized 
in a tree structure based on the number of hierarchy levels set up in the system. The top 
level of the hierarchy is the root level that identifies your company’s name. All hierarchy 
folders are added below the root level. The lowest level of the hierarchy includes a folder 
with pipelines added in the system (Figure 4-1, page 128). 

NOTE: The names of hierarchy folders as well as ROW Code and ROW Name support up 
to 100 characters. 

To add a folder in the hierarchy, follow these steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-1).

2 Select a level in the hierarchy you want to add a folder. The following example 
shows level 2 selected in a three level hierarchy tree. 

Figure 4-1.  Select ROWs

3 Click  Add to open the Add New Node dialog box (Figure 4-2, page 129). 

NOTE: You can also open the Add New Node dialog box by right-clicking a 
selection in the hierarchy tree and selecting Add in the shortcut menu that opens.

4 Add information for the new hierarchy folder. Fields requiring information include 
a  red icon, such as System and ROW Code shown in the next figure. 
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5 Click the option Expand After Adding if you want to expand the selection tree 
after clicking Apply. 

6 Click  Apply. Repeat steps 2 through 5 as needed to add additional folders in 
the hierarchy tree. 

Figure 4-2.  Add New Node

Adding a Pipeline in the Hierarchy
To add a pipeline in the hierarchy, follow these steps: 

1 If the Select ROWs window is not open, click File > Select ROWs (Figure 4-3). 

2 Select a folder in the hierarchy you want to add a pipeline. In the following 
example, another pipeline will be added in the Mains folder. 

Figure 4-3.  Select ROWs
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3 Click  Add to open the Add New Node dialog box (Figure 4-4). Right-clicking 
the selected hierarchy folder and selecting Add in the shortcut menu also opens 
the Add New Node dialog box. 

Figure 4-4.  Add New Node

4 Enter a pipeline code for the new pipeline in the ROW Code field. Fields 
requiring information include a  red icon, such as ROW Code in the previous 
figure (Figure 4-4). 

NOTE: The names of hierarchy folders as well as ROW Code and ROW Name 
support up to 100 characters. 

5 Type a name for the pipeline in the ROW Name field. 

6 Click the option Expand After Adding if you want to expand the selection tree 
after clicking Apply. 

7 Click  Apply. Repeat steps 3 through 6 as needed to add another pipeline in the 
selected hierarchy folder. 

8 Continue with Understanding Default Location Formats (page 134) for 
information about setting this required field for all pipelines in the system. 
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Using Find in Select ROWs
Use the Find drop-down list in the Select ROWs window when searching for a particular 
pipeline segment in the hierarchy. The Find drop-down list includes the following options 
for locating and selecting a pipeline segment in the hierarchy: 

• Code: searches the hierarchy by ROW Code. 

• Name: searches the hierarchy by ROW Name. 

• Code and Name: searches the hierarchy by ROW Code and Name. Using this 
option requires that you include the semi-colon separator between the ROW Code 
and ROW Name, such as LG123A ; NE Paddock LG123. 

To search the hierarchy for a particular pipeline segment in the Select ROWs window, 
follow these steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-5). 

2 Choose an option in the Find Now drop-down list to search for a pipeline segment 
in the hierarchy. Click the down arrow in Find ROW and select Code, Name, or 
Code and Name. 

3 Based on the selected search option, type the ROW Code, ROW Name, or the 
ROW Code and Name of the pipeline segment in the field Enter Search Text. 

4 Select one of the following options to choose how search results are handled: Find 
Only, Find and Select, Clear Selections, Find and Select. Hovering the mouse 
over an option displays a tooltip with a description of option. 

5 Click the check box Expand Display if you want PCS Axis to expand the hierarchy 
when a search match is located. 

6 Click  Find. 
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Figure 4-5.  Select ROWs

Moving and Renaming a Pipeline
Complete the following steps to move or rename a pipeline in the hierarchy: 

1 If the Select ROWs window is not open, click File > Select ROWs and then select 
a pipeline in the hierarchy (Figure 4-6). 

2 To move the selected pipeline to a different hierarchy folder, right-click the pipeline 
and select Cut in the shortcut menu that opens. Right-click the hierarchy folder 
you want to move the pipeline to and then select Paste in the shortcut menu that 
opens (Figure 4-6). 

Figure 4-6.   Move Pipeline
132 Working with Pipeline Records



PCS Axis User and Administrator Guide
3 To rename the selected pipeline, follow these steps:

a Click  Rename to open the Rename dialog box (Figure 4-7). Right-clicking 
the selected pipeline and selecting Rename in the shortcut menu also opens 
the dialog box. 

b Type a name for the pipeline in the pipeline Code field. In the following 
example, D-1234 has been entered in the ROW Code field. Click  Save to 
apply the change and close the dialog box. 

Figure 4-7.  Rename Pipeline

Deleting a Pipeline
The procedure in this section explains how to delete a pipeline in the hierarchy. Deleting a 
pipeline also deletes all facilities and history records associated with the pipeline. 

IMPORTANT: Instead of deleting a pipeline, consider creating a new hierarchy folder 
labeled Sold, Abandoned, or something similar and then moving the pipeline to that 
folder. Another option is to change the operational status of the pipeline by disabling the 
Active check box in Edit ROW Detail (Data Entry > Edit ROW Detail). Using either of these 
methods will preserve data for future references. 

To delete a pipeline, follow these steps: 

1 Click File > Select ROWs to open the Select ROWs window. Select a pipeline in 
the hierarchy you want to delete (Figure 4-8). 
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Figure 4-8.  Select ROWs

2 Click  Delete to open the Confirm Delete dialog box (Figure 4-9, page 134). Or, 
right-click the selected pipeline in the hierarchy tree and select Delete in the 
shortcut menu to open the Confirm Delete dialog box. 

NOTE: The Confirm Delete dialog box identifies the pipeline and number of 
associated facilities to be deleted in the Count column (Figure 4-9, page 134). 

3 Click  Delete to delete the pipeline or  Cancel to cancel the operation. 

Figure 4-9.  Confirm Delete

Understanding Default Location Formats
The following table (Table 4-1) identifies milepost formats available for selection when 
setting the Default Location Format for a pipeline in Edit ROW Detail. Choosing a 
Default Location Format allows PCS Axis to automatically apply the correct formatting to 
milepost values you enter for a facility location on a pipeline. 
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Table 4-1.  Description of Default Location Formats

Location Format Format Example Description

Metric Milepost 1.234AB, 1,234AB, 
or 1+234AB

Measurements are in metrics. This 
format can include two alpha characters 
at the end of the milepost and can also 
be graphed. Measurements are in 
kilometers and meters. Based on the 
metric delimiter set in system Options, 
this format supports a Period, Comma, 
or Plus sign. For example, 1.234AB is 1 
kilometer (km) and 234 meters (m). 

Milepost (3 Decimals) 12345.567

-or-

1234.567AB

Format supports two alpha characters at 
the end of the milepost and can also be 
graphed. This format uses the U.S. 
Standard measurement system. 

Milepost (4 Decimals) 123.5678

-or-

1234.5678A

Format supports one alpha character at 
the end of the milepost and can also be 
graphed. This format uses the U.S. 
Standard measurement system. 

Reading Number 12345678AB This is an alphanumeric format with 
support for two alpha characters at the 
end. It is typically used for stations. The 
format also uses the U.S. Standard 
measurement system. 

This format cannot be graphed and the 
CP Compliance Report does not 
calculate total feet, total miles, or miles 
below criteria.
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Location ID 1234567891

-or-

ABCDEFGHIJ

NOTE: Location ID cannot be changed 
once it is set up. 

Use Location ID when footages are not 
applicable. This format is typically used 
in distribution systems. Other features 
include those in the following list: 

• Uses the U.S. Standard measurement 
system; accepts alphanumeric 
characters; and cannot be graphed. 

• CP Compliance Report does not 
calculate total feet, total miles, or 
miles below criteria when using this 
format. 

Station Number 12345+67AB Measurements are in feet. This format 
can be graphed; supports two alpha 
characters at the end of the milepost; 
and uses the U.S. Standard 
measurement system. 

Miles+100 Feet 12345+12

-or-

12345+12AB

Format uses miles plus two digits to the 
right to indicate hundreds of feet. For 
example, 110+12 indicates 110 miles 
and 1,200 feet. Do not enter values 
greater than 53 feet; doing so indicates 
another mile.

Other characteristics include:

• Format can be graphed.

• Two alpha characters can be used 
after the first 3 numbers.

• CP Compliance Report does not 
calculate total feet, total miles, or 
miles below criteria. 

• Uses the U.S. Standard 
measurement system.

Table 4-1.  Description of Default Location Formats

Location Format Format Example Description
136 Working with Pipeline Records



PCS Axis User and Administrator Guide
Selecting a Default Location Format
Information in this section explains how to set up Default Location Format and other 
pipeline information. A Default Location Format must be set for each pipeline added in 
the system hierarchy. See Understanding Default Location Formats (page 134) for 
information about available formats. 

Complete the following steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-10).

2 Select one or more pipelines and then click  Save to close the window. 

Figure 4-10.  Select ROWs

3 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-11, page 138). 

4 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 

Miles/Station Number 123A 45+67

-or-

123A 12+34

Format uses Miles<space>Station 
Number with Milepost (3 Decimals) in 
graphs. This format uses the U.S. 
Standard measurement system.

Table 4-1.  Description of Default Location Formats

Location Format Format Example Description
Working with Pipeline Records 137



PCS Axis User and Administrator Guide
5 Select a pipeline in the Information grid. 

6 Select the field Default Location Format to display a drop down arrow. Click the 
arrow and select a location format in the selection list. (See Understanding 
Default Location Formats (page 134) for a description of available choices.)

7 Click  Add in the Facility Location ID Formats mini-grid. A list of all facility 
types display in the mini-grid with the location format selected in step 6. If you 
want to change the location format for a particular facility type listed in the mini-
grid, follow these steps:

a Select a row of records in the mini-grid with the facility type you want to 
change the location format. 

b Select the field Facility Location Format to display a drop down arrow. Click 
the arrow and select a location format in the selection list. 

8 Set up other pipeline information as needed then click  Refresh. When you 
finish, click the  close icon to close the Edit ROW Detail window. 

Figure 4-11.  Edit ROW Detail

Click the Selected ROWs 
bar to expand and collapse 
the Selected ROWs panel. 
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Adding a Pipeline Information Record
Use the Information grid in Edit ROW Detail to add an information record for a pipeline 
selected in the Select ROWs window. Adding an information record allows you to maintain 
history records when important permanent information changes, such as when a pipeline 
is taken out of service or is sold to another business. 

NOTE: If you are working with the optional Telluric Compensation feature, the required 
field labeled Telluric Compensation Required must be added in the Information grid and 
enabled for each pipeline segment requiring telluric compensation. For more information 
refer to Adding a Layout Theme (page 156). 

To add a pipeline information record, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 4-12, 
page 139). 

2 Select one or more pipeline segments you want to work with by clicking the check 
box for each pipeline segment. Click  Save to close the window. 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 

Figure 4-12.  Select ROWs
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3 Open the Edit ROW Detail grid. Click Data Entry > Edit ROW Detail (Figure 4-
13). 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 If the Information grid is not visible, click the Information tab . 

Figure 4-13.  Information Grid

6 Click  Add to open the Add Record dialog box (Figure 4-14). 

Figure 4-14.  Add Record
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7 Select the pipeline in the dialog box that you want to add an information record. 
For example, pipeline LG123-A is selected in the next figure (Figure 4-15). 

Figure 4-15.  Add Record

8 Click  Save to display required field(s) for data entry (Figure 4-16). 

9 Type a date in the Effective Date field using the format MM/DD/YYYY to indicate 
the month, day, and year. Or click the down arrow in the field and select a date 
using a calendar. 

Effective Date is the date a history record becomes effective, such as when a 
pipeline becomes inactive or is taken out of service. See Creating History Records 
Using an Effective Date (page 233) for more information. 

Figure 4-16.  Add Record
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10 Click  Save to close the Add Record dialog box and add an information record 
in the grid for the existing pipeline (Figure 4-16). 

11 Provide other pipeline data in the grid as needed, such as Permanent Comments. 

12 Click  Refresh to update the grid. 

Figure 4-17.  Information

Adding a Pipeline Maintenance Record
Use the Maintenance grid in Edit ROW Detail to add a maintenance record for a pipeline 
selected in the Select ROWs window. Adding pipeline maintenance records allows you to 
examine the effectiveness of a maintenance program. You can either view data in the 
maintenance grid of Edit ROW Detail or run a ROW maintenance report. 

To add a pipeline maintenance record, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 4-12, 
page 139). Select one or more pipeline segments you want to work with by clicking 
the check box for each pipeline segment. Then click  Save to close the window. 

2 Open Edit ROW Detail. Click Data Entry > Edit ROW Detail (Figure 4-18, 
page 143). 

3 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.
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4 Click the Maintenance tab  to open the Maintenance grid (Figure 4-
18). 

Figure 4-18.  Maintenance

5 Click  Add to open the Add Record dialog box (Figure 4-19). 

Figure 4-19.  Add Record
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6 Select a pipeline in the dialog box that you want to add a maintenance record. For 
example, pipeline LG123-C is selected in the next figure (Figure 4-20). 

Figure 4-20.  Add Record

7 Click  Save to display required field(s) for data entry. Required fields are 
identified with the  icon, such as ROW Repair Code in the next figure 
(Figure 4-21). 

8 Type a repair code in the field ROW Repair Code. Repair code is a designation 
used by your company to identify the type of repair. The field accepts up to 15 
alphanumeric characters including special characters such as the pound sign (#), 
asterisk (*), or hyphen (-). 

9 Type a date in the field ROW Repair Found Date using the format MM/DD/YYYY 
to indicate the month, day, and year. Or click the down arrow in the field and select 
a date using a calendar. 

Figure 4-21.  Add Record
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10 Click  Save to close the Add Record dialog box and add a pipeline maintenance 
record in the grid (Figure 4-22). 

11 Provide other maintenance data in the grid as needed. For example, provide a date 
in the fields ROW Repair Initiated Date and ROW Repair Corrected Date; a 
maintenance reference number in the field ROW Reference Number ; and remarks 
about the repair in the field ROW Repair Remarks. 

12 Click  Refresh to update the grid. 

Figure 4-22.  Maintenance
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Attaching a Document to a Pipeline Record
Attaching a document to a pipeline record in Edit ROW Details is similar to attaching a 
document to a record in a data entry grid (page 317). Use the Attached Document field in 
the Information and Maintenance grid of Edit ROW Details to link or embed a file or 
webpage address to a pipeline record. Supported file types include image, video, HTML, 
XML, music, and text files (such as Microsoft Word, WordPad, Notepad, or PowerPoint 
files). 

As an example, you can attach an image of a pipeline; a document describing your 
company’s safety procedures; or a document identifying a manufacturer’s specification for 
a piece of equipment. 

Linking a document identifies the file location on a local computer, company network, FTP 
site, or webpage on the Internet. Linking documents stored on a local computer are 
accessible only from that computer. Embedding a document stores a copy of the file in the 
PCS Axis database. 

NOTE: Storing copies of documents in the PCS Axis database increases the size of the 
database. 

If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes. 

Editing an embedded document applies changes only to the copy stored in the PCS Axis 
database; changes do not apply to the source file stored outside of PCS Axis. Likewise, 
editing a source file applies changes only to the source file, not the copy stored in PCS 
Axis. 

Topics in this section include those in the following list:

• Adding the Attached Document Field in the Grid

• Attaching a Document to a Pipeline Record (page 148)

• Viewing an Attached Document (page 153)

NOTE: For information about how to attach a document to a record in a data entry 
grid, Using Data Entry Grids and Forms (page 209). 
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Adding the Attached Document Field in the Grid
If the Attached Document field is not present in the Information or Maintenance grid of 
Edit ROW Details, complete the following steps to add the field: 

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Details to open the Edit ROW Detail window 
(Figure 4-23). 

Figure 4-23.  Edit ROW Detail

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again (Figure 4-23, page 147). 

4 Based on the grid you want to add the Attached Document field, click the 
Information  or Maintenance  tab if either of these grids is 
not visible. 

5 Click the Customize tab  to view the Layouts page (Figure 4-24, 
page 148). 

6 Choose a grid layout theme. Click the down arrow in Select Layout Theme and 
select a layout theme in the selection list. 

7 Double-click  All Fields in the left pane of the window to view a list of fields 
available for selection. 
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8 Add the field ROW Attached Documents in the layout theme. Double-click ROW 
Attached Documents in the left pane of the Layouts page to move it to the right 
pane. Add other fields as required. The layout theme includes all fields listed in the 
right pane (Figure 4-24). 

9 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the  up or  down button. 

10 Click  Save and Close to save changes and return to the grid. 

Figure 4-24.  Layouts

Attaching a Document to a Pipeline Record
Complete the following steps to attach a document to a pipeline record in the 
Information or Maintenance grid of Edit ROW Detail: 

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-25). 

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 
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4 If you want to attach a document to a pipeline record in the Information grid, click 
the Information tab if the grid is not visible. 

To attach a document to a pipeline record in the Maintenance grid, click the 
Maintenance tab to display the Maintenance grid. 

5 Click the edit icon  in the ROW Attached Document field for the pipeline 
record you plan to attach a document (Figure 4-25). 

Figure 4-25.  Edit ROW Detail 

6 When the Maintain Attached Documents dialog box opens, click  Attach and 
then select one of the following options (Figure 4-26, page 150):

• Link Document: Select Link Document if you plan to link to a document on 
a local computer or company network, or want to add a link to a webpage on 
the Internet. Then continue with step 7 (page 150) or step 8 (page 151). 

• Embedded Document: Select Embedded Document if you want to store a 
copy of an attached document in the PCS Axis database. Then continue with 
step 9 (page 152). 

NOTE: Storing copies of attached documents in the database increases the 
size of the database. 
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7 If you selected Link Document in step 6 and want to link to a file on a local 
computer or company network, follow these steps (Figure 4-26): 

a Click the ellipsis button … in the Document field to open the Link File dialog 
box. Then navigate to the file and select it. Click Open to link to the file and 
close the dialog box. 

b Type a description for the linked file in the Description field of the Maintain 
Attached Documents dialog box. When a description is not provided, PCS 
Axis uses the filename of the linked document as the description. 

NOTE: A list of attached documents display in the dialog box. Selecting an 
item in the list displays its location in the Document field. 

Figure 4-26.  Maintain Attached Documents

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 
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8 If you selected Link Document in step 6 and want to add a link to a webpage on 
the Internet, follow these steps (Figure 4-27): 

a Type an Internet address in the Document field. For example, type 
http://www.aiworldwide.com in the field. 

b Type a description for the link in the Description field. When a description is 
not provided, PCS Axis uses the Internet address in the Document field as the 
description. 

Figure 4-27.  Maintain Attached Documents

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 
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9 If you selected Embedded Document in step 6, complete the following steps 
(Figure 4-28):

a Click the ellipsis button … in the Document field to open the Embed File 
dialog box. Then navigate to the file and select it. Click Open to embed a copy 
of the file and close the dialog box. 

b Type a description for the embedded file in the Description field. If a 
description is not provided, PCS Axis uses the filename of the embedded file 
as the description. 

NOTE: A list of attached documents display in the dialog box. Selecting an 
item in the list displays its location in the Document field. 

Figure 4-28.  Embedded Document

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Local changes made to embedded documents won’t be saved into PCS. 
Do you want to continue? 

NOTE: Editing an embedded document applies changes only to the copy 
stored in the PCS Axis database; changes do not apply to the source file stored 
outside of PCS Axis. Likewise, editing a source file applies changes only to the 
source file, not the copy stored in PCS Axis. 
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Viewing an Attached Document
If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes. 

To view or open an attached document, follow these steps:

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-29). 

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 

4 Open the grid that includes the pipeline record with the attached document by 
clicking either the Information  or Maintenance  tab.

5 Click the preview icon  for the pipeline record with the attached document you 
want to view. 

Figure 4-29.  Edit ROW Detail
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6 Select a file in the list on the left side of the window to view the file in the Preview 
Attached Documents window (Figure 4-30). 

7 If the file type of the attached document is associated with a default software 
program on the local computer, click  Open to open the file. 

8 Click the close button  to close the Preview Attached Documents window.

NOTE: When you open and then edit an embedded document, changes apply 
only to the copy stored in the PCS Axis database; changes do not apply to the 
source file stored outside of PCS Axis. Likewise, editing the source file applies 
changes to the source file, not the copy stored in the PCS Axis database. 

Figure 4-30.  Preview Attached Documents
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Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as grid layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] ROW 
Information. 

A filter group is a named set of one or more filters that affect the data output in the Edit 
ROW Detail grid. PCS Axis provides two types of filter groups you can define. These 
include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in the Edit ROW Detail grid. Adding an AND filter group produces a 
subset of records that meet all filter conditions. Adding an OR filter group produces a 
subset of records that meet any filter condition. When you apply a filter group to the grid, 
PCS Axis processes filters in descending order beginning with the filter at the top of the 
group. 

The following sections describe how to add a layout theme, sort theme, and an optional 
filter group in the Information and Maintenance grids of Edit ROW Detail. Topics include 
those in the following list: 

• Adding a Layout Theme

• Adding a Sort Theme (page 160)

• Adding an AND Filter Group (page 163)

• Adding an OR Filter Group (page 166)

• Editing and Arranging Filters and Filter Groups (page 168)

NOTE: Also see Filtering Data in a Grid (page 171) for information about 
filtering the data output in a data entry grid. 
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Adding a Layout Theme
A layout theme is a group of fields that determine which fields are available for use in the 
Information and Maintenance data grid of Edit ROW Detail. Adding a new Layouts 
theme allows you to choose which fields to include in the data grid and then save the 
layout as a theme for later use. 

IMPORTANT: If you are working with the optional Telluric Compensation feature, you can 
add a layout theme that includes the required field Telluric Compensation Required. This 
field must be enabled in the Information data grid of Edit ROW Detail for each pipeline 
segment requiring telluric compensation. 

To add a layout theme for the Information or Maintenance data entry grid in Edit ROW 
Detail, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31). 

Figure 4-31.  Select ROWs

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. If you 
want to collapse the Selected ROWs panel to view more of the Edit ROW Detail 
grid, click Selected ROWs. To expand the panel, click Selected ROWs again 
(Figure 4-32, page 157). 

3 To add a layout theme for the Information grid, click the Information tab 
 if the grid is not visible. Click the Maintenance tab  to 

display the Maintenance grid if you want to create a layout theme for this grid. 
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Figure 4-32.  Edit ROW Detail

4 Click the Customize tab  then  Add to open the New Layout Theme 
dialog box. The following figure shows an example when adding a layout for the 
Information grid (Figure 4-33). 

Figure 4-33.  New Layout Theme

5 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 
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6 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

7 Click  OK to save changes and return to the Layouts page (Figure 4-34). 

Figure 4-34.  Layouts

8 Complete the following steps in the Layouts page to add and remove fields in the 
new layout theme as needed:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The grid layout theme includes all fields listed in the right 
pane of the Layouts page. 

c If telluric compensation is required for the selected pipeline segment(s), add 
the field labeled Telluric Compensation Required in the layout theme. 

d To remove a field in the layout theme, double-click a field listed in the right 
pane to move it to the left pane. Repeat this step as needed. 

NOTE: Fields with a lock icon  are required and cannot be removed from the 
theme, such as  ROW Code shown in the previous example (Figure 4-34, 
page 158). 
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9 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the  up or  down button. 

10 Click  Save to save changes. 

11 To apply the new layout theme to the data entry grid: 

a Click the Options tab  to open the options page (Figure 4-35). 

b Click the down arrow in the field Select Layout Theme and select the new 
layout theme in the selection list. 

c Click  Apply to save changes and return to the data entry grid. 

Figure 4-35.  Options

12 If telluric compensation is required for the selected pipeline segment(s), click the 
Telluric Compensation Required check box for each pipeline segment requiring 
compensation. 

A check mark inside the check box indicates the option is enabled. To disable the 
option, click the check box again to remove the check mark. 
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Adding a Sort Theme
A sort theme determines how PCS Axis sorts records in a data entry grid. Adding a sort 
theme allows you to choose which field(s) to sort records by and if records sort 
alphanumerically in ascending or descending order. 

To add a sort theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 156). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 157).

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 To add a sort theme for the Information grid, click the Information tab 
 if the grid is not visible. Click the Maintenance tab  to 

display the Maintenance grid if you want to create a sort theme for this grid. 

4 Click the Customize tab  then the Sorts button  to open 
the Sorts page (Figure 4-36). 

Figure 4-36.  Sorts
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5  Click  Add to open the New Sort Layout dialog box (Figure 4-37). 

Figure 4-37.  New Sort Layout

6 Type a name for the sort theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the sort theme saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

7 Select a sort theme with fields you want to copy to the new sort theme. Click the 
down arrow in Copy Fields From Theme and select a theme in the selection list. 

8 Click  OK to save changes and return to the Sorts page (Figure 4-38, page 162). 

9 Complete the following steps in the Sorts page to add and remove fields in the 
new sorting theme as needed: 

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The sorting theme includes all fields listed in the right 
pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. Repeat this step as needed. 
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10 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

11 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

Figure 4-38.  Sorts

12 Click  Save to save changes.

13 To apply the new sort theme to the data entry grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 4-39, 
page 163). 

b Click the down arrow in the field Select Sort Theme and select the new sort 
theme in the selection list. 

c Click  Apply to save and apply changes and then return to the data entry 
grid. To cancel changes, click the Options tab  or  Cancel to return 
to the grid. 
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Figure 4-39.  Options

Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in the 
Edit ROW Detail grid. Adding an AND filter group produces a subset of records that meet 
all filter conditions. PCS Axis processes filters in a filter group in descending order 
beginning with the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 156). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 157). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 

4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-40, page 164). 

5 Click  New ‘And’ Group to open the filter properties group box. 
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Figure 4-40.  Filters

6 Type a name for the filter group in the field Filter Group Caption. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. Then click the 
 edit icon to display selection fields. 

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps 7 through 9 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 
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12 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

13 To apply one or more custom filter groups to the data entry grid of Edit ROW 
Detail, follow these steps (Figure 4-41, page 165):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. 

c Click  Apply to save changes and return to the data entry grid. To cancel 
changes, click the Options tab  or  Cancel to return to the data 
entry grid. 

Figure 4-41.  Options
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Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output of a 
report. Adding an OR filter group produces a subset of records that meet any filter 
condition. PCS Axis processes filters in a filter group in descending order beginning with 
the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 156). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 157). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 

4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-42). 

5 Click  New ‘Or’ Group to open the filter properties group box. 

Figure 4-42.  Filters
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6 Type a name for the filter group in the field Include records that match any of 
these conditions (Figure 4-42, page 166). 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps 7 and 8 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save.

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

13 To apply one or more custom filter groups to the data entry grid of Edit ROW 
Detail, follow these steps (Figure 4-43, page 168):

a Click the Options tab  to open the options page. 
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b Click the check box for each filter you want to apply. 

c Click  Apply to save changes and return to the data entry grid. To cancel 
changes, click the Options tab  or  Cancel to return to the data 
entry grid. 

Figure 4-43.  Options

Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 156). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 157). 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 
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4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-44). 

5 Click the edit icon  to display a filter’s property settings.

Figure 4-44.  Filters

6 To delete a filter in a filter group, click the filter’s  delete button (Figure 4-
45). Then click  Yes when the Delete message displays. 

7 To rename a filter, type a description in the filter’s name field. 

8 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 

9 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

10 Click the  close button to close the filter’s property settings group box. 
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11 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save and Close to save changes and return to the data entry grid. 

Figure 4-45.  Filters
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Filtering Data in a Grid
Information in this section explains how to filter the data output in any data entry grid in 
Edit ROW Detail. It includes a description of the options and filters available in the 
Options page when working with the Information and Maintenance grids. Filtering data 
allows you to work with only those records you are interested seeing in the grid. 

Topics in this section include those in the following list:

• Filtering Data in the Information Grid

• Filtering Data in the Maintenance Grid (page 172)

Filtering Data in the Information Grid
To filter the data output in the Information grid of Edit ROW Detail, follow these steps: 

1 Click Data Entry > Edit ROW Detail. 

2 Click the Information tab , then the Options tab  to open the 
Options page (Figure 4-46). 

Figure 4-46.  Options/Information Grid
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3 To include only the most recent information record for each pipeline, select the 
check box Only the most recent information record for each facility. This 
option uses the Effective Date to filter the data output. 

NOTE: When using the Filters group box to apply additional filters to the data 
output, the most recent information record is found first, and then all other filters 
are applied to the data output. For more information about filters, see Adding an 
AND Filter Group (page 163) and Adding an OR Filter Group (page 166). 

4 Click  Apply to save and apply changes and then return to the Information 
grid. To cancel changes, click the Options tab  or  Cancel to return to 
the grid. 

Filtering Data in the Maintenance Grid
To filter the data output in the Maintenance grid of Edit ROW Detail, follow these steps: 

1 Click Data Entry > Edit ROW Detail. 

2 Click the Maintenance tab , then the Options tab  to open the 
Options page (Figure 4-47). 

Figure 4-47.  Options/Maintenance Grid
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3 Review the following descriptions and then select one or more filter options as 
required:

• Only include facilities with maintenance during the reporting time 
period: The data output for this option only includes those maintenance 
records that meet the filter criteria defined for a particular date or date 
range. Filter criteria is defined by filter settings in the Filters group box for 
any of the following time period fields: Effective Date, Repair Found Date, 
Repair Initiated Date, and Repair Corrected Date. 

• All maintenance that meet the filter criteria: This option includes all 
maintenance records in the data output that meet filter criteria based on filter 
settings in the Filters group box. 

• Apply other filters to the most recent maintenance found within the report 
timeframe: This option finds the most recent maintenance record within the 
reporting time frame first, and then applies other filter settings to the data 
output. Filter criteria for both of these are defined in the Filters group box. 
Use any of the following fields when defining filter criteria for the reporting 
time frame: Effective Date, Repair Found, Repair Initiated, and Repair 
Complete.

• The most recent maintenance after the filter criteria has been met: The 
data output for this option includes the most recent maintenance record only 
for those pipeline records that meet all other filter criteria first. Filter criteria 
for both of these are defined in the Filters group box. Use any of the following 
fields when defining a time period for the most recent maintenance record:
Effective Date, Repair Found, Repair Initiated, and Repair Complete.

NOTE: For more information about filters, see Working with Themes and 
Filter Groups (page 155). 

4 Click  Apply to save and apply changes and then return to the Maintenance 
grid. To cancel changes, click the Options tab  or  Cancel to return to 
the grid. 
Working with Pipeline Records 173



PCS Axis User and Administrator Guide
Notes
174 Working with Pipeline Records



5

Setting Up User Management

This chapter explains how to work with PCS Axis user accounts in User Management. The 
information is intended for users with SysAdmin security permissions. Topics in this 
chapter include those in the following list:

• Understanding User Management

• Using Computer Name User Authentication (page 176)

• Adding and Editing Users (page 176)

Understanding User Management
User Management controls system security using a role based method. Each PCS Axis 
user is defined in User Management and assigned a PCS Axis installed user role. A user 
role is a collection of security permissions that tells PCS Axis which system features a user 
has access to and if the user is allowed to add and edit data. 

The following list identifies the three types of PCS Axis installed user roles. Each type gives 
users a different level of security permissions. Users are assigned only one user role. The 
SysAdmin user role has full control of all PCS Axis features and functions. For a list of user 
role permissions assigned to the User and Read Only user roles, see Appendix C. System 
Security (page 791). 

• SysAdmin

• User

• Read Only

When PCS Axis first installs, it creates the first system account using Computer Name user 
authentication. This account is automatically assigned the SysAdmin user role, which has 
the highest set of privileges. See Using Computer Name User Authentication 
(page 176) for more information. 
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Using Computer Name User Authentication
PCS Axis uses Computer Name user authentication when logging users in to the PCS 
Axis database. If more than one user will share a single computer installed with PCS 
Axis, contact your IT department for information about setting up the required 
Windows user accounts on the computer. Login credentials must be unique for each 
PCS Axis user. If needed, refer to Windows Help and Support (Start > Help and 
Support), or visit the Microsoft website at the following address to learn more about 
Windows user accounts:  
http://windows.microsoft.com/en-US/windows7/User-accounts-recommended-links. 

Adding and Editing Users
Information in this section explains how to work with user accounts in User Management. 
The information is intended for the PCS Axis SysAdmin. Topics include those in the 
following list:

• Adding a New User (page 177)

• Editing an Existing User Account (page 178)

• Changing User Account Status from Active to Inactive (page 179)
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Adding a New User
To add a new user in PCS Axis, follow these steps:

1 Click Tools > User Management >  Add (Figure 5-1). 

Figure 5-1.  Adding a New User

2 Type a user name in the User Name field and the user’s email address in the 
Email field. 

3 Complete the following steps as needed:

a Edit information in the fields First Name, Last Name and Display Name.

b Type information in the Comment field. 

4 Select a PCS Axis user role by clicking the Read Only, User, or SysAdmin button. 
If needed, see System Security (page 791) for information about user role security 
permissions.

5 If you want to allow the user to create new facilities on the Allegro Field PC, click 
the check box Can Create New Facilities On the Allegro. 

NOTE: Clicking the Hierarchy Rights bar collapses the Hierarchy Rights panel 
allowing you to view more of the grid. Clicking the bar again expands the panel.
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6 If you want to include an image in the user account, complete the following steps. 
Maximum image size is 150 x 150 (measured in pixels). Valid image formats are 
BMP, JPG, GIF, and PNG. 

a Hover the mouse over the Image field to display a toolbar .

b Click the open icon  in the image toolbar to open Windows Explorer. 
Locate and select an image, then click Open to close the window.

7 If PCS Axis i set up with Hierarchical Security in Options, set permissions in 
Hierarchy Rights to identify which parts of the hierarchy the user will have access. 
This step applies only to users assigned with the User or Read Only user role. 
SysAdmin has full access to all items in the hierarchy.

To grant access, click the check box for an item in the hierarchy to place a check 
mark inside the check box. To remove access, click the check box again to remove 
the check mark. When you finish, click Apply. For information about Hierarchical 
Security in Options, see Setting Security Options (page 50). 

NOTE: Items in the hierarchy with a check mark indicate the user has access. If a 
check mark is not present, the user does not have access.

8 Click  Save to save changes. 

Editing an Existing User Account
Complete the following steps to edit an existing user account in User Management:

1 Click Tools > User Management (Figure 5-1, page 177). 

2 Select a user record in the grid. 

3 Change user information and Hierarchy Rights as needed. User information 
includes all fields, such as Domain, User Name, Email, Display Name, and so on.

4 Click  Save to save changes
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Changing User Account Status from Active to Inactive
If a user no longer requires access to PCS Axis, change the status of the user account in the 
following manner: 

1 Click Tools > User Management (Figure 5-2). 

2 Select a user record in the grid. PCS Axis indicates a selection by highlighting the 
record and displaying an arrow next to the Active property field. 

3 Click the Active check box to remove the check mark and change the user account 
status from active to inactive. 

4 Click Save to save changes. 

The Active property setting changes from Yes to No indicating the user account is 
now inactive (Figure 5-2). 

Figure 5-2.  User Account Status
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Using Survey Folder Maintenance

This chapter explains how to add, delete, and manage facility and continuous survey 
folders in Survey Folder Maintenance. The information is intended for users with 
SysAdmin security permissions unless noted otherwise. Topics in this chapter include 
those in the following list: 

• Working with a Facility Survey Folder (page 181). Information applies to all 
modules except Indirect Survey Manager.

• Working with a Continuous Survey Folder (page 184). Information applies only 
to Indirect Survey Manager (ISM). 

Working with a Facility Survey Folder
A facility survey folder is a group of inspection readings in a facility survey. PCS Axis uses 
facility survey folders to organize and track facility survey data. Facility survey folders are 
used throughout PCS Axis, including data entry grids, reports, Bridge, and Field Computer. 
You can also use a facility survey folder as an optional filter in a grid or report to easily 
retrieve a specific set of inspection records. 

Names of facility survey folders typically follow regulatory requirements for surveying 
pipeline segments and facilities. For example, when you create an annual survey folder 
labeled 2012 Annual Survey, you can then assign inspection readings to the facility 
survey folder throughout the year as they are completed. Names of facility survey folders 
are editable allowing you to name a survey folder using a naming convention that best 
suits your business needs. Examples of typical survey folder names include 2012 Feb 
Monthly Survey and 2001-2010 Ten Year Survey (Figure 6-1, page 182). 

Continue with the following topics for information about how to add, delete, and manage 
a facility survey folder: 

• Adding a Facility Survey Folder (page 182)

• Deleting a Facility Survey Folder (page 183)

• Using a Facility Survey Folder (page 184)
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Adding a Facility Survey Folder
A facility survey folder is typically added in PCS Axis before entering inspection readings in 
a data entry grid or importing inspection readings using Bridge or Field Computer. Adding 
a survey folder requires that you enter a survey folder name; select a survey start date; and 
then select a survey frequency. Based on this information PCS Axis automatically calculates 
the survey end date. 

If no survey folders exist when adding a new survey folder, PCS Axis names the survey 
folder using the current year, such as 2013 Annual Survey. When other survey folders do 
exist, PCS Axis increments the year by 1. For example, if the latest annual survey folder is 
2002 Annual Survey, PCS Axis names the next new survey folder as 2003 Annual Survey. 
Survey folder names are editable allowing you to name a survey folder based on your 
company’s standards. 

To add a survey folder, follow these steps:

1 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window (Figure 6-1). 

2 Click the  Add button to add a row in the grid. 

Figure 6-1.  Survey Folder Maintenance

3 If you want to rename the newly added survey folder, type a name in the Survey 
Name field. 

4 Type the survey start date in the Start Date field. Or, click the down arrow in the 
field to choose a date using a calendar. 
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5 Select a survey frequency in the field Survey Frequency field. Click the field to 
display a drop-down arrow, then click the drop-down arrow and select an option in 
the selection list. 

The new survey folder is now available for use in data entry grids, reports, Bridge, 
Field Computer, and as an optional filter selection. For more information, see 
Using a Facility Survey Folder (page 184). 

Deleting a Facility Survey Folder
Deleting a survey folder removes all references to the survey folder throughout PCS Axis. 
For example, when facility inspection records have been assigned to a survey folder you 
plan to delete, PCS Axis removes references to the survey folder for each inspection record 
assigned to the survey folder. Inspection records are not deleted however, only references 
to the survey folder are deleted. 

Deleting a survey folder typically occurs when you want to clean up data that is no longer 
needed or when a survey folder has been created accidentally. A message displays listing 
all facility records assigned to the survey folder allowing you to either cancel the operation 
or delete the survey folder (Figure 6-2). 

To delete a survey folder, follow these steps: 

1 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window (Figure 6-1, page 182). 

2 Select a survey folder in the grid, then click the  Delete button. 

3 When the Delete message displays, click  Yes to delete the survey folder or 
 No to cancel the operation (Figure 6-2). 

Figure 6-2.  Example of Survey Folder Delete Message
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Using a Facility Survey Folder
You can assign inspection readings to a survey folder in any of the following areas of PCS 
Axis: 

• Inspection data entry grid. Assign an inspection record to a survey folder using 
the Survey field in the Inspection data entry grid. 

• Bridge import file. Use the options in the Add Data Item group box to assign 
inspection readings to an annual and/or periodic survey folder. PCS Axis assigns 
inspections to the appropriate survey folder based on the survey inspection date. 

• Receiving survey files from the Allegro. Use the Options group box in the Field 
Computer Receive Data window to assign inspection readings to a survey folder. 
Choosing Automatic Assignment allows PCS Axis to assign inspections to the 
appropriate survey folder based on the survey inspection date. 

• Filter option in the Inspection data entry grid. To view a set of inspection records 
for a particular survey in the Inspection data entry grid, select a survey folder 
option in the Filters group box of the Customize Options page. 

• Filter option in Reports. To view a set of inspection records for a particular survey 
in a report, select a survey folder option in the Filters group box of the Options 
page. 

Working with a Continuous Survey Folder
A continuous survey folder is a container for a group of survey readings associated with a 
continuous survey, such as survey readings in a close interval (CI) survey or other type of 
above ground indirect survey. Continuous survey folders are used throughout PCS Axis 
when working with a data entry grid, report, or graph in the Indirect Survey Manager 
module. They allow PCS Axis to organize and track continuous survey readings. 

Information in this section explains how to use the most common features of Survey 
Folder Maintenance. Topics include those in the following list. For information about 
other features, see Working with Themes and Filter Groups (page 192). 

• Adding a Continuous Survey Folder

• Deleting a Continuous Survey Folder (page 189)

• Using a Continuous Survey Folder (page 191)

• Working with Themes and Filter Groups (page 192)
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Adding a Continuous Survey Folder
A continuous survey folder must first be added in Survey Folder Maintenance before 
working with survey readings in an ISM data grid, report, or graph. Adding a continuous 
survey folder includes the following tasks: 

• Choosing the type of continuous survey, such as CIS, AC CIS, DCVG, ACVG, ACCA, 
Soil Resistivity, or Pearson. 

For a description of the different types of continuous surveys supported in PCS 
Axis, see Appendix B (see page 781). 

• Providing the survey start date and survey name. These property settings allow 
you to identify the correct survey folder when adding survey readings or working 
with reports and graphs in ISM. 

• As an option, providing the name of the surveyor and/or the vendor performing 
the survey. 

To add a continuous survey folder, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 6-3). 
Select the pipeline segment(s) with the facilities you want to work with, then click 

 Save to close the window. 

Figure 6-3.  Select ROWs
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2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window (Figure 6-4). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

Figure 6-4.  Survey Folder Maintenance

4 Click a button labeled with the type of continuous survey that you want to add a 
survey folder. For example, clicking the CIS button  adds a survey 
folder for close interval survey readings (Figure 6-4). 

5 Click the  Add button to open the Add Record dialog box (Figure 6-5, 
page 187). 

6 Select the pipeline segment that you want to add a continuous survey folder. In the 
following example, pipeline segment LG123-E is selected. 
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Figure 6-5.  Add Record

7 Click  Save to display required fields for data entry. Required fields are 
identified with the  icon, such as Start Date and CI Survey Name in the next 
figure (Figure 6-6).

8 Type a survey start date in the Start Date field using the format MM/DD/YYYY to 
indicate the month, day, and year. Or click the down arrow in the field and select a 
date using a calendar. 

9 Type a name for the survey folder in the field CI Survey Name. The field accepts up 
to 50 alphanumeric characters. 

Figure 6-6.  Add Record
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10 Click  Save to close the Add Record dialog box and add a row of records in the 
grid for the new continuous survey folder (Figure 6-7). 

11 Provide other information about the survey folder as needed. For example, type 
the surveyor’s name in the Surveyor field; the survey interval in the Survey 
Interval field; and the name of the company performing the survey in the Vendor 
field. 

12 Click  Refresh to update the grid. 

The survey folder is now available for selection when working with survey readings 
in Edit ISM Data (Data Entry > Edit ISM Data), reports, and graphs. 

Figure 6-7.  Survey Folder Maintenance
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Deleting a Continuous Survey Folder
Deleting a continuous survey folder in Survey Folder Maintenance also deletes survey 
readings associated with the survey folder. 

To delete a continuous survey folder, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window. Select the 
pipeline segment(s) associated with the continuous survey folder you want to 
delete. Then click  Save to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

4 Click a button labeled with the type of continuous survey folder you want to 
delete. For example, click the CIS button  to delete the survey folder 
and associated survey readings for a close interval survey (Figure 6-7, page 188). 

5 Select a pipeline segment in the grid that includes the continuous survey folder 
you want to delete. For example, the row of records for pipeline segment LG123-D 
are selected in the following figure (Figure 6-8, page 190). 
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Figure 6-8.  Survey Folder Maintenance

6 Click  Delete. When the message Delete Record displays, click  Delete 
again (Figure 6-9).

Figure 6-9.  Delete Record

7 Click  Yes when a warning displays asking if you want to continue deleting the 
survey folder and associated survey readings (Figure 6-10). 

The survey folder and associated survey readings are now deleted from PCS Axis. 

Figure 6-10.  Warning
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Using a Continuous Survey Folder
You can use a continuous survey folder in any of the following areas of the Indirect Survey 
Manager module: 

• Data entry grid. Add survey readings in a continuous survey folder associated 
with a pipeline segment using Edit ISM Data (Data Entry > Edit ISM Data). 

• Filter option in Criteria Report. View survey readings based on a survey folder 
selected in Options when working with a columnar Criteria Report. 

• Filter option in PCS Axis Inspections Graph. View a graph of survey readings 
based on a survey folder selected in Survey Selections when working with a PCS 
Axis Inspections Graph. 

• Receiving survey files from the Allegro. Use the Options group box in the Field 
Computer Receive Data window to assign survey readings to a continuous survey 
folder associated with a pipeline segment. 
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Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as grid layout or sorting 
themes. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] CIS Survey 
Folders. 

A filter group is a named set of one or more filters that affect the data output in the 
Survey Folder Maintenance grid. PCS Axis provides two types of filter groups you can 
define. These include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in the Survey Folder Maintenance grid. Adding an AND filter group 
produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. When you apply a filter group 
to the grid, PCS Axis processes filters in descending order beginning with the filter at the 
top of the group. 

The following sections describe how to add a layout theme, sort theme, and an optional 
filter group in the Survey Folder Maintenance grid. Topics include those in the following 
list: 

• Adding a Layout Theme (page 193)

• Adding a Sort Theme (page 196)

• Adding an AND Filter Group (page 199)

• Adding an OR Filter Group (page 202)

• Editing and Arranging Filters and Filter Groups (page 205)
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Adding a Layout Theme
A layout theme is a group of fields in a grid layout. Adding a new Layouts theme allows 
you to choose which fields you want to include in the grid layout and then save the layout 
as a theme for later use. 

To add a layout theme in Survey Folder Maintenance, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

4 Click a button labeled with the type of continuous survey that you want to add a 
layout theme. For example, click the CIS button  to add a layout 
theme for a continuous survey associated with close interval survey readings 
(Figure 6-8, page 190). 

5 Click the Customize tab  then the  Add button to open the New 
Layout Theme dialog box (Figure 6-11). 

Figure 6-11.  New Layout Theme
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6 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

7 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

8 Click  OK to save changes and return to the Layouts page (Figure 6-12). 

Figure 6-12.  Layouts

9 Complete the following steps in the Layouts page to add and remove fields in the 
new layout theme as needed:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The layout theme includes all fields listed in the right pane 
of the Layouts page. 
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c To remove a field in the layout theme, double-click a field listed in the right 
pane to move it to the left pane. Repeat this step as needed. 

NOTE: Fields with a lock icon  are required and cannot be removed from the 
theme, such as  ROW Code and Pipe shown in the previous example 
(Figure 6-12, page 194). 

10 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

11 Click  Save to save changes.

12 To apply the new layout theme to the data entry grid in Survey Folder 
Maintenance, follow these steps: 

a Click the Options tab  to open the options page (Figure 6-13). 

b Click the down arrow in the field Select Layout Theme and select the new 
layout theme in the selection list. 

c Choose a method for sorting survey folders in the data entry grid based on the 
survey date in the Start Date field. Click Oldest First or Newest First in Sort 
Dates to sort survey folders with the oldest or newest survey Start Date first. 

d Click  Apply to save and apply changes. If you want to cancel changes 
instead, click  Cancel. PCS Axis closes the options page and returns to the 
Survey Folder Maintenance window. 

Figure 6-13.  Options
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Adding a Sort Theme
A sort theme determines how PCS Axis sorts records in a data entry grid. Adding a sort 
theme allows you to choose which field(s) to sort records by and if records sort 
alphanumerically in ascending or descending order. 

To add a sort theme for a continuous survey in Survey Folder Maintenance, follow these 
steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

4 Click a button labeled with the type of continuous survey that you want to add a 
sorting theme. For example, click the CIS button  to add a sorting 
theme for a continuous survey associated with close interval survey readings 
(Figure 6-8, page 190). 

5 Click the Customize tab  then the Sorts button  to open 
the Sorts page (Figure 6-14). 

Figure 6-14.  Sorts
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6  Click the  Add button to open the New Sort Theme dialog box (Figure 6-15). 

Figure 6-15.  New Sort Theme

7 Type a name for the sort theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the sort theme saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

8 Select a sort theme with fields you want to copy to the new sort theme. Click the 
down arrow in Copy Fields From Theme and select a theme in the selection list. 

9 Click  OK to save changes and return to the Sorts page (Figure 6-16, page 198). 

10 Complete the following steps in the Sorts page to add and remove fields in the 
new sorting theme as needed: 

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The sorting theme includes all fields listed in the right 
pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. Repeat this step as needed. 
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11 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

12 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

Figure 6-16.  Sort Theme

13 Click  Save to save changes.

14 To apply the new sort theme in the data entry grid of Survey Folder Maintenance, 
follow these steps: 

a Click the Options tab  to open the options page (Figure 6-17, 
page 199). 

b Click the down arrow in the field Select Sort Theme and select the new 
sorting theme in the selection list. 

c Choose a method for sorting survey folders in the data entry grid based on the 
survey date in the Start Date field. Click Oldest First or Newest First in Sort 
Dates to sort survey folders with the oldest or newest survey Start Date first. 

d Click  Apply to save and apply changes. If you want to cancel changes 
instead, click  Cancel. PCS Axis closes the options page and returns to the 
Survey Folder Maintenance window. 
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Figure 6-17.  Options

Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in the 
Survey Folder Maintenance grid. Adding an AND filter group produces a subset of 
records that meet all filter conditions. PCS Axis processes filters in a filter group in 
descending order beginning with the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

4 Click a button labeled with the type of continuous survey that you want to add an 
AND filter group. For example, click the CIS button  to add a filter 
group for a continuous survey associated with close interval survey readings 
(Figure 6-8, page 190). 
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5 Select a survey in the Survey Folder Maintenance grid, then click the Customize 
tab . 

6 Click the Filters button  to open the Filters page. Then click 
 New ‘And’ Group to open a filter properties group box (Figure 6-18). 

7 Type a name for the filter group in the field Filter Group Caption. 

8 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

9 If the AND filter group includes a date filter, such as Start Date Is Between shown 
in Figure 6-18, set a date range using a calendar or dynamic dates in the following 
manner:

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field.

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

10 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

11 Type a name for the filter in the field Enter Custom Filter Caption. 

Figure 6-18.  Filters
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12 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Repeat steps 8 through 11 to set up filter criteria. 

13 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

14 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

15 To apply one or more custom filter groups to the Survey Folder Maintenance grid 
(Figure 6-19, page 202):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply to the grid. 

16 Choose a method for sorting records in the grid. Click Oldest First or Newest 
First in Sort Dates to sort records with the oldest or newest inspection dates first. 

17 Click  Apply to save changes and return to the grid. If you want to cancel 
changes and return to the grid, click  Cancel. 

Clicking the Options tab  also allows you to save changes and return to 
the grid. 
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Figure 6-19.  Options

Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output in the 
Survey Folder Maintenance grid. Adding an OR filter group produces a subset of records 
that meet any filter condition. PCS Axis processes filters in a filter group in descending 
order beginning with the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 

3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

4 Click a button labeled with the type of continuous survey that you want to add an 
AND filter group. For example, click the CIS button  to add a filter 
group for a continuous survey associated with close interval survey readings 
(Figure 6-8, page 190). 
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5 Select a survey in the Survey Folder Maintenance grid, then click the Customize 
tab . 

6 Click the Filters button  to open the Filters page. Then click 
 New ‘Or’ Group to open a filter properties group box (Figure 6-20). 

7 Type a name for the filter group in the field Include records that match any of 
these conditions. 

8 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

9 If the OR filter group includes a date filter, such as Start Date Is Between shown in 
Figure 6-20, set a date range using a calendar or dynamic dates in the following 
manner:

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field.

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

10 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

11 Type a name for the filter in the field Enter Custom Filter Caption. 
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Figure 6-20.  Filters

12 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Repeat steps 8 through 11 to set up filter criteria. 

13 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

14 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 
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15 To apply one or more custom filter groups to the Survey Folder Maintenance grid 
(Figure 6-21, page 205):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply to the grid. 

16 Choose a method for sorting records in the grid. Click Oldest First or Newest 
First in Sort Dates to sort records with the oldest or newest inspection dates first. 

17 Click  Apply to save changes and return to the grid. If you want to cancel 
changes and return to the grid, click  Cancel. 

Clicking the Options tab  also allows you to save changes and return to 
the grid. 

Figure 6-21.  Options

Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 6-3, page 185). 

2 Click Modules > Indirect Survey Manager (ISM) to open the ISM module. 
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3 Click Data Entry > Survey Folder Maintenance to open the Survey Folder 
Maintenance window. 

4 Click a button labeled with the type of continuous survey you want to work with, 
such as the CIS button . 

5 Select a survey in the Survey Folder Maintenance grid.

6 Click the Customize tab , then the Filters button  to open 
the Filters page. 

7 Click a filter’s edit icon  to display filter property settings (Figure 6-22). 

Figure 6-22.  Filters
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8 To delete a filter in a filter group, click the filter’s  delete button (Figure 6-
23). Then click  OK when the Delete message displays. 

Figure 6-23.  Filters

9 To rename a filter, type a description in the filter’s name field. 

10 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 

11 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

12 Click the  close button to close the filter’s property settings group box (Figure 6-
23, page 207).

13 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

14 Click  Save and Close to save changes and return to the grid. 
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Notes
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Using Data Entry Grids and Forms

Information in this chapter explains how to use the data entry grids and forms in Edit 
<module> Data. It explains how to add and edit facility information, inspection, and 
maintenance records as well as records for continuous survey data. The information is 
intended for all users unless noted otherwise. 

Topics in this chapter include those in the following list: 

• Data Entry Grid Overview

• Working with Data Entry Grids (page 215)

• Working with Data Entry Forms (page 265)

• Working with Continuous Survey Data (page 270)

• Working with Themes and Filter Groups (page 295)

• Working with Records (page 311)

Data Entry Grid Overview
PCS Axis provides different types of data entry grids (also referred to as grids) and mini-
grids for organizing and managing facility data. Information in this section provides a 
description of these grids. Topics include those in the following list: 

• Types of Data Entry Grids (page 210)

• Understanding Field Caption Colors (page 211)

• Rearranging and Resizing Grid Columns (page 212)

• Locking and Unlocking Grid Columns (page 212)

• Replacing All Values (page 213)

• Working with Derived Fields (page 214)
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Types of Data Entry Grids
PCS Axis provides the following data entry grids and mini-grids for organizing and 
managing facility data. These grids are similar to a spreadsheet in appearance with facility 
data presented in columns, rows, and individual fields. Several options are available for 
customizing the layout and sorting order of a grid, as well as applying data filters that 
allow you to work with a subset of facility records. 

• Information grid: Use the Information grid to add and edit permanent facility 
information, such as the milepost number, location description, operating status, 
protection criteria, and permanent comments. The Information grid is also used 
for activating fields in the Inspection grid. 

• Inspection grid: Use the Inspection grid to add and edit survey inspection data 
for facilities on a pipeline segment, such as facility inspection readings, GPS 
coordinates, survey folder assignment, survey remarks, technician name, and so on. 

• Test Point Detail Information and Inspection mini-grids: Use the CPDM Test 
Point Detail mini-grids to manage multiple potential measurements for survey 
points linked to a test point record. These mini-grids function in a similar manner 
as the rectifier mini-grids when linking rectifier anodes and negatives. The 
potential measurement selected for compliance reporting in the Detail Inspection 
mini-grid copies to the linked test point record in the main Inspection grid. 

NOTE: The Test Point Detail mini-grids become available for use after enabling 
the system option Show Detail Inspection Entry Grid. When using the optional 
Telluric Compensation feature, the mini-grids display by default and cannot be 
disabled. 

• Maintenance grid: Use the Maintenance grid to add and edit maintenance and 
repair records for facilities on a pipeline segment. 

• Facility Level Override mini-grid: The Information grid for all modules includes 
the Facility Level Override mini-grid. Scheduling properties in Edit Schedule 
Settings (page 415) can be overridden at the facility level using this mini-grid. 

• Rectifier Information mini-grids: The CPDM Rectifier Information grid includes 
the Rectifier Anode Information and Rectifier Negative Information mini-grids. Use 
these mini-grids to add and delete records for impressed anodes and negatives 
linked to a rectifier information record. 

• Rectifier Inspection mini-grids: The CPDM Rectifier Inspection grid includes the 
Rectifier Anode Inspection and Rectifier Negative Inspection mini-grids. Use these 
mini-grids to enter inspection readings for rectifier anode(s) and negatives linked 
to one or more pipeline segments. 
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Understanding Field Caption Colors
PCS Axis uses a color code system in field captions throughout the system that allows you 
to easily identify one data type from another (Figure 7-1). 

Field captions in column headings of a data entry grid are color-coded to help distinguish 
different data types, such as information, inspection, and maintenance fields. Likewise, 
field captions in selection lists are also color-coded when creating themes in the 
Customize tab. The following table identifies the different data types with corresponding 
colors.

Figure 7-1.  Colors in Field Captions

Data Type Color

Facility Field Black

Facility Information Field Blue

Inspection Field Red

Maintenance Field Red

ROW and Pipeline Field Green

All Others Black

Grid colummn headings with
color-coded field captions.

Grid layout theme with 
color-coded field captions.
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Rearranging and Resizing Grid Columns
Rearranging grid columns in a data entry grid is easily accomplished by dragging and 
dropping a grid column to a new position. Performing this function requires appropriate 
user permissions for modifying a data entry grid layout theme. If the data entry grid layout 
theme is Public, changes apply only to the current session of the data entry grid and are 
not saved in the layout theme. When the data entry grid layout theme is Private, the new 
column order is saved in the data entry grid layout theme. 

To rearrange a grid column:

• Drag and drop a selected grid column to a new position in the data entry grid. 

To resize a grid column:

• Place the mouse over a column boundary to change the cursor to a horizontal 
resize cursor . Then click and drag the column boundary to resize the grid 
column.

Locking and Unlocking Grid Columns
You can lock a group of grid columns on the left side of a data entry grid to prevent them 
from moving when scrolling the data entry grid. Grid columns to the right of locked 
columns remain scrollable. 

To lock a grid column:

• Right-click a grid column and then select Lock Column in the shortcut menu that 
opens (Figure 7-2, page 213). 

To unlock a locked grid column:

• Right-click the locked grid column and then select Unlock Column in the shortcut 
menu that opens. 
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Figure 7-2.  Lock Grid Column

Replacing All Values
When you want to replace a value in all fields of a selected grid column with the same 
value, right-click the grid column and select Replace All Values in the shortcut menu. 
When the Replace All Values dialog box opens, enter the information that will be used to 
replace values in all fields of the selected grid column and then click OK. 

The Replace All Values command is not available for read-only grid columns, fields in a 
mini-grid, or picklist fields. 
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Working with Derived Fields
A derived field is a system calculated field with a value based on values in dependent 
fields. For example, PCS Axis calculates a value for the field Effective IR Correction based 
on values in the following dependent fields: 

• User IR Correction

• Structure P/S

• Structure IRF

• Inspection Date

When a value for a dependent field has been updated in a data entry grid, a  
notification icon displays in the derived field indicating the value has changed and the 
data entry grid should be refreshed. Clicking the  Refresh button updates all derived 
values and removes the notification icon (Figure 7-3, page 214). 

Figure 7-3.  Derived Field
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Working with Data Entry Grids
Data entry grids in Edit <module> Data allow you to edit and manage multiple facility 
records linked to one or more pipeline segments. You can add and edit facility information, 
inspection, and maintenance records using the Information Inspection, and Maintenance 
data entry grids. 

Although the CPDM module is used in the following examples, the information applies to 
all modules except Indirect Survey Manager (ISM). For information about the ISM module, 
begin with the section entitled Working with Continuous Survey Data (page 270). 

Information in this section explains how to use the most common features of a data entry 
grid. For information about other features, see Working with Themes and Filter Groups 
(page 295) and Working with Records (page 311). 

Topics in this section include those in the following list: 

• Adding Facility Records (page 215)

• Creating History Records Using an Effective Date (page 233)

• Viewing Records in a Grid (page 238)

• Filtering Data in a Grid (page 253)

• Building a Survey in the Inspection Grid (page 258)

• Using Find to Search a Data Entry Grid (page 262)

• Printing, Exporting, or Emailing Grid Content (page 263)

Adding Facility Records
Instructions in the following topics describe how to add facility information, inspection, 
and maintenance records in a data entry grid:

• Adding a Facility Information Record

• Adding a Facility Inspection Record (page 222)

• Adding a Facility Maintenance Record (page 228)
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Adding a Facility Information Record
Use the Information grid to add a record for a new facility on a pipeline; add an 
information record for an existing facility in the grid; add a history record to maintain 
permanent information about a facility; and activate certain fields for data entry in the 
Inspection grid – such as Activate Structure P/S and Activate Casing P/S.

The procedure in this section covers the following scenarios for adding a record in the 
Information grid: 

• adding an information record for an existing facility in the grid (step 7, page 218)

• adding a record for a new facility on a pipeline (step 8, page 219)

Complete the following steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). 

2 Select one or more pipeline segments with facilities you want to work with by 
clicking the check box for each pipeline segment. Click  Save to close the 
window. 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 

Figure 7-4.  Select ROWs
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NOTE: Although the CPDM module and test point facility type are both referenced 
in this procedure, instructions apply to any PCS Axis module and facility type. 

3 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-5, page 217). 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Open the Information grid for a facility type. For example, click the Information 
tab  and then a facility type button, such as Test Point . 

Figure 7-5.  Information Grid

6 Click  Add to open the Add Record dialog box (Figure 7-6). Then continue with 
one of the following steps:

• To add an information record for an existing facility in the grid, continue with 
step 7 (page 218). 

• To add a new facility in the grid with an information record, continue with 
step 8 (page 219). 2
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Figure 7-6.  Add Record

7 To add an information record for an existing facility in the grid:

a Click the option Test Point Information Record. Then select a facility in the 
list of facilities in the Add Record dialog box. For example, the facility at 
Milepost 0.000 is selected in the previous figure (Figure 7-6, page 218). 

b Click  Save to display required field(s) for data entry (Figure 7-7). 

c Type a date in the Effective Date field using the format MM/DD/YYYY to 
indicate the month, day, and year. Or click the down arrow in the field and 
select a date using a calendar. 

Effective Date is the date a history record becomes effective. New history 
records are created with an Effective Date when important permanent 
information changes. See Creating History Records Using an Effective Date 
(page 233) for more information. 

Figure 7-7.  Add Record
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d Click  Save to close the Add Record dialog box and add an information 
record in the grid for the existing facility. 

e Provide other facility data in the grid as needed, such as Permanent 
Comments (Figure 7-8, page 219). 

f Click  Refresh to update the grid. 

Figure 7-8.  Add Record

8 To add a record in the Information grid for a new facility: 

a Click the option Test Point Facility and Information Record.

b Select the pipeline in the dialog box that you want to add a new facility and 
information record. For example, pipeline T-1401 is selected in the next figure 
(Figure 7-9). 
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Figure 7-9.  Add Record

c Click  Save to display required field(s) for data entry. Required fields are 
identified with the  icon, such as Milepost in the following figure (Figure 7-
10). 

d Type the facility milepost number in the Milepost field. Based on your system 
configuration, the Milepost field may have a different caption for User 
Location Name, such as Station Number or other type of identifier. 

e Click  Save to close the dialog box and add the new facility record in the 
Information grid. 

Figure 7-10.  Add Record
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f Activate one or more fields for data entry in the Inspection grid. Click the 
check box for an “activate” field in the Information grid to place a check mark 
inside the check box. 

For example, click the check box Activate Casing P/S for Milepost 0.002 as 
shown in the following figure (Figure 7-11, page 221). 

g Provide other facility information as needed. For example, type a description of 
the facility location in the Location Description field and comments about 
the facility in the Permanent Comments field. 

h Click  Refresh to update the grid. 

Figure 7-11.  Information Grid
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Adding a Facility Inspection Record
Information in this section covers the following scenarios for adding a record in the 
Inspection grid: 

• adding an inspection record for an existing facility (step 6, page 223)

• adding a new facility with an inspection record (step 7, page 225)

Complete the following steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select one or more pipeline segments with facilities you want to work 
with, then click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-12). 

3 Open the Inspection grid for a facility type. For example, click the Inspection tab 
 and then a facility type button, such as Test Point . 

NOTE: Although the CPDM module and test point facility type are both referenced 
in this procedure, instructions apply to any PCS Axis module and facility type. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-12.  Inspection Grid
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5 Click  Add to open the Add Record dialog box (Figure 7-13, page 223). Then 
continue with one of the following steps:

• To add an inspection record for an existing facility in the grid, continue with 
step 6. 

• To add a new facility in the grid with an inspection record, continue with step 
7 (page 225). 

6 To add an inspection record for an existing facility in the grid: 

a Click the option Test Point Inspection Record. 

b Select a pipeline with the facility you want to add an inspection record. For 
example, pipeline T-1401 and the facility at Relative Milepost 0.000 are 
selected in the next figure (Figure 7-13, page 223). 

Figure 7-13.  Add Record
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c Click  Save to display required field(s) for data entry (Figure 7-14). 

d Type an inspection date in the Inspection Date field using the format 
MM/DD/YYYY to indicate the month, day, and year. Or click the down arrow 
in the field and select an inspection date using a calendar. 

Figure 7-14.  Add Record

e Click  Save to close the dialog box and add an inspection record in the grid 
for the existing facility (Figure 7-15). 

f Provide other inspection data in remaining fields. For example, click the 
Survey field and select a survey folder in the selection list. Then enter a 
structure pipe-to-soil reading in the field Structure P/S. 

g Click  Refresh. 
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Figure 7-15.  Inspection Grid

7 To add a new facility with an inspection record in the Inspection grid: 

a Click the option Test Point Facility and Inspection Record. 

Figure 7-16.  Add Record
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b Click  Save to display required field(s) for data entry. Required fields are 
identified with the  icon, such as Milepost in the following figure (Figure 7-
17).

c Type the facility milepost number in the Milepost field. Based on your system 
configuration, the Milepost field may have a different caption for User 
Location Name, such as Station Number or other type of identifier. 

d Type an inspection date in the Inspection Date field using the format 
MM/DD/YYYY to indicate the month, day, and year. Or click the down arrow 
in the field and select an inspection date using a calendar. 

Figure 7-17.  Add Record

e Click  Save to close the dialog box and add the new facility with an 
inspection record in the grid (Figure 7-18, page 227). 

f Provide other inspection data in remaining fields. For example, click the 
Survey field and select a survey folder in the selection list. Then enter a 
structure pipe-to-soil reading in the field Structure P/S. 

In the following example, a new facility and inspection record has been added 
for Milepost 0.003 (Figure 7-18, page 227). 

g Click  Refresh. 
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Figure 7-18.  Inspection Grid
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Adding a Facility Maintenance Record
Information in this section covers the following scenarios for adding a record in the 
Maintenance grid: 

• adding a maintenance record for an existing facility (step 6, page 229)

• adding a new facility with a maintenance record (step 7, page 231)

Complete the following steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select one or more pipeline segments with facilities you want to work 
with, then click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-19). 

3 Open the Maintenance grid for a facility type. For example, click the 
Maintenance tab  and then a facility type button, such as Test Point 

. 

NOTE: Although the CPDM module and test point facility type are both referenced 
in this procedure, instructions apply to any PCS Axis module and facility type. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-19.  Maintenance Grid
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5 Click  Add to open the Add Record dialog box (Figure 7-20). Then continue with 
one of the following steps:

• To add a maintenance record for an existing facility in the grid, continue with 
step 6. 

• To add a new facility in the grid with a maintenance record, continue with 
step 7 (page 231). 

Figure 7-20.  Add Record

6 To add a maintenance record for an existing facility in the grid: 

a Click the option Test Point Maintenance Record. Then select a facility in the 
list of facilities. For example, the facility at Milepost 2.753 is selected in the 
previous figure (Figure 7-20). 

b Click  Save to display required field(s) for data entry (Figure 7-21, 
page 230). Required fields are identified with the  icon, such as Test Point 
Repair Code in the next figure (Figure 7-21, page 230). 
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c Type a date in the field Repair Found Date using the format MM/DD/YYYY to 
indicate the month, day, and year. Or click the down arrow in the field and 
select a date using a calendar. 

d Type a repair code in the field Test Point Repair Code. Repair code is a 
designation used by your company to identify the type of repair. The field 
accepts up to 15 alphanumeric characters including special characters such as 
the pound sign (#), asterisk (*), or hyphen (-). 

Figure 7-21.  Add Record

e Click  Save to close the dialog box and add a maintenance record in the 
grid for the existing facility (Figure 7-22, page 231). 

f Provide other maintenance data as needed, such as Repair Initiated Date, 
Repair Corrected Date, Repair Priority, and Repair Remarks. 

g Click  Refresh to update the grid. 
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Figure 7-22.  Maintenance Grid

7 To add a new facility in the grid with a maintenance record: 

a Click the option Test Point Facility and Maintenance Record in the Add 
Record dialog box (Figure 7-23, page 231). 

b Select a pipeline in the dialog box that you want to add a new facility and 
maintenance record. For example, pipeline T-1403 is selected in the next 
figure (Figure 7-23, page 231). 

Figure 7-23.  Add Record
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c Click  Save to display required field(s) for data entry (Figure 7-24). 
Required fields are identified with the  icon, such as Milepost and Test Point 
Repair Code in the next figure (Figure 7-24). 

Figure 7-24.  Add Record

d Type the facility milepost number in the Milepost field. Based on your system 
configuration, the Milepost field may have a different caption for User 
Location Name, such as Station Number or other type of identifier. 

e Type a date in the field Repair Found Date using the format MM/DD/YYYY to 
indicate the month, day, and year. Or click the down arrow in the field and 
select a date using a calendar. 

f Type a repair code in the field Test Point Repair Code. Repair code is a 
designation used by your company to identify the type of repair. The field 
accepts up to 15 alphanumeric characters including special characters such as 
the pound sign (#), asterisk (*), or hyphen (-). 

g Click  Save to close the dialog box and add the new facility with an 
maintenance record in the grid (Figure 7-25). 

h Provide other maintenance data as needed, such as Repair Initiated Date, 
Repair Corrected Date, Repair Priority, and Repair Remarks. 

i Click  Refresh to update the grid. 
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Figure 7-25.  Maintenance Grid

Creating History Records Using an Effective Date
A history record is a record that identifies changes in facility information, such as the 
operating status changing from active to inactive. Instead of deleting a facility record, 
create a history record. 

History records help ensure compliance reports are accurate and other reports include 
correct facility data. For example, information for inactive facilities does not appear in a 
compliance or scheduling report. Other reports provide an optional filter for excluding 
inactive facilities. Because information for the time period prior to deactivating a facility is 
still valuable and is often needed for compliance reports, creating a history record helps 
ensure facility reporting is accurate. 

Other scenarios describing when to create a history record include those in the following 
list: 

• A facility is deactivated for a period of time and you want to ensure records exist 
showing when the facility was first activated, then deactivated, and finally 
reactivated again. By creating history records for each of these events, a complete 
history is available showing (1) when the facility was first active; (2) when the 
facility was deactivated; and (3) when the facility was reactivated. 
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• When a change is made to the protection criteria value, such as changing the value 
from .85 On to 100 mV, creating a history record with an Effective Date 
identifying when the change occurred allows you to maintain a history for all 
readings with .85 On prior to the Effective Date, as well as all readings with 100 
mV after the Effective Date. Creating a history record in this case is important 
because the facility may meet the 100mV criterion but fail the .85 On criterion. If 
history records do not exist, changing the criteria may show readings that were 
previously within criteria, are now out of criteria. 

• You remove a casing and want to document that you are no longer recording 
Casing P/S inspection readings. Instead of disabling the Activate Casing P/S field 
in the Information grid, create a history record instead. History records provide 
useful data for an audit or compliance review. 

The following list identifies other considerations when creating a history record:

• When you create a history record, all fields in the original record copy to the new 
record. Both records are initially the same except for the Effective Date. This allows 
you to change only the field(s) that are different in the new record and also create 
a history trail that includes the previous record. 

• When the operating status of a facility changes from active to inactive or vice versa, 
do not use the original information record to change the operating status. Doing 
so causes information for the original record to be excluded in reports, such as 
compliance and delinquency reports. Create a history record to document this type 
of change instead. 

• Do not enter the date a facility was put into service as the Effective Date. Use the 
Effective Date field to enter a date when a facility is taken out of service; when a 
change is made to the protection criteria; or when a facility is made inactive. 
Effective Date is used only with history records; it is empty in the original facility 
record. When a facility is put into service, add the date in the field labeled 
Installation Date. 

• To help with using history records consistently, enable the field labeled Warn 
Before Permanent History Record Changed Option in Options (Tools > Options). 
When enabled, PCS Axis displays a warning message stating a history record 
should first be created before making changes. 
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To create a history record
Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-26). 

3 Open the Information grid for a facility type. For example, click the Information 
tab  and then a facility type button, such as Test Point . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-26.  Test Point Information Grid

5 Click  Add to open the Add Record dialog box. (Figure 7-27, page 236). 

6 Click the option Test Point Information Record. 

7 Select a facility record in the Add Record dialog box that you want to create a 
history record. For example, the facility record with Relative Milepost 1.627 is 
selected in the following figure (Figure 7-27, page 236). 
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Figure 7-27.  Add Record

8 Click  Save to close the dialog box and return to the Information grid.

PCS Axis adds a new record in the Information grid for the selected facility with 
today’s date showing in the Effective Date field. The Facility Active check box is 
also enabled by default in order for the facility to be included in facility survey 
schedules. The original record becomes the history record (Figure 7-28, page 237). 

9 Change information in the new record as needed. For example, to document when 
the facility was taken out of service:

• Enter the out-of-service date in the Effective Date field (Figure 7-28, 
page 237). 

• Click the Facility Active check box to remove the check mark and 
subsequently deactivate the facility. 

• As a recommendation, enter a comment in the Permanent Comments field 
about the record change. 
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Figure 7-28.  Test Point Information Grid
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Viewing Records in a Grid
By default PCS Axis displays records in a data entry grid based on the selected ROW(s) and 
in alphanumeric order by ROW Code and Pipe and then Milepost. As an option you can 
choose to display records based on a route or schedule instead (Figure 7-29). 

Topics in this section include those in the following list. Examples are based on the CPDM 
module, however the information applies to all PCS Axis modules.

• Viewing Records Based on Selected ROWs (page 239)

• Viewing Records Based on a Route (page 242)

• Viewing Records Based on a Schedule (page 245)

A status line near the top of the data entry grid identifies the mode for displaying records 
(by route, schedule, or selected ROWs); the currently selected layout and sort theme; and a 
filter icon indicating grid data is filtered. Hovering the mouse over the filter icon displays a 
tool tip with a description for currently selected filters. For example, the filter Active 
Facilities Only is applied in the data grid shown in the following example (Figure 7-29). 

Figure 7-29.  Status Line

Status Line
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Viewing Records Based on Selected ROWs
To display records in a data entry grid based on pipeline segments selected in the Select 
ROWs window, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid (Figure 7-30). 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-30.  Test Point Inspection Grid

5 Complete either step "a" or "b" to display records in the grid based on selected 
ROWs: 

a Click the Based On tab  to open the based on panel and then 
complete the following steps (Figure 7-31, page 240): 

• Click the option Selected ROWs, then click  Apply. 

• Click  Close to close the based on panel. 
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Figure 7-31.  Based On Selected ROWs

b Click the Options tab  to open the options page. Then click the 
option Selected ROWs in the Based On group box (Figure 7-32). 

Figure 7-32.  Options

6 If you want to change the grid layout, sorting theme, or apply one or filters to the 
grid, complete the following steps: 

a To change the grid layout theme, click the down arrow in the field Select 
Layout Theme and select a theme in the selection list.
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b To change the grid sorting method, click the down arrow in the field Select 
Sort Theme and select a theme in the selection list. 

c To apply a filter to the grid, click the check box for a filter listed in the Filters 
group box (Figure 7-32, page 240). 

For example, to only include active facilities in the grid, click the Active 
Facilities Only check box. A check mark inside the check box indicates a 
selection. To remove a filter from the grid, clear the check mark by clicking the 
check box. 

NOTE: To add a new AND or OR filter group, refer to Adding an AND Filter 
Group (page 302). 

d When applying a date filter to the grid, such as Inspection Date is between, 
set a date range using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end 
date field. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

e Click  Apply to save and apply changes. 

Records display in the grid based on selected options. 
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Viewing Records Based on a Route
Information in this section explains how to display records in a data entry grid based on a 
route. A route is a user-created list of facilities for inspection arranged in a particular order. 
For example, if a route has previously been set up with facilities arranged in survey order, 
you can work with records in a data entry grid using the same route to display the grid in 
survey order. 

NOTE: To perform the following procedure, one or more routes must first be set up. For 
information about how to set up a route, see Using a Route, page 349. 

To view records in a grid based on a route, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities in a route, then click  Save 
to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-33). 

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-33.  Test Point Inspection Grid
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5 Complete either step "a" or "b" to display records in the grid based on a route: 

a Click the Based On tab  to open the based on panel and then 
complete the following steps (Figure 7-34): 

• Click the Route option. Then select a route in the adjacent group box.

• Click  Apply and then click  Close to close the based on panel. 

Figure 7-34.  Based On Route

b Click the Options tab  to open the options page and then complete 
the following steps (Figure 7-35, page 244):

• Click the Route option. Then select a route in the adjacent group box. 

• Click  Apply to save and apply changes. 
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Figure 7-35.  Based on Route

6 If you want to change the grid layout theme, sort theme, or apply one or more 
filters to the grid, complete the following steps: 

a To change the grid layout theme, click the down arrow in the field Select 
Layout Theme and select a theme in the selection list (Figure 7-35). 

b To change the grid sort theme, click the down arrow in the field Select Sort 
Theme and select a theme in the selection list. 

c Choose a method for sorting records in the data entry grid. Click Oldest First 
or Newest First in Sort Dates to sort records with the oldest or newest 
inspection dates first. 

d To apply a filter to the grid, click the check box for a filter listed in the Filters 
group box. 

For example, to only include active facilities in the grid, click the Active 
Facilities Only check box. A check mark inside the check box indicates a 
selection. To remove a filter from the grid, clear the check mark by clicking the 
check box. 

NOTE: To add a new AND or OR filter group, refer to Adding an AND Filter 
Group (page 302). 
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e When applying a date filter to the grid, such as Inspection Date is between, 
set a date range using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end 
date field. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

f Click  Apply to save and apply changes. 

Records display in the grid based on selected options. 

Viewing Records Based on a Schedule
Information in this section explains how to display records in a data entry grid based on a 
schedule. Examples are based on the CPDM module, however the information applies to 
all modules. Topics in this section include those in the following list:

• Using the Based On Tab to View Records Based on a Schedule

• Using the Options Page to View Records Based on a Schedule (page 249)

NOTE: Scheduling criteria must first be set up as well as a schedule definition to perform 
the procedure in this section. For more information see Using a Schedule, page 415.

Using the Based On Tab to View Records Based on a Schedule
Complete the following steps using the Based On tab to view records in a grid based on a 
schedule: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities included in a schedule, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-36, page 246). 
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Figure 7-36.  Test Point Inspection Grid

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Click the Based On tab  and then select Schedule (Figure 7-37, 
page 247). 

6 Choose a schedule definition. Click the down arrow in the field Select Schedule 
Definition and select an item in the list. 
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Figure 7-37.  Based On Schedule

Complete step 7 to set up a schedule date range using a calendar or step 8 
(page 248) to set up a schedule date range using dynamic dates. 

7 To set up a schedule date range using a calendar:

a Set a schedule start date. Type a date in the Start Date field or click the down 
arrow and select a date using a calendar. 

b Set a schedule end date. Type a date in the End Date field or click the down 
arrow and select a date using a calendar.

NOTE: When typing a date, use the format MM/DD/YYYY to indicate the 
month, day, and year. 

c Click  Apply and then click  Close to close the based on panel. Records 
display in the data entry grid based on the selected schedule definition and 
date range. 
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8 To set a schedule date range using dynamic start and end dates, follow these steps 
(Figure 7-38): 

a Click the Start Date  calculator to open dynamic start date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the Start Date field and select one of the 
following options: Today, End Of Month, Beginning Of Year, or End Of 
Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic start date fields.

b Click the End Date  calculator to open dynamic end date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the End Date field and select one of the following 
options: Today, End Of Month, Beginning Of Year, or End Of Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic end date fields.

c Click  Apply and then click  Close to close the based on panel. Records 
display in the data entry grid based on the selected schedule definition and 
dynamic date range. 

Figure 7-38.  Based On Schedule
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Using the Options Page to View Records Based on a Schedule
Complete the following steps using the Options page to view records in a grid based on a 
schedule: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities included in a schedule, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-39). 

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-39.  Test Point Inspection Grid
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5 Click the Options tab  to open the options page (Figure 7-40). 

6 Click the Schedule option and then choose a schedule definition. Click the down 
arrow in the field Select Schedule Definition and select an item in the list. 

Figure 7-40.  Options

Complete step 7 to set up a schedule date range using a calendar or step 8 to set up a 
schedule date range using dynamic dates (page 251). 

7 To set up a schedule date range using a calendar:

a Set a schedule start date. Click the down arrow in the Start Date field and 
select a date in the calendar. 

b Set a schedule end date. Click the down arrow in the End Date field and select 
a date in the calendar. 

c If you want to set additional property settings in the options page, continue 
with step 9 (page 252). Otherwise, click  Apply to apply changes and return 
to the data entry grid. 
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8 To set a schedule date range using dynamic start and end dates, follow these steps 
(Figure 7-41):

a Click the Start Date  calculator to open dynamic start date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the Start Date field and select one of the 
following options: Today, End Of Month, Beginning Of Year, or End Of 
Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic start date fields.

b Click the End Date  calculator to open dynamic end date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the End Date field and select one of the following 
options: Today, End Of Month, Beginning Of Year, or End Of Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic end date fields.

c If you want to set additional property settings in the options page, continue 
with step 9 (page 252). Otherwise, click  Apply to apply changes and return 
to the data entry grid. 

Figure 7-41.  Based On Schedule
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9 To change the grid layout, sorting method, or apply one or more filters to the grid, 
follow these steps: 

a To change the grid layout theme, click the down arrow in the field Select 
Layout Theme and select a layout theme in the selection list.

b To change the grid sorting method, click the down arrow in the field Select 
Sort Theme and select a sorting theme in the selection list. 

c To apply a filter to the grid, click the check box for a filter listed in the Filters 
group box. 

For example, to only include active facilities in the grid, click the Active 
Facilities Only check box. A check mark inside the check box indicates a 
selection. To remove a filter from the grid, clear the check mark by clicking the 
check box. 

NOTE: For more information related to filters (New 'And' Group or New 'Or' 
Group), refer to Adding an AND Filter Group (page 302). 

d When applying a date filter to the grid, such as Inspection Date is between, 
set a date range using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end 
date field. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

e Click  Apply to apply changes and return to the data entry grid

Records display in the grid based on selected options. 
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Filtering Data in a Grid
Information in this section explains how to filter the data output in any data entry grid in 
Edit <module> Data, such as Edit CPDM Data. It includes a description of the options 
and filters available in the Options page when working with the Information, Inspection, 
and Maintenance grids. Filtering data allows you to work with only those records you are 
interested seeing in the grid. 

Topics in this section include those in the following list:

• Filtering Data in the Information Grid

• Filtering Data in the Inspection Grid (page 254)

• Filtering Data in the Maintenance Grid (page 256)

Filtering Data in the Information Grid
To filter the data output in the Information grid of Edit <module> Data, complete the 
following steps. The placeholder <module> refers to any module, such as Edit CPDM 
Data.

1 Click Data Entry > Edit <module> Data. 

2 Open the Information grid for a facility type. For example, click the Information 
tab  and then a facility type button, such as Test Point . 

3 Click the Options tab  to open the Options page (Figure 7-42). 

Figure 7-42.  Options/Information Grid
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4 To include only the most recent information record, select the check box Only the 
most recent information record for each facility. This option uses the 
Effective Date to filter the data output. 

NOTE: When using the Filters group box to apply additional filters to the data 
output, the most recent information record is found first, and then all other filters 
are applied to the data output. For more information about filters, see Adding an 
AND Filter Group (page 302) and Adding an OR Filter Group (page 305). 

5 Click  Apply to save and apply changes and then return to the Information 
grid. To cancel changes, click the Options tab  to return to the grid. 

Filtering Data in the Inspection Grid
To filter the data output in the Inspection grid of Edit <module> Data, complete the 
following steps. The placeholder <module> refers to any module, such as Edit CPDM 
Data. 

1 Click Data Entry > Edit <module> Data. 

2 Open the Inspection grid for a facility type. For example, click the Inspection tab 
 and then a facility type button, such as Test Point . 

3 Click the Options tab  to open the Options page (Figure 7-43). 

Figure 7-43.  Options/Inspection Grid
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4 Review the following descriptions and then select one or more filter options as 
required:

• Only include facilities with inspections during the reporting time period:
The data output for this option only includes those inspection records that 
meet the filter criteria defined for a particular date or date range. Filter criteria 
is defined by filter settings in the Filters group box for any of the following 
time period fields: Inspection Date is between, Survey is equal to, Periodic 
Survey is equal to, and Periodic Survey Year is equal to. 

• All inspections that meet the filter criteria: This option includes all 
inspection records in the data output that meet filter criteria based on filter 
settings in the Filters group box. 

• Apply other filters to the most recent inspection found within the report 
timeframe: This option finds the most recent inspection record within the 
reporting time frame first, and then applies other filter settings to the data 
output. Filter criteria for both of these are defined in the Filters group box. 
Use any of the following fields when defining filter criteria for the reporting 
time frame: Inspection Date, Survey, Periodic Survey, and Periodic Survey 
Year.

• The most recent inspection after the filter criteria has been met: The data 
output for this option includes the most recent inspection record only for 
those facilities that meet all other filter criteria first. Filter criteria for both of 
these are defined in the Filters group box. Use any of the following fields 
when defining a time period for the most recent maintenance record: 
Inspection Date, Survey, Periodic Survey, and Periodic Survey Year.

5 When applying a time period filter to the grid, such as Inspection Date is 
between, set a date range using a calendar or dynamic dates in the following 
manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

6 Click  Apply to save and apply changes and then return to the Inspection grid. 
To cancel changes, click  Cancel or the Options tab  to return to the 
grid. 

NOTE: For more information about filters, see Working with Themes and Filter 
Groups (page 295). 
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Filtering Data in the Maintenance Grid
To filter the data output in the Maintenance grid of Edit <module> Data, complete the 
following steps. The placeholder <module> refers to any module, such as Edit CPDM 
Data.

1 Click Data Entry > Edit <module> Data.

2 Open the Maintenance grid for a facility type. For example, click the 
Maintenance tab  and then a facility type button, such as Test Point 

. 

3 Click the Options tab  to open the Options page (Figure 7-44). 

Figure 7-44.  Options/Maintenance Grid

4 Review the following descriptions and then select one or more filter options as 
required:

• Only include facilities with maintenance during the reporting time 
period: The data output for this option only includes those maintenance 
records that meet the filter criteria defined for a particular date or date 
range. Filter criteria is defined by filter settings in the Filters group box for 
any of the following time period fields: Effective Date, Repair Found Date, 
Repair Initiated Date, and Repair Corrected Date. 

• All maintenance that meet the filter criteria: This option includes all 
maintenance records in the data output that meet filter criteria based on filter 
settings in the Filters group box. 
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• Apply other filters to the most recent maintenance found within the report 
timeframe: This option finds the most recent maintenance record within the 
reporting time frame first, and then applies other filter settings to the data 
output. Filter criteria for both of these are defined in the Filters group box. 
Use any of the following fields when defining filter criteria for the reporting 
time frame: Effective Date, Repair Found, Repair Initiated, and Repair 
Complete.

• The most recent maintenance after the filter criteria has been met: The 
data output for this option includes the most recent maintenance record only 
for those pipeline records that meet all other filter criteria first. Filter criteria 
for both of these are defined in the Filters group box. Use any of the following 
fields when defining a time period for the most recent maintenance record:
Effective Date, Repair Found, Repair Initiated, and Repair Complete.

5 Click  Apply to save and apply changes and then return to the Maintenance 
grid. To cancel changes, click  Cancel or the Options tab  to return to 
the grid. 

NOTE: For more information about filters, see Working with Themes and Filter 
Groups (page 295). 
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Building a Survey in the Inspection Grid
Building a survey in the inspection grid based on a schedule allows PCS Axis to 
automatically add empty inspection records in the grid ready for data entry. This feature 
saves time by eliminating the need to manually add empty inspection records in the grid, 
one-by-one. 

To build a survey in the Inspection grid based on a schedule, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-45). 

3 Select the Inspection data entry grid for a facility type. For example, click the 
Inspection tab  and then the Test Point button  to display 
the Test Point Inspection data entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-45.  Test Point Inspection Grid
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5 Click the Based On tab  to open the based on panel. Then select the 
Schedule option (Figure 7-46). 

6 Choose a schedule definition. Click the down arrow in the field Select Schedule 
Definition and select an item in the list. 

Figure 7-46.  Based On Schedule

Complete step 7 to set up a schedule date range using a calendar or step 8 (page 260) 
to set up a schedule date range using dynamic dates. 

7 To set up a schedule date range using a calendar:

a Set a schedule start date. Click the down arrow in the Start Date field and 
select a date in the calendar. 

b Set a schedule end date. Click the down arrow in the End Date field and select 
a date in the calendar. 

c Click  Apply to apply changes and display the data entry grid. To hide 
the based on panel, click  Close or click the Based On  tab. 
Continue with step 9 (page 261). 
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8 To set a schedule date range using dynamic start and end dates, follow these steps 
(Figure 7-47):

a Click the Start Date  calculator to open dynamic start date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the Start Date field and select one of the 
following options: Today, End Of Month, Beginning Of Year, or End Of 
Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic start date fields.

b Click the End Date  calculator to open dynamic end date fields. Set 
properties in these fields in the following manner: 

1) Click the down arrow in the End Date field and select one of the following 
options: Today, End Of Month, Beginning Of Year, or End Of Year. 

2) In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic end date fields.

c Click  Apply to apply changes and display the data entry grid. To hide 
the based on panel, click  Close or click the Based On  tab. 
Continue with step 9 (page 261). 

Figure 7-47.  Based On Schedule
260 Using Data Entry Grids and Forms



PCS Axis User and Administrator Guide
9 Click  Build Survey to open the Build Survey dialog box (Figure 7-48). 

Figure 7-48.  Build Survey

10 Select one of the following options in the Build Survey dialog box to assign 
inspection records to a survey folder: 

• No Assignments: Select this option if you do not want to assign inspection 
records to a survey folder.

• Assign Survey: Select this option to assign inspection records to an annual or 
multi-year survey folder. Then click the down arrow in the Survey field and 
select a survey folder in the selection list. 

• Assign Periodic Survey: Select this option to assign inspection records to a 
periodic survey. Click the down arrow in the Periodic Survey field and select 
a survey folder in the selection list. Then click the down arrow in the Year field 
and select the survey year. 

• Auto Assignment: Select this option and then click either Assign Survey or 
Assign Periodic Survey and Year to have PCS Axis automatically assign 
inspection readings to a survey folder based on the schedule date range. 

11 Click  Build. Then click OK when the Build Survey message displays “Build 
Survey Completed”. 

The data entry grid now includes blank inspection records ready for data entry. 
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Using Find to Search a Data Entry Grid
To search the content of a data entry grid, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Click the Find tab  to open the search properties panel (Figure 7-49, 
page 262). 

Figure 7-49.  Find

6 Select a Find Operator option. If you want search results to meet all search 
criteria, select the AND operator. If you want search results to meet any search 
criteria, select the OR operator. 

7 Set up search criteria. Select a PCS Axis field, operator, and value using the 
selection fields. To add another row of selection fields, click  Add Field and then 
select a PCS Axis field, operator and a value using the added row of selection 
fields. 
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8 Click  Find Next Match to search the grid. Click the button again to find the 
next match.

9 Click  Reset Find to clear and reset search selection fields. If you want to search 
for another item in the data entry grid, repeat steps 6 through 8. 

10 Click the Find tab  to close the search properties panel. 

Printing, Exporting, or Emailing Grid Content
The following information explains how to print and export a report with content in a data 
entry grid. Supported file formats for exporting a report include PDF, HTML, MHT, RTF, 
XLS, XLSX, CSV, TXT, and Image (BMP, EMF, WMF, GIF, JPEG, PNG, and TIFF). 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window (Figure 7-50). 

3 Select a data entry grid. For example, click the Inspection tab  and then 
the Test Point button  to display the Test Point Inspection data 
entry grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

Figure 7-50.  Test Point Inspection Grid
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5 Click  Print to open a print preview window (Figure 7-51, page 265). 

6 To print the report using the default Windows printer, click the  Quick Print 
button. 

7 To open a print dialog box and select a printer to print the report, click the 
 Print button.

8 To select a file format and export the report, follow these steps:

a Click the down arrow in  Export Document and select a file format in 
the selection list. 

b When the Options dialog box opens, set up optional property settings and 
then click OK to close the dialog box. 

c When the Save As dialog box opens, type a name for the report in the File 
name field and then navigate to a location on your computer to save the 
report. 

d Click Save. When the message Do you want to open this file displays, click 
Yes or No. 

9 To select a file format and send the report as an attachment in an email, follow 
these steps:

a Click the down arrow in  Send via E-mail and select a file format in the 
selection list. 

b When the Options dialog box opens, set up optional property settings and 
then click OK to close the dialog box. 

c When the Save As dialog box opens, type a name for the report in the File 
name field and then navigate to location on your computer to save the report. 

d When an email message opens with the report as an attachment, select an 
email recipient and then click Send. 

10 Click the  Exit button to close the print preview window and return to the data 
entry grid. 
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Figure 7-51.  Print Preview

Working with Data Entry Forms
A data entry form (also referred to as “form”) provides a single record view of facility 
information. All fields related to a single facility record display in one page of a form. Using 
this feature allows you to display large amounts of information and data entry fields for 
one facility record on one form page. 

A PCS Axis form typically resembles a familiar paper-based form used by field technicians 
or data entry personnel. It can also be used as an inspection report or a compliance report 
when the selected Form Theme includes the appropriate PCS Axis fields. For example, a 
field technician can use a form to enter survey data when inspecting points along a 
pipeline segment. 

IMPORTANT: Using a data entry form in PCS Axis requires that the form be created and 
designed in PCS v7.5 or higher and then imported in PCS Axis. Creating and designing 
forms in PCS Axis is not currently supported but will be in a future software release.  
Importing a form in PCS Axis requires the assistance of PCS Technical Services. Contact 
information for PCS Technical Services is available in the section entitled Technical 
Support (page 25). 
Using Data Entry Grids and Forms 265



PCS Axis User and Administrator Guide
Other topics related to forms in PCS Axis include those in the following list: 

• Viewing a Form or Grid and Form

• Navigating a Form or Grid and Form (page 268)

• Arranging a Grid and Form (page 269)

Viewing a Form or Grid and Form
Information in this section explains how to view a form by selecting the option labeled 
Form or Grid And Form in the Options page of a data entry grid. 

To view a form, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to view in a form. Click  Save to 
close the window (Figure 7-4, page 216). 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Open the Inspection grid for a facility type. For example, click the Inspection tab 
and then a facility type button, such as Test Point (Figure 7-50, page 263).

4 Click the Options tab  to open the options page. In the View group box, 
click the option labeled  Form or  Grid And Form and then click Apply 
(Figure 7-52). 
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Figure 7-52.  Options

Based on your selection earlier, a form or grid and form display after clicking Apply. 
The following figure shows an example of a grid and form (Figure 7-53). 

Figure 7-53.  Grid and Form
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Navigating a Form or Grid and Form
PCS Axis displays data in a grid and form at the same time. The grid and form synchronize 
when browsing records or entering data in a record. When editing a record in a grid, the 
same record displays and updates in the form. The same is true for the grid when editing a 
record in a form. In the following example, the facility record for milepost 0+20 is selected 
in both the grid and form (Figure 7-54). 

Navigation buttons at the top of a form allow you to view the first , previous , 
next , and last  facility record for a selected pipeline segment (Figure 7-54). 

Functions performed with the Based On and Find tabs as well as command buttons (such 
as Build Survey, Add, Delete, and Refresh) perform the same as those previously 
described when working in a grid. See Viewing Records in a Grid (page 238) and Using 
Find to Search a Data Entry Grid (page 262) for more information. 

Figure 7-54.  Grid and Form

Navigation Buttons
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Arranging a Grid and Form
When the option Grid And Form is selected in the Options window, you can arrange the 
grid and form using any of the following methods:

• Right-clicking the title bar in the Form or Grid panel opens a shortcut menu 
allowing you to select the Dock or Float command. Selecting Dock docks a 
floating panel while selecting Float floats a docked panel. 

• Double-clicking the title bar in the Form or Grid panel floats these panels when 
they are docked. Likewise, when the form or grid panel is floating, double-clicking 
the respective title bar docks the panel. 

• Selecting the title bar of a form or grid and then dragging the panel displays a 
guide diamond. Drag the form or grid panel to the guide diamond to select where 
you want the panel to dock in the window. In the following example, the right 
guide in the diamond is selected for the new docking position as indicated by the 
yellow highlight color in both the guide diamond and window (Figure 7-55). 

Figure 7-55.  Arranging a Grid and Form
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Working with Continuous Survey Data
Information in this section explains how to manage survey readings and other data 
associated with a continuous survey using the Indirect Survey Manager (ISM) module. 

Data entry grids in ISM are organized based on the following continuous survey 
methods: CIS (Close Interval Survey), AC CIS (AC Close Interval Survey), DCVG (DC 
Voltage Gradient), ACVG (AC Voltage Gradient), ACCA (AC Current Attenuation), Soil 
Resistivity, and Pearson. For a description of these survey methods, see Appendix B 
(page 781).

Topics in this section include those in the following list:

• Adding or Deleting a Record in a Continuous Survey

• Working with Survey Maintenance (page 274)

• Printing, Exporting, or Emailing a Continuous Survey (page 293)

IMPORTANT: Survey readings must be assigned to a survey folder in Survey Folder 
Maintenance before working with data in ISM. If needed, refer to Adding a Continuous 
Survey Folder (page 185) for more information.

Adding or Deleting a Record in a Continuous Survey
To add or delete a record in a continuous survey, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56). 
Select the pipeline segment(s) with the facilities you want to work with, then click 

 Save to close the window. 

Figure 7-56.  Select ROWs
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2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Open the ISM data entry grid. Click Data Entry > Edit ISM Data (Figure 7-57). 

Figure 7-57.  Edit ISM Data

4 Click a button labeled with the type of continuous survey data you want to work 
with, such as the CIS button  (Figure 7-58, page 272). 

5 Select a survey folder with survey readings you want to modify. Click the down 
arrow in Selected Continuous Survey and select a survey folder in the selection 
list.

6 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel. 
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Figure 7-58.  Edit ISM Data

7 To add a record in a survey, follow these steps:

a Click  Add to open the Add Record dialog box (Figure 7-59). 

b Type a survey location in the Station Number field. 

Figure 7-59.  Add Record
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c Click Save to add the record in the grid. For example, a record for station 
number 10712+56 has been added in the next figure (Figure 7-60). 

d Provide survey data as needed. For example, type a survey reading in the 
CIS Structure P/S field and remarks in the Survey Remarks field. 

e Click  Refresh to update the grid. 

Figure 7-60.  Edit ISM Data

8 To delete a record in a survey:

a Click a station number to select a row of records in the Edit ISM Data grid. 

b Click  Delete. 

c When the Delete Record message opens, click  Delete to delete the 
selected record. Clicking  Cancel cancels the operation. 

d When the following Warning message displays, click Yes to delete the survey 
record:

Delete selected survey reading record? This action cannot be undone?

e Click  Refresh to update the grid. 
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Working with Survey Maintenance
Survey Maintenance provides several functions that simultaneously change a group of 
records. For example, instead of editing one record at a time to reverse the order of survey 
readings, use Reverse to change a range of survey records all at the same time. 

Topics in this section explain how to perform the following tasks: 

• Reversing Survey Readings (page 275)

• Shifting Station Numbers (page 277)

• Copying Station Numbers to a New Survey (page 280)

• Appending a Survey (page 281)

• Deleting a Range of Station Numbers (page 284)

• Using Spike Filtering (page 286)

• Using Rubber Band (page 288)

• Resetting Station Numbers (page 291)
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Reversing Survey Readings
Use Reverse to reverse the order of survey readings so that the first reading becomes the 
last and the last reading becomes the first. Station numbers for all other survey readings 
are changed so that the survey is reversed or “flipped”. This function is typically used when 
survey readings were taken in an upstream direction instead of downstream, or vice versa.

To reverse the order of survey readings, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Open the ISM data entry grid. Click Data Entry > Edit ISM Data. Then click a 
button labeled with the type of continuous survey you want to work with, such as 
the CIS button  (Figure 7-61). 

4 Select a survey folder with survey readings you want to reverse. Click the down 
arrow in Selected Continuous Survey and select a survey folder in the selection 
list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-61.  Edit ISM Data
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5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Reverse if the tab is not selected (Figure 7-62). 

6 Type a starting station number in the field Starting Station Number and an 
ending station number in the field Ending Station Number. 

NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

7 Click  Apply to reverse survey readings and update the data entry grid. 

Figure 7-62.  Reverse Survey Readings
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Shifting Station Numbers
Use Shift to shift a range of station numbers by a specified number of feet (or meters) or 
in the direction of an existing facility. Use the option labeled Distance when shifting 
station numbers by feet or meters. To shift a range of station numbers in the direction of 
an existing facility, use the option labeled Shift To Facility. 

Using Shift allows you to add or subtract a fixed distance to station numbers for a range of 
readings in a survey. This function is typically used when station numbers are not known 
when performing the survey and they need to be shifted to correct station numbers. 

To shift station numbers, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-63, page 278). 

4 Select a survey folder with survey readings you want to shift. Click the down arrow 
in Selected Continuous Survey and select a survey folder in the selection list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.
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Figure 7-63.  Edit ISM Data

5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Shift (Figure 7-64). 

Figure 7-64.  Shift Station Numbers
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6 Type a starting station number in the field Starting Station Number and an 
ending station number in the field Ending Station Number. 

7 Select the Distance option if it is not selected. 

8 Specify a shift distance. Type or select the number of feet (or meters) in the 
Distance field. Clicking the  up arrow increases the value; clicking the  down 
arrow decreases it. 

9 If you want to shift station numbers in the direction of an existing facility location, 
follow these steps: 

a Select the option Shift To Facility.

b Type a facility location in the Shift To Facility field or select one in the Select 
Facility dialog box. To select a facility location, click  Find to open the 
Select Facility dialog box and select a facility in the grid. Then click  Save 
(Figure 7-65). 

Figure 7-65.  Select Facility

NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

10 Click  Apply to shift station numbers and update the data entry grid. 
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Copying Station Numbers to a New Survey
To copy a range of station numbers with survey readings to a new survey, complete the 
following steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-66). 

4 Select a survey folder with survey readings you want to copy. Click the down arrow 
in Selected Continuous Survey and select a survey folder in the selection list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-66.  Edit ISM Data
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5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Copy (Figure 7-67). 

6 Type a starting station number in the field Starting Station Number and an 
ending station number in the field Ending Station Number. 

7 Type a name for the new survey in the field New Survey Name.

8 Click the down arrow in the field New Survey Date and select a survey date using 
a calendar. 

NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

9 Click  Apply to copy the range of station numbers with survey readings to a 
new survey. The new survey is available for selection in the Selected Continuous 
Survey field. 

Figure 7-67.  Copy to New Survey

Appending a Survey
To append a survey with a range of station numbers from another survey (including 
associated survey readings), complete the following steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 
Using Data Entry Grids and Forms 281



PCS Axis User and Administrator Guide
2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-68). 

4 Select the survey folder you want to append with survey readings from another 
survey. Click the down arrow in Selected Continuous Survey and select a survey 
folder in the selection list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-68.  Edit ISM Data

5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Append (Figure 7-70). 

6 Choose a survey with station numbers you want to add (append) to the survey 
currently displayed in the ISM data entry grid. Click the down arrow in field Survey 
To Append From and select a survey in the selection list. 

7 Identify a range of station numbers you want to append to the survey currently 
displayed in the ISM data entry grid. Type a starting station number in the field 
Starting Station Number and an ending station number in the field Ending 
Station Number. 
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NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

8 If duplicate station numbers do exist, a message displays requiring you to make 
one of the following selections: 

Figure 7-69.  Append Survey

9 Click  Apply. If no duplicate station numbers exist, PCS Axis adds the range of 
appended station numbers with survey readings to the survey currently displayed 
in the ISM data entry grid. 

If duplicate station numbers do exist, the Append Duplicates message displays 
requiring you to select one of options shown in the following figure. Select an 
option and then click  OK to close the message. 

Figure 7-70.  Append Duplicates
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Deleting a Range of Station Numbers
Information in this section explains how to delete a range of station numbers in a survey. 
Survey readings associated with the range of station numbers are also deleted. Deleting all 
station numbers in a survey also deletes the survey. 

To delete a range of station numbers in a survey, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-71). 

4 Select a survey folder with station numbers you want to delete. Click the down 
arrow in Selected Continuous Survey and select a survey folder in the selection 
list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-71.  Edit ISM Data
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5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Delete (Figure 7-72). 

6 Identify the range of station numbers you want to delete (includes associated 
survey readings). Type a starting station number in the field Starting Station 
Number and an ending station number in the field Ending Station Number. 

NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

7 Click  Apply. 

Figure 7-72.  Delete Range of Station Numbers

8 When the message Delete Survey Readings displays, click  OK to delete station 
numbers and associated survey readings. Clicking  Cancel cancels the operation 
(Figure 7-73). 

Figure 7-73.  Delete Survey Readings
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Using Spike Filtering
Spike filtering is available only when working with a close interval survey (CIS). Use spike 
filtering to exclude inaccurate survey readings in graphs and reports that are typically due 
to poor contact between the soil and reference electrode. Using this feature allows you to 
consider only those survey readings that are accurate when analyzing survey data. 

Inaccurate readings are excluded based on a percentage value you specify for the filter. 
PCS Axis compares the on/off values of the current reading with the on/off values of the 
previous and next reading. If the current survey reading differs from the previous and next 
survey reading by more than the percentage allowed, PCS Axis disables the option Plot 
This Point for the current survey reading and also excludes it in the CIS Survey Graph 
report. 

To apply spike filtering to a range of station numbers, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click the 
CIS button  to work with a close interval survey (Figure 7-74, 
page 287). 

4 Select a survey folder with station numbers you want to apply Spike Filtering. Click 
the down arrow in Selected Continuous Survey and select a survey folder in the 
selection list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.
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Figure 7-74.  Edit ISM Data

5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  SpikeFiltering (Figure 7-75, page 288). 

6 Type a starting station number in the field Starting Station Number and an 
ending station number in the field Ending Station Number. 

7 Type a value in the Spike Percentage field. Valid entries are in a range of 1-99. 

NOTE: Clicking the Windows close button  cancels the operation and closes 
the dialog box. 

8 Click  Apply and then click  OK when a status message displays. 

The option Plot This Point is disabled in the data entry grid only for station 
numbers that meet Spike Filtering criteria. 
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Figure 7-75.  Spike Filtering

Using Rubber Band
Use Rubber Band to adjust a range of station numbers by stretching or shrinking sections 
of a survey so that station numbers line up with known points along the survey or existing 
facilities.

Using Rubber Band allows you to re-align station numbers for a selected survey. After 
entering known station numbers for the first, last, and any other station numbers in 
between, Rubber Band adjusts remaining station numbers in a linear manner between 
known station numbers. Station numbers are then listed in ascending order (lowest to 
highest). 

When you first use Rubber Band, the fields labeled Original and Target include two 
match point records by default. These match point records are the first and last station 
numbers in the selected survey. Station numbers in the Original field are the original 
station numbers initially stored in PCS Axis as a result of importing survey data, entering 
survey data manually, or receiving survey data from the Allegro Field PC. Station numbers 
in the Target field are the corrected or adjusted station numbers that you enter or are 
entered as a result of the Rubber Band feature. 

To adjust a range of station stations using the Rubber Band function, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 
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3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-76). 

4 Select a survey folder with station numbers you want to apply the Rubber Band 
function. Click the down arrow in Selected Continuous Survey and select a 
survey folder in the selection list. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-76.  Edit ISM Data

5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  RubberBand (Figure 7-77, page 290). 

6 Complete the following steps to re-align station numbers in a survey:

a To re-align the first station number in the survey, type a new station number in 
the Target field of the first station number. 

If you want to re-align the first station number to an existing facility instead, 
click  the find button to open the Select Facility dialog box and select a 
facility in the grid. Then click  Save. 
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b To re-align the last station number in the survey, type a new station number in 
the Target field of the last station number. 

If you want to re-align the last station number to an existing facility instead, 
click  the find button to open the Select Facility dialog box and select a 
facility in the grid. Then click  Save. 

c To add new match points for known station numbers, click  New to add 
empty Original and Target match point fields. Then type the station number 
you want to re-align in the Original field and the adjusted (or corrected) 
station number in the Target field. 

If you want to re-align the adjusted station number to an existing facility 
instead, click  the find button to open the Select Facility dialog box and 
select a facility in the grid. Then click  Save. 

d To delete a row of match points, select the row and then click  Delete. 

NOTE: Clicking  Reset before clicking Apply resets station numbers to 
their original values. 

e Click  Apply. When the Apply message displays, click  OK to continue or 
 Cancel to cancel the operation. 

7 Click  Refresh to update data in the grid. 

Figure 7-77.  Rubber Banding
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Resetting Station Numbers
Use Reset to return all station numbers in the selected survey to original station numbers 
that were collected when the survey was first entered in the ISM data entry grid. 

To reset station numbers, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-78). 

4 Select a survey folder with survey readings you want to shift. Click the down arrow 
in Selected Continuous Survey and select a survey folder in the selection list.

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

Figure 7-78.  Edit ISM Data
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5 Click  Survey Maintenance to open the Survey Maintenance dialog box. 
Then click  Reset (Figure 7-79). 

Figure 7-79.  Reset

6 Click  Apply. When the Reset Station Numbers message displays, click  OK 
to reset all station numbers or  Cancel to cancel the operation (Figure 7-80). 

The data entry grid now displays original station numbers. 

Figure 7-80.  Reset Station Numbers
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Printing, Exporting, or Emailing a Continuous Survey
The following information explains how to print, export, or email a report for a continuous 
survey displaying in the Edit ISM Data grid. Supported file formats for exporting a report 
include PDF, HTML, MHT, RTF, XLS, XLSX, CSV, TXT, and Image (BMP, EMF, WMF, GIF, JPEG, 
PNG, and TIFF). 

Complete the following steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-56, 
page 270). Select the pipeline segment(s) with the facilities you want to work with, 
then click  Save to close the window. 

NOTE: If you want to collapse the Selected ROWs panel, click the Selected 
ROWs bar. Clicking the bar again expands the panel.

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Click Data Entry > Edit ISM Data to open the ISM data entry grid. Then click a 
button labeled with the type of continuous survey data you want to work with, 
such as the CIS button  (Figure 7-81). 

4 Select a survey folder with survey readings you want to print or export. Click the 
down arrow in Selected Continuous Survey and select a survey folder in the 
selection list. 

Figure 7-81.  Edit ISM Data
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5 Click  Print to open a print preview window (Figure 7-82). 

6 To print the report using the default Windows printer, click  Quick Print. 

7 To open a print dialog box and select a printer to print the report, click  Print. 

Figure 7-82.  Print Preview

8 To select a file format and export the report, follow these steps:

a Click the down arrow in  Export Document and select a file format in 
the selection list. 

b When the Options dialog box opens, set up optional property settings and 
then click OK to close the dialog box. 

c When the Save As dialog box opens, type a name for the report in the File 
name field and then navigate to a location on your computer to save the 
report. 

d Click Save. When the message Do you want to open this file displays, click 
Yes or No. 

9 To send the report as an attachment in an email, follow these steps:

a Click the down arrow in  Send via E-mail and select a file format in the 
selection list. 
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b When the Options dialog box opens, set up optional property settings and 
then click OK to close the dialog box. 

c When the Save As dialog box opens, type a name for the report in the File 
name field and then navigate to location on your computer to save the report. 
Click Save. 

d When an email message opens with the report as an attachment, select an 
email recipient and then click Send. 

10 Click  Exit to close the print preview window and return to the data entry grid. 

Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] Test Point 
Inspections. 

A filter group is a named set of one or more filters that affect the data output in the 
Define Routes grid and subsequently the route itself. PCS Axis provides two types of filter 
groups you can define. These include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in the Define Routes grid and the route. Adding an AND filter group 
produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. When you apply a filter group, 
PCS Axis processes filters in descending order beginning with the filter at the top of the 
group. 

The following sections describe how to add a layout theme, sort theme, and one or more 
optional filter groups. Topics include those in the following list: 

• Adding a Data Grid Layout Theme

• Adding a Sort Theme (page 299)

• Adding an AND Filter Group (page 302)

• Adding an OR Filter Group (page 305)

• Editing and Arranging Filters and Filter Groups (page 309)
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Adding a Data Grid Layout Theme
A layout theme is a group of fields in a grid layout. Adding a new layout theme allows you 
to choose which fields you want to include in the grid layout and then save the layout as a 
theme for later use. The following procedure applies to the grid layout for any data entry 
grid in PCS Axis. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 7-4, page 216). 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Open the data entry grid that you want to add a new grid layout theme. For 
example, click the Inspection tab  and then the Test Point button 

 to display the Test Point Inspection grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Click the Customize tab  then the  Add button to open the New 
Layout Theme dialog box (Figure 7-83). 

Figure 7-83.  New Layout Theme
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6 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it.

7 If you want to copy fields from an existing layout theme, click the Copy Content 
check box to place a check mark inside the check box. Then click the down arrow in 
the field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing layout theme, remove the check 
mark inside the Copy Content check box by clicking the check box. 

8 Click  OK to save changes and return to the Layouts page (Figure 7-84, 
page 298). 

9 Complete the following steps to add and remove fields in the new layout theme as 
needed:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The grid layout theme includes all fields listed in the right 
pane of the Layouts page. 

c To remove a field in the layout theme, double-click a field listed in the right 
pane to move it to the left pane. Repeat this step as needed. 

10 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

11 Click  Save to save changes.
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Figure 7-84.  Layouts

12 To apply the new layout theme to the data entry grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 7-85). 

b Click the down arrow in the field Select Layout Theme and select the new 
layout theme in the selection list. 

13 Click  Apply to apply changes and return to the data entry grid. 

Figure 7-85.  Options
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Adding a Sort Theme
A sort theme determines how PCS Axis sorts records in the data entry grid. Adding a sort 
theme allows you to choose which field(s) to sort records by and if records sort 
alphanumerically in ascending or descending order. 

To add a sort theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 7-4, page 216). 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Open the data entry grid that you want to add a new grid sorting theme. For 
example, click the Inspection tab  and then the Test Point button 

 to display the Test Point Inspection grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Click the Customize tab  then the Sorts button  to open 
the Sorts page (Figure 7-86). 

Figure 7-86.  Sorts
Using Data Entry Grids and Forms 299



PCS Axis User and Administrator Guide
6  Click the  Add button to open the New Sort Theme dialog box (Figure 7-87). 

7 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

8 If you want to copy fields from an existing layout theme, click the Copy Content 
check box to place a check mark inside the check box. Then click the down arrow in 
the field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing layout theme, remove the check 
mark inside the Copy Content check box by clicking the check box. 

9 Click  OK to save changes and return to the Sorts page. 

Figure 7-87.  New Sort Theme

10 Complete the following steps to add and remove fields in the new sorting theme 
as needed (Figure 7-88): 

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 
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b Double-click a field listed in the left pane to move it to the right pane. (Clicking 
the top arrow button  also moves the selected field.) Repeat this step as 
needed. The sorting theme includes all fields listed in the right pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. (Clicking the bottom arrow button 

 also moves the selected field.) Repeat this step as needed. 

11 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

12 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

13 Click  Save to save changes.

Figure 7-88.  Sorts

14 To apply the new sorting theme to the data entry grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 7-89, 
page 302). 

b Click the down arrow in the field Select Sort Theme and select the new 
sorting theme in the selection list. 
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15 Click  Apply to apply changes and return to the data entry grid. 

Figure 7-89.  Options

Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in a 
data entry grid in Data Entry. Adding an AND filter group produces a subset of records 
that meet all filter conditions. PCS Axis processes filters in a filter group in descending 
order beginning with the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data > to open the Edit CPDM Data window. 

3 Select the data grid you want to filter data. For example, click the  
Inspections tab. 

4 Click the Customize tab , then the Filters button  to open 
the Filters page. 
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5 Click  New ‘And’ Group to open a filter properties group box (Figure 7-90, 
page 304). 

6 Type a name for the filter group in the field Filter Group Caption. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If the AND filter group includes a date filter, such as Facility Delinquent Date Is 
Between shown in Figure 7-90, set a date range using a calendar or dynamic dates 
in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields.

9 If you want the filter to remain on for all sessions when working with the data entry 
grid, click the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

10 Type a name for the filter in the field Enter Custom Filter Caption. 

11 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Type a name for the filter in the field Enter Custom Filter Caption. Repeat 
steps 7 through 10 to set up filter criteria. Then click the close button  to 
close the filter group. 
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Figure 7-90.  Filters

12 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

13 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

14 To apply one or more filters to the data entry grid (Figure 7-91, page 305):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. Then click  Apply to 
save changes and return to the data entry grid. 
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Figure 7-91.  Options

Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output in a 
data entry grid in Data Entry. Adding an OR filter group produces a subset of records that 
meet any filter condition. PCS Axis processes filters in a filter group in descending order 
beginning with the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Select the data grid you want to filter data. For example, click the  
Inspections tab. 

4 Click the Customize tab , then the Filters button  to open 
the Filters page. 
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5 Click  New ‘Or’ Group to open a filter properties group box (Figure 7-92, 
page 306). 

6 Type a name for the filter group in the field Include records that match any of 
these conditions. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If the OR filter group includes a date filter, such as Facility Delinquent Date Is 
Between shown in Figure 7-92 (page 306), set a date range using a calendar or 
dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields.

9 If you want the filter to remain on for all sessions when working with the selected 
route, click the check box Filter is Always On. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

10 Type a name for the filter in the field Enter Custom Filter Caption. 

Figure 7-92.  Filters
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11 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Repeat steps 6 through 10 to set up the filter group. Then click the close 
button  to close the filter group. 

12 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

13 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

14 To apply one or more filters to the data entry grid (Figure 7-93):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. Then click  Apply to 
save changes and return to the data entry grid. 
Using Data Entry Grids and Forms 307



PCS Axis User and Administrator Guide
Figure 7-93.  Options
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Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Select the data grid you want to filter data. For example, click the  
Inspections tab. 

4 Click the Customize tab , then the Filters button  to open 
the Filters page (Figure 7-94). 

5 Click the edit icon  to display a filter’s property settings. 

Figure 7-94.  Filters

6 To delete a filter in a filter group, click the filter’s  delete button. Then click 
 OK when the Delete message displays. 

7 To rename a filter, type a description in the filter’s name field. 

8 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 
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9 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

10 Click the  close button to close the filter’s property settings group box. 

11 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save. 

13 To apply filter changes to the data entry grid:

a Click the Options tab  to open the options page. 

b Click  Apply to apply filter changes and return to the data entry grid. 

Figure 7-95.  
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Working with Records
The information in this section explains how to work with various types of records in a data 
entry grid. Topics include those in the following list:

• Activating Facility Inspection Fields for Data Entry

• Working with Multiple Test Point Potentials (page 313)

• Attaching a Document to a Grid Record (page 317)

• Working with the Target Structure P/S Field (page 329)

• Recording Facility Current Values (page 332)

• Linking Rectifiers to ROWs (page 338)

• Working with Rectifier Anodes (page 340)

• Working with Rectifier Negatives (page 343)

Activating Facility Inspection Fields for Data Entry
Inspection fields with Activate in the field description must first be added and enabled in 
the facility Information grid to allow data entry of inspection readings in the facility 
Inspection grid. 

To activate facility inspection fields for data entry, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with facilities you want to work with, then 
click  Save to close the window. 

2 Open the Edit <module> Data window. For example, click Data Entry > Edit 
CPDM Data to open the Edit CPDM Data window. 

3 Open the Information grid for a facility type. For example, click the Information 
tab  and then a facility type button, such as Test Point  
(Figure 7-96, page 312). 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Click the check box of an Activate inspection field for a facility in the grid to place 
a check mark in the check box. For example, click the check box Activate 
Structure P/S (Volts) for a facility in the grid.
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6 Click Yes to apply the change when a warning message displays to notify you of a 
change to the facility’s permanent history record. 

The inspection field is now available for data entry in the Inspection grid for the 
selected facility. If the inspection field is not present in the Inspection grid, refer to 
Adding a Data Grid Layout Theme (page 296) for information about adding 
fields in a grid. 

NOTE: You can also activate an inspection field in the Inspection grid by right-
clicking the field and selecting Activate Item in the shortcut menu that opens. 

Figure 7-96.  Information
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Working with Multiple Test Point Potentials
Use the CPDM Test Point Detail Information and Test Point Detail Inspection mini-grids 
to manage multiple potential measurements for test point subfacilities linked to a test 
point facility. These mini-grids function in a similar manner as the rectifier mini-grids when 
linking rectifier anodes and negatives. 

The Test Point Detail Inspection mini-grid allows you to choose which potential 
measurement to use for compliance reporting. After selecting a potential measurement for 
compliance reporting, PCS Axis automatically copies it to the associated test point facility 
in the Inspection grid. 

NOTE: The Test Point Detail mini-grids become available for use after enabling the system 
option Show Detail Inspection Entry Grid. When using the optional Telluric 
Compensation feature, the mini-grids display by default and cannot be disabled. 

Linking Multiple Subfacilities to a Parent Test Point Facility
The procedure in this section explains how to link multiple subfacilities to a parent test 
point facility and then select one of the subfacility potential measurements (survey 
readings) for compliance reporting.

The process begins with adding and linking new subfacility records to a parent test point 
facility in the Test Point Detail Information mini-grid. After adding these records, they are 
then available for use in the Test Point Detail Inspection mini-grid. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 7-4, 
page 216). Choose pipeline segments with test point facilities you want to work 
with, then click  Save to close the window. 

2 Click Data Entry > Edit CPDM Data to open the Edit CPDM Data window. 

3 Click Test Point  and then the Information tab  to open 
the Information grid. 

4 If the Test Point Detail Information mini-grid is not visible, double-click the 
Test Point Det... button  to open the mini-grid (Figure 7-97, 
page 314). 
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Figure 7-97.  Test Point Detail Information

5 To add and link new subfacility records to a parent test point facility in the 
Information grid, follow these steps: 

a Select a test point facility in the Information grid. Then click  Add in the 
mini-grid to add and link a subfacility record. Fields requiring information 
include a  red icon, such as Name and PCS Field Name shown in the 
following example (Figure 7-98). 

Figure 7-98.  Test Point Detail Information
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b Type a unique name for the new subfacility in the Name field. This field 
supports up to 10 alphanumeric characters. 

IMPORTANT: To prevent adding duplicate subfacility records in the system, it 
is important to enter a unique name in the Name field for each subfacility 
record. Do not use the default name in the Name field or leave it empty 
(blank). 

c Click the field PCS Field Name. Then click the selection arrow and select the 
name of a PCS field. Choose a PCS field that matches the type of potential 
measurement associated with the new subfacility, such as Structure P/S. 

d Repeat steps 5 "a" through "c" for each new subfacility record you want to add 
and link to the currently selected test point facility record. 

NOTE: The Currently Active check box indicates when a subfacility is active or 
inactive. A check mark inside the check box indicates an active subfacility and 
can also be included in Prompts sent to the Allegro Field Computer. When 
the check box is empty, this indicates an inactive subfacility, such as a 
damaged subfacility or one that has been replaced. 

6 Complete the following steps to add potential measurements (survey readings) for 
subfacilities in the Test Point Detail Inspection mini-grid, and then select one of 
these for compliance reporting: 

a Click the Inspection tab  to open the Inspection grid. 

b If the Test Point Detail Inspection mini-grid is not visible, double-click the 
Test Point Det... button  to open the mini-grid.

c Select a test point facility in the Inspection grid that includes subfacilities you 
want to add potential measurements (Figure 7-99, page 316). 

d If potential measurements have not previously been added in the mini-grid, 
click  Add to enable the mini-grid for data entry. 

e Select a subfacility in the mini-grid. Then add potential measurements and 
other related survey data in appropriate mini-grid fields. Repeat this step as 
needed for other linked subfacilities in the mini-grid. 
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f To select a potential measurement to use for compliance reporting, click the 
Compliance option button in the mini-grid associated with the subfacility 
record. 

NOTE: Based on your PCS Axis license, the Compliance field may be named 
Selected Reading instead. 

g Click  Refresh to copy the selected potential measurement to the linked 
test point facility in the Inspection grid. 

Figure 7-99.  Test Point Detail Inspection Mini-Grid

NOTE: When a value for a dependent field has been updated in a data entry 
grid, a  notification icon displays in the derived field indicating the value has 
changed and the data entry grid should be refreshed. Clicking the  Refresh 
button updates all derived values and removes the notification icon. See 
Working with Derived Fields (page 214) for more information. 
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Attaching a Document to a Grid Record
When you want to attach a document to a record in the grid, use the Attached Document 
field to link or embed a file or webpage address to a ROW, facility, inspection, or 
maintenance record. Supported file types include image, video, HTML, XML, music, and 
text files (such as Microsoft Word, WordPad, Notepad, or PowerPoint files). 

As an example, you can attach an image of a survey site or damaged facility; a document 
describing your company’s safety procedures; or a document identifying a manufacturer’s 
specification for a piece of equipment. 

Linking a document identifies the file location on a local computer, company network, FTP 
site, or webpage on the Internet. Linking documents stored on a local computer are 
accessible only from that computer. Embedding a document stores a copy of the file in the 
PCS Axis database. 

NOTE: Storing copies of documents in the PCS Axis database increases the size of the 
database. 

If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes.

Editing an embedded document applies changes only to the copy stored in the PCS Axis 
database; changes do not apply to the source file stored outside of PCS Axis. Likewise, 
editing a source file applies changes only to the source file, not the copy stored in PCS 
Axis. 

For more information, continue with one of the following topics: 

• Adding an Attached Document Field in the Grid (page 318)

• Attaching a Document to a ROW, Facility, Inspection, or Maintenance Record 
(page 322)

• Viewing an Attached Document (page 327)

NOTE: For information about how to attach a document to a pipeline record, see 
Working with Pipeline Records (page 127). 
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Adding an Attached Document Field in the Grid
Each of the following fields allow you to attach a document to a record in the grid. If any of 
these fields are not present in the grid, use the procedure in this section to add one or 
more fields as needed. 

• ROW Attached Documents: add this field in the Information, Inspection, or 
Maintenance grid if you plan to attach a document to a ROW record. 

• Facility Attached Documents: add this field in the Information, Inspection, or 
Maintenance grid if you plan to attach a document to a facility record. 

• Inspection Record Attached Documents: add this field in the Inspection grid if 
you plan to attach a document to an inspection record.

• Maintenance Record Attached Documents: add this field in the Maintenance grid 
if you plan to attach a document to a maintenance record. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 7-4, page 216). 

2 Click Data Entry > Edit <module> Data, such as Edit CPDM Data. If present, 
click a facility type button, such as Test Point in CPDM or Coupons in ICM. 

3 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

4 Based on the attached document field you want to add, complete one of the 
following steps to open the grid:

a To add the attached document fields Facility Attached Documents and/or 
ROW Attached Documents in the Information, Inspection, or Maintenance 
grid, click the Information, Inspection, or Maintenance tab to open the 
grid. 

b To add the field Inspection Record Attached Documents in the Inspection 
grid, click the Inspection tab  to open the grid.

c To add the field Maintenance Record Attached Documents in the 
Maintenance grid, click the Maintenance tab  to open the grid. 

5 Click the Customize tab  to view the Layouts page. 
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6 Click the down arrow in Select Layout Theme and select a layout theme in the 
selection list. 

7 Type attached in the search field of the left pane to display a list of attached 
document fields available for selection. 

8 To add the fields Facility Attached Documents and/or ROW Attached 
Documents in the Information, Inspection, or Maintenance grid, follow these 
steps:

a Click the check box for the fields Facility Attached Documents and/or 
ROW Attached Documents in the left pane of the window (Figure 7-100, 
page 319). 

b Click the top arrow button  to move selected fields to the right pane. The 
grid includes all fields listed in the right pane. Click  Save.

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 
If you want to remove a field in the right pane, double-click the field to move it 
back to the left pane. Fields with a lock icon  are required and cannot be 
removed. 

Figure 7-100.  Layouts

Search Field
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9 To add the field Inspection Record Attached Documents in the Inspection grid, 
complete the following steps:

a Click the check box for the field Inspection Record Attached Document in 
the left pane of the window (Figure 7-101, page 320). 

b Click the top arrow button  to move the field to the right pane. The grid 
includes all fields listed in the right pane. Click  Save.

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 
If you want to remove a field in the right pane, double-click the field to move it 
back to the left pane. Fields with a lock icon  are required and cannot be 
removed. 

Figure 7-101.  Layouts

Search Field
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10 To add the field Maintenance Record Attached Documents in the Maintenance 
grid, complete the following steps:

a Click the check box for the field Maintenance Record Attached Document 
in the left pane of the window (Figure 7-102, page 321). 

b Click the top arrow button  to move the field to the right pane. The grid 
includes all fields listed in the right pane. Click  Save. 

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 
If you want to remove a field in the right pane, double-click the field to move it 
back to the left pane. Fields with a lock icon  are required and cannot be 
removed. 

Figure 7-102.  Layouts

11 To apply the layout theme in the grid, follow these steps: 

a Click the Options tab  to open the options page. 

b Click the down arrow in Select Layout Theme and select the layout theme 
that includes attached document fields. 

c Click  Apply to apply changes and return to the grid. 

Search Field
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Attaching a Document to a ROW, Facility, Inspection, or 
Maintenance Record
Information in this section explains how to attach a document to a record in the grid using 
the options Link Document and Embedded Document. 

NOTE: If the option Disable Link Attachments has been enabled in system Options by your 
company's system administrator, the option Link Document is unavailable for selection. 
Use the option Embedded Document instead when attaching a document to a record. 
This places a copy of the document in the PCS Axis database. See Table 3-3 (page 46) for 
more information. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 7-4, page 216). 

2 Click Data Entry > Edit <module> Data, such as Edit CPDM Data. If present, 
click a facility type button, such as Test Point in CPDM or Coupons in ICM. 

3 Based on the type of record you want to attach a document, complete one of the 
following steps:

a To attach a document to a ROW or facility record, click the Information tab 
 to open the Information grid.

b To attach a document to an inspection record, click the Inspection tab 
 to open the Inspection grid.

c To attach a document to a maintenance record, click the Maintenance tab 
 to open the Maintenance grid. 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.
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5 Click the edit icon  in the Attached Documents field for the grid record you 
plan to attach a document (Figure 7-103). 

Figure 7-103.  Attached Document Field

6 When the Maintain Attached Documents dialog box opens, click  Attach and 
then select the option Link Document or Embedded Document. 

Select Link Document if you plan to link to a document on a local computer or 
company network, or want to add a link to a webpage on the Internet. 

Select Embedded Document if you want to store a copy of an attached document 
in the PCS Axis database. 

NOTE: Storing copies of attached documents in the database increases the size of 
the database. 

7 If you selected Link Document in step 6 and want to link to a file on a local 
computer or company network, follow these steps (Figure 7-104): 

a Click the ellipsis button … in the Document field to open the Link File dialog 
box. 

b Navigate to the file and select it. Click Open to link to the file and close the 
dialog box. 
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c Type a description for the linked file in the Description field. When a 
description is not provided, PCS Axis uses the filename of the linked document 
as the description. 

Figure 7-104.  Maintain Attached Documents

d Click  Save, then click OK when the following message displays:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 

e When you finish attaching documents, click the close button  to close 
the window and return to the grid. 

NOTE: A list of attached documents and whether they are linked or 
embedded displays in the window. Selecting an item in the list displays its 
location in the Document field. 

8 If you selected Link Document in step 6 and want to add a link to a webpage on 
the Internet, follow these steps (Figure 7-105): 

a Type an Internet address in the Document field. For example, type 
http://www.aiworldwide.com in the field. 
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b Type a description for the link in the Description field. When a description is 
not provided, PCS Axis uses the filename of the linked document as the 
description. 

Figure 7-105.  Maintain Attached Documents

c Click  Save, then click OK when the following message displays:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 

d When you finish attaching documents, click the close button  to close 
the window and return to the grid. 

NOTE: A list of attached documents and whether they are linked or 
embedded displays in the window. Selecting an item in the list displays its 
location in the Document field. 

9 If you selected Embedded Document in step 6, complete the following steps 
(Figure 7-106):

a Click the ellipsis button … in the Document field to open the Embed File 
dialog box. 
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b Navigate to the file and select it. Click Open to embed a copy of the file and 
close the dialog box. 

c Type a description for the embedded file in the Description field. If a 
description is not provided, PCS Axis uses the filename of the embedded file 
as the description. 

Figure 7-106.  Maintain Attached Documents

d Click  Save, then click OK when the following message displays:

Local changes made to embedded documents won’t be saved into PCS. 
Do you want to continue? 

NOTE: Editing an embedded document applies changes only to the copy 
stored in the PCS Axis database; changes do not apply to the source file stored 
outside of PCS Axis. Likewise, editing a source file applies changes only to the 
source file, not the copy stored in PCS Axis. 

e When you finish attaching documents, click the close button  to close 
the window and return to the grid. 

NOTE: A list of attached documents and whether they are linked or 
embedded displays in the window. Selecting an item in the list displays its 
location in the Document field. 
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Viewing an Attached Document
If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes. 

To view or open an attached document, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 7-4, page 216). 

2 Open the data entry grid that includes the grid record with the attached document. 
For example, click Data Entry > Edit CPDM Data > Test Point > Inspection to 
open the Test Point Inspection grid. 

3 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

4 Click the preview icon  for the grid record with the attached document 
(Figure 7-107). 

Figure 7-107.  View Attached Document

5 When the Preview Attached Documents window opens, select a file in the list on 
the left side of the window to preview the file (Figure 7-108, page 328). 

6 If the file type of the attached document is associated with a default software 
program on the local computer, click  Open to open the file. 
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7 Click the close button  to close the Preview Attached Documents window.

NOTE: When you open and then edit an embedded document, changes apply 
only to the copy stored in the PCS Axis database; changes do not apply to the 
source file stored outside of PCS Axis. Likewise, editing the source file applies 
changes to the source file, not the copy stored in the PCS Axis database. 

Figure 7-108.  Preview Attached Documents
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Working with the Target Structure P/S Field
The Target Structure P/S field is a system-generated field available in the CPDM Test 
Point Inspection grid. The field is gray to indicate its contents are system-generated. 
Target Structure P/S is used by PCS Axis to calculate a target reading with a minimum 
pipe-to-soil (P/S) for meeting criteria. The target reading is calculated based on your 
selected protection criterion and information in other fields (Table 7-1, page  330). 

The default setting for Target Structure P/S is -0.850. To change the setting, follow these 
steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select one or more pipeline segments with facilities you want to work 
with, then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Test Point Information grid. Click the Information tab  and 
then the Test Point button  (Figure 7-109). 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select the field Test Point Protection Criteria for a test point in the grid. Click 
the down arrow and select a protection criterion in the selection list. Repeat this 
step for other test points as needed. 

Figure 7-109.  Test Point Information Grid
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6 Set up other fields used to calculate Target Structure P/S according to the 
information in the next table (Table 7-1). Based on how your data entry grids are 
arranged, fields may be in the Test Point Information or Inspection grid.

The following table describes how Target Structure P/S is calculated for each 
protection criterion. Each protection criterion identifies fields required for 
calculating Target Structure P/S. Equations with pipe brackets ( | ) represent 
absolute values (Table 7-1).

Table 7-1.  Calculating Target Structure P/S 

Protection Criterion Target Structure P/S Calculation

.85 On (default) –0.850 V

.85 IRF –0.850 – | Structure P/S – Structure IRF |

Example:–0.850 – | –1.200 –  –0.800 | = –1.250

Note:The value in the field User IR Correction (if any) is used 
instead of the | Structure P/S – Structure IRF | equation.

100 mV Native P/S – 0.100 – | Structure P/S – Structure IRF |

Example:–0.550 – 0.100 – | –1.200 –  –0.800 | = –1.050

Note:The fields Native P/S and Native Date can be included 
with any survey regardless of how old. PCS Axis always finds the 
most recent native reading and date, and the most recent pair 
of structure “on/off” readings (Structure P/S and Structure IRF). 
This means if the current-year survey includes only “on” 
readings, PCS Axis uses the last “on/off” reading and native 
date. This is the case until a new “on/off” reading is taken. 

300 mV This is no longer recognized by NACE RP0169 or DOT 
regulations. 

Ref Read Add the field Test Point Reference P/S in the grid when using 
“Ref Read” (reference reading) protection criterion.

Ag/AgCl Functions the same as “.85 On” but uses –0.800V instead. Use 
this protection criterion for off-shore (saltwater) or tank “on” 
readings when using silver/silver chloride half cell. 
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The field Target Structure IRF is used for a facility to meet criteria and the calculated 
minimum value for the Structure IRF field. 

.85 On criteria Calculation: Target Structure IRF = Null 

.85 IRF (off) and 
100mV criteria 

Structure IRF can be compared to Target Structure IRF to 
determine if the inspection is in compliance. If Structure IRF is 
more negative than Target Structure IRF, the test point is in 
compliance.

• Calculation for .85 IRF Criteria: Target Structure IRF = -.85. 

Target Structure P/S is calculated for an inspection that has a 
Structure IRF.

• Calculation for 100mV Criteria: Target Structure IRF = Native 
P/S - 0.1. Native Date must be added in the grid. 

Target Structure IRF is calculated for an inspection that has a 
Structure IRF. 

Native P/S = Most recent Native P/S before the date of the 
Structure P/S and Structure IRF. 

.85 On Calculation: Target Structure IRF = Null

300 mV Calculation: Target Structure IRF = Null

Ref Read Calculation: Structure P/S = Null

Table 7-1.  Calculating Target Structure P/S (continued)

Protection Criterion Target Structure P/S Calculation
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Recording Facility Current Values
Information in this section identifies required and optional fields for recording facility 
current values in data entry grids:

• Recording Rectifier Current

• Recording Pipeline Current (page 334)

• Recording Bond Current (page 337)

Recording Rectifier Current
Information in the following table (Table 7-2) identifies the fields required for recording 
rectifier current (rectifier DC amps and volts; rectifier anode output current, and rectifier 
negative output current). 

Table 7-2.  Recording Rectifier Current Values 

Facility & Current Type Description

Rectifier: 
DC Amps and DC Volts

1 Add the following fields in the Rectifier Information 
grid: 

• Activate Rectifier Output Current Found

• Activate Rectifier Output Volts Found

As an option you can also add the following fields in 
the Information grid: 

• Rectifier Output Shunt Factor (A/mV): use this 
fields to enter the amps value of the shunt 
conversion factor. Enter as a whole number value. 
Together the value in this field and in the Rectifier 
Output Shunt Rating (mV/A) field make up the 
shunt conversion factor. 

• Rectifier Output Shunt Rating (mV/A): use this 
field to enter the millivolts value of the shunt 
conversion factor. Enter as a whole number value. 
Together the value in this field and in the Rectifier 
Output Shunt Factor (A/mV) field make up the 
shunt conversion factor.

2 Add the following fields in the Rectifier Inspection grid:

• Rectifier Output Current Found (Amps)

• Rectifier Output Volts Found (Volts)

• Rectifier Output Current Left (Amps)

• Rectifier Output Volts Left (Volts)

• Rectifier Current Adjusted
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Rectifier: 
Anode Output Current

Add the field Number of Impressed Anodes in either the 
Rectifier Information or Inspection grid. 

The Rectifier Anode Information mini-grid in the Rectifier 
Information grid automatically includes the following fields 
for entering anode data: 

• Impressed Anode Current Minimum (Amps)

• Impressed Anode Current Maximum (Amps)

• Impressed Anode Shunt Rating (mV/A)

• Impressed Anode Shunt Resistance (Ohms)

• Impressed Anode Shunt Factor (A/mV)

See Working with Rectifier Anodes (page 340) for more 
information. 

Rectifier: 
Negative Output Current

Add the field Number of Negatives in either the Rectifier 
Information or Inspection grid. 

The Rectifier Negative Information mini-grid in the 
Rectifier Information grid automatically includes the 
following fields for entering rectifier negative data: 

• Negative Current Min (Amps)

• Negative Current Max (Amps)

• Negative Current Shunt Rating (mV/A)

• Negative Current Shunt Resistance (Ohms)

• Negative Shunt Factor (A/mV)

See Working with Rectifier Negatives (page 343) for more 
information. 

Table 7-2.  Recording Rectifier Current Values (continued)

Facility & Current Type Description
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Recording Pipeline Current
Information in the following table (Table 7-3) identifies the fields required for recording 
pipeline current values. 

Table 7-3.  Recording Pipeline Current

Facility & Current Type Description

Pipeline Current: 
IR Drop Test Station

1 Add the following fields in the Test Point 
Information grid. Enable “activate” fields for use. 

• Activate Pipeline Current On - mV Drop 

• Activate Pipeline Current Direction

• Pipeline Current Calibration Factor (A/mV): 
Enter the amps value of the current factor when 
using the resistance of the pipeline to measure 
current flow on the pipeline. Enter value as 
whole number. The value is used in the pipeline 
current calculation. 

• Pipeline Current Measurement Ratio (mV/A): 
Enter the current factor when using the 
resistance of the pipeline to measure current 
flow on the pipeline. Enter value as whole 
number. The value is used in the pipeline current 
calculation. 

2 Add the following fields in the Test Point Inspection 
grid:

• Pipeline Current On (Amps): Enter amps 
reading for pipeline current measured with 
rectifier on. 

• Pipeline Current Direction: Use this field to 
describe the direction of the current, such as 
upstream or downstream.
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Pipeline Insulator Current: 
Shunt for Insulated Flange

1 Add the following fields in the Test Point 
Information grid. Enable “activate” fields for use. 

• Activate Insulator Current 

• Insulator Shunt Factor (A/mV)

• Insulator Shunt Rating (mV/A)

2 Add the field Insulator Current (Amps) in the Test 
Point Inspection grid. 

Use the field Insulator Current (Amps) to enter 
the amps value of the insulator shunt reading. PCS 
Axis uses the reading and the value in the field 
Insulator Shunt Rating (mV/A) to calculate and 
enter a value in the field Insulator Shunt Factor 
(A/mV). 

Pipeline Insulator P/S 1 Add and enable the field Activate Insulator P/S in 
the Test Point Information grid. 

2 Add the field Insulator P/S in the Test Point 
Inspection grid. 

Use the Insulator P/S field to enter a potential 
reading for the other side of an insulated flange, 
relative to the soil. This type of reading is also 
referred to as an “insulator-to-soil” potential 
reading. 

If the protection criteria option .85 IRF or 100mV is 
selected in the field Test Point Protection Criteria, 
add and enable the field Activate Insulator IRF in 
the Test Point Information grid and then add the 
field Insulator IRF (Volts) in the Test Point 
Inspection grid. 

Table 7-3.  Recording Pipeline Current

Facility & Current Type Description
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Pipeline Galvanic Current: 
Shunt for Galvanic Anode

1 Add the following fields in the Galvanic Anode 
Information grid. Enable “activate” fields for use. 

• Activate Galvanic Current 

• Galvanic Anode Shunt Factor (A/mV)

• Galvanic Anode Shunt Rating (mV/A)

2 Add the field Galvanic Current (Amps) in the 
Galvanic Anodes Inspection grid. 

Use the field Galvanic Anode Current (Amps) to 
enter the amps value of the galvanic anode shunt 
reading. PCS Axis uses the reading and the value in 
the field Galvanic Anode Shunt Rating (mV/A) to 
calculate and enter a value in the field Galvanic 
Anode Shunt Factor (A/mV). 

Table 7-3.  Recording Pipeline Current

Facility & Current Type Description
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Recording Bond Current
Table 7-4 identifies the fields required for recording bond current using the Bond 
Information and Inspection data entry grids (Data Entry > Edit CPDM Data > Foreign 
Bond). 

Table 7-4.  Recording Bond Current Values 

Facility Type Description

Bond Current 1 Add the following fields in the Foreign Bond 
Information grid: 

• Bond Shunt Rating

• Bond Shunt Resistance

Use the field Bond Shunt Rating to enter the amps 
reading of the bond conversion shunt factor. Use 
the field Bond Shunt Resistance to enter the 
millivolt (mV) reading of the bond conversion 
factor. Readings in both of these fields 
automatically update the field Bond Shunt Factor. 

2 Add the following fields in the Foreign Bond 
Inspection grid:

• Bond Current Found

• Bond Current Left

• Bond Current Adjusted

Use the field Bond Current Found to enter the 
current reading for a foreign bond as it is found 
(before adjusting the current). The value 
automatically copies to the field Bond Current 
Left. To adjust the Bond Current Found reading, 
click the check box Bond Current Adjusted and 
then type the adjusted reading in the field Bond 
Current Left.
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Linking Rectifiers to ROWs
When the same rectifier provides current to one or more pipeline segments, or parallel 
lines entered in the hierarchy as pipeline segments, use the ROW Links mini-grid to link 
the rectifier to each pipeline segment or parallel line. This allows you to enter rectifier 
information once instead of re-entering the same rectifier information for each pipeline 
segment or parallel line. This in turn reduces the number of database records and the 
potential for data entry errors. 

To link a rectifier to one or more pipeline segments, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select the pipeline segment(s) with the rectifier you want to work with, 
then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Rectifier Information grid. Click the Information tab  and 
then the Rectifier button . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select a row of records in the Rectifier Information grid with the rectifier you want 
to link to a pipeline segment. For example, the record for pipeline segment T-1403 
is selected in the following figure (Figure 7-110, page 338). 

6 Click the minimize button  in the upper right-hand corner of the Facility Level 
Override mini-grid to hide the mini-grid. Then double-click the ROW Links 
button  to open the ROW Links mini-grid (Figure 7-110). 

Figure 7-110.  ROW Links
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7 Click  Add in the ROW Links mini-grid to open the Add Row Link dialog box 
(Figure 7-111). 

Figure 7-111.  Add Row Link

8 Identify the milepost number of the pipeline segment you want to link. Type the 
milepost number in the Milepost field, then select the pipeline segment. Click 
Save to save changes and close the dialog box. 

After clicking Save the following operations occur:

• PCS Axis adds a new ROW link for the selected milepost and pipeline segment 
in the ROW Links mini-grid. 

If this is the first link in the mini-grid, it automatically becomes the Primary 
Link . PCS Axis copies rectifier information from the Primary Link to 
subsequent links added later in the mini-grid. You can however set any link in 
the mini-grid as the Primary Link by clicking the option button. Only one link 
can be set as the Primary Link . 

• PCS Axis adds a new record for the selected milepost and pipeline segment in 
the Rectifier Information grid. 

The new record includes rectifier information copied from the record selected 
as the Primary Link in the ROW Links mini-grid. 

9 Provide a date in the Creation Date field to identify when you linked the rectifier 
to the pipeline segment. Select the Creation Date field and then click the down-
arrow to select a date using a calendar. 
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Working with Rectifier Anodes
PCS Axis provides two mini-grids for working with rectifier impressed anodes. Use the 
Rectifier Anode Information mini-grid to provide anode information, such as the shunt 
rating or shunt resistance for each anode in the ground bed of a rectifier. PCS Axis uses 
this information to automatically calculate the anode shunt factor. 

Use the Rectifier Anode Inspection mini-grid to enter inspection readings for each anode 
in the ground bed of a rectifier, such as a current or shunt reading for each impressed 
anode in the ground bed. 

Tracking rectifier impressed anodes in PCS Axis allows you to monitor the capacity of the 
anode ground bed for a rectifier that produces current. You can track the current flow for 
each anode to determine which anodes have low or no current output. 

Topics in this section include those in the following list:

• Adding Rectifier Anode Information (page 340)

• Adding Rectifier Anode Inspections (page 342)

Adding Rectifier Anode Information
To add a record in the Rectifier Anode Information mini-grid for each anode in the 
ground bed, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select the pipeline segment(s) with the rectifier you want to work with, 
then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Rectifier Information grid. Click the Information tab  and 
then the Rectifier button . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select a row of records in the Rectifier Information grid with the rectifier you 
want to add impressed anode records. For example, the record for pipeline 
segment T-1401 with rectifier R-202 is selected in the next figure (Figure 7-112, 
page 341). 

6 If the Rectifier Anode Information mini-grid is not visible, double-click the 
Rectifier Anode... button  to open the mini-grid (Figure 7-112, 
page 341). Click the minimize button  in the upper right-hand corner of all other 
mini-grids to hide these mini-grids. 

7 Click  Add in the Rectifier Anode Information mini-grid to add an empty 
record in the mini-grid. 
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8 Type a name for the anode in the Name field. Fields requiring information include 
a  red icon, such as Name shown in the next figure (Figure 7-112). 

9 Enter a value in either the field labeled Impressed Anode Shunt Rating or 
Impressed Anode Shunt Resistance. 

NOTE: If entering a shunt rating, enter it as a mV per A ratio using the format nn.n/
nn.n, such as 50.0/25.0 for the shunt rating 50 mV/25 A. If entering a shunt 
resistance value, enter the actual resistance of the shunt in ohms. When both of 
these fields are empty, you can enter a value in the field Impressed Anode Shunt 
Factor instead. Otherwise, PCS Axis automatically calculates the shunt factor based 
on the value in the shunt rating or shunt reading field. 

10 Repeat steps 7 through 9 to add each remaining anode in the ground bed. 

11 Click  Refresh to update  derived fields, such as Number of Impressed 
Anodes shown in the next figure (Figure 7-112). For more information about 
derived fields, refer to Working with Derived Fields (page 214). 

Figure 7-112.  Rectifier Anode Information

NOTE: PCS Axis displays the total number of anodes in the system calculated field 
labeled Number of Impressed Anodes in the Rectifier Information and 
Inspection grid. This value is based on the total number of anodes in the Rectifier 
Anode Information mini-grid. If the field is not present in your grid, refer to 
Adding a Data Grid Layout Theme (page 296) to add the field. 
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Adding Rectifier Anode Inspections
If rectifier anode records have not yet been added in the Rectifier Anode Information 
mini-grid, complete the procedure in the previous section first (Adding Rectifier Anode 
Information, page 340) and then continue with the procedure in this section. 

To enter anode inspection readings in the Rectifier Anode Inspection mini-grid, follow 
these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select the pipeline segment(s) with the rectifier you want to work with, 
then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Rectifier Inspection grid. Click the Inspection tab  and then 
the Rectifier button . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select a row of records in the Rectifier Inspection grid with the rectifier and 
anodes you want to add anode inspection readings. For example, the record for 
pipeline segment T-1401 with rectifier R-202 is selected in Figure 7-113 
(page 343). 

6 If the Rectifier Anode Inspections mini-grid is not visible, double-click the 
Rectifier Anode... button  to open the mini-grid. Click the minimize 
button  of all other mini-grids to hide these mini-grids. 

7 Select an anode record in the mini-grid and then click  Add. 

8 Type an inspection reading in either the Impressed Anode Current or Anode 
Shunt Reading field. 

9 Click  Refresh to update  derived fields, such as Number of Impressed 
Anodes shown in Figure 7-113 (page 343). 

NOTE: For more information about  derived fields, refer to Working with 
Derived Fields (page 214). 

10 Repeat steps 7 through 9 to enter inspection readings for remaining anodes. 
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Figure 7-113.  Rectifier Anode Inspections

Working with Rectifier Negatives
A rectifier can typically have from 1 to 5 negative wires that protect different pipelines. 
Tracking rectifier negatives in PCS Axis allows you to easily identify which rectifier negative 
wire is connected to which pipeline. You can also monitor the current flow for each rectifier 
negative in an effort to determine how much of the total current is used to protect each 
pipeline. 

PCS Axis provides two mini-grids for working with rectifier negatives. Use the Rectifier 
Negative Information mini-grid to provide negative information, such as the shunt rating 
or shunt resistance for each negative wire of the rectifier. PCS Axis uses this information to 
automatically calculate the negative shunt factor.

Use the Rectifier Negative Inspections mini-grid to enter inspection readings for each 
negative wire of the rectifier, such as a current or shunt reading for each negative wire. 

Topics in this section include those in the following list:

• Adding Rectifier Negative Information (page 344)

• Adding Rectifier Negative Inspections (page 346)
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Adding Rectifier Negative Information
To add a record in the Rectifier Negative Information mini-grid for each negative wire of 
a rectifier providing current to a pipeline(s), follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select the pipeline segment(s) with the rectifier you want to work with, 
then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Rectifier Information grid. Click the Information tab  and 
then the Rectifier button . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select a row of records in the Rectifier Information grid with the rectifier you want 
to add negative records. For example, the record for pipeline segment T-1401 with 
rectifier R-202 is selected in the following figure (Figure 7-114, page 345). 

6 If the Rectifier Negative Information mini-grid is not visible, double-click the 
Rectifier Negati... button  to open the mini-grid. Click the minimize 
button  in the upper right-hand corner of all other mini-grids to hide these mini-
grids. 

7 Click  Add in the Rectifier Negative Information mini-grid to add an empty 
record. Fields requiring information include a  red icon, such as the Name field. 

8 Type a negative name in the Name field.

9 If the rectifier rating is different than the minimum and maximum values provided 
by PCS Axis in the fields Negative Current Min and Negative Current Max, 
type the rectifier rating in these fields. 

10 Type a value in either the field labeled Negative Shunt Rating or Negative 
Shunt Resistance. 

NOTE: If entering a shunt rating, enter it as a mV per A ratio using the format nn.n/
nn.n, such as 50.0/25.0 for the shunt rating 50 mV/25 A. If entering a shunt 
resistance value, enter the actual resistance of the shunt in ohms. When both of 
these fields are empty, you can enter a value in the field Negative Shunt Factor 
instead. Otherwise, PCS Axis automatically calculates the shunt factor based on the 
value in the shunt rating or shunt reading field. 
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11 Click  Refresh to update  derived fields, such as Number of Negatives 
shown in Figure 7-114. 

NOTE: For more information about  derived fields, refer to Working with 
Derived Fields (page 214). 

12 Repeat steps 7 through 11 to add a record for each remaining negative wire. 

NOTE: PCS Axis displays the total number of negatives in the system calculated 
field labeled Number of Negatives in the Rectifier Information and Inspection 
grid. If the field is not present in your grid, refer to Adding a Data Grid Layout 
Theme (page 296) to add the field. 

Figure 7-114.  Rectifier Negative Information
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Adding Rectifier Negative Inspections
If rectifier negative records have not yet been added in the Rectifier Negative 
Information mini-grid, complete the procedure in the previous section first (Adding 
Rectifier Negative Information, page 344) and then continue with the procedure in this 
section. 

To enter negative inspection readings in the Rectifier Negative Inspection mini-grid, 
follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 7-4, 
page 216). Select the pipeline segment(s) with the rectifier you want to work with, 
then click  Save to close the window. 

2 Open the Edit CPDM Data window. Click Data Entry > Edit CPDM Data. 

3 Open the Rectifier Inspection grid. Click the Inspection tab  and then 
the Rectifier button . 

4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 Select a row of records in the Rectifier Inspection grid with the rectifier and 
negatives you want to add negative inspection readings. For example, the record 
for pipeline segment T-1401 with rectifier R-201 is selected in the following figure 
(Figure 7-115). 

6 If the Rectifier Negative Inspections mini-grid is not visible, double-click the 
Rectifier Negati... button  to open the mini-grid. Click the minimize 
button  of all other mini-grids to hide these mini-grids. 

7 Select a row of records in the Rectifier Negative Inspections mini-grid and then 
click  Add. 

8 If the rectifier output current has been adjusted and the check box Rectifier 
Current Adjusted is enabled in the Inspection grid, complete the following steps: 
in the Rectifier Negative Inspections mini-grid: 

a Type the amperage reading taken before rectifier adjustments in the field 
Negative Current Found.

b Type the amperage reading taken after rectifier adjustments in the field 
Negative Current Left. 

9 Type an inspection reading in either the field Negative Shunt Read Found or 
Negative Shunt Read Left. 
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10 Click  Refresh to update  derived fields, such as Number of Negatives 
shown in Figure 7-115. 

NOTE: For more information about  derived fields, refer to Working with 
Derived Fields (page 214). 

11 Repeat steps 7 through 10 to enter readings for another negative. 

Figure 7-115.  Rectifier Negative Inspections
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Notes
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Using a Route

This chapter explains how to work with a route. The information is intended for users with 
SysAdmin, User, and Read Only permissions. Topics in this chapter include those in the 
following list:

• What is a Route?

• Quick Start (page 350)

• Creating a Route (page 355)

• Changing the Order of Facilities (page 358)

• Preparing a Route for an Averaged Reading Survey (page 359)

• Preparing a Route for Inspection GPS Fields (page 375)

• Working with Themes and Filter Groups (page 389)

• Previewing a Route (page 410)

• Using a Route in PCS Axis (page 412)

What is a Route?
A route is a user-created list of facilities for inspection. You can include facilities for one or 
more facility types in the same route, such as test points, valves, and atmospherics. The 
main advantage in a route is the ability to arrange facilities in a particular order that is 
more suitable in a survey. For example, you can arrange facilities in survey order instead of 
numerically by ROW Code and milepost number. 

Routes are used in several areas of PCS Axis. You can view inspection records in a grid 
based on a route; transfer a survey to the Allegro Field PC based on a route; and generate 
reports based on a route. 
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Quick Start
Information in this section assumes one or more routes have previously been created. If no 
routes exist, skip this section and begin with Creating a Route (page 355).

The following procedure explains how to display and set properties in a route. Property 
settings include selection of a layout and sort theme. Both of these themes determine how 
PCS Axis displays facility records in a route. 

As an option, you can also set up one or more filter groups that apply only to the current 
session. A filter group filters data in a route by including or excluding certain facility 
records. It allows you to work with a subset of facility records for the currently selected 
ROW based on filter selection criteria. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the route. Click  Save 
to close the window.

2 Click Data Entry > Define Routes to open the Define Routes window. 

3 Click the down arrow in Routes and select a route in the selection list (Figure 8-1). 

Figure 8-1.  Define Routes

Route Selection
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4 Click the Options tab  to open the options page (Figure 8-2). 

Figure 8-2.  Options

5 Choose a layout and sort theme. Click the down arrow in the field Select Layout 
Theme and select a layout theme. Then click the down arrow in the field Select 
Sort Theme and select a sort theme (Figure 8-2). 

6 If you want to filter records in the grid and route, complete the following steps. 
Otherwise, click  Apply to save and apply changes. PCS Axis closes the options 
page and returns to the Define Routes window. 

Clicking  Cancel allows you to close the options page without saving and 
applying changes.

IMPORTANT: Filter settings in the options page of Define Routes apply only to the 
current session and are not saved. See Working with Themes and Filter Groups 
(page 389) for information about saving filter settings in a theme. 

a Click the check box of one or more options in Filters and then click  Apply. 
For example, click Active Facilities Only to only include active facilities 
(Figure 8-3, page 352). 

A check mark inside a check box indicates a selection. To clear a selection, click 
the check box again to remove the check mark. 
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b If you want to add a filter, click the  Add button and then use filter 
selection fields to set up filter criteria. Select a PCS Axis field, operator, and 
one or more filter conditions. Then click  Apply to save and apply changes.

PCS Axis closes the options page and returns to the Define Routes window.

c If you want to add a new AND or OR filter group, continue with one of the 
following steps: 

• To add a new AND filter group continue with step 7. 

• To add a new OR filter group continue with step 8 (page 354). 

Figure 8-3.  Filters

7 If you want to add a new AND filter group, complete the following steps. With an 
AND filter group, PCS Axis includes a subset of records that meet all filter 
conditions defined for the filter group. Records are filtered in the grid and in the 
route (Figure 8-4, page 353). 

a Click  New ‘And’ Group to open the filter properties group box. 
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b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings. 

c Click  Apply to save and apply changes. PCS Axis closes the options page 
and returns to the Define Routes window. 

Figure 8-4.  New ‘And’ Filter Group
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8 If you want to add a new OR filter group, complete the following steps. With an OR 
filter group, PCS Axis includes a subset of records that meet any filter condition 
defined for the filter group. Records are filtered in the grid and in the route:

a Click  New ‘Or” Group to open a filter properties group box (Figure 8-5).

Figure 8-5.  New ‘Or Filter Group

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

Clicking the  toggle button in the  information bar displays important 
information related to required settings. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

c Click  Apply to save and apply changes. PCS Axis closes the options page 
and returns to the Define Routes window. 
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Creating a Route
The following information explains how to create a route with a list of facilities for 
inspection. Facilities for inspection are based on the pipeline segment(s) you select in the 
Select ROWs window. 

Complete the following steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 8-6). 
Select one or more pipeline segments with facilities you want to include in the 
route. Click  Save to close the window. 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 

Figure 8-6.  Select ROWs
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2 Click Data Entry > Define Routes. 

3 If this is the first route to be created, the Add New Route dialog box opens. Type a 
name for the new route in the field Enter Route Name. Then click  OK 
(Figure 8-7).

Figure 8-7.  Add New Route

4 Select the facility type(s) you want to work with using the method described in step 
"a" or "b":

a To select a facility type, click the facility type option button and then click the 
down arrow and select a facility type in the list, such as  [PCS] Rectifier 
Survey (Figure 8-8). 

Figure 8-8.  Facility Type Theme Option

b To select multiple facility types, click the option button Ad Hoc Theme and 
then click the check box for one or more facility types, such as Test Point, 
Rectifier, and Foreign Bond (Figure 8-9, page 357). 

NOTE: An Ad Hoc Theme only applies to the current session and is not saved. 
A facility type is selected when a check mark appears inside the check box. To 
clear the check mark, click the check box again. 

Facility Type Theme 
Selection List
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Figure 8-9.  Ad Hoc Theme Option

5 Complete the following steps in the Facilities Available grid (Figure 8-10):

a Select which facilities to include in the route. To include all facilities, click 
 Add All and then click Yes when the Add All message opens. 

To only include facilities you select, click the check box for each facility in the 
Facilities Available grid. Or double-click each facility. 

NOTE: Selected facilities display in the Facilities in Route grid. 

b Click  Save to save changes. Continue with the next section to change the 
order of facilities in the route (page 358). 

Figure 8-10.  Define Routes

Ad Hoc Theme Option

Facility Type Selection(s)
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Changing the Order of Facilities
The order of facilities shown in the Facilities in Route grid identifies the facility order used 
in a route. You can easily change the order of facilities by dragging and dropping one or 
more grid rows to a different location in the grid. Changing the order allows you to 
arrange facilities based on particular criteria, such as arranging facilities in the order a 
survey is taken. 

To change the order of facilities in a route, follow these steps: 

1 If the Define Routes window is not open, complete the following steps:

a Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click Save to close the window. 

b Click Data Entry > Define Routes, then click the down arrow in Routes and 
select a route (Figure 8-1, page 350). 

2 Arrange the order of facilities listed in the Facilities in Route grid as needed using 
any of the following methods (Figure 8-11): 

• To move a single grid row, select the row, then drag and drop the row in a 
different location in the grid. Click  Save to save changes. 

NOTE: A message displays when moving selected grid rows to confirm the 
new location in the grid (Figure 8-11, page 359). 

• To move a group of consecutive grid rows, click the first row, press and hold 
the Shift key, then click the last row. Drag and drop selected rows in a 
different location in the grid. Click  Save to save changes. 

• To move a group of non-consecutive grid rows, press and hold the Ctrl key, 
then click each row you want to select. Drag and drop selected rows in a 
different location in the grid. Click  Save to save changes. 
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Figure 8-11.  Arranging the Order of Facilities

Preparing a Route for an Averaged Reading Survey
This section applies only to the CPDM module. It explains how to prepare and send a 
survey to the Allegro based on a route with facilities in an averaged reading survey. 
Facilities for inspection are also set up with timed reading fields in the Test Point 
Information and Inspection data entry grid.

Topics in this section include those in the following list:

• Adding Timed Reading Fields in the Information Grid

• Adding Timed Reading Fields in the Inspection Grid (page 363)

• Editing a Route for an Averaged Reading Survey (page 365)

• Sending a Survey to the Allegro Based on a Route (page 367)

NOTE: See the Allegro User Guide for information about taking an averaged 
reading survey using the Periodic Survey software on the Allegro. 
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Adding Timed Reading Fields in the Information Grid
Timed reading fields are added in the Test Point Information data entry grid to allow data 
entry of inspection readings in the Test Point Inspection data entry grid for an averaged 
reading survey. Information in this section explains how to add timed reading fields in a 
layout theme and then apply the theme to the Information data entry grid. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Select pipeline segments with facilities you plan to include in the route. 
Click  Save to close the window. 

2 Click Data Entry > Edit CPDM Data. 

3 Click the Test Point button , then the Information tab  to 
open the Test Point Information data entry grid (Figure 8-12, page 360). 

Figure 8-12.  Test Point Information Data Entry Grid
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4 Click the Customize tab  to open the Layouts page (Figure 8-13, 
page 361). 

5 Choose a data entry grid layout theme. Click the down arrow in Select Layout 
Theme and select a theme in the selection list. 

6 Double-click  Test Point Information Fields in the left pane of the window to 
view a list of fields available for selection. 

7 Add the following list of timed reading fields in the layout theme. To add fields, 
double-click each timed reading field listed in the left pane of the Layouts page to 
move fields to the right pane. Add other fields as required. The data entry grid 
layout theme includes all fields listed in the right pane of the Layouts page. 

• Activate Average P/S

• Activate Max P/S

• Activate Min P/S

• Activate P/S Sample Time

Figure 8-13.  Layouts
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8 Click  Save, then click the Options tab  to open the options page 
(Figure 8-14). 

9 Apply the layout theme to the data entry grid. Click the down arrow in the field 
Select Layout Theme and select the layout theme with timed reading fields. 

10 Click  Apply to save and apply changes. PCS Axis closes the options page and 
returns to the Test Point Information data entry grid. 

Figure 8-14.  Options
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11 In each column labeled with an “activate” timed reading field, click the check box 
associated with the facility you plan to record Allegro timed readings (Figure 8-15). 

12 Continue with the next section Adding Timed Reading Fields in the Inspection 
Grid (page 363). 

Figure 8-15.  Test Point Information Data Entry Grid

Adding Timed Reading Fields in the Inspection Grid
Complete the following steps to add timed reading fields in a layout theme and then apply 
the theme to the Test Point Inspection data entry grid: 

1 If the Test Point Inspection data entry grid is not visible, click the Test Point 
button  and then the Inspection tab . 

2 Click the Customize tab  to display the Layouts page. 

3 Choose a layout theme. Click the down arrow in Select Layout Theme and select 
a theme in the selection list.

4 Double-click  Test Point Inspection Fields in the left pane of the window to 
view a list of fields available for selection (Figure 8-16, page 364). 

Activate Timed 
Reading Fields
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5 Add the following list of timed reading fields in the layout theme. To add a field, 
double-click a timed reading field listed in the left pane to move the field to the 
right pane. Add other fields as required. The layout theme includes all fields listed 
in the right pane of the Layouts page. 

• Average P/S

• Max P/S

• Min P/S

• P/S Sample Time

Figure 8-16.  Layouts

6 Click  Save, then click the Options tab  to open the options page 
(Figure 8-17, page 365). 

7 Apply the layout theme to the data entry grid. Click the down arrow in the field 
Select Layout Theme and select the layout theme with timed reading fields. 

8 Click  Apply to save and apply changes. PCS Axis closes the options page and 
returns to the Test Point Inspection data entry grid. 

9 Click the  close icon to close the Edit CPDM Data window. Continue with the 
next section Editing a Route for an Averaged Reading Survey (page 365). 
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Figure 8-17.  Options

Editing a Route for an Averaged Reading Survey
Complete the following steps to set up a route with facilities for inspection in an averaged 
reading survey:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Select pipeline segments with facilities you plan to include in a route for 
an averaged reading survey. Click  Save to close the window. 

2 Open the Define Routes window and select a route. Click Data Entry > Define 
Routes. Then click the down arrow in Routes and select a route in the selection 
list. 

3 Click the down arrow in Facility Types and select  [PCS] Test Point Survey. 
Or, select Ad Hoc Theme and then click the Test Point check box. 

4 Select which facilities to include in the route. To include all facilities, click  Add 
All and then click Yes when the Add All message opens. 

To only include facilities you select, click the check box for each facility in the 
Facilities Available grid. Or double-click each facility.

NOTE: Selected facilities display in the Facilities in Route grid. 
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5 Arrange the survey order of facilities listed in the Facilities in Route grid as 
needed using any of the following methods: 

• To move a single grid row, select the row, then drag and drop the row in a 
different location in the grid. 

NOTE: A message displays when moving selected grid rows to confirm the 
new location in the grid (Figure 8-11, page 359). 

• To move a group of consecutive grid rows, click the first row, press and hold 
the Shift key, then click the last row. Drag and drop selected rows in a 
different location in the grid. 

• To move a group of non-consecutive grid rows, press and hold the Ctrl key, 
then click each row you want to select. Drag and drop selected rows in a 
different location in the grid. 

6 Click  Save to save changes and then click the close icon  to close the Define 
Routes window.

7 Continue with the next section Sending a Survey to the Allegro Based on a 
Route (page 367). 
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Sending a Survey to the Allegro Based on a Route
Information in this section explains how to send a survey to the Allegro based on a route 
with facilities in an averaged reading survey. The process includes adding a theme with 
prompts for timed reading fields. Prompts are data entry fields in an Allegro survey file 
that require survey data, such as an inspection reading at each facility location. 

Complete the following steps: 

1 Verify the Allegro is connected to your computer. If needed, refer to the Allegro 
User Guide for information about how to connect the device. 

2 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Select pipeline segments with facilities you plan to include in an 
averaged reading survey. Click  Save to close the window. 

3 Click Field Computer > Send to open the Field Computer Send window 
(Figure 8-18). 

Figure 8-18.  Field Computer Send
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4 Click the Customize tab , then the Prompts button  to 
open the Prompts page (Figure 8-19). 

Figure 8-19.  Prompts

5 Click  Add to open the New Prompt dialog box (Figure 8-20). 

6 Type a name for the theme in the field Enter Theme Name. If you want to create 
a public theme, click the Public check box to place a check mark inside the check 
box. When the check box is empty, the theme saves as a private theme. 

7 If you want to copy fields from an existing theme, click the Copy Content check 
box to place a check mark inside the check box. Then click the down arrow in the 
field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing prompt theme, clear the check 
mark inside the Copy Content check box by clicking the check box. 

8 Click  OK to save changes and return to the Prompts page. 

Figure 8-20.  New Prompt
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9 Verify the name of the new theme displays in the Select Prompt field. If not, click 
the down arrow and select the theme in the selection list (Figure 8-21). 

10 Click the down arrow in Select Facility Type and select Test Point. 

Figure 8-21.  Prompts

11 To add information prompts, follow these steps:

a Double-click  All Fields in Facility, Information and ROW Fields to view a 
list of fields available for selection. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. All fields listed in the right pane are included in the prompt theme 
(Figure 8-21). 

12 To add timed reading prompts, follow these steps:

a Double-click  All Fields in Inspection and Maintenance Field (Figure 8-21). 

b Double-click the following timed reading fields to move the fields to the right 
pane: 

• Average P/S

• Max P/S

• Min P/S

• P/S Sample Time

NOTE: If you want to remove information, inspection, or maintenance fields, 
double-click a field listed in the right pane to move it back to the left pane. 
Using a Route 369



PCS Axis User and Administrator Guide
13 Complete the following steps to add site string prompts that help identify one 
facility from another when using the Allegro. Site string prompts are included with 
each facility and can be viewed in the Allegro Site List window. 

a Click the  Site String tab to view a list of fields available for selection 
(Figure 8-21, page 369).

b Double-click one or more fields in the selection list to move fields to the 
right pane. For example, double-click Facility ID and Location 
Description. Click the  Site String tab again to close the pane. 

14 If you want to add another page of prompts, click  Copy and then double-click 
one or more fields as needed in the left pane of Inspection and Maintenance 
Fields. When you have multiple pages of prompts, clicking a page number icon, 
such as , displays prompts for the selected page. 

NOTE: Information fields in Facility, Information, and ROW Fields automatically 
copy to each page of prompts. 

15 Click  Save and Close to save changes and return to the Field Computer Send 
window. 

16 Click the Route option and select a route in the selection box. Then click 
 Apply to update the grid (Figure 8-22). 

Figure 8-22.  Field Computer Send
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17 Click the down arrow in Select Prompt and select a theme with timed reading 
fields (Figure 8-22, page 370). 

18 Select a layout and sort theme as follows: 

a Click the down arrow in the field Select Layout Theme and select a theme in 
the list.

b Click the down arrow in the field Select Sort Theme and select a theme in 
the list. 

19 If you want to rename the survey file, type a name in the Output File field making 
sure to include the .dat file extension. 

20 Select the option Send to Allegro. 

21 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file. 

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled and 
unavailable for selection when maintenance prompts are not included in the 
currently selected prompt theme. 

22 Click the  Filters button to open the Filters panel (Figure 8-23). 

23 If you want to filter records in the grid and in the route sent to the Allegro, select 
one or more options in Filters. For example, click Active Facilities Only to only 
include active facilities. 

IMPORTANT: Filter settings in Field Computer Send apply only to the current 
session and are not saved. See Working with Themes and Filter Groups 
(page 389) for information about saving filter settings in a theme.
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Figure 8-23.  Filters

If you want to add a new AND or OR filter group, continue with step 24 or 
step 25 (page 373). 

24 To filter records in the grid and in the route sent to the Allegro based on a subset 
of records that meet all filter conditions, complete the following steps to add a 
new AND filter group (Figure 8-24, page 373): 

a Click  New ‘And’ Group to open the filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 
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NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings (Figure 8-24). 

Figure 8-24.  New ‘And’ Filter Group

25 To filter records in the grid and in the route sent to the Allegro based on a subset 
of records that meet any filter condition, complete the following steps to add a 
new OR filter group (Figure 8-25): 

a Click  New ‘Or” Group to open a filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 
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Figure 8-25.  New ‘Or Filter Group

26 Click the  Filters button to close the Filters panel. Then click  Apply to 
update the grid. 

27 Click  Send to send the survey file to the Allegro. 

28 When a message displays confirming the send process is complete, click  OK to 
close the message (Figure 8-26). PCS Axis sends the survey file to the PSData 
folder on the Allegro. 

Figure 8-26.  Send Process Complete
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Preparing a Route for Inspection GPS Fields
This section explains how to prepare and send a survey to the Allegro based on a route 
with inspection GPS fields. Facilities for inspection are also set up in the Inspection data 
entry grid with inspection GPS fields. 

Including inspection GPS fields in a survey allows you to capture GPS location data for 
each facility inspection reading. These fields also allow you to verify inspection readings 
are taken at the correct location. 

Information in this section applies to all PCS Axis modules. Examples are based on the 
CPDM module. Topics in this section include those in the following list:

• Adding Inspection GPS Fields in the Inspection Grid (page 375)

• Editing a Route with Facilities for Inspection (page 378)

• Sending a Survey to the Allegro Based on a Route (page 379)

Adding Inspection GPS Fields in the Inspection Grid
The procedure in this section explains how to add inspection GPS fields in a layout theme 
and then apply the theme to an Inspection data entry grid. The procedure uses the Test 
Point Inspection data entry grid as an example. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Select pipeline segments with facilities you plan to include in a route. 
Click  Save to close the window. 

2 Open the Inspection data entry grid for a facility type. 

For example, click Data Entry > Edit CPDM Data. Click the Test Point button 
, then the Inspection tab  to open the Test Point Inspection 

data entry grid (Figure 8-27). 
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Figure 8-27.  Test Point Inspection Data Entry Grid

3 Click the Customize tab  to view the Layouts page (Figure 8-28, 
page 377). 

4 Choose a data entry grid layout theme. Click the down arrow in Select Layout 
Theme and select a theme in the selection list.

5 Double-click the Inspection Fields category in the left pane of the window to view 
a list of fields available for selection. For example, double-click  Test Point 
Inspection Fields. 

6 Add the following inspection GPS fields in the layout theme. To add a field, 
double-click a inspection GPS field in the left pane to move the field to the right 
pane. Add other fields as required. The layout theme includes all fields listed in the 
right pane. 

• Inspection Elevation

• Inspection GPS Accuracy

• Inspection GPS Difference

• Inspection Latitude

• Inspection Longitude
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Figure 8-28.  Layouts

7 Click  Save, then click the Options tab  to open the options page 
(Figure 8-29, page 378). 

8 Apply the layout theme to the data entry grid. Click the down arrow in Select 
Layout Theme and select the theme with inspection GPS fields. 

9 Click  Apply. 

PCS Axis saves and applies changes, then closes the options page and returns to 
the Test Point Inspection data entry grid. 

10 Click the  close icon to close the Edit CPDM Data window. Continue with the 
next section Editing a Route with Facilities for Inspection (page 378). 
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Figure 8-29.  Options

Editing a Route with Facilities for Inspection
Complete the following steps to set up a route with facilities for inspection that include 
inspection GPS fields:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Select pipeline segments with facilities you plan to include in the route. 
Click  Save to close the window. 

2 Open the Define Routes window and select a route. Click Data Entry > Define 
Routes. Then click the down arrow in Routes and select a route in the selection 
list. 

3 Click the down arrow in Facility Types and select a facility type theme. Or, select 
Ad Hoc Theme and then click the check box for one or more facility types. 

4 Choose which facilities to include in the route. To include all facilities, click 
 Add All in the Facilities Available grid. 

To only include facilities you select, click the check box for each facility in the 
Facilities Available grid. Or double-click each facility. 

NOTE: Selected facilities display in the Facilities in Route grid.
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5 Arrange the survey order of facilities listed in the Facilities in Route grid as 
needed using any of the following methods: 

• To move a single grid row, select the row, then drag and drop it in a different 
location in the grid. 

NOTE: A message displays when moving selected grid rows to confirm the 
new location in the grid (Figure 8-11, page 359). 

• To move a group of consecutive grid rows, click the first row, press and hold 
the Shift key, then click the last row. Drag and drop selected rows in a 
different location in the grid. 

• To move a group of non-consecutive grid rows, press and hold the Ctrl key, 
then click each row you want to select. Drag and drop selected rows in a 
different location in the grid. 

6 Click  Save to save changes. Then click the close icon  to close the Define 
Routes window.

7 Continue with the next section Sending a Survey to the Allegro Based on a 
Route (page 379). 

Sending a Survey to the Allegro Based on a Route
Information in this section explains how to send a survey to the Allegro based on a route 
with facilities that include inspection GPS fields. The process includes adding a prompts 
theme with prompts for inspection GPS fields. Prompts are data entry fields in an Allegro 
survey file that require survey data, such as GPS data for each facility inspection reading. 

Complete the following steps: 

1 Verify the Allegro is connected to your computer. If needed, refer to the Allegro 
User Guide for information about how to connect the device. 

2 Select one or more pipeline segments in the Select ROWs window. Select 
pipeline segments with facilities you plan to survey. Click  Save to close 
the window (Figure 8-6, page 355). 

3 Click Field Computer > Send to open the Field Computer Send window 
(Figure 8-30, page 380). 
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Figure 8-30.  Field Computer Send

4 Click the Customize tab , then the Prompts button  to 
open the Prompts page (Figure 8-31). 

Figure 8-31.  Prompts
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5 Click the  Add button to open the New Prompt dialog box (Figure 8-32). 

6 Type a name for the theme in the field Enter Theme Name. If you want to create 
a public theme, click the Public check box to place a check mark inside the check 
box. When the check box is empty, the theme saves as a private theme. 

7 If you want to copy fields from an existing theme, click the Copy Content check 
box to place a check mark inside the check box. Then click the down arrow in the 
field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing prompt theme, remove the check 
mark inside the Copy Content check box by clicking the check box. 

8 Click  OK to save changes and return to the Prompts page. 

Figure 8-32.  New Prompt

9 Verify the name of the new theme displays in the Select Prompt field. If not, click 
the down arrow and select the theme in the selection list (Figure 8-33, page 382). 

10 Click the down arrow in Select Facility Type and select a facility type in the 
selection list. For example, select Test Point. 
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Figure 8-33.  Prompts

11 To add information prompts, follow these steps (Figure 8-33):

a Double-click  All Fields in Facility, Information and ROW Fields to view a 
list of fields available for selection. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. All fields listed in the right pane are included in the prompt theme. 

12 To add inspection GPS prompts, follow these steps:

a Double-click  All Fields in Inspection and Maintenance Fields. 

b Double-click the following inspection GPS fields to move the fields to the right 
pane: 

• Inspection Elevation

• Inspection GPS Accuracy

• Inspection GPS Difference

• Inspection Latitude

• Inspection Longitude

NOTE: If you want to remove information, inspection, or maintenance fields, 
double-click a field listed in the right pane to move it back to the left pane. 
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13 Complete the following steps to add site string prompts that help identify one 
facility from another when using the Allegro. Site string prompts are included with 
each facility and can be viewed in the Allegro Site List window.

a Click the  Site String and then double-click  All Fields in the left pane to 
view a list of fields available for selection (Figure 8-33, page 382). 

b Double-click one or more fields in the left pane to move fields to the right 
pane. For example, double-click Facility ID and Facility Location. Click the 

 Site String button again to close the pane. 

14 If you want to add another page of prompts, click  Copy and then double-click 
one or more fields as needed in the left pane of Inspection and Maintenance 
Fields. Information fields in Facility, Information, and ROW Fields automatically 
copy to each page of prompts (Figure 8-21, page 369). 

15 Click  Save. 

16 If you have multiple pages of prompts, clicking a page number icon displays 
prompts for the selected page. For example, clicking  displays prompts set up in 
page 2 as shown in the following example (Figure 8-34). 

Figure 8-34.  Prompts
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17 Click  Close to return to the Field Computer Send window. 

18 Click the Route option and select a route in the selection box. Then click 
 Apply to update the grid (Figure 8-35). 

19 Complete the following steps to select a prompt, layout, and sort theme:

a Click the down arrow in Select Prompt and select the prompt theme with 
inspection GPS fields. 

b Click the down arrow in Select Layout Theme and select a layout theme in 
the selection list.

c Click the down arrow in Select Sort Theme and select a sort theme in the 
selection list. 

20 If you want to rename the survey file, type a name in the field Output File. 

21 Select Send to Allegro to send the survey file to the Allegro. 

22 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file. 

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled when 
maintenance prompts are not included in the currently selected prompt theme. 

Figure 8-35.  Field Computer Send
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23 If you want to filter records in the grid and in the route sent to the Allegro, 
complete the following steps.

IMPORTANT: Filter settings in Field Computer Send apply only to the current 
session and are not saved. See Working with Themes and Filter Groups 
(page 389) for information about saving filter settings in a theme. 

a Click the  Filters tab to open the Filters panel (Figure 8-35, page 384). 

b Select one or more options in Filters. For example, click Active Facilities 
Only to only include active facilities in the grid and in the route sent to the 
Allegro (Figure 8-36). 

c If you want to add a new AND or OR filter group, continue with one of the 
following steps. Otherwise continue with step 26 (page 388). 

• To add a new AND filter group continue with step 24 (page 372). 

• To add a new OR filter group continue with step 25 (page 373). 

Figure 8-36.  Filters
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24 If you want to add a new AND filter group, complete the following steps. With an 
AND filter group, PCS Axis includes a subset of records that meet all filter 
conditions defined for the filter group. Records are filtered in the grid and in the 
route sent to the Allegro (Figure 8-37). 

a Click  New ‘And’ Group to open the filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings. 

Figure 8-37.  New ‘And’ Filter Group
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25 If you want to add a new OR filter group, complete the following steps. With an OR 
filter group, PCS Axis includes a subset of records that meet any filter condition 
defined for the filter group. Records are filtered in the grid and in the route sent to 
the Allegro (Figure 8-38): 

a Click  New ‘Or” Group to open a filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings. 

Figure 8-38.  New ‘Or Filter Group
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26 Click the  Filters tab to close the Filters panel. Then click  Apply to update 
the grid. 

27 Click  Send to send the survey file to the Allegro. 

28 Click  OK when the message Send Process Complete displays (Figure 8-39). 
PCS Axis sends the survey file to the PSData folder on the Allegro. 

Figure 8-39.  Send Process Complete
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Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] Route Grid. 

A filter group is a named set of one or more filters that affect the data output in the 
Define Routes grid and subsequently the route itself. PCS Axis provides two types of filter 
groups you can define. These include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in the Define Routes grid and the route. Adding an AND filter group 
produces a subset of records that meet all filter conditions. Adding an OR filter group 
produces a subset of records that meet any filter condition. When you apply a filter group, 
PCS Axis processes filters in descending order beginning with the filter at the top of the 
group. 

The following sections describe how to add a layout theme, sort theme, and one or more 
optional filter groups. Topics include those in the following list: 

• Working with a Layout Theme

• Working with a Sort Theme (page 397)

• Adding an AND Filter Group (page 403)

• Adding an OR Filter Group (page 406)

• Editing and Arranging Filters and Filter Groups (page 408)
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Working with a Layout Theme
A layout theme is a named set of fields that are present when working in the route grid. A 
layout theme also determines which fields are included when printing a route. 

Two types of layout themes are available for use. They include installed and addition 
layout themes. An installed layout theme is one that has been installed during the PCS Axis 
software installation, such as [PCS] Route Grid. A layout theme addition is one that you 
create. 

Topics in this section explain how to work with a layout theme and include those in the 
following list: 

• Editing an Installed Layout Theme

• Adding a Layout Theme Addition (page 393)

• Editing a Layout Theme Addition (page 395)

Editing an Installed Layout Theme
An installed layout theme includes [PCS] in the name of the theme, such as  [PCS] 
Route Grid. A layout theme determines which fields are present when viewing or printing 
a route. The procedure in this section explains how to complete the following tasks to edit 
a PCS Axis installed layout theme: 

• add fields in an installed layout theme

• remove fields in an installed layout theme

• revert an installed layout theme

To edit a PCS Axis installed layout theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 
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2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the list (Figure 8-40). 

Figure 8-40.  Define Routes

3 Click the Customize tab  to view the Layouts page (Figure 8-41, 
page 392). 

4 Select a PCS Axis installed layout theme. Click the down arrow in Select Layout 
Theme and select a theme in the selection list, such as  [PCS] Route Grid. 

5 Click the toggle arrow  for a field category in the left pane to view a list of fields 
available for selection, such as  All Fields. 

6 Click the check box for each field you want to include in the theme. Then click the 
top arrow button  to move selected fields to the right pane. The theme includes 
all fields listed in the right pane. 

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 

Route Selection
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7 To remove fields in an installed layout theme:

• Select one or more fields listed in the right pane, then click the bottom arrow 
button . 

NOTE: Double-clicking a field in the right pane also moves it back to the left 
pane. Fields with a lock icon  are required and cannot be removed from the 
theme, such as  Milepost. 

Figure 8-41.  Layouts

8 Click  Save to save changes. 

9 To revert an installed theme and restore settings prior to editing:

• Click  Revert, then click Yes when the Confirm Revert message displays. 

10 Click  Save and Close to save changes and return to the Define Routes 
window. 
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Adding a Layout Theme Addition
Complete the following steps to add a layout theme addition:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list (Figure 8-
40, page 391). 

3 Click the Customize tab  to view the Layouts page (Figure 8-41). 

4 Click  Add to open the New Layout Theme dialog box (Figure 8-42, page 393). 

Figure 8-42.  New Layout Theme

5 Type a name for the theme in the field Enter Theme Name.

6 Select the Public check box if you want the new theme available to all PCS Axis 
users. When a theme is not public, it is a private theme available only to the user 
who creates it. 

NOTE: Creating public themes is a function available only to users assigned the 
SysAdmin user role. Private themes can be created by users assigned the User, 
Read Only, or SysAdmin user role. See System Security (page 791) for more 
information. 

7 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

8 Click  OK to save changes and return to the Layouts page. 
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9 Verify the name of the new layout theme displays in the field Select Layout 
Theme. If not, click the down arrow in Select Layout Theme and select the new 
theme in the selection list. 

10 Add and remove fields in the new layout theme as required. If needed, refer to 
Editing a Layout Theme Addition (page 395). When you finish, click  Save. 

11 To apply the new layout theme in the Define Routes grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 8-43, 
page 394). 

b Click the down arrow in Select Layout Theme and select the new layout 
theme in the selection list.

c Click  Apply to apply changes and return to the grid in Define Routes. 

NOTE: Clicking  Cancel allows you to close the Options page without 
saving changes. 

Figure 8-43.  Options
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Editing a Layout Theme Addition
Information in this section explains how to perform the following tasks when working with 
a layout theme addition: 

• add or remove fields in a layout theme addition

• revert a layout theme addition

• create a new baseline layout theme addition

• delete a layout theme addition

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list (Figure 8-
40, page 391). 

3 Click the Customize tab  to view the Layouts page (Figure 8-41, 
page 392). 

4 Click the down arrow in Select Layout Theme and select a layout theme in the 
selection list. 

5 To add fields in a layout theme addition:

a Click the toggle arrow  for a field category in the left pane to view a list of 
fields available for selection, such as  All Fields. 

b Click the check box for each field you want to include in the theme. Then click 
the top arrow button  to move selected fields to the right pane. The theme 
includes all fields listed in the right pane. 

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 

c Click  Save to save changes. 
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6 To remove fields in a layout theme addition:

• Select one or more fields listed in the right pane of the window, then click the 
bottom arrow button . 

To multi-select fields in the right pane, press the Ctrl key when selecting fields 
in non-consecutive order; or press the Shift key when selecting fields in 
consecutive order. 

7 Click  Save to save changes. The layout theme includes all fields listed in the 
right pane (Figure 8-44, page 396). 

8 To revert a layout theme addition and restore settings prior to editing: 

• Click  Revert, then click Yes when the Confirm Revert message displays. 

9 To save current settings as new baseline settings, click  New Baseline. 
When future changes are made and then reverted, PCS Axis restores the 
theme with baseline settings.

10 To delete a layout theme addition:

a Click the down arrow in Select Layout Theme and select a layout theme 
addition. 

b Click  Delete, then click Yes when the Confirm Delete message displays. 

11 Click  Close to close the Layouts page and return to the Define Routes 
window. 

Figure 8-44.  Layouts
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Working with a Sort Theme
A sort theme is a named set of one or more fields that indicate the sorting order of grid 
rows in the route grid. A sort theme also determines the sorting order when printing a 
route. 

Two types of sort themes are available for use. They include installed and addition sort 
themes. An installed sort theme is one that has been installed during the PCS Axis software 
installation, such as [PCS] Address, [PCS] Facility ID, and [PCS] ROW Code and 
Milepost. A sort theme addition is one that you create. 

Topics in this section explain how to work with a sort theme and include those in the 
following list: 

• Editing an Installed Sort Theme

• Adding a Sort Theme Addition (page 399)

• Editing a Sort Theme Addition (page 401)

Editing an Installed Sort Theme
An installed sort theme includes [PCS] in the name of the theme, such as  [PCS] Facility 
ID. The procedure in this section explains how to complete the following tasks to edit an 
installed layout theme:

• add fields in an installed sort theme

• remove fields in an installed sort theme

• revert an installed sort theme

To edit an installed sort theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list (Figure 8-
40, page 391). 

3 Click the Customize tab , then the Sorts button  to open 
the Sorts page (Figure 8-45, page 398). 

4 Click the down arrow in Select Sort Theme and select a PCS Axis installed sort 
theme, such as  [PCS] Facility ID. 
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5 Click the toggle arrow  for a field category in the left pane to view a list of fields 
available for selection, such as  All Fields. 

6 Click the check box for each field you want to include in the theme. Then click the 
top arrow button  to move selected fields to the right pane. The theme includes 
all fields listed in the right pane. 

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 

7 Select a sort method for each field listed in the right pane. To sort grid rows in 
ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

8 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

9 Click  Save. 

Figure 8-45.  Sorts

10 To apply the sort theme in the grid, follow these steps: 

a Click the Options tab  to open the options page. 
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b Click the down arrow in Select Sort Theme and select the sort theme in the 
selection list. 

c Click  Apply to apply changes and return to the grid in Define Routes. 

NOTE: Clicking  Cancel allows you to close the Options page without 
saving changes. 

Adding a Sort Theme Addition
Complete the following steps to add a sort theme addition:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list (Figure 8-
40, page 391). 

3 Click the Customize tab , then the Sorts button  to open 
the Sorts page (Figure 8-45, page 398). 

4 Click  Add to open the New Sort Layout dialog box (Figure 8-46, page 399). 

Figure 8-46.  New Sort Layout

5 Type a name for the theme in the field Enter Theme Name. 
Using a Route 399



PCS Axis User and Administrator Guide
6 Select the Public check box if you want the new theme available to all PCS Axis 
users. When a theme is not public, it is a private theme available only to the user 
who creates it. 

NOTE: Creating public themes is a function available only to users assigned the 
SysAdmin user role. Private themes can be created by users assigned the User, 
Read Only, or SysAdmin user role. See System Security (page 791) for more 
information. 

7 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

8 Click  OK to save changes and return to the Sorts page. 

9 Verify the name of the new sort theme displays in the field Select Sort Theme. If 
not, click the down arrow in Select Sort Theme and select the new theme in the 
selection list (Figure 8-47, page 401). 

10 Add and remove fields in the new theme as required. If needed, refer to Editing a 
Layout Theme Addition (page 395).

11 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

12 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

13 Click  Save to save changes. 

14 To apply the sort theme in the grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 8-47, 
page 401). 

b Click the down arrow in Select Sort Theme and select the sort theme in the 
selection list. 

c Click  Apply to apply changes and return to the grid in Define Routes. 

NOTE: Clicking  Cancel allows you to close the Options page without 
saving changes. 
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Figure 8-47.  Options

Editing a Sort Theme Addition
The following procedure explains how to perform the following tasks to edit a sort theme 
addition: 

• add or remove one or more sort fields

• revert a sort theme addition

• delete a sort theme addition

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list (Figure 8-
40, page 391). 

3 Click the Customize tab , then the Sorts button  to open 
the Sorts page (Figure 8-48, page 402). 

4 Click the down arrow in Select Sort Theme and select a sort theme addition. 

5 To add fields and select a sort order: 

a Click the toggle arrow  for a field category in the left pane to view a list of 
fields available for selection, such as  All Fields.
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b Click the check box for each field you want to include in the theme. Then click 
the top arrow button  to move selected fields to the right pane. The theme 
includes all fields listed in the right pane. 

NOTE: Double-clicking a field in the left pane also moves it to the right pane. 

c Select a sorting method for each field listed in the right pane. To sort grid rows 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

d To change the order of fields listed in the right pane and subsequently in the 
grid, click and drag a field to a new position in the list. Or, select a field and 
then click the up  or down  button. 

e Click  Save to save changes. 

Figure 8-48.  Sorts

6 To remove fields in the sort theme addition:

• Select one or more fields listed in the right pane of the window, then click the 
bottom arrow button . Click  Save to save changes. The sort theme 
includes all fields listed in the right pane. 

To multi-select fields in the right pane, press the Ctrl key when selecting fields 
in non-consecutive order; or press the Shift key when selecting fields in 
consecutive order. 
402 Using a Route



PCS Axis User and Administrator Guide
7 To revert a sort theme addition and restore settings prior to editing:

• Click  Revert, then click Yes when the Confirm Revert message displays. 

8 To delete a sort theme addition:

a Click the down arrow in Select Sort Theme and select a sort theme addition. 

b Click  Delete, then click Yes when the Confirm Delete message displays. 

9 To apply a sort theme addition in the grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 8-47, 
page 401). 

b Click the down arrow in Select Sort Theme and select the sort theme in the 
selection list. 

c Click  Apply to apply changes and return to the grid in Define Routes. 

NOTE: Clicking  Cancel allows you to close the Options page without 
saving changes. 

Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in a 
route selected in Define Routes. Adding an AND filter group produces a subset of records 
that meet all filter conditions. PCS Axis processes filters in a filter group in descending 
order beginning with the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 8-6, page 355). 

2 Click Data Entry > Define Routes to open the Define Routes window. Then click 
the down arrow in Routes and select a route in the selection list (Figure 8-40, 
page 391). 

3 Click the Customize tab , then the Filters button  to open 
the Filters page. 

4 Click  New ‘And’ Group to open a filter properties group box (Figure 8-49). 
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5 Type a name for the filter group in the field Filter Group Caption. 

6 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

Figure 8-49.  Filters

7 If you want the filter to remain on for all sessions when working with the selected 
route, click the check box Filter is Always On. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

8 Type a name for the filter in the field Enter Custom Filter Caption. 

9 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. Then click the  
edit icon to display selection fields. 

b Type a name for the filter in the field Enter Custom Filter Caption. Repeat 
steps 6 through 8 to set up filter criteria. 

10 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 
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b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

11 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

12 To apply one or more filters to the selected route and the Define Routes grid 
(Figure 8-50, page 405):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. Then click  Apply to 
save changes and return to the Define Routes grid. 

Figure 8-50.  Options
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Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output of a 
route selected in Define Routes. Adding an OR filter group produces a subset of records 
that meet any filter condition. PCS Axis processes filters in a filter group in descending 
order beginning with the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 8-6, page 355). 

2 Click Data Entry > Define Routes to open the Define Routes window. Then click 
the down arrow in Routes and select a route in the selection list (Figure 8-40, 
page 391). 

3 Click the Customize tab , then the Filters button  to open 
the Filters page. 

4 Click  New ‘Or’ Group to open a filter properties group box (Figure 8-51). 

5 Type a name for the filter group in the field Include records that match any of 
these conditions. 

6 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

7 If you want the filter to remain on for all sessions when working with the selected 
route, click the check box Filter is Always On. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

8 Type a name for the filter in the field Enter Custom Filter Caption. 
406 Using a Route



PCS Axis User and Administrator Guide
Figure 8-51.  Filters

9 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. Then click the  
edit icon to display filter selection fields. 

b Repeat steps 5 through 8 to set up the filter group. 

10 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

11 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 
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12 To apply one or more filters to the selected route and the Define Routes grid 
(Figure 8-52):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. Then click  Apply to 
save changes and return to the Define Routes grid. 

Figure 8-52.  Options

Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 8-6, page 355). 

2 Click Data Entry > Define Routes to open the Define Routes window. Then click 
the down arrow in Routes and select a route in the selection list (Figure 8-40, 
page 391). 

3 Click the Customize tab , then the Filters button  to open 
the Filters page. 
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4 Click the edit icon  to display a filter’s property settings (Figure 8-53). 

Figure 8-53.  Filters

5 To delete a filter in a filter group, click the filter’s  delete button. Then click 
 OK when the Delete message displays. 

6 To rename a filter, type a description in the filter’s name field. 

7 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 

8 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

9 Click the  close button to close the filter’s property settings group box. 
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10 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

11 Click  Save. 

12 To apply filter changes to the selected route and the Define Routes grid:

a Click the Options tab  to open the options page. 

b Click  Apply to apply filter changes and return to the Define Routes grid. 

Previewing a Route
Information in this section describes how to view, print, and export a route with selected or 
available facilities. 

Selected facilities are those included in the route. These facilities are also listed in the 
Facilities in Route grid of the Define Routes window (Figure 8-54, page 411). Available 
facilities are linked to the current ROW selection, but are not included in the route. 
Available facilities are listed in the Facilities Available grid of the Define Routes window. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window (Figure 8-6, 
page 355). Click  Save to close the window. 

2 Click Data Entry > Define Routes to open the Define Routes window. Click the 
down arrow in the Routes field and select a route in the selection list. 
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3 To view selected facilities in a Print Preview window (Figure 8-54), click the 
 Selected Facilities button in the Facilities in Route grid. 

To view available facilities in a Print Preview window, click the  Available 
Facilities button in the Facilities Available grid. 

Clicking  Selected Facilities allows you to view a report with facilities included 
in the route. Clicking  Available Facilities opens a report with facilities listed in 
the Facilities Available grid. 

4 Click the  Print button to open the Print dialog box and select a printer to print 
the route. Or, click the  Quick Print button to print the route using the default 
printer set up in Windows. 

5 If you want to export the route, click the  Export Document button and select 
any of the following file formats: PDF, HTML, MHT, RTF, XLS, XLSX, CSV, TXT, IMG, 
and XPS. 

6 Click the  Close button to close the Print Preview window and return to the 
Define Routes window. 

Figure 8-54.  Print Preview
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Using a Route in PCS Axis
You can use a route in PCS Axis to perform any of the following tasks: 

• view inspection records in a grid based on a route. Refer to Viewing Records 
Based on a Schedule (page 245). 

• transfer a survey to the Allegro Field PC based on a route. Refer to Using Field 
Computer (page 559). 
412 Using a Route



PCS Axis User and Administrator Guide
Notes
Using a Route 413



PCS Axis User and Administrator Guide
414 Using a Route



9

Using a Schedule

This chapter explains how to work with a schedule. The information is intended for users 
with SysAdmin, User, and Read Only permissions. Topics in this chapter include those in 
the following list:

• What is Scheduling?

• Scheduling Workflow (page 416)

• Setting Up Scheduling Criteria (page 417)

• Creating a Schedule (page 439)

• Working with a Schedule Definition (page 444)

• Using a Schedule in PCS Axis (page 450)

What is Scheduling?
A schedule is a group of facilities to be surveyed for a specific time period, such as a 
month or year. The same schedule can include multiple facility types as well as facilities 
requiring bi-monthly, annual, and multi-year inspections, if those inspections are due in 
the same year. You can set up some schedules to include every facility that may be due for 
inspection and others to include one type of facility or survey period. PCS Axis dynamically 
generates a schedule with the most current information.

A schedule is different from a route, which assigns a specific order to facility inspections. A 
schedule is a list of facilities that are due to be inspected. A schedule is always ordered by 
due date and then as an option, sorted by facility ID, address, or route order. If you plan to 
create a schedule in route order, routes must be defined first (Data Entry > Define 
Routes). 

A valuable feature of scheduling is the ability to transfer a survey based on a schedule to 
the Allegro Field PC. Once the survey is complete, the PCS Axis database is easily updated 
by transferring inspection data from the Allegro Field PC to PCS Axis. 
415



PCS Axis User and Administrator Guide
Scheduling Workflow
The process for working with a schedule includes the following tasks (Figure 9-1):

• Set up scheduling properties in Edit Schedule Settings (Data Entry > Edit Schedule 
Settings). Scheduling properties define the parameters PCS Axis uses to calculate 
facility inspection due dates. 

• Create a schedule definition with one or more schedule types in Define Schedules 
(Data Entry > Define Schedules). A schedule type identifies which facility types to 
include in the schedule, and as an option, to include all facility types on a ROW that are 
due for an inspection. 

• Use a schedule to view facility records in a data grid based on a schedule; transfer a 
survey based on a schedule to the Allegro Field PC; and view and print a data collection 
form based on a schedule. 

Figure 9-1.  Scheduling Workflow
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Setting Up Scheduling Criteria
Setting up scheduling criteria begins with setting properties in the Time Between Survey 
Settings tab of Edit Schedule Settings. Settings apply system wide but can be overridden 
based on your company’s survey policy. You can set up scheduling overrides by facility 
type, at the hierarchy level, or at the facility level. 

Topics in this section explain how to set up scheduling properties using the following three 
tabs in Edit Schedule Settings: 

• Time Between Survey Settings

• Schedule Type Settings (page 423)

• Hierarchy Level Overrides (page 434)

NOTE: Certain conventions are used in Edit Schedule Settings to indicate whether 
or not a scheduling property is set up with a baseline setting or an override. Bold 
text indicates an override. A setting inside parentheses indicates a baseline setting. 
Those with N/A (not applicable) indicate the setting does not apply to the 
scheduling property. 

Time Between Survey Settings
Time Between Survey Settings allows you to set up scheduling properties for a survey, 
such as an annual, periodic, 5 year, or 10 year survey. Setting up survey scheduling 
properties includes identifying the survey start month and year; grace period; delinquent 
time period; and the number of inspections required in a calendar year. 

PCS Axis provides baseline settings based on government compliance regulations and 
industry standards. Baseline settings can be changed so that they match your company’s 
survey policy. 

To set up survey scheduling properties, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 9-2, 
page 418). Select one or more pipeline segments by clicking the check box for 
each pipeline segment. Click  Save to close the Select ROWs window. 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 
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Figure 9-2.  Select ROWs

2 Click Data Entry > Edit Schedule Settings > Time Between Survey Settings 
tab (Figure 9-3).

Figure 9-3.  Time Between Survey Settings
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3 Refer to the following table (Table 9-1, page 419) for a description of survey 
property settings and how to set up each of these. 

Table 9-1.  Setting Up Time Between Survey Settings 

Property Name Property Description

Time Between Survey A list of surveys indicating the number of months 
or years between inspections. These fields cannot 
be changed. 

An arrow  or edit icon  displays beside the 
survey indicating a selection. 

Target Month Target Month is only used when Targets is 
selected as the scheduling method. Otherwise, 
property settings are ignored and do not need to 
be set up. 

Target Month refers to the first survey month. 
Options in the selection list are based on the Time 
Between Survey value. 

For example, if Time Between Surveys is 2 months 
and the Target Month (first survey month) is 
January, surveys are set at 2 month intervals 
beginning in January. The next survey is due in 
March, the next in May, and so on. 

To select a target month:

1 For a survey listed in Time Between Surveys, 
click the Target Month field to display a drop 
down arrow.

2 Click the down arrow and select a target month 
in the selection list. 
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Target Year Target Year is only used when Targets is selected 
as the scheduling method. Otherwise, property 
settings are ignored and do not need to be set up. 

Target Year is the year within the survey period 
when you want the first survey to take place. This 
field is only used for facilities with more than 12 
months between surveys. PCS Axis calculates 
Target Year based on the current year and values 
in the fields Time Between Surveys and Multi-
Year Survey Start.

The target year selection list includes a list of valid 
survey years with corresponding target year dates. 

To select a target year:

1 For a survey listed in Time Between Surveys, 
click the Target Year field to display a drop 
down arrow.

2 Click the down arrow and select a target survey 
year. 

If an appropriate survey year is not listed, type a 
different year in the field Multi-Year Survey 
Start to update items in the selection list. 

Grace Period, Grace Period Unit A period of time in days or months an inspection 
can be late without incurring a compliance 
violation. 

To set a grace period:

1 Type a value in the Grace Period field.

2 Select the Grace Period Unit field. Click the 
down arrow and select either Days or Months 
in the selection list. 

Table 9-1.  Setting Up Time Between Survey Settings (continued)

Property Name Property Description
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Early Survey Limit Days Early Survey Limit Days is only used when Targets 
is selected as the scheduling method. When the 
selected scheduling method is Last Survey or X 
years / Y%, PCS Axis displays N/A (not applicable) 
indicating Early Survey Limit Days does not apply. 

Early Survey Limit Days refers to how early an 
inspection can occur before the actual due date 
and still count as an inspection for that survey 
period.

To set the number of days an inspection can occur 
before the actual due date: 

• Type a value in the field Early Survey Limit 
Days. 

Include Delinquent Within Days If a facility inspection will become delinquent 
within a number of days, include the facility in the 
schedule with those due for inspection. For 
example, if a facility inspection is delinquent in 5 
days, include that facility in the schedule with 
others due for inspection. 

To set a delinquent time period in days: 

• Type a value in the field Include Delinquent 
Within Days. 

Required Inspections Per 
Calendar Year

Number of required inspections per calendar year. 
To set the number of required inspections:

• Type a value in the field Required Inspections 
Per Calendar Year. 

Table 9-1.  Setting Up Time Between Survey Settings (continued)

Property Name Property Description
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Multi-Year Survey Start Refers to the year a multi-year survey starts 
(starting point). PCS Axis uses the starting year to 
calculate future survey dates available for selection 
in the Target Year selection list. 

To set a starting year for a multi-year survey:

• Type a year in the field Multi-Year Survey Start. 

Minimum Percent Scheduled Refers to a minimum percentage of facilities that 
must be inspected. This setting works in 
conjunction with the due date calculation method 
X years/Y% selected in the Schedule Type 
Settings tab. 

To set a minimum percentage of facilities that must 
be inspected:

• Type a value in the field Minimum Percent 
Scheduled. The field supports decimal 
formatting, such as 30.75. 

Table 9-1.  Setting Up Time Between Survey Settings (continued)

Property Name Property Description
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Schedule Type Settings
Scheduling properties set up in Schedule Type Settings apply at the facility type level. 
Some scheduling properties inherit settings from those previously set up in Time Between 
Survey Settings. Inherited settings changed at the facility type level override and have 
precedent over those in Time Between Survey Settings.

To set up scheduling properties at the facility type level, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window. Select one or 
more pipeline segments by clicking the check box for each pipeline segment 
(Figure 9-2, page 418). Click  Save to close the Select ROWs window. 

2 Click Data Entry > Edit Schedule Settings > Schedule Type Settings tab 
(Figure 9-4). 

Figure 9-4.  Schedule Type Settings
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3 Select the facility type you want to work with using one of the following methods 
described in step "a" or "b":

a To select a facility type theme, click the themes option button and then click 
the down arrow and select a theme in list, such as [PCS] Rectifier Survey 
(Figure 9-5). 

Figure 9-5.  Facility Type Theme Option

b To select multiple facility types, click the Ad Hoc Theme option and then click 
the check box for one or more facility types, such as Test Point, Rectifier, and 
Foreign Bond (Figure 9-6). 

NOTE: An Ad Hoc Theme only applies to the current session and is not saved. 
A facility type is selected when a check mark appears inside the check box. To 
clear the check mark, click the check box again. 

Figure 9-6.  Ad Hoc Theme Option

Facility Type Theme 
Selection List

Ad Hoc Theme Option

Facility Type Selection(s)
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4 Refer to the following table (Table 9-2, page 425) for a description of facility type 
scheduling properties and how to set up each of these. 

IMPORTANT: Certain property names in the following table include an asterisk (*). 
The asterisk identifies scheduling properties you can set at the facility type level 
that will override and take precedent over those in Time Between Survey Settings. 

Table 9-2.  Schedule Type Settings 

Property Name Property Description

Selected Include or exclude schedule settings at the facility 
type level when generating a schedule with 
facilities due for inspection. 

To include or exclude schedule settings: 

1 Click Selected to display a drop down arrow.

2 Click the drop down arrow and select one of the 
following options in the selection list: 

• No: Excludes schedule settings when 
generating a schedule. 

• Yes: Includes schedule settings when 
generating a schedule.

• Auto Select: If an Auto Select Expression 
has previously been created, select to 
include the expression with other schedule 
settings when generating a schedule. 

For information about how to create an 
expression, see Auto Select Expression 
(page 427). 
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Scheduling Type Name A named set of schedule settings for a facility type, 
such as Periodic Rectifier and Annual Rectifier. 

To add a new scheduling type:

1 Select a Facility Types theme or set up an Ad 
Hoc Theme with a facility type you want to add 
a new scheduling type. 

2 Click Add to open the Add Schedule Type 
dialog box. 

3 Type a name for the new scheduling type in the 
field Scheduling Type Name.

4 Set up schedule settings as required. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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Auto Select Expression A database query set up for a scheduling type that 
defines the criteria for including specific facilities in 
a survey schedule. The expression is a combination 
of an operator, PCS Axis field, condition, and user-
selected criteria. 

To create an expression for a scheduling type:

1 Click Create Expression to display an ellipsis 
button (…). Click the button to open the Auto 
Select Expression dialog box. 

2 Choose an expression operator by selecting 
either New ‘And’ Group or New ‘Or’ Group. 

3 Type a name for the expression and then 

click the add button .

3 Set up expression fields in the following 
manner:

• Click the down arrow and select a PCS Axis 
field.

• Click the down arrow and select a condition, 
such as Is equal to or Is missing. 

• Type criteria in the last expression field if the 
field is present. This field is present based on 
selections in the previous two expression 
fields.

4 Click Save. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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Scheduling Priority Facilities due for inspection are scheduled for 
survey at the facility type level based on the priority 
level of the scheduling type. Priority level is any 
value from 1 to 99 with 1 being the highest priority. 
To set a priority level at the facility type level for a 
scheduling type: 

1 Verify Yes is set for the scheduling property 
Only Highest Priority Due Is Scheduled. 

2 Type a value for Scheduling Priority using any 
number from 1 to 99. 

NOTE: A priority level set at the facility type 
level can be overridden at the ROW level in 
Hierarchy Level Overrides. 

Due Date Calculation Method Facilities due for inspection are scheduled for 
survey at the facility type level based on the due 
date calculation method of the scheduling type. 

To set a due date calculation method for a 
scheduling type: 

1 Click Due Date Calculation Method to 
display a drop down arrow. 

2 Select one of the following options in the 
selection list:

• Targets: Facilities due for inspection are 
scheduled for survey based on the Last 
Inspection Date, Target Month and Target 
Year. 

• Last Survey: Facilities due for inspection are 
scheduled for survey based on the Last 
Inspection Date and setting for the 
scheduling property Time Between Surveys. 

• X years/Y%: Facilities due for inspection are 
scheduled for survey based on the Last 
Inspection Date and settings for the 
scheduling properties Time Between 
Surveys, Multi-Year Survey Start, and 
Minimum Percent Scheduled. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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Only Highest Priority Due Is 
Scheduled

If the scheduling type is set up with a Scheduling 
Priority level, include only those facilities with the 
highest priority level that are due for inspection in 
the survey schedule. 

Complete the following steps:

1 For a scheduling type listed in Scheduling Type 
Name, click the field Only Highest Priority 
Due Is Scheduled to display a drop down 
arrow. 

2 Click the down arrow and select one of the 
following options in the selection list:

• Yes: Only those facilities due for inspection 
with the highest priority level are scheduled 
for survey. 

• No: Any facility due for inspection is 
scheduled for survey. 

Percent Needed to Complete 
Survey

A value from 0 to 100 indicating the percentage of 
facilities that must be surveyed before the survey 
(annual or multi-year) is considered complete. 

To set a percentage: 

• Type a value in the field Percent Needed To 
Complete Survey for a scheduling type listed 
in Scheduling Type Name. 

*Time Between Surveys Number of months or years between inspections. 
(See note about overrides in step 4 on page 425.)

To set the time between surveys: 

1 For a scheduling type listed in Scheduling Type 
Name, click the field Time Between Surveys 
to display a drop down arrow. 

2 Click the down arrow and select the number of 
months or years in the selection list. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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*Target Month Used only when Targets is selected as the 
scheduling method. Refers to the first survey 
month. Options in the selection list are based on 
the Time Between Survey value. (See note about 
overrides in step 4 on page 425.)

As an example, if Time Between Surveys is 2 
months and the Target Month (first survey month) 
is January, surveys are set at 2 month intervals 
beginning in January. The next survey is due in 
March, the next in May, and so on. 

To set the target month:

1 For a scheduling type listed in Scheduling Type 
Name, click the field Target Month to display 
a drop down arrow.

2 Click the down arrow and select a month in the 
selection list. 

*Target Year Used only when Targets is selected as the 
scheduling method. Refers to the first survey year 
when Time Between Surveys is more than 12 
months. (See note about overrides in step 4 on 
page 425.)

To set the target year:

1 For a scheduling type listed in Scheduling Type 
Name, click the field Target Year to display a 
drop down arrow.

2 Click the down arrow and select a year in the 
selection list. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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*Grace Period / *Grace Period 
Unit

Refers to a period of time in days or months an 
inspection can be late without incurring a 
compliance violation. (See note about overrides in 
step 4 on page 425.)

To set a grace period for a scheduling type listed in 
Scheduling Type Name:

1 Type a value in the Grace Period field.

2 Click the Grace Period Unit field to display a 
drop down arrow. Click the drop down arrow 
and select either Days or Months in the 
selection list. 

*Early Survey Limit Days Refers to how early an inspection can occur before 
the actual due date and still count as an inspection 
for the survey period. (See note about overrides in 
step 4 on page 425.)

To set an early survey limit for a scheduling type 
listed in Scheduling Type Name: 

• Type the number of days in the field Early 
Survey Limit Days. 

*Include Delinquent Within 
Days

If an inspection will become delinquent within a 
number of days, include the facility in the schedule 
with facilities due for inspection. (See note about 
overrides in step 4 on page 425.)

To set a delinquent time period in days for a 
scheduling type listed in Scheduling Type Name: 

• Type the number of days in the field Include 
Delinquent Within Days. 

*Required Inspections Per 
Calendar Year

Number of required inspections per calendar year. 
(See note about overrides in step 4 on page 425.)

To set the number of required inspections for a 
scheduling type listed in Scheduling Type Name:

• Type a value in the field Required Inspections 
Per Calendar Year. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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*Multi-Year Survey Start Refers to the year a multi-year survey starts. PCS 
Axis uses the starting year to calculate future 
survey dates available for selection in the Target 
Year selection list. (See note about overrides in 
step 4 on page 425.)

To set the starting year of a multi-year survey for a 
scheduling type listed in Scheduling Type Name:

• Type a year in the field Multi-Year Survey Start. 

*Minimum Percent Scheduled Refers to a minimum percentage of facilities that 
must be inspected in a multi-year survey. This 
setting works in conjunction with the due date 
calculation method X years/Y%. (See note about 
overrides in step 4 on page 425.)

To set a minimum percentage of facilities that must 
be inspected for a scheduling type listed in 
Scheduling Type Name:

• Type a value in the field Minimum Percent 
Scheduled. The field supports decimal 
formatting, such as 30.75. 

*Survey Season Start Month Refers to the starting month in the survey season 
for a multi-year survey. (See note about overrides 
in step 4 on page 425.)

To set the starting month in the survey season for a 
scheduling type listed in Scheduling Type Name:

1 Click the field Survey Season Start Month to 
display a drop down arrow.

2 Click the drop down arrow and select a starting 
month in the selection list. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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*Survey Season End Month Refers to the ending month in the survey season 
for a multi-year survey. (See note about overrides 
in step 4 on page 425.) 

To set the ending month in the survey season for a 
scheduling type listed in Scheduling Type Name:

1 Click the field Survey Season Start Month to 
display a drop down arrow.

2 Click the drop down arrow and select a starting 
month in the selection list. 

Level Work Load Refers to PCS Axis balancing the work load for 
facilities that are due for inspection in a multi-year 
survey. The property setting applies at the facility 
type level.

To enable this scheduling option:

• Click the check box Level Work Load for a 
scheduling type listed in Scheduling Type 
Name. 

To disable the option, clear the check mark by 
clicking the check box again. 

Hide Refers to hiding a scheduling type in the Facility 
Level Override mini-grid of the data entry grid. 
Hiding the mini-grid prevents scheduling changes 
at the facility level when working with the data 
entry grid based on a schedule. 

To enable this scheduling option:

• Click the Hide check box for a scheduling type 
listed in Scheduling Type Name. 

To disable the option, clear the check mark by 
clicking the check box again. 

Table 9-2.  Schedule Type Settings (continued)

Property Name Property Description
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Hierarchy Level Overrides
Scheduling properties set up in Hierarchy Level Overrides apply at the ROW (pipeline) 
level. Some scheduling properties inherit settings from those previously set up in Time 
Between Survey Settings and ROW and Facility Settings. Inherited settings changed at 
the ROW level override and have precedent over those in the Time Between Survey 
Settings and ROW and Facility Settings.

To set up scheduling properties at the ROW level, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window. Select one or 
more pipeline segments by clicking the check box for each pipeline segment 
(Figure 9-2, page 418). Click  Save to close the Select ROWs window. 

2 Click Data Entry > Edit Schedule Settings > Hierarchy Level Overrides tab 
(Figure 9-7). 

Figure 9-7.  Hierarchy Level Overrides
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3 Choose the facility type(s) you want to work with by selecting a facility type theme 
or setting up an Ad Hoc Theme in Facility Types. See Figure 9-5 or Figure 9-6 on 
page 424. 

4 Select the ROW(s) you want to work with by clicking the check box for each ROW 
in the middle pane of the Hierarchy Level Overrides window (Figure 9-8). 

Figure 9-8.  ROW Selection(s)

5 Refer to the following table (Table 9-3, page 436) for a description of scheduling 
properties that apply at the ROW level and how to set up each of these. 

IMPORTANT: Certain property names in the following table include an asterisk (*). 
The asterisk identifies scheduling properties you can set at the ROW level that will 
override and take precedent over those in ROW and Facility Settings and Time 
Between Survey Setting
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Table 9-3.  Hierarchy Level Overrides 

Property Name Property Description

Selected Include or exclude schedule settings at the ROW 
level when generating a schedule with facilities due 
for inspection. 

To include or exclude schedule settings: 

1 Click Selected to display a drop down arrow.

2 Click the drop down arrow and select one of the 
following options in the selection list: 

• No: Excludes schedule settings when 
generating a schedule. 

• Yes: Includes schedule settings when 
generating a schedule.

• Auto Select: If an Auto Select Expression 
has previously been created in the Schedule 
Type Settings tab, select to include the 
expression with other schedule settings 
when generating a schedule. 

For information about how to create an 
expression, see Auto Select Expression 
(page 427). 

Scheduling Type Name A named set of schedule settings for a facility type 
created in the Schedule Type Settings tab. 

For information about how to create a Scheduling 
Type Name, see page 426. 

Due Date Calculation Method Shows the property setting inherited from Due 
Date Calculation Method in the Schedule Type 
Settings tab. 
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*Time Between Surveys Number of months or years between inspections. 
(See note about overrides in step 5 on page 435.) 

To set the time between surveys: 

1 For a scheduling type listed in Scheduling Type 
Name, click the field Time Between Surveys 
to display a drop down arrow. 

2 Click the down arrow and select the number of 
months or years in the selection list. 

*Target Month Refers to the first survey month. Options in the 
selection list are based on the Time Between 
Survey value. (See note about overrides in step 5 
on page 435.) 

As an example, if Time Between Surveys is 2 
months and the Target Month (first survey month) 
is January, surveys are set at 2 month intervals 
beginning in January. The next survey is due in 
March, the next in May, and so on. 

To set the target month:

1 For a scheduling type listed in Scheduling Type 
Name, click the field Target Month to display 
a drop down arrow.

2 Click the down arrow and select a month in the 
selection list. 

*Target Year Refers to the first survey year when Time Between 
Surveys is more than 12 months. (See note about 
overrides in step 5 on page 435.) 

To set the target year:

1 For a scheduling type listed in Scheduling Type 
Name, click the field Target Year to display a 
drop down arrow.

2 Click the down arrow and select a year in the 
selection list. 

Table 9-3.  Hierarchy Level Overrides (continued)

Property Name Property Description
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*Grace Period / *Grace Period 
Unit

Refers to a period of time in days or months an 
inspection can be late without incurring a 
compliance violation. (See note about overrides in 
step 5 on page 435.) 

To set a grace period for a scheduling type listed in 
Scheduling Type Name:

1 Type a value in the Grace Period field.

2 Click the Grace Period Unit field to display a 
drop down arrow. Click the drop down arrow 
and select either Days or Months in the 
selection list. 

*Early Survey Limit Days Refers to how early an inspection can occur before 
the actual due date and still count as an inspection 
for the survey period. (See note about overrides in 
step 5 on page 435.) 

To set an early survey limit for a scheduling type 
listed in Scheduling Type Name: 

• Type the number of days in the field Early 
Survey Limit Days. 

Table 9-3.  Hierarchy Level Overrides (continued)

Property Name Property Description
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Creating a Schedule
Information in this section explains how to create a schedule based on a scheduling 
method. Scheduling methods include Targets, Last Survey, and X years/Y%. The 
scheduling method in conjunction with other schedule settings determines when facilities 
are due for inspection.

Topics in this section include those in the following list: 

• Creating a Schedule Based on Targets

• Creating a Schedule Based on Last Survey (page 441)

• Creating a Schedule Based on X years/Y% (page 442)

Creating a Schedule Based on Targets
If you want to schedule facilities for survey using a recurring time period, such as every 
January of each year, create a schedule based on the Targets scheduling method. With this 
method, facilities due for inspection are scheduled for survey based on the Last 
Inspection Date, Target Month, and Target Year. 

To create a schedule based on the Targets scheduling method, follow these steps: 

1 Select a pipeline segment in the Select ROWs window. Click  Save to close the 
window. 

2 Click Data Entry > Edit Schedule Settings > Time Between Survey Settings 
tab. 

3 Set up all related scheduling properties for a survey selected in Time Between 
Surveys. Scheduling properties marked with N/A (not applicable) are not required, 
such as Target Year for a survey with Time Between Surveys of 12 months or less. 
If needed, refer to Table 9-1 on page 419 for field descriptions. 

NOTE: Scheduling properties set up in Time Between Surveys apply system wide. 
Settings can however be overridden at the facility type level in ROW and Facility 
Settings; at the hierarchy level in Hierarchy Level Overrides; and at the facility 
level in the Facility Level Override mini-grid of the Information grid. 

4 To select the Targets due date method:

a Click the Schedule Type Settings tab. 
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b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c For a scheduling type listed in Scheduling Type Name, click the field Due 
Date Calculation Method to display a drop down arrow. Click the arrow and 
select Targets in the selection list. 

d Set up remaining scheduling properties as required. Scheduling properties 
inherit values from those in the Time Between Survey Settings tab and can be 
overridden at the facility type level as needed. Property settings marked N/A 
(not applicable) are not required. Refer to Table 9-2 on page 425 for field 
descriptions. 

5 If you want to override one or more scheduling properties at the ROW level, 
complete the following steps:

a Click the Hierarchy Level Overrides tab. 

b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c Select the ROW(s) you want to set up a survey schedule. Select one or more 
ROWs (pipeline segments) listed in the middle pane of the window. 

d For a scheduling type listed in Scheduling Type Name, set up scheduling 
properties as required. Scheduling properties inherit values from those in the 
Schedule Type Settings tab and can be overridden at the ROW level as 
needed. Refer to Table 9-3 on page 436 for field descriptions. 

The schedule is now set up with the Targets scheduling method. 
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Creating a Schedule Based on Last Survey
If you want to schedule facilities for survey based on the last time facilities were inspected, 
create a schedule based on the Last Survey scheduling method. With this method, 
facilities due for inspection are scheduled for survey based on Last Inspection Date and 
settings for the scheduling property Time Between Surveys. 

To create a schedule based on the Last Survey scheduling method, follow these steps:

1 Select a pipeline segment in the Select ROWs window. Then click  Save to close 
the window. 

2 Click Data Entry > Edit Schedule Settings > Time Between Survey Settings 
tab. 

3 Set up all related scheduling properties for a survey selected in Time Between 
Surveys. Scheduling properties marked with N/A (not applicable) are not required, 
such as Target Year for a survey with Time Between Surveys of 12 months or less. 
If needed, refer to Table 9-1 on page 419 for field descriptions. 

NOTE: Scheduling properties set up in Time Between Surveys apply system wide. 
Settings can however be overridden at the facility type level in ROW and Facility 
Settings; at the hierarchy level in Hierarchy Level Overrides; and at the facility 
level in the Facility Level Override mini-grid of the Information grid. 

4 To select the Last Survey due date method:

a Click the Schedule Type Settings tab. 

b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c For a scheduling type listed in Scheduling Type Name, click the field Due 
Date Calculation Method to display a drop down arrow. Click the arrow and 
select Last Survey in the selection list. 

d Set up remaining scheduling properties as required. Scheduling properties 
inherit values from those in the Time Between Survey Settings tab and can be 
overridden at the facility type level as needed. Property settings marked N/A 
(not applicable) are not required. Refer to Table 9-2 on page 425 for field 
descriptions. 

5 If you want to override one or more scheduling properties at the ROW level, 
complete the following steps:

a Click the Hierarchy Level Overrides tab. 
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b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c Select the ROW(s) you want to set up a survey schedule. Select one or more 
ROWs (pipeline segments) listed in the middle pane of the window. 

d For a scheduling type listed in Scheduling Type Name, set up scheduling 
properties as required. Scheduling properties inherit values from those in the 
Schedule Type Settings tab and can be overridden at the ROW level as 
needed. Refer to Table 9-3 on page 436 for field descriptions.

The schedule is now set up with the Last Survey scheduling method. 

Creating a Schedule Based on X years/Y%
If facilities require inspection based on a multi-year cycle, use the X years/Y% scheduling 
method. With this method, facilities due for inspection are scheduled for survey based on 
the Last Inspection Date and settings for the scheduling properties Time Between 
Surveys, Multi-Year Survey Start, and Minimum Percent Scheduled. 

To create a schedule for a multi-year survey based on the X years/Y% method, follow 
these steps:

1 Select a pipeline segment in the Select ROWs window. Click  Save to close the 
window. 

2 Click Data Entry > Edit Schedule Settings > Time Between Survey Settings 
tab. 

3 Set up all related scheduling properties for a survey selected in Time Between 
Surveys. Scheduling properties marked with N/A (not applicable) are not required, 
such as Required Inspections Per Calendar Year for a survey with Time Between 
Surveys of 2 Years or more. If needed, refer to Table 9-1 on page 419 for field 
descriptions. 

NOTE: Scheduling properties set up in Time Between Surveys apply system wide. 
Settings can however be overridden at the facility type level in ROW and Facility 
Settings; at the hierarchy level in Hierarchy Level Overrides; and at the facility 
level in the Facility Level Override mini-grid of the Information grid. 

4 To select the X years/Y% due date method:

a Click the Schedule Type Settings tab. 
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b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c For a scheduling type listed in Scheduling Type Name, click the field Due 
Date Calculation Method to display a drop down arrow. Click the arrow and 
select X years/Y% in the selection list. 

d Set up remaining scheduling properties as required. Scheduling properties 
inherit values from those in the Time Between Survey Settings tab and can be 
overridden at the facility type level as needed. Property settings marked N/A 
(not applicable) are not required. Refer to Table 9-2 on page 425 for field 
descriptions. 

5 If you want to override one or more scheduling properties at the ROW level, 
complete the following steps:

a Click the Hierarchy Level Overrides tab. 

b Select one or more facility types in the Facility Types pane using either an 
installed facility type theme or an Ad Hoc Theme. 

c Select the ROW(s) you want to set up a survey schedule. Select one or more 
ROWs (pipeline segments) listed in the middle pane of the window. 

d For a scheduling type listed in Scheduling Type Name, set up scheduling 
properties as required. Scheduling properties inherit values from those in the 
Schedule Type Settings tab and can be overridden at the ROW level as 
needed. Refer to Table 9-3 on page 436 for field descriptions.

The schedule is now set up with the X years/Y% scheduling method. 
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Working with a Schedule Definition
A schedule definition is a named set of one or more scheduling types to be included in a 
schedule. For example, a schedule definition can include test point, rectifier, and bond 
scheduling types – each with different scheduling properties set up in Edit Schedule 
Settings (page 423). A schedule definition is used when performing any of the following 
tasks in PCS Axis:

• viewing facilities in a data entry grid based on a schedule

• building a survey in a data entry grid based on a schedule

• transferring a survey that is based on a schedule to the Allegro Field PC 

• printing a data collection form that is based on a schedule for manually recording 
survey data

NOTE: A scheduling type is a named set of scheduling properties for a facility type 
set up in Edit Schedule Settings. For more information, see Schedule Type 
Settings (page 423). 

Two types of schedule definitions are available for use. They include installed and 
addition schedule definitions. An installed schedule definition is one that has been 
installed during the PCS Axis software installation. An addition schedule definition is one 
that you create. 

Topics in this section explain how to work with a schedule definition and include those in 
the following list: 

• Editing an Installed Schedule Definition (page 445)

• Adding a Schedule Definition Addition (page 448)

• Editing a Schedule Definition Addition (page 449)
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Editing an Installed Schedule Definition
An installed schedule definition includes [PCS] in the title of the schedule definition name, 
such as [PCS] Installed Schedule Definition. The procedure in this section explains how 
to complete the following tasks to edit an installed schedule definition:

• add a schedule type

• remove a schedule type

• revert an installed schedule definition

To edit an installed schedule definition, follow these steps: 

1 Click Data Entry > Define Schedules to open the Define Schedules window 
(Figure 9-9).

2 Click the down arrow in the Select Schedule Definition field and select an 
installed schedule definition, such as [PCS] Installed Schedule Definition. 

Figure 9-9.  Define Schedules
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3 To add one or more schedule types to an installed schedule definition:

a Select a schedule type listed in the Available Schedule Types pane, such as 
Periodic Rectifier. To select multiple schedule types, press the Ctrl key on the 
computer keyboard while selecting each schedule type. 

b Click the top arrow button  to move the schedule type(s) to the Selected 
Schedule Types pane (Figure 9-10). Click  Save. 

NOTE: Double-clicking a schedule type in the Available Schedule Types pane 
also moves it to the Selected Schedule Types pane. 

Figure 9-10.  Adding a Schedule Type

4 To remove one or more schedule types from an installed schedule definition:

a Select a schedule type listed in the Selected Schedule Types pane (Figure 9-
10). To select multiple schedule types, press the Ctrl key on the computer 
keyboard while selecting each schedule type. 

b Click the bottom arrow button  to move the schedule type to the Available 
Schedule Types pane. Click  Save. 

NOTE: Double-clicking a schedule type in the Selected Schedule Types pane 
also moves it to the Available Schedule Types pane. 
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5 After saving changes to an installed schedule definition, complete the following 
step to revert to installed values: 

• Click Revert then click  Yes when the Revert message displays (Figure 9-
11). 

Figure 9-11.  Revert Message
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Adding a Schedule Definition Addition
To add a schedule definition addition, follow these steps: 

1 Click Data Entry > Define Schedules to open the Define Schedules window 
(Figure 9-12).

2 Click Add and then type a name for the addition in the Schedule Name field. The 
field supports up to 120 characters including spaces. 

3 Select a schedule type listed in the Available Schedule Types pane, such as 
Periodic Bond-Critical. To select multiple schedule types, press the Ctrl key on the 
computer keyboard while selecting each schedule type. 

4 Click the top arrow button  to move the schedule type(s) to the Selected 
Schedule Types pane (Figure 9-12). Click  Save. The addition is now available in 
the Select Schedule Definition selection list. 

NOTE: Double-clicking a schedule type in the Available Schedule Types pane also 
moves it to the Selected Schedule Types pane. 

Figure 9-12.  Adding a Schedule Definition Addition
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Editing a Schedule Definition Addition
The following procedure explains how to delete, rename, or edit a schedule definition 
addition. 

Complete the following steps:

1 Click Data Entry > Define Schedules to open the Define Schedules window 
(Figure 9-12, page 448).

2 Click the down arrow in the Select Schedule Definition field and select an 
addition in the selection list.

3 If you want to delete the addition, click  Delete, then click  Yes when the 
Delete message displays (Figure 9-13). 

Figure 9-13.  Delete Message

4 If you want to rename an addition, type a new name in the Schedule Name field 
and then click  Save. 

5 If you want to edit the addition by adding one or more schedule types, follow 
these steps:

a Select a schedule type listed in the Available Schedule Types pane. To select 
multiple schedule types, press the Ctrl key on the computer keyboard while 
selecting each schedule type. 

b Click the top arrow button  to move the schedule type(s) to the Selected 
Schedule Types pane, then click  Save. 

6 If you want to edit the addition by removing one or more schedule types, follow 
these steps:

a Select a schedule type listed in the Selected Schedule Types pane. To select 
multiple schedule types, press the Ctrl key on the computer keyboard while 
selecting each schedule type. 

b Click the bottom arrow button  to move the schedule type to the Available 
Schedule Types pane, then click  Save. 
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Using a Schedule in PCS Axis
After setting up scheduling criteria in Edit Schedule Settings and creating a schedule 
definition in Define Schedules, you can use a schedule in any of the following ways:

• View records in a grid based on a schedule. For instructions, see Viewing Records 
Based on a Schedule (page 245). 

• Build a survey in an inspection grid based on a schedule. For instructions, see 
Building a Survey in the Inspection Grid (page 258). 

• Transfer a survey to the Allegro Field PC based on a schedule. For instructions, see 
Using Field Computer (page 559). 
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Using Bridge

Bridge is an optional add-on feature that allows you to transfer data between PCS Axis and 
an external system, such as a GIS (geographic information system) or work management 
system. If you have an account on American Innovations’ Bullhorn® Asset Tracker (BAT™) 
website, you can transfer facility survey data to PCS Axis, such as rectifier, bond, or test 
point inspection readings. 

If your company purchased the optional Bridge add-on or you plan to transfer data from 
BAT in PCS Axis, running Bridge for the first time requires you to enter a Bridge activation 
key. If you are unable to locate your Bridge activation key, contact PCS Technical services 
for assistance at pcstechservices@aiworldwide.com. For more information, refer to 
Activating Bridge Import for Operation (page 15). 

Topics in this chapter include those in the following list: 

• Understanding the Bridge Transition File

• Using a Facility Key in Bridge (page 454)

• Adding a Bridge Definition (page 456)

• Viewing Bridge Job Status and Log (page 519)

• Icons and Colors Used in Bridge Job Status (page 522)

Understanding the Bridge Transition File
Bridge uses a transition file to import and export data. The import file is in a format that 
both Bridge and the external system can read and write. File formats supported by Bridge 
include those in the following list:

• Excel Spreadsheet 2007 or higher (.xlsx)

• ASCII, comma-delimited (.txt or .csv)

• Extensible Markup Language (.xml)
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Using a Facility Key in Bridge
Bridge provides the option of associating a facility key in PCS Axis with an external system 
ID when setting up a Bridge import definition. The facility key must be unique for each 
facility. It is used to update mileposts, ROWs, or facility IDs for existing facilities. 

A facility key is a user-defined field set up in PCS Axis. An external system ID is typically a 
unique identifier generated by an external system, such as a GIS or work management 
system. The facility key is used in place of the PCS Axis fields labeled ROW Code or 
Milepost when setting up the Bridge import definition. The facility key allows you to map 
(or link) facilities between PCS Axis and the external system. 

NOTE: The Facility Key feature applies only to a Bridge Import. 

To add a facility key for an external system ID, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 10-1, page 455). 

2 Open the folders labeled Facility Surveys and Common to All Facilities in the 
selection tree. Then click ROW and Pipeline to display related fields in the grid. 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 10-1.  Field and UDF Customizations

3 Click  Normal in the toolbar to open the Add Normal Field dialog box 
(Figure 10-2). 

4 Type a unique name for the UDF in the Caption field. Then click  Save to 
save changes and close the dialog box. 

The UDF is now ready to be used as the Facility Key in a Bridge import or export 
definition file. 

Figure 10-2.  Add Normal Field
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Adding a Bridge Definition
Information in this section explains how to add a Bridge import, export, import/export, 
and Bullhorn definition. Topics include those in the following list:

• Adding a Bridge Import Definition

• Adding a Bridge Import Definition for an SDL Survey File

• Adding a Bridge Export Definition (page 475)

• Adding a Bridge Import/Export Definition (page 489)

• Adding a Bullhorn Bridge Definition (page 505)

Adding a Bridge Import Definition
A Bridge import definition specifies the property settings and options for importing data 
in PCS Axis. It defines the data transfer options; location of the import file; and field 
mappings in PCS Axis and the import file. 

To add a Bridge import definition, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the Bridge definition. Click 

 Save to close the window (Figure 10-3). 

Figure 10-3.  Select ROWs
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2 Click Tools > Bridge to open the Bridge window (Figure 10-4).

Figure 10-4.  Bridge

3 Click  Basic to open the basic definition panel (Figure 10-5). 

Figure 10-5.  Basic Definition Panel
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4 Type a unique name for the definition in the Name field (Figure 10-6, page 459).

NOTE: Clicking the Bridge Definitions bar collapses the panel allowing you to 
view more of the definition panel. Clicking the bar again expands the panel. 

5 To set properties in the Data Transfer group box, follow these steps (Figure 10-6, 
page 459):

a Click the Import check box. 

b If you are importing large amounts of data, click the check box Reindex after 
import to reindex the PCS Axis database after the import process completes. 

NOTE: Enabling this option prevents index fragmentation from occurring in 
the PCS Axis database, which in turn may result in slow system performance. 
Index fragmentation may occur after importing large amounts of data in PCS 
Axis using Bridge Import, Bullhorn Bridge, or Field Computer. You can also 
reindex the database using the option Reindex Database in Job Service 
Viewer (Tools > Job Service Viewer). 

c If you want PCS Axis to automatically run the import file at a scheduled time, 
click the Scheduled check box and then type a scheduled time in the adjacent 
field. Enter a scheduled time using 12-hour time format to specify the hour, 
minute, and AM/PM setting (HH:MM AM or PM). 

When the import file is not scheduled to run automatically, you can run it 
manually by clicking the  Import button. 

IMPORTANT: When scheduling a time to run Bridge, choose a time that does 
not impact other network services or computer resources. For example, 
consider a staggered time schedule instead of running Bridge at the same 
time as other scheduled network services. 
458 Using Bridge



PCS Axis User and Administrator Guide
6 To set properties in the Options group box, follow these steps (Figure 10-6):

a Click the Public check box if you want the import definition file available for 
use by all PCS Axis users. When the check box is empty, the definition file is 
available only to the user who creates it. 

b Click the check box Use Facility Key if you plan to map facilities to a user 
defined field (UDF) set up previously for an external system ID. See Using a 
Facility Key in Bridge (page 454) for more information if needed.

When facilities are not mapped to a facility key, they are mapped to the 
following required fields: ROW Code, Milepost, and Facility ID. 

c If you plan to run the Bridge definition manually and want Bridge to rename 
the file after importing data, click the check box Rename files on manual 
bridge runs. 

Figure 10-6.  Bridge Import Definition

7 Click  Save and then click  Full View to hide the group boxes Data Transfer 
and Options. Clicking Full View again displays these group boxes. 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 
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8 Choose the data item(s) you want to import in PCS Axis. Click  Add Data Item 
to open the Data Items window and then complete the following steps (Figure 10-
7):

a Open the folder(s) containing the data item(s) you want to import. Repeat this 
step as needed for other folders. For example, the folders CPDM and Rectifier 
are selected in the following figure (Figure 10-7). 

b Double-click to select a data item and move it to the right pane of the window. 
Repeat this step as needed for other data items. For example, the data item 
Rectifier Inspection is selected in the next figure. 

Figure 10-7.  Data Items

NOTE: The right pane of the Data Items window lists all selected data items 
for import. To remove a data item for import, double-click the data item in the 
right pane to move it back to the left pane. 

c Click  OK to close the dialog box and return to the definition panel. Then 
click  Save. 

9 Identify the location of the import file using the following steps (Figure 10-8, 
page 461):

a Click the ellipsis button … in the field Import File Name to open the Import 
File dialog box. Navigate to the import file and then select it.

b Click Open to close the dialog box and return to the definition panel. The path 
to the import file displays in the field Import File Name. 
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10 To assign inspections to a survey folder based on the inspection date, complete 
one or both of the following steps in the Options group box as required 
(Figure 10-8, page 461): 

a If you want to assign inspections to an annual survey folder, click the check 
box Assign inspections to an Annual Survey. 

b If you want to assign inspections to a periodic survey folder, click the check 
box Assign inspections to a Periodic Survey. 

Figure 10-8.  Definition

11 To map fields in PCS Axis with fields in the import file, follow these steps: 

a Click  Edit in the Maps group box to open a field mapping window 
(Figure 10-9, page 462). 

NOTE: Fields in the Mappings panel with a lock icon  are required fields for 
mapping, such as ROW Code, Milepost, Facility ID, and Inspection Date 
shown in the following example (Figure 10-9, page 462). 

b Choose PCS Axis fields for mapping. Click the  toggle arrow for a field 
category in the Internal Fields panel to view a list of available fields. For 
example, Rectifier Inspection Fields is selected in the following figure 
(Figure 10-9, page 462). 
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c Click the check box for one or more PCS Axis fields listed in the Internal Fields 
panel. Then click the  top arrow button to move selections to the Mappings 
panel. Double-clicking a field also moves it to the Mappings panel. 

For example, the PCS Axis fields Rectifier Output Current Found (Amps) and 
Rectifier Output Volts Found (Volts) are selected for mapping in the next 
figure. 

Figure 10-9.  Field Mappings

d If you want to sort import fields listed in the Transition Fields panel in 
alphabetical order, click the check box Sort Alphabetically. 

e To map PCS Axis fields with fields in the import file, follow these steps:

• Select a PCS Axis field in the Mappings panel. Map the selected field to a 
field in the import file by double-clicking a field listed in the Transition 
Fields panel. Repeat this step for remaining fields you want to map. 

NOTE: When the  Auto Map button is enabled and the names of 
fields in the import file match those in PCS Axis, double-clicking a PCS 
Axis field in the Mappings panel automatically maps to an import field 
listed in the Transition Fields panel. 

• If the definition is set up to use a facility key, click the Facility Key option 
button in the Mappings panel for the field you want to use as the facility 
key, such as ROW Code or Milepost. 

• If the field Choose a conversion... is present in the Mappings panel for a 
pair of mapped fields and you want to apply a conversion option, click the 
field Choose a conversion ... and select an option in the selection list. 
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f If you want to preview fields for mapping in the import file, click the 
 Preview button to open the import file in the Preview Maps 

window. 

g To remove a field mapping in the Mappings panel, select the field in the 
Mappings panel and then click  Delete Map. Double-clicking the field 
also removes it. Unmapped fields are moved to the Internal Fields panel. 

12 Click  OK to close the mapping window and return to the definition window. 
Then click  Save. 

Field mappings display in the Maps group box. 

13 To validate the definition, click the  Prevalidate button. When the 
validation process completes and the following message displays (Figure 10-
10), click  View Job Status to open the Job Status window or  Return 
to Definition to open the Definitions window. 

NOTE: The Prevalidate process confirms the definition file is set up correctly; it 
does not post data in the database. 

Figure 10-10.  Validated Message

14 If you want to manually import data in PCS Axis, complete one of the following 
steps: 

a If the Job Status window is open, click  Run for a selected import file listed 
in the Job Status window. Then click  Refresh to update status information. 

b If the Definitions window is open for the import file, click  Import. 

15 To view the status of a Bridge session, click  Job Status in the Definitions 
window to open the Job Status window (Figure 10-11, page 464). Clicking  Log 
for a Bridge session opens the log file for the selected session. 

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 
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Figure 10-11.  Job Status

16 To copy the Bridge definition to a file, such as a Notepad or Microsoft Word file, 
follow these steps:

a Click the Definitions tab if the Definitions window is not open.

b Click  Copy to Clipboard.

c Start the software program, such as Notepad or Microsoft Word.

d Open a new file and then Paste the definition file. Click Save. 
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Adding a Bridge Import Definition for an SDL Survey File
Information in this section explains how to set up a Bridge definition for importing one or 
more stationary data logger (SDL) survey files. The Bridge definition specifies property 
settings and options for importing data in PCS Axis; defines the data transfer options; and 
identifies the location of the SDL survey file(s). 

IMPORTANT: Bridge Import is an optional add-on that requires an activation key for 
operation. Running Bridge Import for the first time requires you to enter your Bridge 
activation key. If you are unable to locate your Bridge activation key, contact PCS Technical 
services for assistance at pcstechservices@aiworldwide.com. For more information, refer 
to Activating Bridge Import for Operation (page 15). 

To add a Bridge Import definition and import an SDL survey file, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) you want to import SDL survey files. Click  Save to close 
the window (Figure 10-3, page 456). 

2 Click Tools > Bridge to open the Bridge window (Figure 10-12).

Figure 10-12.  Bridge
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3 Click  Basic to open the basic definition panel. Then click the title bar of the 
Bridge Definitions panel to hide the panel. (Figure 10-13). 

Figure 10-13.  Basic Definition Panel

4 Type a unique name for the definition in the Name field (Figure 10-14, page 467).

5 Complete the following steps to set properties in the Data Transfer group box 
(Figure 10-14, page 467):

a Click the Import check box. 

NOTE: Because SDL imports are typically run manually “on demand”, setting 
property settings for Scheduled option are not required. 

b Click the check box Reindex after import to reindex the PCS Axis database 
after the import process completes. 

IMPORTANT: Enabling this option prevents index fragmentation from 
occurring in the PCS Axis database, which in turn may result in slow system 
performance. Index fragmentation may occur after importing large amounts of 
data in PCS Axis using Bridge Import, Bullhorn Bridge, or Field Computer. 
You can also reindex the database using the option Reindex Database in Job 
Service Viewer (Tools > Job Service Viewer). 
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Figure 10-14.  Bridge Import Definition

6 Complete the following steps to set properties in the Options group box 
(Figure 10-14):

a Click the Public check box if you want the import definition file available for 
use by all PCS Axis users. When the check box is empty, the definition file is 
available only to the user who creates it. 

NOTE: The option labeled Use Facility Key does not apply when using Bridge 
to import SDLs. See Using a Facility Key in Bridge (page 454) for more 
information if needed. 

b If you want the Bridge import process to rename the import file after 
importing data, click the check box Rename files on manual bridge runs. 

7 Click  Save and then click  Full View to hide the group boxes Data Transfer 
and Options. Clicking Full View again displays these group boxes. 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 
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8 Select the PCS Axis data item used to import SDL survey files. Click  Add Data 
Item to open the Data Items window and then complete the following steps 
(Figure 10-7):

a Click the  toggle arrow to open the System Items folder (Figure 10-15). 

b Double-click Stationary Survey Measurement to move the data item to the 
right pane of the window. 

NOTE: The right pane of the Data Items window lists all selected data items 
for import. To remove a data item for import, double-click the data item in the 
right pane to move it back to the left pane. 

c Click  OK to close the dialog box and return to the definition panel. 

Figure 10-15.  Data Items

9 Click  Save to save the definition file. 

10 Complete the following steps to identify the location of the SDL survey file(s) 
(Figure 10-16): 

a Click the ellipsis button … in the field Import File Name. 

b When the Import File dialog box opens, navigate to the SDL survey file(s) and 
select each one you want to import. Then click Open. 
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Figure 10-16.  Select SDL Import File

11 When the Stationary Survey(s) window opens (Figure 10-17, page 469), select the 
SDL survey file and then click the Snap To Facility button to open the Snap To 
Facility window (Figure 10-18, page 470). 

NOTE: A yellow  Snap To Facility button indicates the SDL survey file is 
matched to an unregistered milepost location. A green  Snap To Facility 
button indicates the SDL survey file has been automatically matched to a milepost 
location already established in PCS Axis. A blue  Snap To Facility button 
indicates a match was not found for the pipeline segment or pipeline Series. 

Figure 10-17.  Stationary Survey(s)
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12 When the milepost location of the SDL survey does not match a pipeline segment 
already established in PCS Axis, it is identified as an UnRegistered Milepost 
(Figure 10-18). 

When the milepost location of the SDL survey does match an existing pipeline 
segment in PCS Axis, use the Snap To Facility window to match the SDL survey to 
a milepost location on the pipeline segment. This process ensures telluric 
compensation calculations are accurate. 

To match the SDL survey to an existing milepost location, follow these steps:

a Click Existing Facilities to enable the grid for use (Figure 10-18). 

b If the pipeline segment is not selected in the ROW field, click the down arrow 
and select the pipeline segment in the selection list. 

c Select a milepost record in the grid and then click  OK to snap the SDL 
survey to the selected milepost. 

Figure 10-18.  Snap To Facility 
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13 When the Stationary Survey(s) window opens, click  Process Files to 
automatically map data fields in the SDL survey with data fields in PCS Axis 
(Figure 10-19). 

Figure 10-19.  Process Files / Stationary Survey(s)

After processing files, the definition window opens. The Maps group box includes 
a list of field mappings in the columns labeled Internal Field (PCS Axis) and 
Transition Field (SDL survey) as shown in the following example (Figure 10-20). 

Figure 10-20.  Bridge Definition
Using Bridge 471



PCS Axis User and Administrator Guide
14 If you want to apply an Import Voltage Conversion filter to survey 
measurements (such as On Voltage survey measurements), complete the following 
steps: 

a Click  Edit in the Maps group box to open the Stationary Survey 
Measurement dialog box (Figure 10-21). 

Figure 10-21.  Stationary Survey Measurement

b Select a survey measurement field in the grid. Then click the down arrow in the 
Import Voltage Conversion field and select one of the following filter 
options in the selection list (Figure 10-22, page 473). 

• No Conversion 

Does not apply a voltage conversion filter.

• (# * 0.001) – Convert mV to V 

Converts millivolt measurements to volts. 

• (# * 1000) – Convert V to mV 

Converts voltage measurements to millivolts. 

• (# * –1) – Invert polarity 

Reverses the polarity of survey measurement. 

• (# * –0.001) – Invert polarity and convert mV to V 

Reverses the polarity and converts millivolt measurements to volts. 

• (# * –1000) – Invert polarity and convert V to mV 

Reverses the polarity and converts voltage measurements to millivolts. 

c Click  OK to apply settings and close the Stationary Survey Measurement 
dialog box. 
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Figure 10-22.  Stationary Survey Measurement

15 To assign the SDL survey to a survey folder based on the survey date, complete 
one or both of the following steps in the Options group box as required 
(Figure 10-20, page 471): 

a If you want to assign the SDL survey to an annual survey folder, click the check 
box Assign inspections to an Annual Survey. 

b If you want to assign the SDL Survey to a periodic survey folder, click the check 
box Assign inspections to a Periodic Survey. 

c Click  Save to save the definition file. 

16 To validate the Bridge definition, click the  Prevalidate button. When the 
validation process completes and the following message displays, click  View 
Job Status to open the Job Status window or  Return to Definition to open 
the Definitions window (Figure 10-23). 

NOTE: The Prevalidate process confirms the definition file is set up correctly; it 
does not post data in the database. 

Figure 10-23.  Validated Message
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17 To import the SDL survey in PCS Axis, click  Import in the Definitions 
window (Figure 10-20, page 471). 

18 To view the status of the Bridge session, click  Job Status in the Definitions 
window to open the Job Status window (Figure 10-24, page 474). Clicking  Log 
for a Bridge session opens the log file for the selected session. 

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

Figure 10-24.  Job Status

19 To copy the Bridge definition to a file, such as a Notepad or Microsoft Word file, 
follow these steps:

a Click the Definitions tab if the Definitions window is not open. 

b Click  Copy to Clipboard.

c Start the software program, such as Notepad or Microsoft Word.

d Open a new file and then Paste the definition file. Click Save. 
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Adding a Bridge Export Definition
A Bridge export definition specifies the property settings and options for exporting data 
from PCS Axis. It defines the data transfer options; file format and location of the export 
file; and the data to be exported. 

NOTE: Bridge currently supports use of a facility key only in a Bridge import file. Future 
enhancements will include use of a facility key in a Bridge export file. 

To add a Bridge export definition, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the Bridge definition. Click 

 Save to close the window (Figure 10-25). 

Figure 10-25.  Select ROWs

2 Click Tools > Bridge to open the Bridge window (Figure 10-26, page 476)
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Figure 10-26.  Bridge

3 Click  Basic to open the basic definition panel (Figure 10-27). 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 

Figure 10-27.  Basic Bridge Definition
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4 Type a unique name for the definition in the Name field (Figure 10-28, 
page 478). 

NOTE: Clicking the Bridge Definitions bar collapses the panel allowing you to 
view more of the definition. Clicking the bar again expands the panel. 

5 To set properties in the Data Transfer group box, follow these steps (Figure 10-28, 
page 478):

a Click the Export check box. 

b If you want PCS Axis to automatically run the export file at a scheduled time, 
click the Scheduled check box and then type a scheduled time in the adjacent 
field. Enter a scheduled time using 12-hour time format to specify the hour, 
minute, and AM/PM setting (HH:MM AM or PM). 

IMPORTANT: When scheduling a time to run Bridge, choose a time that does 
not impact other network services or computer resources. For example, 
consider a staggered time schedule instead of running Bridge at the same 
time as other scheduled network services. 

c Select which records to export. Click the down arrow in the field From 
Selected ROWs, export and select an option in the selection list, such as All 
Records. 

NOTE: When the export file is not scheduled to run automatically, it is a 
manual Bridge definition. You can run the export file manually by clicking 
the  Export button in the Definitions window. 

6 To set properties in the Options group box, follow these steps (Figure 10-28, 
page 478):

a Click the Public check box if you want the export definition available for use 
by all PCS Axis users. When the check box is empty, the export definition is 
available only to the user who creates it. 

IMPORTANT: Do not enable the option Use Facility Key in an export 
definition. Bridge does not currently support this option in the export file. 
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b If you plan to run the Bridge definition manually and want Bridge to rename 
the file after exporting data, click the check box Rename files on manual 
bridge runs. 

7 Click  Save. 

Figure 10-28.  Bridge Export Definition

8 If you want to set up one or more filters that apply to all data items in the export 
definition, click  Edit in the Filters group box to open the Edit Filter dialog box 
(Figure 10-29). 

NOTE: You can also apply filters to a selected data item instead of all data items in 
the export definition. Information is provided later in step 15 on page 483. 
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Figure 10-29.  Edit Filter

9 If you want to include a subset of records in the export file that meet all filter 
conditions, create an AND filter group using the following steps:

a Click  New ‘And’ Group to open the filter properties group box 
(Figure 10-30). 

b Type a name for the filter group in the field Filter Group Caption. 

Figure 10-30.  New ‘And’ Filter Group
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c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

d If you want the filter to remain on for all sessions of the export definition, 
select the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

10 If you want to include a subset of records in the export definition that meet any 
filter condition, create an OR filter group using the following steps:

a Click  New ‘Or’ Group to open a filter properties group box (Figure 10-31, 
page 480).

b Type a name for the filter group in the field Include records that match any 
of these conditions. 

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

Figure 10-31.  New ‘Or’ Filter Group
480 Using Bridge



PCS Axis User and Administrator Guide
d If you want the filter to remain on for all sessions of the export definition, 
select the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

11 Click  OK to close the Edit Filter dialog box and return to the definition window.

NOTE:  Filter settings apply automatically when the export definition is set up to 
run at a scheduled time. When the export definition is run manually, a dialog box 
opens allowing you to choose which filters to apply before running the export 
definition. 

12 Click  Save and then click  Full View to hide the group boxes Data 
Transfer, Options, and Filters. Clicking Full View again displays these group 
boxes. 

13 Choose the data item(s) you want to export from PCS Axis. Click  Add Data 
Item to open the Data Items window and then complete the following steps 
(Figure 10-32, page 482):

a Open the folder(s) containing the data item(s) you want to export. Repeat this 
step as needed for other folders. For example, the folders CPDM and Rectifier 
Inspection are selected in the next figure. 

b Double-click to select a data item and move it to the right pane of the window. 
Repeat this step as needed for other data items. For example, the data item 
Rectifier Inspection is selected for exporting in the next figure. 
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Figure 10-32.  Data Items

NOTE: The right pane of the Data Items window lists all selected data items 
for export. To remove a data item for export, double-click the data item in the 
right pane to move it back to the left pane. 

c Click  OK to close the dialog box and return to the definition window 
(Figure 10-33). Then click  Save. 

Figure 10-33.  Bridge Definition
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14 Select a file format and a location to save the export file using the following steps:

a Click the ellipsis button … in the field Export Directory to open the Browse 
For Folder dialog box. Navigate to a folder on your computer where you want 
to save the export file. Then click OK to close the dialog box and return to the 
definition window. 

b Type a name for the export file in the field Export File Name. Then click the 
down arrow in the field Export Format and select a file format for the export 
file. Options include Excel files (*.xlsx) and Text files (*.txt, *.csv). 

c Click  Save. 

15 If you want to set up one or more filters that apply only to the currently selected 
data item, follow these steps:

a If more than one data item is included in the export file, select a data item in 
the menu on the left side of the window. 

b Click  Edit in the Filters group box to open the Edit Filter dialog box 
(Figure 10-34).

Figure 10-34.  Edit Filter

16 If you want to include a subset of records in the export file that meet all filter 
conditions, create an AND filter group using the following steps:

a Click  New ‘And’ Group to open the filter properties group box 
(Figure 10-35, page 484). 

b Type a name for the filter group in the field Filter Group Caption. 
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Figure 10-35.  New ‘And’ Filter Group

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

17 If you want to include a subset of records in the export file that meet any filter 
condition, create an OR filter group using the following steps:

a Click  New ‘Or’ Group to open a filter properties group box (Figure 10-36, 
page 485).

b Type a name for the filter group in the field Include records that match any 
of these conditions. 

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 
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Figure 10-36.  New ‘Or’ Filter Group

d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

18 Click  OK to close the Edit Filter dialog box and return to the definition window.

NOTE: Filter settings apply automatically when the export file is set up to run at a 
scheduled time. When the export file is run manually, a dialog box opens allowing 
you to choose which filters to apply before running the export file. 

19 Click  Save. 

20 To select the data you want to export from PCS Axis, complete the following steps:

a Click  Edit in the Maps group box to open a field selection dialog box 
(Figure 10-37, page 486). 
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b Click the toggle arrow  for a field category listed in the Internal Fields panel 
to view a list of available fields. In the following example, Rectifier Inspection 
Fields is selected (Figure 10-37). 

c Select one or more fields and then click the top arrow button  to move 
fields to the Mappings panel. Double-clicking a field also moves it to the 
Mappings panel.

d If the definition is set up to use a facility key, click the Facility Key option 
button in the Mappings panel for the field you want to use as the facility key, 
such as ROW Code or Milepost. 

e If the field Choose a conversion... is present in the Mappings panel for one or 
more mapped fields and you want to apply a conversion option, click the field 
Choose a conversion ... and select an option in the selection list. 

21 If you want to rename a field listed in the Transition Field column, select the field 
and then type a description. 

22 If you want to remove a field in the Mappings panel, double-click the field and 
then click Yes when a message displays to verify you want to remove the field. 

Fields with a  lock icon are required and cannot be removed, such as ROW Code, 
Milepost, Facility ID, and Inspection Date. 

Figure 10-37.  Export Field Selections

23 Click  OK to close the field selection dialog box and return to the definition 
window. Then click  Save. 
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24 To manually export data from PCS Axis, click  Export and then complete the 
following steps to choose which filters to apply if the export file is set up with 
filters: 

a Click the tab All Data Items. Click the check box for each filter you want to 
apply to all data items in the export file (Figure 10-38). 

b Click a data item tab. For example, the data item tab labeled Rectifier 
Inspection is selected in the following figure. Click the check box for each filter 
you want to apply to the selected data item. 

Figure 10-38.  Export Filters

c Click OK to close the Export Filters dialog box and run the Bridge export file. 

d When the message Completed displays, click  View Job Status to open 
the Job Status window or  Return to Definition to open the Definitions 
window. 
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25 To view the status of a Bridge session, click  Job Status in the Definitions 
window to open the Job Status window (Figure 10-39). Clicking  Log for a 
Bridge session opens the log file for the selected session. 

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

Figure 10-39.  Job Status

26 To copy the Bridge definition to a file, such as a Notepad or Microsoft Word file, 
follow these steps:

a Click the Definitions tab if the Definitions window is not open.

b Click  Copy to Clipboard.

c Start the software program, such as Notepad or Microsoft Word.

d Open a new file and then Paste the definition file. Click Save. 
488 Using Bridge



PCS Axis User and Administrator Guide
Adding a Bridge Import/Export Definition
A Bridge import/export definition specifies the property settings and options for 
importing and exporting data in PCS Axis. It defines the data transfer options; location of 
the import file; location for the export file; and mappings for data items in PCS Axis and 
the import file. 

NOTE: Bridge currently supports use of a facility key only in a Bridge import file. Future 
enhancements will include use of a facility key in a Bridge export file. 

To add a Bridge import/export definition, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the Bridge definition. Click 

 Save to close the window (Figure 10-40). 

Figure 10-40.  Select ROWs

2 Click Tools > Bridge to open the Bridge window (Figure 10-41, page 490)
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Figure 10-41.  Bridge

3 Click  Basic to open the definition panel (Figure 10-42). 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 

Figure 10-42.  Basic Bridge Definition
490 Using Bridge



PCS Axis User and Administrator Guide
4 Type a unique name for the definition in the Name field (Figure 10-43, page 492). 

NOTE: Clicking the Bridge Definitions bar collapses the panel allowing you to 
view more of the Bridge definition. Clicking the bar again expands the panel. 

5 To set properties in the Data Transfer group box, follow these steps (Figure 10-43, 
page 492):

a Click the Import and Export check boxes. 

b If you want PCS Axis to automatically run the import file at a scheduled time, 
click the Scheduled check box and then type a scheduled time in the adjacent 
field. Enter a scheduled time using 12-hour time format to specify the hour, 
minute, and AM/PM setting (HH:MM AM or PM). 

IMPORTANT: When scheduling a time to run Bridge, choose a time that does 
not impact other network services or computer resources. For example, 
consider a staggered time schedule instead of running Bridge at the same 
time as other scheduled network services. 

c If you are importing large amounts of data, click the check box Reindex after 
import to reindex the PCS Axis database after the import process completes. 

NOTE: Enabling this option prevents index fragmentation from occurring in 
the PCS Axis database, which in turn may result in slow system performance. 
Index fragmentation may occur after importing large amounts of data in PCS 
Axis using Bridge Import, Bullhorn Bridge, or Field Computer. You can also 
reindex the database using the option Reindex Database in Job Service 
Viewer (Tools > Job Service Viewer). 

d Select which records to export. Click the down arrow in the field From 
Selected ROWs, export and select an option in the selection list, such as All 
Records. 
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6 To set properties in the Options group box, follow these steps (Figure 10-43, 
page 492):

a Click the Public check box if you want the import/export definition file 
available for use by all PCS Axis users. When the check box is empty, the 
definition file is available only to the user who creates it. 

b If you want to use a facility key for facilities in the import file, click the check 
box Use Facility Key. This option is not currently available for facilities in the 
export file. For more information about facility keys, see Using a Facility Key 
in Bridge (page 454). 

When facilities are not mapped to a facility key, they are mapped to the 
following required fields: ROW Code, Milepost, and Facility ID. 

c If you plan to run the import/export file manually and want Bridge to rename 
the file, click the check box Rename files on manual bridge runs. 

Figure 10-43.  Bridge Import Export Definition

7 If you want to set up one or more filters that apply to all data items in the 
definition file, click  Edit in the Filters group box to open the Edit Filter dialog 
box (Figure 10-44, page 493).

NOTE: You can also set up one or more filters that only apply to a selected data 
item instead of all data items in the definition file. Information is provided later in 
step 16 on page 498. 
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Figure 10-44.  Edit Filter

8 If you want to include a subset of records in the export file that meet all filter 
conditions, create an AND filter group using the following steps:

a Click  New ‘And’ Group to open the filter properties group box 
(Figure 10-45). 

b Type a name for the filter group in the field Filter Group Caption. 

Figure 10-45.  New ‘And’ Filter Group
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c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

9 If you want to include a subset of records in the export file that meet any filter 
condition, create an OR filter group using the following steps:

a Click  New ‘Or’ Group to open a filter properties group box (Figure 10-
46).

b Type a name for the filter group in the field Include records that match any 
of these conditions. 

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

Figure 10-46.  New ‘Or’ Filter Group
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d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

10 Click  OK to close the Edit Filter dialog box and return to the definition window.

NOTE:  Filter settings apply automatically when the Bridge definition is set to run 
at a scheduled time. When the Bridge definition is run manually, a dialog box 
opens allowing you to choose which filters to apply before running the definition. 

11 Click  Save and then click  Full View to hide the group boxes Data 
Transfer, Options, and Filters. Clicking Full View again displays these group 
boxes. 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 

12 Choose data item(s) you want to import and export. Click  Add Data Item to 
open the Data Items window and then complete the following steps (Figure 10-
47):

a Open the folder(s) containing the data item(s) you want to import and export. 
Repeat this step as needed for other folders. For example, the folders CPDM 
and Rectifier are selected in the next figure. 

b Double-click to select a data item and move it to the right pane of the window. 
Repeat this step as needed for other data items. For example, the data item 
Rectifier Inspection is selected in the next figure. 
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Figure 10-47.  Data Items

NOTE: The right pane of the Data Items window lists all selected data items 
for import. To remove a data item for import, double-click the data item in the 
right pane to move it back to the left pane. 

c Click  OK to close the dialog box and return to the definition window. Then 
click  Save. 

13 Identify the location of the import file using the following steps: 

a Click the ellipsis button … in the field Import File Name to open the Import 
File dialog box. Navigate to the import file and then select it.

b Click Open to close the dialog box and return to the definition panel. The path 
to the import file displays in the field Import File Name. 
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14 Select a file format and a location to save the export file using the following steps 
(Figure 10-48, page 497):

a Click the ellipsis button … in the field Export Directory to open the Browse 
For Folder dialog box. Navigate to a folder on your computer where you want 
to save the export file. Then click OK to close the dialog box and return to the 
definition window. 

b Type a name for the export file in the field Export File Name. Then click the 
down arrow in the field Export Format and select a file format for the export 
file. Options include Excel files (*.xlsx) and Text files (*.txt, *.csv). 

c Click  Save. 

15 If you want to assign inspections in the import file to a survey folder based on the 
inspection date, complete one or both of the following steps in the Options group 
box as required (Figure 10-48, page 497). 

a If you want to assign inspections to an annual survey folder, click the check 
box Assign inspections to an Annual Survey. 

b If you want to assign inspections to a periodic survey folder, click the check 
box Assign inspections to a Periodic Survey. 

Figure 10-48.  Bridge Import Export
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16 If you want to set up one or more filters for the export file that apply only to the 
currently selected data item, follow these steps:

a If more than one data item is included in the export file, select a data item in 
the menu on the left side of the window. 

b Click  Edit in the Filters group box to open the Edit Filter dialog box 
(Figure 10-49).

Figure 10-49.  Edit Filter

17 If you want to include a subset of records in the export file that meet all filter 
conditions, create an AND filter group using the following steps:

a Click  New ‘And’ Group to open the filter properties group box 
(Figure 10-50). 

b Type a name for the filter group in the field Filter Group Caption. 
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Figure 10-50.  New ‘And’ Filter Group

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

18 If you want to include a subset of records in the export file that meet any filter 
condition, create an OR filter group using the following steps:

a Click  New ‘Or’ Group to open a filter properties group box (Figure 10-
51).

b Type a name for the filter group in the field Include records that match any 
of these conditions. 

c Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 
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Figure 10-51.  New ‘Or’ Filter Group

d If you want the filter to remain on for all sessions of the data entry grid, select 
the check box Filter is Always On. When this check box is not selected, 
toggle the filter on and off in the options page using the filter’s check box. 

e Type a name for the filter in the field Enter Custom Filter Caption. 

f If you want to set up additional filter criteria for the filter group:

• Click the  Add button to open another filter properties group box.

• Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps "c" through "e" to set up filter criteria. 

19 Click  OK to close the Edit Filter dialog box and return to the definition window. 

NOTE:  Filter settings apply automatically when the Bridge definition is set to run 
at a scheduled time. When the Bridge definition is run manually, a dialog box 
opens allowing you to choose which filters to apply before running the definition. 

20 Click  Save. 
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21  To map fields in PCS Axis with fields in the import file, follow these steps: 

a Click  Edit in the Maps group box to open a field mapping window 
(Figure 10-52). 

NOTE: Fields in the Mappings panel with a lock icon  are required fields for 
mapping, such as ROW Code, Milepost, Facility ID, and Inspection Date 
shown in the following example (Figure 10-52, page 501). 

b Choose PCS Axis fields for mapping. Click the  toggle arrow for a field 
category in the Internal Fields panel to view a list of available fields. For 
example, Rectifier Inspection Fields is selected in the next figure. 

c Click the check box for one or more PCS Axis fields listed in the Internal Fields 
panel. Then click the  top arrow button to move selections to the Mappings 
panel. Double-clicking a field also moves it to the Mappings panel. 

For example, the PCS Axis fields Rectifier Output Current Found (Amps) and 
Rectifier Output Volts Found (Volts) are selected for mapping in the next 
figure.

Figure 10-52.  Field Mappings

d If you want to sort import fields listed in the Transition Fields panel in 
alphabetical order, click the check box Sort Alphabetically. 
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e To map PCS Axis fields with fields in the import file, follow these steps:

• Select a PCS Axis field in the Mappings panel. Map the selected field to a 
field in the import file by double-clicking a field listed in the Transition 
Fields panel. Repeat this step for remaining fields you want to map. 

NOTE: When the  Auto Map button is enabled and the names of 
fields in the import file match those in PCS Axis, double-clicking a PCS 
Axis field in the Mappings panel automatically maps to an import field 
listed in the Transition Fields panel. 

• If the definition is set up to use a facility key, click the Facility Key option 
button in the Mappings panel for the field you want to use as the facility 
key, such as ROW Code or Milepost. 

• If the field Choose a conversion... is present in the Mappings panel for a 
pair of mapped fields and you want to apply a conversion option, click the 
field Choose a conversion ... and select an option in the selection list. 

f If you want to preview fields for mapping in the import file, click the 
 Preview button to open the import file in the Preview Maps 

window. 

22 Click  OK to close the mapping window and return to the definition window. 
Then click  Save. 

Field mappings display in the Maps group box. 

23 To validate the definition, click the  Prevalidate button. When the validation 
process completes and the following message displays, click  View Job Status 
or  Return to Definition (Figure 10-53).

NOTE: The Prevalidate process confirms the Bridge definition is set up correctly; 
it does not post data in the database. 

Figure 10-53.  Validated Message
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24 If you want to manually import data in PCS Axis, click  Import in the 
Definitions window. When the message Completed displays, click  View 
Job Status to open the Job Status window or  Return to Definition to 
open the Definitions window. 

25 To manually export data from PCS Axis, click  Export in the Definitions window 
and then complete the following steps to choose which filters to apply if the 
Bridge definition is set up with filters: 

a Click the tab All Data Items. Click the check box for each filter you want to 
apply to all data items in the Bridge definition (Figure 10-54). 

b Click a data item tab. For example, the data item tab labeled Rectifier 
Inspection is selected in the following figure. Click the check box for each filter 
you want to apply to the selected data item. 

Figure 10-54.  Export Filters

c Click OK to close the Export Filters dialog box and run the Bridge export file. 

d When the message Completed displays, click  View Job Status to open 
the Job Status window or  Return to Definition to open the Definitions 
window. 
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26 To view the status of a Bridge session, click  Job Status in the Definitions 
window to open the Job Status window (Figure 10-55). Clicking  Log for a 
Bridge session opens the log file for the selected session. 

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

Figure 10-55.  Job Status

27 To copy the Bridge definition to a file, such as a Notepad or Microsoft Word file, 
follow these steps:

a Click the Definitions tab if the Definitions window is not open.

b Click  Copy to Clipboard.

c Start the software program, such as Notepad or Microsoft Word.

d Open a new file and then Paste the definition file. Click Save. 
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Adding a Bullhorn Bridge Definition
A Bullhorn Bridge definition specifies the property settings and options for importing data 
in PCS Axis from a user account on the Bullhorn Asset Tracker (BAT) website. It defines how 
often to run the definition; the unique Key assigned by BAT to the Extract; and field 
mappings for PCS Axis and data imported from BAT. 

After running a Bullhorn Bridge definition, PCS Axis automatically adds the phrase 
Bullhorn Import in the Inspection Remarks field of the facility data entry grid. 

To add a Bullhorn Bridge definition, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the Bullhorn Bridge 
definition. Click  Save to close the window (Figure 10-56). 

Figure 10-56.  Select ROWs
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2 Click Tools > Bridge to open the Bridge window (Figure 10-57).

Figure 10-57.  Bridge

3 Click  Bullhorn to open the Bullhorn definition panel (Figure 10-58). 

Figure 10-58.  Bullhorn Definition Panel
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4 Type a unique name for the definition in the Name field. 

NOTE: Clicking the Bridge Definitions bar collapses the panel allowing you to 
view more of the definition panel. Clicking the bar again expands the panel. 

5 Click the down arrow in the Time Period field and select how often you want to 
run the Bullhorn Bridge definition. 

IMPORTANT: When choosing an option in the Time Period field, choose a time 
that does not impact other network services or computer resources. For example, 
consider a staggered time schedule instead of running Bridge at the same time as 
other scheduled network services.

6 Log in to your account on the BAT website and then copy the unique key 
generated by BAT for the Extract. Paste the unique key in the Bullhorn Token field 
of the Bullhorn Bridge definition. 

7 To assign survey readings to a survey folder based on the inspection date, 
complete one or both of the following steps as required: 

a If you want to assign inspections to an annual survey folder, click the check 
box Assign inspections to an Annual Survey. 

b If you want to assign inspections to a periodic survey folder, click the check 
box Assign inspections to a Periodic Survey. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required property settings. 

8 Click  Save and then click  Full View to hide the Name, Bullhorn Token, 
Time Period, and survey folder fields. Clicking Full View again displays these 
fields (Figure 10-59, page 509).

9 Choose the PCS Axis module that will receive imported data. Click the down arrow 
in the module selection list and select a module, such as CPDM. 
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10 Choose the type of facility data you plan to import. Click a facility type button, such 
as Rectifier (Figure 10-59, page 509). 

11 To map PCS Axis fields with a Bullhorn data point, follow these steps: 

a In the center Mappings panel, click the check box Do Not Map for each 
Bullhorn data point you do not plan to map, such as Battery Voltage. 

A check mark inside the check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. 

NOTE: Clicking any of the following options allows you to filter records in the 
Mappings panel based on the selected option: Un-mapped, Marked as Do 
Not Map, Mapped, and All. For example, clicking Mapped allows you to view 
only mapped data points in the Mappings panel. 

b Select a row in the Mappings panel that includes the Bullhorn data point and 
engineering units you want to map. 

NOTE: To rearrange grid columns in the Facilities, Mappings, or Fields panel, 
drag and drop the name of a grid column to a new position. To resize a grid 
column, place the mouse over a column boundary to change the cursor to a 
horizontal resize cursor . Then click and drag the column boundary to 
resize the grid column. 

c In the left Facilities panel, map a PCS Axis milepost to the Bullhorn data point 
selected in the Mappings panel. Double-click the milepost in the Facilities 
panel to move it to the Milepost field in the Mappings panel. 

NOTE: Double-clicking a mapped field in the Mappings panel allows you to 
unmap the selected field. When a message displays, click  Yes to unmap the 
selected field, or  No to cancel the operation. 

d In the right Fields panel, map a PCS Axis field to the Bullhorn Engineering 
Units field in the Mappings panel. Double-click a PCS Axis field in the Fields 
panel to move it to the Field column in the Mappings panel. 

e Repeat steps "a" through "d" as needed and then click  Save.
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Figure 10-59.  PCS Axis and Bullhorn Mappings

12 When Bullhorn units are added or removed in the unit group set up for the Extract, 
or the Bullhorn client name changes, click the  Sync button to synchronize and 
update the definition file in PCS Axis. 

13 To validate the definition, click the  Prevalidate button. The Prevalidate 
process confirms the Bridge definition is set up correctly; it does not post data 
in the database.

14 When the validation process completes and the following message displays 
(Figure 10-60), click  View Job Status to open the Job Status window or 

 Return to Definition to open the Definitions window. 

Figure 10-60.  Validated Message

15 To manually run the definition, follow these steps:

a Click  Run in the Definitions window. 

b When a date range dialog box opens, specify a date range for the data you 
want to import from BAT. Type a date in the Start Date and End Date fields 
or click the down arrow in these fields to choose a date using a calendar. 
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c Click  Apply to run the Bullhorn Bridge definition and close the date range 
dialog box.

d When the message Completed displays, click  View Job Status to open 
the Job Status window or  Return to Definition to open the Definitions 
window. 

NOTE: PCS Axis adds the phrase Bullhorn Import in the Inspection Remarks 
field of the facility Inspection data entry grid. 

16 To view the status of a Bridge session, click  Job Status in the Definitions 
window to open the Job Status window (Figure 10-61). Clicking  Log for a 
Bridge session opens the log file for the selected session. 

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

Figure 10-61.  Job Status
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17 To copy the Bridge definition to a file, such as a Notepad or Microsoft Word file, 
follow these steps:

a Click the Definitions tab if the Definitions window is not open.

b Click  Copy to Clipboard.

c Start a text editor or word processor program, such as Notepad or Microsoft 
Word.

d Open a new file and then Paste the definition file. Click Save. 
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Importing Pipeline Series
The following procedure explains how to use Bridge to import pipeline series in PCS Axis. 
The import transition file must include fields that you can map to the following required 
PCS Axis fields: 

• ROW Code

• Series Number

• Start Milepost

• End Milepost

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the Bridge definition. Click 

 Save to close the window (Figure 10-56, page 505). 

2 Click Tools > Bridge to open the Bridge window. Then click  Basic to open the 
basic definition panel (Figure 10-62). 

Figure 10-62.  Basic Definition Panel
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3 Type a unique name for the Bridge definition in the Name field (Figure 10-62, 
page 512).

NOTE: Clicking the Bridge Definitions bar collapses the panel allowing you to 
view more of the definition panel. Clicking the bar again expands the panel. 

4 Set properties in the Data Transfer group box in the following manner:

a Click the Import check box. 

b If you want PCS Axis to automatically run the import file at a scheduled time, 
click the Scheduled check box and then type a scheduled time in the adjacent 
field. Enter a scheduled time using 12-hour time format to specify the hour, 
minute, and AM/PM setting (HH:MM AM or PM). 

When the import file is not scheduled to run automatically, you can run it 
manually by clicking the  Import button. 

IMPORTANT: When scheduling a time to run Bridge, choose a time that does 
not impact other network services or computer resources. For example, 
consider a staggered time schedule instead of running Bridge at the same 
time as other scheduled network services. 

5 Set properties in the Options group box as follows (Figure 10-63, page 514):

a Click the Public check box if you want the import definition file available for 
use by all PCS Axis users. When the check box is empty, the definition file is 
available only to the user who creates it. 

b Do not enable the option Use Facility Key. It is not required to import pipeline 
series. See Using a Facility Key in Bridge (page 454) for more information if 
needed

c If you plan to run the Bridge definition manually and want Bridge to rename 
the file after importing data, click the check box Rename files on manual 
bridge runs. 
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Figure 10-63.  Bridge Import Definition

6 Click  Save and then click  Full View to hide the group boxes Data Transfer 
and Options. Clicking Full View again displays these group boxes. 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required property settings. 

7 Click  Add Data Item to open the Data Items window and then complete the 
following steps (Figure 10-64, page 515):

a Open the System Items folder and then double-click Series to move the data 
item to the right pane of the window. 

b Click  OK to close the window and return to the definition panel. Then click 
 Save. 
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Figure 10-64.  Data Items

8 Identify the location of the import transition file using the following steps 
(Figure 10-65, page 516):

a Click the ellipsis button … in the field Import File Name to open the Import 
File dialog box. Navigate to the import file and then select it.

b Click Open to close the dialog box and return to the definition panel. The path 
to the import transition file displays in the field Import File Name. 

9 To assign inspections to a survey folder based on the inspection date, complete 
one or both of the following steps in the Options group box as required 
(Figure 10-8, page 461): 

a If you want to assign inspections to an annual survey folder, click the check 
box Assign inspections to an Annual Survey. 

b If you want to assign inspections to a periodic survey folder, click the check 
box Assign inspections to a Periodic Survey. 
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Figure 10-65.  Definition

10 To map fields in PCS Axis with fields in the import transition file, follow these steps: 

a Click  Edit in the Maps group box to open a field mapping window 
(Figure 10-66, page 517). 

NOTE: Fields in the Mappings panel with a lock icon  are required fields for 
mapping, such as ROW Code, Series, End Milepost, and Start Milepost shown 
in Figure 10-66 (page 517). 

b If you want to sort import fields listed in the Transition Fields panel in 
alphabetical order, click the check box Sort Alphabetically. 

c To map PCS Axis fields with fields in the import transition file, follow these 
steps:

• Select a PCS Axis field in the Mappings panel. 

• Map the selected field to a field in the import file by double-clicking a 
field listed in the Transition Fields panel. Repeat this step for remaining 
fields. 
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Figure 10-66.  Field Mappings

NOTE: When the  Auto Map button is enabled and the names of fields in 
the import transition file match those in PCS Axis, double-clicking a PCS Axis 
field in the Mappings panel automatically maps to an import field listed in the 
Transition Fields panel. 

d If you want to preview fields for mapping in the import transition file, 
click the  Preview button to open the import file in the Preview 
Maps window. 

11 Click  OK to close the mapping window and return to the definition window. 
Then click  Save. 

Field mappings display in the Maps group box. 

12 To validate the definition, click the  Prevalidate button. When the 
validation process completes and the following message displays (Figure 10-
67), click  View Job Status to open the Job Status window or  Return 
to Definition to open the Definitions window. 

NOTE: The Prevalidate process confirms the definition file is set up correctly; it 
does not post data in the database. 

Figure 10-67.  Validated Message
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13 To manually import the Pipeline Series in PCS Axis, complete one of the 
following steps: 

a If the Job Status window is open, click  Run for a selected import file listed 
in the Job Status window (Figure 10-68). Then click  Refresh to update 
status information. 

b If the Definitions window is open for the import file, click  Import. 

14 To view the status of a Bridge session, click  Job Status in the Definitions 
window to open the Job Status window. Clicking  Log for a Bridge session 
opens the log file for the selected session. 

Figure 10-68.  Job Status

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

15 To view the imported Pipeline Series, click Data Entry > Pipeline Series. 

When the import transition file includes facility survey readings that have also 
been mapped in the Bridge definition, PCS Axis imports this data in the facility 
Inspections grid (Data Entry > Edit <module> Data). 
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Viewing Bridge Job Status and Log
To view the job status and log for a Bridge definition, follow these steps:

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window. 

2 Click Tools > Bridge to open the Bridge window (Figure 10-69). 

Figure 10-69.  Select Definition

3 Click the Job Status tab to open the job status window (Figure 10-70, page 520). 

4 Select a definition to display status information in the bottom panel of the job 
status window. 
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Figure 10-70.   Job Status

NOTE: For a description of the icons and colors used in Job Status, see Icons and 
Colors Used in Bridge Job Status (page 522). 

5 If you want to delete prevalidated data that has not posted in the database yet, 
click  Delete to remove the job from the Job Status window (Figure 10-70). 

6 Click  Log for a selected definition to open a window with detailed information 
(Figure 10-71). 
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Figure 10-71.  Log
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Icons and Colors Used in Bridge Job Status
The Data Items grid in Job Status includes icons and colors for records imported in PCS 
Axis to indicate a particular status (Figure 10-72). For a description of these icons and 
colors, see Table 10-1 below. 

Figure 10-72.  Data Items Grid in Job Status

Table 10-1.  Icons and Colors in Job Status Data Items Grid

Icons and Colors Description

Matched Key: Bridge found an existing entry for this data.

Duplicate Key: Occurs for any redundancies found in the 
import file. Such as when a new ROW will be created and all 
other ROW entries in the import file after the first are 
redundant. 

Unmatched Key: No existing entry was found for this data. 

Green indicates a new record.

Red indicates a rejected record.

Yellow indicates an out-of-range record.

Gray indicates data that cannot be imported because it failed 
type conversion. The imported data does not match the PCS 
Axis field type, such as a non-date value for a date/time field or 
an alpha character for a numeric field such as Structure P/S.

�

�

�

�
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11

Using Job Service Viewer

When you need to know which job is currently running, which jobs are in the queue 
waiting to run, or a history of jobs that have run, use Job Service Viewer to view details for 
each of these scenarios. 

Topics in this chapter include those in the following list:

• About Job Service Viewer (page 526)

• Viewing Current and Past Jobs (page 531)

• Restarting the PCS Axis Job Service (page 532)

NOTE: For information about activating a Bridge license using Job Service Viewer, see 
Activating Bridge Import for Operation (page 15). For information about Reindex 
Database, see Managing the Database (page 747).
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About Job Service Viewer
Information in this section explains how to view job status information for the following 
types of PCS Axis jobs. 

NOTE: For information about activating the optional Bridge add-on, refer to Activating 
Bridge Import for Operation (page 15). See Managing the Database (page 747) for 
information about Reindex Database. 

Job Service Viewer provides status information for the type of jobs in the following list. 
Status information identifies which job is currently running; which jobs are waiting in the 
queue to run; and a history of completed jobs (Figure 11-1). 

• Bridge Import, Bridge Export, and Bridge Import/Export 

• Email Notification 

• Field Computer Receive 

Figure 11-1.  Current Jobs
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The Current Jobs grid displays by default when you first open Job Service Viewer. You 
can also display the grid by clicking the Current Jobs button (Figure 11-1, page 526). Use 
the Job Type field near the top of the window to filter data in the window. For example, if 
you only want to view Bridge job types, click the down arrow in the Job Type field and 
select Bridge in the selection list. 

Information in the following table identifies the type of information that displays in the 
Current Jobs grid (Table 11-1). 

Table 11-1.  Current Jobs Grid Field Descriptions

Field Description

Job Type Job types include:

• Bridge: Displays for all Bridge and Field 
Computer Receive jobs. 

• EmailReports: Displays for Email Notification 
jobs. 

• ResendEmailReport: Displays when you resend 
an Email Notification. 

• Reindex Database: Displays for a Reindex 
Database job type. For important information 
about using this function, see Managing the 
Database (page 747). 

Direction Import displays for a Bridge import job. Export 
displays for a Bridge export job. 

State Identifies the status of a job as:

• Running: Job currently in progress. 

• Waiting: Job waiting in the queue to run. 

• Validated: Indicates data has been validated for 
a manually run Bridge Import job. When the 
job begins processing, the status changes from 
Validated to Running. 
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Last Update Job status date and time stamp. 

Suspended When a job is in a Waiting or Validated state, 
clicking the gold Suspended  button suspends 
processing of the job. Other jobs in the queue 
continue to process. 

Clicking the green Suspended  button displays 

the Resume Job message. Click  Yes to resume 
processing of the job or  No to continue 
suspending the job and close the message. 

NOTE: A job with a Running, Completed, or 
Failed state cannot be suspended. 

Delete If you want to delete a job that is in a Suspended 
state, click  Delete. Jobs in any other state 
cannot be deleted, such as Running, Waiting, 
Validated, Failed, or Completed. 

Table 11-1.  Current Jobs Grid Field Descriptions

Field Description
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Clicking the Job History button displays the Job History grid. This grid provides status 
information for past jobs (completed and failed jobs). Use the Job Type and Date range 
fields near the top of the window to filter data in the window (Figure 11-2). 

For example, if you only want to view Bridge job types for a particular date range: 

1 Click the down arrow in the Job Type field and select Bridge in the selection list.

2 Click the down arrow in the Date range field and select an item in the selection 
list, such as All, Today, or Last 72 hours. 

For a description of the various fields in the Job History grid, see Table 11-2 (page 530). 

Figure 11-2.  Job History
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Table 11-2.  Job History Grid Field Descriptions 

Field Description

Job Type Job types include:

• Bridge: Displays for all Bridge and Field 
Computer Receive jobs. 

• EmailReports: Displays for Email Notification 
jobs. 

• ResendEmailReport: Displays when you 
resend an Email Notification. 

• Reindex Database: Displays for a Reindex 
Database job type. For important information 
about using this function, see Managing the 
Database (page 747). 

Direction Import displays for a Bridge import job. Export 
displays for a Bridge export job. 

State Identifies the status of a job as:

• Completed: Jobs that have run successfully are 
labeled Completed. 

• Failed: Jobs that have not run successfully are 
labeled Failed. 

Enqueue Time Date and time stamp showing when a job was 
placed in the queue to run. 

Start Time Date and time stamp showing when a job began 
running. 

End Time Date and time stamp showing when a job finished 
running. 

Duration Time stamp showing the total amount of time a job 
was processed. 
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Viewing Current and Past Jobs
To view current and past jobs, follow these steps: 

1 Click Tools > Job Service Viewer to open the Job Service Console (Figure 11-1, 
page 526).

2 To view jobs that are currently running and in the queue, click Current Jobs. 

3 To view a list of all past jobs that have previously run, click Job History. If you 
want to view additional information about a job listed in the Job History grid, 
click the  log icon for that job. 

4 If you want to filter the data view in the console to only view a particular job type, 
click the down arrow in the Job Type field and select an option in the list, such as 
Email Reports or Field Computer. 

5 To close the Job Service Console, click the  close button. 

Log Log with job summary information.

Detail Log Log with job summary and status information. You 
can also re-send an Email Notification report to 
one or more email recipients by clicking the 
ReSend check box. 

Delete If you want to delete an entry in the Job History 
grid, select an entry and then click  Delete. The 
grid also supports multiple selections by pressing 
either the Shift or Ctrl key on the computer 
keyboard while selecting multiple entries. 

Table 11-2.  Job History Grid Field Descriptions (continued)

Field Description
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Restarting the PCS Axis Job Service
If the message Not Running displays in the Status field of the Job Service Console as 
shown in the following figure (Figure 11-3), use the procedure in this section to restart the 
PCS Axis Job Service. PCS Axis Job Service monitors the job queue, initiating jobs as they 
become available. 

Figure 11-3.  Job Service Status

Complete the following steps to verify connection settings are correct and restart the PCS 
Axis Job Service:

1 Start PCS Axis Connection Manager and verify connection settings specify the 
correct server and database as follows: 

a Click the Windows Start button  and navigate to the program folder 
labeled PCS Axis 1.8. Select PCS Axis Connection Manager 1.8 to start the 
program (Figure 11-4, page 533). 

b Verify the server name is correct in the Server field and the database name is 
correct in the Database field. If either is incorrect, click  Select in the 
Server field to select the correct server or click  Select in the Database 
field to select the correct database. 

c Verify the Connection String field includes the correct server and database 
name. 

“Not Running” 
Job Service Status
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d Click  Save and then click  Test to verify connection settings. When 
connection settings are correct, the message Connection successful displays. 
Click  OK to close the message and then click  Close to exit PCS Axis 
Connection Manager. 

IMPORTANT: If connection settings are incorrect, contact your company’s 
Database Administrator or IT Administrator for the name of the correct server 
and database. The information will then need to be set in PCS Axis 
Connection Manager using the steps in this procedure. 

Figure 11-4.  PCS Axis Connection Manager

2 If the PCS Axis database and PCS Axis Job Service are installed on two different 
network servers, complete the following steps to set up a user account to log on as 
a service. The user account must be a member of the Axis_Users group and have 
access to the central database server and PCS Axis database. 

a Click the Windows Start button  and navigate to Computer. Right-click 
Computer and select Manage in the shortcut menu to open the Computer 
Management console (Figure 11-5, page 534). 

b Double-click Services and Applications in the left pane of the console. Then 
click Services to display a list of services in the middle pane. 
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Figure 11-5.  Computer Management Console

c Right-click PCS Axis Job Service 1.8 (Figure 11-7) and select Properties in 
the shortcut menu to open the Properties dialog box (Figure 11-6). 

d Click the Log On tab and select the option This account. To set up a user 
account to log on as a service, type the user name and password in the 
appropriate fields. You can also view a list of appropriate user accounts by 
clicking Browse > Advanced > Find Now. 

e Click Apply and then OK to close the Properties dialog box and return to the 
Computer Management console. 

Figure 11-6.  PCS Axis Job Service Properties
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3 Complete the following steps in the Computer Management console to restart 
the PCS Axis Job Service: 

a Select PCS Axis Job Service 1.8 and then click Start (Figure 11-7). 

b Click File > Exit to close the Computer Management console. 

c In PCS Axis, verify the message Running displays in the Status field of the Job 
Service Console (Figure 11-3, page 532). 

IMPORTANT: If the PCS Axis Job Service does not start, contact PCS Technical 
Services using the contact information in section titled Technical Support 
(page 25). 

Figure 11-7.  Computer Management Console
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Using Email Notification

Email Notification is a feature that allows you to send reports at a regularly scheduled 
time as an attachment in an email to recipients. Reports are in Adobe® PDF format and 
can be sent to one or more PCS Axis users as well as to non-PCS Axis users. You can set up 
email notifications with email reports that only include data for pipeline segments 
assigned to a recipient as well as pipeline segments assigned to an email report.

IMPORTANT: Because some email servers are set up to process emails no larger than 10 
MB (megabytes) in size, it may be necessary to contact your IT department for this 
information to ensure email recipients receive email notifications.

Topics in this chapter include those in the following list and are intended for users with 
SysAdmin permissions: 

• Adding Email Recipients (page 538)

• Adding an Email Report (page 544)

• Assigning Reports by Recipient or Email Report (page 550)

• Viewing the Log (page 552)

• Re-sending Reports (page 553)

• Stopping Delivery of Email Notifications (page 554)

NOTE: Using Email Notification requires property settings in Options (Tools > Options). 
For more information refer to Setting Email Notification Options (page 41). 
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Adding Email Recipients
Information in this section explains how to add email recipients of reports. Email recipients 
are both users and non-users of PCS Axis and can be set up with more than one email 
address. Topics in this section include:

• Adding a PCS Axis User 

• Adding an External User (page 542)

NOTE: Do not assign all pipeline segments in the hierarchy to recipients of email reports. 
Doing so may cause server problems when sending email notifications.  
 
Likewise, use a limited hierarchy selection for users with SysAdmin privileges. Email 
reports are generated based on the hierarchy view in Email Notifications for SysAdmin 
users, which is ALL pipeline segments in PCS Axis. 

Adding a PCS Axis User
The following procedure explains how to add a PCS Axis user in Email Notification. The 
process includes assigning one or more pipeline segments to the PCS Axis user. This allows 
PCS Axis to send email reports that include data only for those pipeline segments 
assigned to the PCS Axis user. 

Complete the following steps: 

1 Click Tools > Email Notification to open the Email Notification window. 

2 Click  Add Pcs Axis User to display a list of PCS Axis users. All PCS Axis users 
added in User Management (Tools > User Management) display in the center 
panel of the Email Notification window.

3 Select a user name in the center panel (Figure 12-1, page 539). 
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Figure 12-1.  Recipients / Add PCS Axis User

4 If PCS Axis is set up with Hierarchical Security in system Options (Tools > 
Options), click the down arrow in the Hierarchy field and select one of the 
following options. Your selection determines which pipeline segments are assigned 
to the user.

• Select By Hierarchy Security if you want to use the same pipeline segments 
assigned to the user in Hierarchy Rights of User Management (Tools > User 
Management). 

• Select By Recipient Selection if you want to assign one or more pipeline 
segments to the PCS Axis user in the Hierarchy panel of the Recipients tab. 

NOTE: For information about Hierarchical Security, refer to Setting Security 
Options (page 50) and Setting Up User Management (page 175). 
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5 If By Recipient Selection is selected in the Hierarchy field, click the  toggle 
arrow in the Hierarchy panel to view a list of pipeline segments in the hierarchy. 
Click the check box for each pipeline segment you want to assign to the user. 

A check mark inside the check box indicates a selection. To clear a selection, click 
the check box to remove the check mark. 

NOTE: Clicking the  toggle button in the  information bar displays 
information related to required property settings. 

6 If you want to add an additional email address for the PCS Axis user, complete the 
following steps:

a Click  Add Email to open the Add Email Address dialog box (Figure 12-2). 

b Type an email address in the Email Address field and then click  OK. 
Repeat this step as needed to add another email address. 

Figure 12-2.  Add Email Address

7 Click  Save to save changes. 

The Email Address panel displays all email addresses set up for a user selected in 
the center panel (Figure 12-3). 
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Figure 12-3.  Recipients / Email Address
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Adding an External User
An external user is a person who is not set up with login credentials for PCS Axis in User 
Management (Tools > User Management). The following procedure explains how to add 
an external user as a recipient of one or more email reports.

Complete the following steps:

1 Click Tools > Email Notification to open the Email Notification window. 

2 Click  Add External User. Type the user’s First Name, Middle Initial 
(optional), and Last Name in the respective fields located in the center panel of 
the window (Figure 12-4). 

NOTE: Clicking the  toggle button in the  information bar displays 
information related to required property settings. 

Figure 12-4.  Recipients / Add External User
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3 Click  Add Email to open the Add Email Address dialog box. Type the user’s 
email address in the Email Address field and then click  OK. Repeat this step as 
needed to add another email address (Figure 12-5). 

Figure 12-5.  Add Email Address

4 Click the toggle arrow  in the Hierarchy panel to view a list of pipeline segments 
in the hierarchy. Click the check box for each pipeline segment you want to assign 
to the user (Figure 12-6). 

Assigning pipeline segments to the external user allows PCS Axis to send email 
reports with data only for those pipeline segments assigned to the external user. 

A check mark inside the check box indicates a selection. To clear a selection, click 
the check box to remove the check mark. 

5 Click  Save to save changes. 

The Email Address panel displays all email addresses set up for a user selected in 
the center panel (Figure 12-6). 

Figure 12-6.  Recipients / External User
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Adding an Email Report
An email report is a named set of property settings that define the content and 
transmission schedule of emails sent to recipients. It is the definition file that identifies the 
PCS Axis report, pipeline segment selection(s), and transmission schedule. Email reports 
are set up independently of email recipients. This allows you to assign the same email 
report to more than one recipient.

An email report can include any columnar report available in the Reports/Graph menu. 
Custom columnar reports must also be set up with the public property setting. Graph 
reports are not currently supported in Email Notification. 

NOTE: For information about custom columnar reports and the public property setting, 
see Adding a Custom Report (page 700). 

To add an email report, follow these steps:

1 Click Tools > Email Notification to open the Email Notification window.

2 Click Email Reports , then click  Add (Figure 12-7). 

Figure 12-7.  Email Reports
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3 Type a name for the email report in the Name field. Fields requiring information 
include a  red icon, such as Name shown in the previous example (Figure 12-7, 
page 544). 

The filename of the PDF report sent as an attachment in an email to recipients 
includes the Name of the email report and transmission date. This same 
information is used as the Subject of the email, such as 
My_Email_Report_03_10_2013.pdf. 

NOTE: Clicking the  toggle button in the  information bar displays 
information related to required property settings. 

4 Complete one of the following steps to set the check box Send No Data Found:

a To always have an email sent to recipients, including when no report data is 
found, click the check box Send No Data Found to place a check mark inside 
the check box. When no report data is found, the recipient receives a report 
with the message No Data Found. 

b To only send a report to an email recipient when report data is found, clear the 
check mark by clicking the check box Send No Data Found. 

5 Choose which data to include in the report. Click the down arrow in the Mode field 
and select one of the following options:

• Full: Report includes current and historical data. 

• Incremental: Report only includes new data that has occurred since the last 
time the report was sent to email recipients. 

6 Click the down arrow in the Hierarchy field and select one of the following 
options that determine which pipeline segments to include in the report:

• By Assigned Recipient: Report includes data only for those pipeline 
segments assigned to a recipient in the Recipients tab of Email Notification. 

• By Email Report Selection: Report includes data only for those pipeline 
segments assigned to the email report in the Hierarchy panel of the Email 
Reports tab in Email Notification. 
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7 If you selected By Email Report Selection in step 6, complete the following steps 
to select which pipeline segments to include in the email report:

a Click the toggle arrow  in the Hierarchy panel to view a list of pipeline 
segments in the hierarchy (Figure 12-8). 

b Click the check box for each pipeline segment you want to include in the 
report. A check mark inside the check box indicates a selection. To clear a 
selection, click the check box to remove the check mark. In the following 
figure, pipeline segments LG123-D and LG123-E have been selected in the 
Hierarchy panel. 

Figure 12-8.  Email Reports

8 Complete the following steps to set up a transmission schedule for sending email 
reports to recipients. 

IMPORTANT: When setting up a transmission schedule, consider a time and 
frequency interval that does not impact other network services or computer 
resources. 

a Choose a date to begin sending the report. Click the down arrow in the Seed 
Date field to select a start date using a calendar. 
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b If you want to override the default time set up in Options for sending reports, 
enter a time in the Time field. Use 12-hour time format to indicate the hour, 
minute, and AM/PM setting (HH:MM AM/PM). 

NOTE: For more information about Options, see Setting Email Notification 
Options (page 41). 

c Choose how often to send reports to email recipients. Select one of the 
following options to set a Frequency schedule: 

• Daily: Sends first report on the Seed Date and recurring reports at 
regular intervals based on the Recurs every setting. 

• Weekly: Sends first report on the Seed Date and recurring reports at 
regular intervals based on settings for Recurs every and a day of the week 
selection.

• Monthly: Sends first report on the Seed Date and recurring reports at 
regular intervals based on day and month settings.

• Quarterly: Sends first report on the Seed Date and recurring reports at 
regular intervals based on the first day of each quarter. 

9 To select a PCS Axis report to send to email recipients, follow these steps:

a Click  Add Associated Report to open the Add Associated Report 
window (Figure 12-9, page 548). 

b Double-click a  folder to view a list of reports available for selection. Clicking 
the  toggle arrow for a report category also displays available reports. 

For example, double-clicking  ROW Reports >  ROW Maintenance 
Report displays a list of reports available for selection (Figure 12-9, page 548). 
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c Select a report in the list to move it to the Selected Report panel and then 
click  OK (Figure 12-9). 

Figure 12-9.  Add Associated Report

10 Click  Full View to only display fields for setting report options. Clicking Full 
View again displays all fields (Figure 12-10). 

NOTE: Clicking the Hierarchy bar hides the Hierarchy panel. Clicking the bar 
again opens the panel. 

Figure 12-10.  Email Reports
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11 Set report options as required, such as a layout and sorting theme. For more 
information about report options, see Working with a Report Based on the 
Columnar Report Style (page 690). 

12 Click  Save. 

Email reports currently set up in the system display in the Email Reports window 
as shown in the following example (Figure 12-11, page 549). 

Figure 12-11.  Email Reports
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Assigning Reports by Recipient or Email Report
Assigning email reports By Recipient allows PCS Axis to only include data for pipeline 
segments assigned to the recipient in the Recipients tab of Email Notification. When 
assigning email reports By Email Report, the report only includes data for pipeline 
segments assigned to the email report in the Email Reports tab of Email Notification.

To assign an email report either By Recipient or By Email Report, follow these steps: 

1 If the Email Notification window is not open, click Tools > Email Notification. 

2 Click  Assignments and then click  Add/Remove 
Assignments. 

3 To include data in an email report only for those pipeline segments assigned to a 
selected recipient, complete the following steps:

a Click  By Recipient if it is not selected (Figure 12-12). 

b Select an email recipient in the grid and then double-click a report in the 
Available Email Reports panel to move the report to the Assignments panel. 
Repeat this step as needed for another email recipient listed in the grid. 

Clicking the  top arrow button also moves a selected report to the 
Assignments panel. 

c Click  Save. 

Figure 12-12.  Assignments By Recipient
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4 To include data in an email report only for those pipeline segments assigned to the 
email report, complete the following steps: 

a Click  By Email Report (Figure 12-13). 

b Select an email report in the grid and then double-click a recipient user name 
in the Available Recipients panel to move the user name to the Assignments 
panel. Repeat this step as needed for another email report listed in the grid.

Clicking the  top arrow button also moves a selected user name to the 
Assignments panel. 

c Click  Save. 

Figure 12-13.  Assignments by Email Report
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Viewing the Log
The Email Notification log is an activity log that identifies PCS Axis reports sent to email 
recipients. It includes a transmission date; whether or not email reports transmitted 
successfully; and set up information such as Frequency and Mode settings in the Email 
Reports tab of Email Notification. 

If your computer is installed with Adobe® Reader, you can also view a copy of a report sent 
to an email recipient by clicking the Preview button in the Details For group box 
(Figure 12-14). Clicking ReSend for a selected email recipient in the Recipients For group 
box allows PCS Axis to re-send reports assigned to the user. 

NOTE: PCS Axis retains log information and associated email reports in PDF format for the 
length of time specified in system Options. See Setting Email Notification Options 
(page 41) for more information. 

To open the Email Notification log, follow these steps:

1 If the Email Notification window is not open, click Tools > Email Notification. 

2 Click  Log to open the Email Notification log (Figure 12-14, 
page 553). 

3 Click the down arrow in the Date range field and select an option, such as Last 24 
hours. 

4 To sort information alphanumerically in ascending or descending order, click a 
column heading in the reports grid or in the Recipients For group box. 

NOTE: When navigating the reports grid, pressing Home on the computer 
keyboard moves the cursor to the top of the grid. Clicking Full View opens and 
closes the panels Recipients For and Details For allowing you to view only the 
reports grid. 

5 To view a copy of a report sent to an email recipient:

a Select a report in the list and then select an email recipient in the Recipients 
For group box. Information related to your selections display in the Details 
For group box. 

b Click  Preview to open a copy of the selected report in Adobe 
Reader. 
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Figure 12-14.  Email Notification Log

Re-sending Reports
The following procedure explains how to re-send a report to an email recipient. 

NOTE: You can also re-send a report to an email recipient using the Job History Detail 
Log in Job Service Viewer. For more information refer to Table 11-2 in About Job Service 
Viewer (page 526).  

Complete the following steps: 

1 If the Email Notification window is not open, click Tools > Email Notification. 

2 Click  Log to open the Email Notification log (Figure 12-14, 
page 553). 

3 Select a report in the list and then select an email recipient in the Recipients For 
panel. Click the ReSend check box for the selected recipient to place a check mark 
inside the check box. Then click  Resend. 

4 Click  Refresh to update information displaying in the window. 
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The report is sent as a PDF attachment in an email to the recipient. The following 
figure shows an example of a typical email notification in Microsoft® Outlook® 
(Figure 12-15, page 554). 

Figure 12-15.  Example of Email Notification

Stopping Delivery of Email Notifications
Complete step 1 to stop sending scheduled email notifications to all recipients, or step 2 
for one or more recipients: 

1 To stop sending scheduled email notifications to all recipients, follow these steps:

a Click Tools > Options to open the Options window. 

b Click the Email Notifications tab to view property settings for Email 
Notification (Figure 12-16, page 555). 

c Click the check box labeled Disable Email Service to place a check mark 
inside the check box. A check mark inside the check box indicates the service is 
disabled; scheduled email reports are no longer sent to recipients. 

When you want to restart the service and begin sending scheduled email 
reports to recipients again, click the Disable Email Service check box to 
remove the check mark. 
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Figure 12-16.  Options / Email Notification

2 To stop sending scheduled email notifications to one or more recipients, follow 
these steps:

a Click Tools > Email Notification > Assignments tab. Then click 
 Add/Remove Assignments to open the Email Notification 

Assignments window (Figure 12-17). 

b Select how you want to view report assignments. Click   
By Recipient to view report assignments by recipient or   
By Email Report to view assignments by report. 

c If you are viewing report assignments By Recipient, complete the following 
steps:

1) Select a recipient name in the grid.

2) Double-click a report in the Assignments pane to move it to the Available 
Email Reports pane. Then click  Save. The recipient receives email 
notifications only for those reports listed in the Assignments pane 
(Figure 12-17). 
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Figure 12-17.  Email Notification Assignments By Recipient

d If you are viewing report assignments By Email Report, complete the 
following steps:

1) Select the name of an email report in the grid. 

2) Double-click a recipient name in the Assignments pane to move it to the 
Available Recipients pane. Then click  Save. The email report is sent 
only to those recipients listed in the Assignments pane (Figure 12-18). 

Figure 12-18.  Email Notification Assignments By Email Report
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Using Field Computer

Information in this chapter explains how to use PCS Axis with the Allegro Field Computer 
to send and receive survey files. The information is intended for users with SysAdmin, 
User, and Read Only permissions unless noted otherwise. Topics in this chapter include 
those in the following list: 

• Quick Start

• Working with Themes and Filter Groups (page 584) 

• Viewing the Field Computer Log (page 608)

Quick Start
The procedures listed below explain how to use PCS Axis with the Allegro to send and 
receive survey files. The process for sending a survey file to the Allegro requires selection 
of a prompt, layout, and sorting method theme. If themes have not previously been set up 
in PCS Axis, begin with the section Working with Themes and Filter Groups (page 584) 
and then continue with any of the following procedures for sending a survey file to the 
Allegro. 

Topics in this section include those in the following list:

• Sending a Facility Survey Based on Selected ROWs (page 560)

• Sending a Facility Survey Based on a Route (page 564)

• Sending a Facility Survey Based on a Schedule (page 569)

• Sending a Facility Survey Based on an Import Exported List (page 576)

• Receiving a Facility Survey from the Allegro (page 578)

• Receiving a Continuous Survey from the Allegro (page 580)
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Sending a Facility Survey Based on Selected ROWs 
The following procedure explains how to send a facility survey based on selected ROWs to 
the Allegro or a folder on your computer. The survey file includes facilities for inspection 
based on selected pipeline segments in the Select ROWs window. 

Use the following procedure when you plan to take inspection readings using the Periodic 
Survey software on the Allegro or you plan to use the survey file with a third party 
application such as RouteSmart®. 

Complete the following steps:

1 Verify the Allegro is connected to your computer if you plan to send the survey file 
to the Allegro. If needed, refer to the Allegro User Guide for information about 
how to connect the device. 

2 Click the Select ROWs button  to open the Select ROWs window (Figure 13-1). 
Click the check box for each pipeline segment with facilities you want to include in 
the survey file. Click  Save to close the window. 

Figure 13-1.  Select ROWs

3 Click Field Computer > Send to open the Field Computer Send window 
(Figure 13-2, page 561). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 
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4 Click the Selected ROWs option and then choose one or more facility types using 
one of the following options described in step a, b, or c: 

a Click the down arrow and select a facility type theme in the selection list, such 
as  [PCS] Test Point Survey. 

b Click Ad Hoc Theme and then click the check box for each facility type you 
want to view in the grid. 

NOTE: An Ad Hoc Theme only applies to the current session and is not saved. 
A facility type is selected when a check mark appears inside the check box. To 
clear the check mark, click the check box again. 

c Click the Select All button  to select all facility types. 

5 Click  Apply to update the grid. 

6 Select a prompt, layout, and sorting theme as follows (Figure 13-2): 

a Click the down arrow in Select Prompt and select a prompt theme in the 
selection list.

b Click the down arrow in Select Layout Theme and select a layout theme in 
the selection list.

c Click the down arrow in Select Sort Theme and select a sorting theme in the 
selection list. 

Figure 13-2.  Select ROWs and Facility Type(s)
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7 If you want to work with a subset of facility records that meet all filter conditions, 
create an AND filter group using the following steps (Figure 13-3): 

a Click the  Filters button to open the Filters panel.

b Click  Add to open the filter properties group box.

c Set up filter criteria. Select a PCS Axis field, operator, and filter condition(s) 
using filter selection fields.

d If you want to set up an additional filter, click  Add to add another row of 
filter selection fields. Select a PCS Axis field, operator, and filter condition(s) 
to set up filter criteria. Repeat this step as needed. When you finish, click the 

 Filters button to close the Filters panel.

8 If you want to rename the survey file, type a name in the field Output File. 

9 Choose a Send to option using one of the following methods:

a Select Send to Allegro if you plan to send the survey file to the Allegro. 

b Select Send to disk if you plan to send the survey file to a folder on your 
computer. Identify the folder location as follows:

• Click the ellipsis button … in the Output Directory field to open the 
Browse For Folder dialog box. 

• Navigate to the folder and select it. Click OK to close the dialog box and 
return to the Field Computer Send window. 

Figure 13-3.  New ‘And’ Filter
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10 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file 
(Figure 13-3, page 562).

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled and 
unavailable for selection when maintenance prompts are not included in the 
currently selected prompt theme. 

11 Click  Apply to update the grid. 

12 Click  Send. Based on your selection earlier, the survey file is sent either to the 
Allegro or a folder on your computer. 

13 When a message displays confirming the send process is complete, click  OK to 
close the message (Figure 13-4). 

If you selected to send the survey file to the Allegro, PCS Axis sends the survey file 
to the PSData folder on the Allegro. 

Figure 13-4.  Send Process Complete
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Sending a Facility Survey Based on a Route
The procedure in this section explains how to send a facility survey based on a route to the 
Allegro or a folder on your computer. The information assumes a route has previously 
been set up in Define Routes (Data Entry > Define Routes, see page 349). 

Use the following procedure when you plan to take inspection readings using the Periodic 
Survey software on the Allegro or you plan to use the survey file with a third party 
software such as RouteSmart®. 

Complete the following steps:

1 Verify the Allegro is connected to your computer if you plan to send the survey file 
to the Allegro. If needed, refer to the Allegro User Guide for information about 
how to connect the device. 

2 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

3 Click Field Computer > Send to open the Field Computer Send window.

4 Click the Route option and then select a route in the selection box. The 
following figure shows My Route_2 has been selected (Figure 13-5). 

5 Click  Apply to update the grid. 

Figure 13-5.  Field Computer Send
564 Using Field Computer



PCS Axis User and Administrator Guide
6 Select a prompt, layout, and sorting theme as follows (Figure 13-5, page 564): 

a Click the down arrow in Select Prompt and select a prompt theme in the 
selection list.

b Click the down arrow in Select Layout Theme and select a layout theme in 
the selection list.

c Click the down arrow in Select Sort Theme and select a sorting theme in the 
selection list. 

7 If you want to rename the survey file, type a name in the field Output File. 

8 Choose a Send to option using one of the following methods:

a Select Send to Allegro if you plan to send the survey file to the Allegro. 

b Select Send to disk if you plan to send the survey file to a folder on your 
computer. Identify the folder location as follows:

• Click the ellipsis button … in the Output Directory field to open the 
Browse For Folder dialog box. 

• Navigate to the folder and select it. Click OK to close the dialog box and 
return to the Field Computer Send window. 

9 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file. 

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled and 
unavailable for selection when maintenance prompts are not included in the 
currently selected prompt theme. 

10 Click  Apply to update the grid. 
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11 If you want to filter records in the grid and in the route sent to the Allegro, 
complete the following steps.

IMPORTANT: Filter settings in Field Computer Send apply only to the current 
session and are not saved. See Working with Themes and Filter Groups 
(page 584) for information about saving filter settings. 

a Click the  Filters tab to open the Filters panel (Figure 13-5, page 564). 

b Select one or more options in Filters and then click  Apply. For example, 
click Active Facilities Only to only include active facilities in the grid and in 
the route sent to the Allegro (Figure 13-6). 

c If you want to add a new AND or OR filter group, continue with one of the 
following steps. Otherwise continue with step 14 (page 569). 

• To add a new AND filter group continue with step 12 (page 567). 

• To add a new OR filter group continue with step 13 (page 568). 

Figure 13-6.  Filters
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12 If you want to add a new AND filter group, complete the following steps. With an 
AND filter group, PCS Axis includes a subset of records that meet all filter 
conditions defined for the filter group. Records are filtered in the grid and in the 
route sent to the Allegro (Figure 13-7). 

a Click  New ‘And’ Group to open the filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings. 

Figure 13-7.  New ‘And’ Filter Group
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13 If you want to add a new OR filter group, complete the following steps. With an OR 
filter group, PCS Axis includes a subset of records that meet any filter condition 
defined for the filter group. Records are filtered in the grid and in the route sent to 
the Allegro (Figure 13-8): 

a Click  New ‘Or” Group to open a filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 

NOTE: Clicking the  toggle button in the  information bar displays 
important information related to required settings. 

Figure 13-8.  New ‘Or Filter Group
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14 Click the  Filters tab to close the Filters panel. Then click  Apply to update 
the grid. 

15 Click  Send. Based on your selection earlier, the survey file is sent either to the 
Allegro or a folder on your computer. 

16 Click  OK when the message Send Process Complete displays (Figure 13-9). If 
you selected to send the survey file to the Allegro, the survey file transfers to the 
PSData folder on the Allegro. 

Figure 13-9.  Send Process Complete

Sending a Facility Survey Based on a Schedule 
The procedure in this section explains how to send a facility survey based on a schedule to 
the Allegro or a folder on your computer. The survey file includes facilities for inspection 
based on a schedule definition and schedule date range. 

Use the procedure in this section when you plan to take inspection readings using the 
Periodic Survey software on the Allegro or you plan to use the survey file with a third party 
software such as RouteSmart. 

The following procedure assumes scheduling criteria has previously been set up in Edit 
Schedule Settings (page 417) and a schedule definition created in Define Schedules 
(page 444). 

Complete the following steps:

1 Verify the Allegro is connected to your computer if you plan to send the survey file 
to the Allegro. If needed, refer to the Allegro User Guide for information about 
how to connect the device. 

2 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you plan to survey. Click  Save to close the 
window (Figure 13-1, page 560). 
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3 Click Field Computer > Send to open the Field Computer Send window 
(Figure 13-10, page 571). 

4 Click the Schedule option. Then click the down arrow in the field Select 
Schedule Definition and select a schedule definition in the list. 

NOTE: Clicking the  toggle button in the  information bar displays important 
information related to required settings. 

Complete step 5 or step 6 to set a schedule date range: 

5 To set a schedule date range, type a date in the Start Date field and a date in the 
End Date field using the format M/DD/YYYY to indicate the month, day, and year. 
Then continue with step 7 (page 571). 

6 To set a schedule date range using dynamic dates, follow these steps: 

a Click the Start Date  calculator and set properties in the following manner: 

• Click the down arrow in the Start Date field and select one of the 
following options: Today, Beginning Of Month, End Of Month, 
Beginning of Year, or End Of Year. 

• In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic start date fields.

b Click the End Date  calculator and set properties in the following manner: 

• Click the down arrow in the End Date field and select one of the following 
options: Today, Beginning Of Month, End Of Month, Beginning of Year, 
or End Of Year. 

• In the remaining two fields, type an offset value in the first field and then 
click the down arrow in the second field and select one of the following 
options: Day(s), Month(s), or Year(s). Click the  pencil button to close 
dynamic end date fields. 

7 Click  Apply to update the grid. 
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Figure 13-10.  Field Computer Send Schedule

8 If the option Calculate X/Y% years based on selected ROWs only is available 
for selection, click the check box if you want due dates calculated based on your 
ROW selection instead of the X years/y% setting for facility types in Edit Schedule 
Settings. 

NOTE: X/Y due dates refer to inspections older than X years with a minimum of Y 
percent scheduled for inspection. For more information, refer to Using a Schedule 
(page 415). 

9 Select a prompt, layout, and sorting theme in the following manner (Figure 13-10): 

a Click the down arrow in Select Prompt and select a prompt theme in the 
selection list. 

b Click the down arrow in Select Layout Theme and select a layout theme in 
the selection list.

c Click the down arrow in Select Sort Theme and select a sorting method 
theme in the selection list. 

10 Click Oldest First or Newest First in Sort Dates to sort records with the oldest or 
newest dates first. 
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11 If you want to rename the survey file, type a name in the field Output File. 

12 Choose a Send to option using one of the following methods:

a Select Send to Allegro if you plan to send the survey file to the Allegro. 

b Select Send to disk if you plan to send the survey file to a folder on your 
computer. Identify the folder location as follows:

• Click the ellipsis button … in the Output Directory field to open the 
Browse For Folder dialog box. 

• Navigate to the folder and select it. Click OK to close the dialog box and 
return to the Field Computer Send window. 

13 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file. 

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled and 
unavailable for selection when maintenance prompts are not included in the 
currently selected prompt theme. 

14 Click the  Filters button to open the Filters panel (Figure 13-11, page 573). 

15 If you want to filter records in the grid and in the schedule sent to the Allegro, 
select one or more options in Filters. For example, click Active Facilities Only to 
only include active facilities. 

IMPORTANT: Filter settings in Field Computer Send apply only to the current 
session and are not saved. See Working with Themes and Filter Groups 
(page 584) for information about saving filter settings.
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Figure 13-11.  Filters

If you want to add a new AND or OR filter group, continue with step 16 or 
step 17 (page 574). 

16 To filter records in the grid and in the schedule sent to the Allegro based on a 
subset of records that meet all filter conditions, complete the following steps to 
add a new AND filter group (Figure 13-12, page 574): 

a Click  New ‘And’ Group to open the filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 
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Figure 13-12.  New ‘And’ Filter Group

17 To filter records in the grid and in the schedule sent to the Allegro based on a 
subset of records that meet any filter condition, complete the following steps to 
add a new OR filter group (Figure 13-13, page 575): 

a Click  New ‘Or” Group to open a filter properties group box. 

b Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

When adding a date filter, such as Last Inspection Date Is Between, set a date 
range using one of the following methods: 

• Type a date in the start and end date fields. Enter a start and end date 
using the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow 
in the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  
calculator button in the start date field and set up dynamic date 
properties. Repeat this step for the end date field. Clicking the calculator 
button opens and closes dynamic date property fields. 
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Figure 13-13.  New ‘Or Filter Group

18 Click the  Filters button to close the Filters panel. Then click  Apply to 
update the grid. 

19 Click  Send. Based on your selection earlier, the survey file is sent either to the 
Allegro or a folder on your computer. 

20 When a message displays confirming the send process is complete, click  OK to 
close the message (Figure 13-14). If you selected to send the survey file to the 
Allegro, PCS Axis sends the survey file to the PSData folder on the Allegro. 

Figure 13-14.  Send Process Complete
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Sending a Facility Survey Based on an Import Exported List
The following information applies to a survey file that has previously been set up, sent to 
disk, and then altered by a third party software such as RouteSmart®. Use the procedure in 
this section to import the survey file in PCS Axis and then send it to the Allegro. 

Complete the following steps: 

1 Verify the Allegro is connected to your computer. If needed, refer to the Allegro 
User Guide for information about how to connect the device. 

2 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

3 Click Field Computer > Send to open the Field Computer Send window. 

4 Click the option Import Exported List (Figure 13-15, page 577). 

5 Click the ellipsis button … in the field Import Exported List to display the Open 
dialog box. Navigate to the altered survey file and select it. Click Open to close the 
dialog box and return to the Field Computer Send window. 

6 Click the down arrow in Select Prompt and select a prompt theme in the 
selection list. 

7 If you want to rename the survey file, type a name in the field Output File. 

8 Click Send to Allegro if the option is not selected. 

9 If the check box Open Maintenance Items is available for selection, click the 
check box if you want to include open maintenance records in the survey file. 

NOTE: When the selected prompt theme includes maintenance prompts, the 
check box Open Maintenance Items is available for selection. It is disabled and 
unavailable for selection when maintenance prompts are not included in the 
currently selected prompt theme. 

10 If you want to work with a subset of facility records that meet all filter conditions, 
create an AND filter group using the following steps (Figure 13-15, page 577): 

a Click the  Filters button to open the Filters panel. Then click  Add to 
open the filter properties group box. 

b Set up filter criteria. Select a PCS Axis field, operator, and filter condition(s) 
using filter selection fields. 
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c If you want to set up an additional filter, click  Add to add another row of 
filter selection fields. Select a PCS Axis field, operator, and filter condition(s) 
to set up filter criteria. Repeat this step as needed. 

d Click the  Filters button to close the Filters panel. 

Figure 13-15.  New ‘And’ Filter

11 Click  Apply to update the grid. 

12 Click  Send. When a message displays confirming the send process is 
complete, click  OK to close the message (Figure 13-16). 

If you selected to send the survey file to the Allegro, PCS Axis sends the survey file 
to the PSData folder on the Allegro. 

Figure 13-16.  Send Process Complete
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Receiving a Facility Survey from the Allegro
Complete the following steps to receive an Allegro PS periodic survey file in PCS Axis:

1 Verify the Allegro is connected to your computer. If needed, refer to the Allegro 
User Guide for information about how to connect the device. 

2 Click Field Computer > Receive to open the Field Computer Receive Data 
window (Figure 13-17). 

3 Click Receive Facility Data, then click the Allegro option.

4 Click  Retrieve File(s) to view a list of periodic survey files available for 
selection. 

Figure 13-17.  Field Computer Receive

5 Choose survey files you want to transfer from the Allegro. Click the check box for 
one or more survey files in the list of files available for selection (Figure 13-18, 
page 579). 

6 Click the  toggle arrow for a selected survey file to view the following options 
for assigning Allegro survey data to a PCS Axis survey folder: 

a Select No Survey Assignments if you do not want to assign Allegro survey 
data to a survey folder.
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b Select Automatic Assignment and then select one of the following options 
to have PCS Axis automatically assign Allegro survey data to a survey folder:

• Assign Survey: Select this option if you want PCS Axis to automatically 
assign survey data to an annual or multi-year survey folder based on the 
inspection date of the Allegro survey data. 

• Assign Periodic Survey and Year : Select this option if you want PCS Axis 
to automatically assign survey data to a periodic survey folder based on 
the inspection date of the Allegro survey data. 

c Select Manual Assignment and then select one of the following options to 
manually select a survey folder for assigning Allegro survey data:

• Survey: Select this option to choose an annual or multi-year survey folder 
for assigning Allegro survey data. Click the down arrow in the Survey field 
and select a survey in the selection list. 

• Periodic Survey, Year : Select this option to choose a periodic survey 
folder and the survey year for assigning Allegro survey data. Click the 
down arrow in the Periodic Survey field and select a periodic survey 
folder in the selection list. Then click the down arrow in the Year field and 
select the survey year. 

d Click Apply to all selected files if you want to apply the selected survey 
folder option to all selected survey files. 

Figure 13-18.  Field Computer Receive Data
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7 Click  Import to import selected survey file(s) in PCS Axis. 

The Field Computer Receive Status window displays showing the status of the 
import process (Figure 13-19). 

Figure 13-19.  Field Computer Receive Status

Receiving a Continuous Survey from the Allegro
Information in this section explains how to receive an Allegro CeCi close interval survey 
file in PCS Axis. 

IMPORTANT: For data to transfer properly, the name of the pipeline entered in the 
Segment field of the Allegro CeCi survey file must match the ROW Code in PCS Axis. The 
survey name entered in the Run field of the CeCi survey file is used to create a survey 
folder in PCS Axis (Data Entry > Survey Folder Maintenance). See the Allegro MX User 
Guide for more information about setting properties in a CeCi survey file. 

Complete the following steps:

1 Verify the Allegro is connected to your computer. If needed, refer to the Allegro 
User Guide for information about how to connect the device. 

2 Click Field Computer > Receive to open the Field Computer Receive Data 
window. 
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3 Click Receive Cis Data, then click the Allegro option. 

NOTE: CIS is an acronym for Close Interval Survey. 

4 Click  Retrieve File(s) to view a list of survey files available for selection 
(Figure 13-20). 

5 Select the close interval (CI) survey files you want to transfer from the Allegro. Click 
the check box for one or more survey files listed in the Field Computer Receive 
Data window. 

A check mark inside a check box indicates a selection. To remove a selection, clear 
the check mark by clicking the check box again. 

Figure 13-20.  Field Computer Receive
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6 Click  Import to open the Mark Native dialog box (Figure 13-21). 

7 If you are importing a survey file with native survey data, click the Native 
check box to place a check mark inside the check box. 

Figure 13-21.  Mark Native

8 If you want to associate one or more existing pipeline Series with the survey, 
complete the following steps: 

a Click the  pencil button in the Mark Native dialog box to open the Select 
Facility dialog box (Figure 13-22). 

b Click the Row field and select a pipeline segment in the selection list that you 
want to associate with the survey. 

c Click the Series field and select a pipeline Series in the selection list that you 
want to associate with the survey. 

Figure 13-22.  Select Facility
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d If you want to change the date the survey was taken, click the down arrow in 
the Survey Date field and choose a survey date using a calendar. You can also 
type a survey date in the field using the format MM/DD/YYYY to indicate the 
month, day, and year. 

e If you want to change the name of the survey file, type a survey name in the 
Survey Name field.

f If you want to change the name of the person who took the survey, type a 
name in the Surveyor field. 

g Click OK to close the Select Facility dialog box. Updated information displays 
in the Survey Information dialog box. 

h Click OK to close the Mark Native dialog box and import the survey file. 

The Field Computer Receive Status window displays showing the status of 
the import process (Figure 13-23). 

NOTE: Survey data imported from the Allegro is indicated in the Edit ISM 
Data grid with information in the Allegro Survey Information field. 

Figure 13-23.  Field Computer Receive Status
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Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a grid layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] Facility ID. 

A filter group is a named set of one or more filters that affect the data output in the grid of 
Field Computer Send grid and subsequently the file sent to the Allegro. PCS Axis provides 
two types of filter groups you can define. These include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude. Adding an AND filter group produces a subset of records that meet all 
filter conditions. Adding an OR filter group produces a subset of records that meet any 
filter condition. When you apply a filter group, PCS Axis processes filters in descending 
order beginning with the filter at the top of the group. 

The following sections describe how to add a layout theme, sort theme, and one or more 
optional filter groups. Topics include those in the following list: 

• Adding a Layout Theme

• Adding a Prompt Theme (page 590)

• Adding a Sort Theme (page 598)

• Adding an AND Filter Group (page 601)

• Adding an OR Filter Group (page 603)

• Editing and Arranging Filters and Filter Groups (page 605)

Adding a Layout Theme
A layout theme is a group of fields in a grid layout. Adding a new layout theme allows you 
to choose which fields you want to include in the grid and then save the layout as a theme 
for later use. The following procedure applies to the grid layout in Field Computer Send. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.
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Complete step 3, 4, or 5 to choose an option for displaying facility records in the grid: 

3 To view facility records based on pipeline segment(s) selected in the Select ROWs 
window, follow these steps:

a Click the Selected ROWs options. 

b Choose one or more facility types using one of the following options 
(Figure 13-24):

• Click the down arrow and select a facility type theme in the selection list, 
such as  [PCS] Rectifier Survey. 

• Click Ad Hoc Theme and then click the check box for each facility type 
you want to view in the grid. 

• Click the Select All button  to view all facility types in the 
grid.

c Click  Apply to update the grid and then continue with step 6 (page 588). 

Figure 13-24.  Field Computer Send Based on Selected ROWs

4 To view facility records based on a route:

a Click the Route option and then select a route in the selection box (Figure 13-
25, page 586). 

b Click  Apply to update the grid and then continue with step 6 (page 588). 
Using Field Computer 585



PCS Axis User and Administrator Guide
Figure 13-25.  Field Computer Send Based on Route

5 To view facility records based on a schedule, follow these steps:

a Click the Schedule option. Then click the down arrow in the field Select 
Schedule Definition and choose a schedule definition in the selection list. 

Complete step "b" to enter a schedule date range or step "c" (page 586) to set 
a schedule date range using dynamic dates:

b Type a start date in the Start Date field and an end date in the End Date 
field. 

c To set a schedule date range using dynamic start and end dates, follow these 
steps (Figure 13-26, page 587): 

1) Click the Start Date  calculator to open dynamic start date fields. Set 
properties in these fields in the following manner: 

• Click the down arrow in the Start Date field and select one of the 
following options: Today, Beginning Of Month, End Of Month, 
Beginning of Year, or End Of Year. 

• In the remaining two fields, type an offset value in the first field and 
then click the down arrow in the second field and select one of the 
following options: Day(s), Month(s), or Year(s). Click the  pencil 
button to close dynamic start date fields.
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2) Click the End Date  calculator to open dynamic end date fields. Set 
properties in these fields in the following manner: 

• Click the down arrow in the End Date field and select one of the 
following options: Beginning Of Month, End Of Month, Beginning of 
Year, or End Of Year. 

• In the remaining two fields, type an offset value in the first field and 
then click the down arrow in the second field and select one of the 
following options: Day(s), Month(s), or Year(s). Click the  pencil 
button to close dynamic end date fields.

3) Click  Apply to update the grid and then continue with step 6 
(page 588). 

Figure 13-26.  Field Computer Send Based on Schedule
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6 Click the Customize tab  then the  Add button to open the New 
Layout Theme dialog box (Figure 13-27). 

Figure 13-27.  New Layout Theme

7 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

8 If you want to copy fields from another theme to the new layout theme, click the 
check box Copy Content. Then click the down arrow in the field Copy Fields 
From Theme and select a theme in the selection list. 

9 Click  OK to save changes and return to the Layouts page. 

10 Verify the name of the new layout theme displays in the field Select Layout 
Theme. If not, click the down arrow in Select Layout Theme and select the new 
theme in the selection list. 

11 Complete the following steps to add and remove fields in the new layout theme as 
needed:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  Facility Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The grid layout theme includes all fields listed in the right 
pane of the Layouts page. 

c To remove a field in the layout theme, double-click a field listed in the right 
pane to move it to the left pane. Repeat this step as needed. 
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12 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

13 Click  Save and Close to return to the Field Computer Send window. 

14 To apply the new layout theme to the grid, click the down arrow in the field 
Select Layout Theme and select the layout theme in the selection list. Then 
click  Apply to update the grid (Figure 13-28). 

Figure 13-28.  Select Layout Theme
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Adding a Prompt Theme
A prompt theme is similar to a layout theme. It is a named set of fields that provide 
information and prompt the user for survey data when performing a survey using the 
Allegro. 

Adding a prompt theme allows you to choose which fields to include in the survey file sent 
to the Allegro. The same prompt theme can include multiple facility types, such as test 
points, rectifiers, bonds, valves, and so on. Each facility type can also include up to eight 
pages of prompts. For example, you can include up to 8 pages of inspection prompts for 
entering facility inspection and maintenance readings.

When viewing the survey file on the Allegro, prompts display in either the top or bottom 
frame of the window. Information prompts display in the top frame while inspection and 
maintenance prompts display in the bottom frame. See the Allegro User Guide for more 
information about working with a survey file on the Allegro. 

To add a prompt theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Click the Customize tab , then the Prompts button  to 
open the Prompts page (Figure 13-29).

Figure 13-29.  Prompts
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4 Click the  Add button to open the New Prompt dialog box (Figure 13-30). 

5 Type a name for the prompt theme in the field Enter Theme Name. If you want 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the prompt theme saves as a private 
theme. 

6 If you want to copy fields from an existing prompt theme, click the Copy Content 
check box to place a check mark inside the check box. Then click the down arrow in 
the field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing prompt theme, remove the check 
mark inside the Copy Content check box by clicking the check box. 

7 Click  OK to save changes and return to the Prompts page. 

Figure 13-30.  New Prompt

8 Verify the name of the new theme displays in the Select Prompt field. If not, click 
the down arrow and select the theme in the selection list (Figure 13-31, page 592). 

9 Click the down arrow in the field Select Facility Type and select the facility type 
you want to work with in the selection list. 

10 To add information prompts, follow these steps:

a Double-click  All Fields in Facility, Information and ROW Fields to view a 
list of fields available for selection. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. All fields listed in the right pane are included in the prompt theme.
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11 To add inspection and maintenance prompts, follow these steps:

a Double-click  All Fields in Inspection and Maintenance Field. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. All fields listed in the right pane are included in the prompt theme.

12 If you want to remove information, inspection, or maintenance prompts, double-
click a field listed in the right pane to move it back to the left pane. 

Figure 13-31.  Prompts

13 Complete the following steps to add site string prompts that help identify one 
facility from another when using the Allegro. Site string prompts are included with 
each facility and can be viewed in the Allegro Site List window. 

a Click the  Site String tab to view a list of fields available for selection 
(Figure 13-32, page 593).

b Double-click one or more fields in the selection list to move fields to the right 
pane. For example, double-click Address and Facility ID. Click the  Site 
String tab again to close the pane. 
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14 If you want to add another page of prompts, click  Copy and then double-click 
one or more fields as needed in the left pane of Inspection and Maintenance 
Fields. 

Information fields in Facility, Information, and ROW Fields automatically copy to 
each page of prompts. The following example shows three pages of prompts 
(Figure 13-32, page 593). 

Figure 13-32.  Prompts

15 Click  Save and Close to save changes and return to the Field Computer Send 
window. 

16 To apply the new prompt theme to the grid, click the down arrow in the field 
Select Prompt and select the theme in the selection list. Then click  Apply 
to update the grid. 
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Adding a Prompt Theme for Test Point Subfacilities
The following procedure explains how to add a prompt theme for subfacilities in the Test 
Point Detail Inspection mini-grid. A prompt theme is a named set of fields that provide 
information and prompt the user for survey data when performing a periodic or close 
interval survey using the Allegro Field Computer. 

A subfacility is a field in the Test Point Detail Inspection mini-grid that links to a parent 
facility in the Test Point Inspection grid. The prompt theme includes ON/OFF fields for 
both the subfacility and corresponding parent test point facility. The following criteria 
must first be met when including subfacilities in prompts sent to the Allegro Field 
Computer: 

• Subfacilities must be set up as Currently Active in the Test Point Detail 
Information mini-grid. (See CPDM > Data Entry > Edit CPDM Data > Test Point 
> Information > Test Point Detail Information mini-grid.) 

• The parent facility of a subfacility must also be included in prompts sent to the 
Allegro. Parent facilities include any of the following ON/OFF field pairs: AC P/S 
and AC IRF; Casing P/S and Casing IRF; Foreign P/S and Foreign IRF; Insulator 
P/S and Insulator IRF; or Structure P/S and Structure IRF. (See the procedure in 
this section.) 

NOTE: For information about how to link subfacilities to a parent facility, refer to 
Linking Multiple Subfacilities to a Parent Test Point Facility (page 313). 

To add a prompt theme for subfacility fields in the Test Point Detail Inspection mini-grid, 
follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Click the Customize tab , then the Prompts button  to 
open the Prompts page (Figure 13-29, page 590). 

4 Click the  Add button to open the New Prompt dialog box (Figure 13-30, 
page 591). 

5 Type a name for the prompt theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the prompt theme saves as a private 
theme. 
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6 If you want to copy fields from an existing prompt theme, click the Copy Content 
check box to place a check mark inside the check box. Then click the down arrow in 
the field Copy Fields From Theme and select a theme in the selection list. 

If you do not want to copy fields from an existing prompt theme, remove the check 
mark inside the Copy Content check box by clicking the check box. 

7 Click  OK to save changes and return to the Prompts page. 

8 Verify the name of the new theme displays in the Select Prompt field. If not, click 
the down arrow and select the theme in the selection list (Figure 13-31, page 592). 

9 Click the down arrow in the field Select Facility Type and select Test Point in the 
selection list. 

10 To add information prompts:

a Double-click  All Fields in Facility, Information and ROW Fields to view a 
list of fields available for selection. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. All fields listed in the right pane are included in the prompt theme.

If you want to remove information, inspection, or maintenance prompts, 
double-click a field listed in the right pane to move it back to the left pane

11 To add prompts for subfacilities and corresponding parent test point facilities: 

a Double-click  Test Point Detail Inspection Fields in Inspection and 
Maintenance Fields to view a list of fields available for selection. 

b Double-click the fields labeled ON and OFF to move these fields to the right 
pane (Figure 13-33, page 596). 

c Double-click Test Point Inspection Fields in Inspection and Maintenance 
Fields to view a list of fields available for selection. 

d For each subfacility you plan to survey, add ON and OFF prompts for the 
corresponding parent test point facility. Double-click the appropriate ON and 
OFF field to move these fields to the right pane. 

For example, to include ON/OFF prompts for structure pipe-to-soil readings, 
double-click the fields Structure P/S and Structure IRF. This same method 
applies to any of the following test point facility field pairs: Casing P/S and 
Casing IRF; Foreign P/S and Foreign IRF; or Insulator P/S and Insulator IRF. 
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12 To add maintenance prompts:

a Double-click  Test Point Maintenance Fields in Inspection and 
Maintenance Fields. 

b Double-click one or more fields in the selection list to move fields to the right 
pane. 

13 Indicate how many new subfacility records should be created when a new test 
point facility record is added in the survey file using the Allegro Field Computer. 
Click the up/down arrow to select a value in the field labeled Test Point Detail 
Inspection Records. You can also type a value in this field. 

NOTE: The user account of the person adding a new test point facility record on 
the Allegro Field Computer must be set up in PCS Axis with the option labeled Can 
Create New Facilities On The Allegro in User Management (Tools > User 
Management). For more information about setting up a PCS Axis user account, see 
Setting Up User Management (page 175).  

14 Prompts display on the Allegro Field Computer according to how you organize the 
fields listed in the right pane. To change the field order, click and drag a field to a 
new position in the list. Or, select a field and then click the up  or down  
button. 

Figure 13-33.  Test Point Detail Inspection Prompts
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15 Complete the following steps to add site string prompts that help identify one 
facility from another when using the Allegro Field Computer. Site string prompts 
are included with each test point facility and can be viewed in the Site List window 
on the Allegro Field Computer. 

a Click the  Site String tab to open the Site String pane (Figure 13-34).

b Double-click  All Fields to view a list of fields available for selection. Double-
click one or more fields in the selection list to move fields to the right pane. 
For example, double-click Address and Facility ID. 

c If you are using the optional Telluric Compensation feature in PCS Axis and 
want to identify which pipeline segments require telluric compensation, 
double-click the field Telluric Compensation Currently Required to move 
the field to the right pane. 

d Click the  Site String tab to close the pane. 

Figure 13-34.  Site String
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16 If you want to add another page of prompts, click  Copy and then double-click 
one or more fields as needed in the left pane of Inspection and Maintenance 
Fields. 

Information fields in Facility, Information, and ROW Fields automatically copy to 
each page of prompts (Figure 13-32, page 593). 

17 Click  Save and Close to save changes and return to the Field Computer Send 
window. 

18 To apply the new prompt theme to the grid in Field Computer Send, click the 
down arrow in the field Select Prompt and select the theme in the selection list. 
Then click  Apply to update the grid. 

NOTE: Prompts for subfacilities display in the second page of the survey file on 
the Allegro Field Computer.  
 
If you are using the optional Telluric Compensation feature in PCS Axis, inspection 
readings for subfacilities received from the Allegro Field Computer display in the 
Uncompensated On and Uncompensated Off fields of the Test Point Detail 
Inspection mini-grid. For more information, refer to the section entitled Viewing 
Test Point Inspections Eligible for Compensation (page 634).

Adding a Sort Theme
A sorting theme determines how PCS Axis sorts grid records in the Field Computer Send 
window. Adding a sorting theme allows you to choose which field(s) to sort data by and if 
data sorts alphanumerically in ascending or descending order. 

To add a sorting theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Choose a mode for displaying records in the grid by selecting the option Select 
ROWs, Route, or Schedule. Then click  Apply to update the grid. 

4 Click the Customize tab , then the Sorts button . 
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5  Click the  Add button to open the New Sort Layout dialog box (Figure 13-35). 

Figure 13-35.  New Sort Layout

6 Type a name for the sorting theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the sorting theme saves as a private 
theme. 

7 Select a sorting theme with fields you want to copy to the new theme. Click the 
down arrow in Copy Fields From Theme and select a sorting theme in the 
selection list. 

8 Click  OK to save changes and return to the Sorts page (Figure 13-36, page 600). 

9 Complete the following steps to add and remove fields in the new sorting theme:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  Facility Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The sorting theme includes all fields listed in the right 
pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. Repeat this step as needed. 

10 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

11 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 
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Figure 13-36.  Sorts

12 Click  Save and Close to return to the Field Computer Send window. 

13 To apply the new sorting theme to the grid, click the down arrow in the field 
Select Sort Theme and select the sorting theme in the selection list. Then click 

 Apply to update the grid (Figure 13-37). 

Figure 13-37.  Select Sort Theme
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Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in the 
grid of Field Computer Send and subsequently the file sent to the Allegro. Adding an 
AND filter group produces a subset of records that meet all filter conditions. PCS Axis 
processes filters in a filter group in descending order beginning with the filter at the top of 
the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Choose a mode for displaying records in the grid by selecting the option Select 
ROWs, Route, or Schedule. Then click  Apply to update the grid. 

4 Click the Customize tab , then the Filters button  to open 
the Filters page (Figure 13-38, page 602). 

5 Click  New ‘And’ Group to open the filter properties group box (Figure 13-38, 
page 602). 

6 Type a name for the filter group in the field Filter Group Caption. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If the AND filter group includes a date filter, such as Facility Delinquent Date Is 
Between shown in Figure 13-38, set a date range using a calendar or dynamic 
dates in the following manner: 

• Type a date in the start and end date fields. Enter a start and end date using 
the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow in 
the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 
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Figure 13-38.  New ‘And’ Filter Group

9 If you want the filter to remain on for all sessions of Field Computer Send, select 
the check box Filter is Always On. When this check box is not selected, toggle 
the filter on and off in the Field Computer Send window using the filter’s check 
box. 

10 Type a name for the filter in the field Enter Custom Filter Caption. 

11 If you want to set up additional filter criteria for the filter group:

a Click the  Add button to open another filter property group box.

b Type a name for the filter in the field Enter Custom Filter Caption. 

c Repeat steps 7 through 9 to set up filter criteria.

12 Click the close button  to close the filter group. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 
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13 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

14 Click  Save and Close to return to the Field Computer Send window. 

Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output in the 
grid of Field Computer Send and subsequently the file sent to the Allegro. Adding an OR 
filter group produces a subset of records that meet any filter condition. PCS Axis 
processes filters in a filter group in descending order beginning with the filter at the top of 
the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Choose a mode for displaying records in the grid by selecting the option Select 
ROWs, Route, or Schedule. Then click  Apply to update the grid. 

4 Click the Customize tab , then the Filters button  to open 
the Filters page (Figure 13-39, page 604). 

5 Click  New ‘Or” Group to open a filter properties group box (Figure 13-39). 
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Figure 13-39.  New ‘Or’ Filter Group

6 Type a name for the filter group in the field Include records that match any of 
these conditions. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If the OR filter group includes a date filter, such as Facility Delinquent Date Is 
Between shown in Figure 13-39, page 604, set a date range using a calendar or 
dynamic dates in the following manner: 

• Type a date in the start and end date fields. Enter a start and end date using 
the format M/DD/YYYY to indicate the month, day, and year. 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a start date. Then click the down arrow in 
the end date field to open a calendar and select an end date. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 
604 Using Field Computer



PCS Axis User and Administrator Guide
9 If you want the filter to remain on for all sessions of Field Computer Send, select 
the check box Filter is Always On. When this check box is not selected, toggle 
the filter on and off in the Field Computer Send window using the filter’s check 
box. 

10 Type a name for the filter in the field Enter Custom Filter Caption. 

11 If you want to set up additional filter criteria for the filter group:

a Click the  Add button to open another filter property group box.

b Type a name for the filter in the field Enter Custom Filter Caption. 

c Repeat steps 7 through 10 to set up filter criteria.

12 Click the close button  to close the filter group. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

13 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

14 Click  Save and Close to return to the Field Computer Send window. 

Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 13-1, page 560). 

2 Click Field Computer > Send to open the Field Computer Send window.

3 Choose a mode for displaying records in the grid by selecting the option Select 
ROWs, Route, or Schedule. Then click  Apply to update the grid. 
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4 Click the Customize tab , then the Filters button  to open 
the Filters page (Figure 13-40, page 606). 

5 Click the edit icon  to display a filter’s property settings. 

Figure 13-40.  Filters

6 To delete a filter in a filter group, click the filter’s  delete button. Then click 
 OK when the Delete message displays. 

7 To rename a filter, type a description in the filter’s name field. 

8 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 

9 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

10 Click the  close button to close the filter’s property settings group box. 

11 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 
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b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save and Close to close the filters page and return to the grid in Field 
Computer Send. 

13 To apply filter changes to the grid in Field Computer Send and subsequently in 
the file sent to the Allegro, follow these steps:

a Click the  Filters tab to open the Filters panel (Figure 13-41, page 607). 

b Click one or more check boxes in Filters and then click  Apply. For 
example, click Active Facilities Only to only include active facilities in the 
grid and in the file sent to the Allegro. 

c Click the  Filters tab to close the Filters panel.

Figure 13-41.  Filters
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Viewing the Field Computer Log
The field computer log includes a Send Log and Receive Log. The Send Log lists the 
facility records sent to the Allegro with the date and time records were processed. 
Likewise, the Receive Log identifies facility records received in PCS Axis from the Allegro, 
as well as the date and time they were received. Only those facility records updated by the 
Allegro are processed and included in the Receive Log. 

You can use information in the field computer log to:

• verify which facility records have been sent and received;

• compare both logs to verify all facilities that were inspected contain survey data;

• troubleshoot issues if a problem occurs during data transfer. 

To view the field computer log, follow these steps:

1 Click Field Computer > Log to open the Field Computer Log window.

2 Click the Send Log tab to view facility records sent to the Allegro (Figure 13-42).

 

Figure 13-42.  Field Computer Log / Send Log
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3 Click the Receive Log tab to view facility records received in PCS Axis from the 
Allegro Field Computer (Figure 13-43). 

 

Figure 13-43.  Field Computer Log / Receive Log
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Notes
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Working with Telluric Compensation

After importing stationary data logger (SDL) files and Allegro Field Computer™ survey files 
in PCS Axis, use the information in this chapter to prepare survey files and run telluric 
compensation. Topics in this chapter include those in the following list:

• PCS Axis Telluric Compensation Workflow (page 612)

• PCS Axis Telluric Compensation Checklist (page 613)

• Using Stationary Survey Maintenance (page 614)

• Running Telluric Compensation (page 633)

IMPORTANT: Bridge Import is an optional add-on that requires an activation key for 
operation. Running Bridge Import for the first time requires you to enter your Bridge 
activation key. If you are unable to locate your Bridge activation key, contact PCS Technical 
services for assistance at pcstechservices@aiworldwide.com. For more information, refer 
to Activating Bridge Import for Operation (page 15). 
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PCS Axis Telluric Compensation Workflow
The figure below identifies the process for working with telluric compensation in PCS Axis 
(Figure 14-1). 

Figure 14-1.  PCS Axis Telluric Compensation Workflow

1 Compensation Required?

Enable pipeline(s) for telluric compensation:
(Data Entry > Edit ROW Detail)

Enable the check box Telluric 
Compensation Required in the 
Information data grid for pipelines 
requiring telluric compensation.

2 Import Survey Data

Import stationary and Allegro survey data:

Import stationary survey.
(Tools > Bridge > Import)

Import Allegro test point facility 
and/or close interval (CI) inspections. 
(Field Computer > Receive)

3 Review Stationary Survey

In Stationary Survey Maintenance:
(Data Entry > Stationary Survey Maintenance) 

Snap SDL measurement(s) to existing 
milepost location(s).

View stationary data logger (SDL), 
survey, and telluric information.

View graphs of stationary surveys
and wave forms of SDL measurements. 

Exclude SDL measurement(s) in 
compensation calculation.

4 Review Allegro Survey Data

In CPDM and/or ISM module: 

View uncompensated test point facility 
inspections (Data Entry > Edit CPDM 
Data >Test Point > Inspection).

View uncompensated CI inspections
(Data Entry > Edit ISM Data > Survey 
selection).

5 Run Telluric Compensation

Set up telluric compensation run:

Run telluric compensation. 

Review and resolve survey readings not compensated 
during a run (Compensation Results).

Apply compensation results to the database or 
return to compensation setup for another run 
(Compensation Results).

� Select periodic or close interval (CI) survey 
and associated stationary survey(s). 

� Exclude or force telluric correction to zero 
(Un-Compensated Inspections).

� Uncompensate a run or change  compensation 
requirement (Maintenance).

In CPDM and/or ISM module:
(Data Entry > Edit CPDM Data and/or Edit ISM Data)
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PCS Axis Telluric Compensation Checklist
The following table provides a checklist of topics included in this document related to the 
optional Telluric Compensation feature (Table 14-1). Some topics have either been 
described earlier in previous chapters or are included in this chapter. 

Table 14-1.  PCS Axis Telluric Compensation Checklist 

To perform these tasks… Refer to these topics…

Activate Telluric Compensation feature 
in PCS Axis. 

See Activating Telluric Compensation 
(page 17). 

View or edit default system setting for 
telluric threshold. 

See Setting Criteria Options (page 37). 

Add a layout theme for the Information 
data grid in Edit ROW Detail that 
includes the field labeled Telluric 
Compensation Required. Then enable 
this field for each pipeline segment 
requiring telluric compensation. 

See Working with Themes and Filter 
Groups (page 155) in the chapter entitled 
Working with Pipeline Records 
(page 127). 

Add a prompt theme that includes Test 
Point Detail Inspection fields to be 
used with the Allegro Field Computer in 
an annual or periodic survey. 

See Adding a Prompt Theme for Test 
Point Subfacilities (page 594). 

Add a Bridge Import Definition for 
importing stationary data logger (SDL) 
survey files. 

See Adding a Bridge Import Definition 
for an SDL Survey File (page 465). 

IMPORTANT: Using Bridge Import to import 
data in PCS Axis requires a Bridge activation 
key. For more information refer to 
Activating Bridge Import for Operation 
(page 15). 

Receive survey files from the Allegro 
Field Computer (close interval and/or 
annual/periodic survey files). 

See Receiving a Facility Survey from the 
Allegro (page 578) and Receiving a 
Continuous Survey from the Allegro 
(page 580). 

Evaluate and modify imported SDL 
survey files (upstream/downstream data 
set pairs). 

See Using Stationary Survey 
Maintenance (page 614). 
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Using Stationary Survey Maintenance
Stationary Survey Maintenance allows you to determine if telluric current effects are 
present on a pipeline segment. After importing stationary surveys in PCS Axis, use 
Stationary Survey Maintenance to view and edit stationary survey files. 

Tasks you can accomplish in Stationary Survey Maintenance include those described in 
the following topics:

• View a Stationary Survey (page 615)

• Delete a Stationary Survey (page 621)

• View Telluric Summary Information (page 622)

• View a Stationary Survey Graph (page 624)

• View Compensation Runs (page 626)

• View a Survey Record Waveform (page 627)

• Match a Stationary Survey to an Existing Milepost Location (page 629)

• Exclude Survey Records in a Stationary Survey (page 631)

NOTE: A stationary survey includes a pair of survey files provided by two stationary data 
loggers (SDLs). One SDL provides a survey file with upstream voltage measurements while 
the other SDL provides a survey file with downstream voltage measurements. 

Evaluate and modify uncompensated 
test point inspections using CPDM 
and/or ISM. 

See Using Telluric Compensation in 
CPDM (page 633) and Using Telluric 
Compensation in ISM (page 643). 

Run compensation in CPDM and/or ISM 
for test points with telluric effects. 

See Using Telluric Compensation in 
CPDM (page 633) and Using Telluric 
Compensation in ISM (page 643). 

Table 14-1.  PCS Axis Telluric Compensation Checklist (continued)

To perform these tasks… Refer to these topics…
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View a Stationary Survey
The Stationary Survey Maintenance window displays a list of imported stationary 
surveys and associated survey records. Stationary Survey Maintenance is available for 
use when working with either the CPDM module (Modules > Cathodic Protection Data 
Manager) or ISM module (Modules > Indirect Survey Manager). 

To open Stationary Survey Maintenance and view imported stationary surveys, follow 
these steps:

1 Select the pipeline segments you want to work with in the Select ROWs window. 
Click the Select ROWs button  to open the Select ROWs window and then 
select one or more pipeline segments. Click  Save to close the window 
(Figure 14-2). 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 

Figure 14-2.  Select ROWs
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2 Click Data Entry > Stationary Survey Maintenance (Figure 14-3). 

3 If you want to filter the data view to view stationary surveys only for a particular 
time period, date range, or all stationary surveys, click the down arrow in the Date 
range field and select an option in the selection list. Then click  Refresh 
(Figure 14-3). 

NOTE: Survey records with a problem are identified with an  error or  warning 
icon in the survey records grid. A survey record with an error must be resolved 
prior to running telluric compensation. A survey record with a warning does not 
require resolution, however problems may occur during telluric compensation.  
 
Conditions resulting in an  error icon include: missing ON and/or OFF voltage 
measurement; missing survey date and time. A  warning icon is present when 
the same voltage measurement is used for both the ON and OFF reading. See the 
next figure for an example (Figure 14-3). 

For a description of the Stationary Survey Maintenance window, see Table 14-2, 
page 617. 

Figure 14-3.  Stationary Survey Maintenance
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Table 14-2.  Description of Stationary Survey Maintenance Window 

Item Description

Stationary Surveys A list of stationary surveys for the pipeline 
segment(s) currently selected in the Select ROWs 
window display in the Stationary Surveys grid 
located on the left side of the window. 

When you want to view stationary surveys for a 
particular time period, date range, or all stationary 
surveys, click the down arrow in the Date range 
field and select an option in the selection list. Then 
click Refresh to update data showing in the 
Stationary Surveys grid. 

Clicking the Stationary Surveys title bar collapses 
the panel allowing you to view more of the graph 
and survey records grid. Clicking the title bar again 
expands the panel. 

Button/Information Bar Located above the graph is a button/information 
bar with the following features: 

 Snap To Facility: If the currently selected 
stationary survey includes milepost locations that 
do not match milepost locations in PCS Axis, click 
Snap To Facility to open a dialog box and match 
the stationary survey to an existing milepost 
location already established in PCS Axis. Using this 
feature ensures accurate telluric compensation 
calculations. For more information, see Match a 
Stationary Survey to an Existing Milepost 
Location (page 629). 

 Stationary Survey, ROW Code, Milepost:
Selecting a stationary survey displays related 
information above the graph. Information includes 
the name of the stationary survey, ROW Code 
(pipeline segment), and milepost (survey location). 

 Info: Click this button to open the Stationary 
Telluric Info window and view a telluric summary 
for the stationary survey currently selected in the 
Stationary Surveys grid. Use this feature to 
quickly determine if telluric current effects are 
present. For more information, see View Telluric 
Summary Information (page 622). 
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Button/Information Bar 
(continued)

 Compensation Run(s): Click this button to 
open the Compensation Runs dialog box. Use the 
dialog box to view information about a telluric 
compensation run for the currently selected 
stationary survey. Or if required, uncompensate or 
reverse (undo) a compensation run. 

 Show Waveform: This button is available for 
use when the currently selected stationary survey 
includes one or more survey records with a 
waveform. Click the button to open the Waveform 
window and view a survey record in a waveform 
graph. See View a Survey Record Waveform 
(page 627) for more information. 

 Chart Exclusions: Click this button to show or 
hide excluded survey records in the graph. The 
default state shows excluded survey records as 
indicated by the highlighted button. 

Graph Selecting a stationary survey displays associated 
survey measurements in a graph. Features included 
with the graph include those in the following list. 
See View a Stationary Survey Graph (page 624) 
for more information.

• Selection Mode: Select this check box to hide 
or show the ON/OFF tooltips that display when 
hovering the mouse over a graph line. 

• Show Legend: Select this check box to show or 
hide the graph legend. 

• Stroke Thickness: Click the up/down arrows to 
adjust the thickness of the graph line. You can 
also type a value in this field to adjust the 
thickness. 

• Zoom In: If the Selection Mode check box 
includes a check mark, click the check box to 
clear the check mark. Then click and hold the 
mouse while dragging a selection over the 
graph to zoom in on the selected area of the 
graph. 

Table 14-2.  Description of Stationary Survey Maintenance Window (continued)

Item Description
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Graph (continued) • Survey Record Selection: Click anywhere on a 
graph line to highlight the corresponding 
survey record in the list of survey records in the 
bottom panel. A survey record with an  arrow 
and a dashed selection box denotes a survey 
record selection. 

Survey Measurement Records The grid in the bottom panel of the window 
includes a list of all survey measurement records 
associated with the stationary survey currently 
selected in the Stationary Surveys panel. Features 
included with this grid include:

Double-click Measurements To Exclude: 
Double-clicking a survey measurement record 
excludes it from the telluric compensation 
calculation. PCS Axis identifies an excluded record 
with a red highlight; the exclusion date; and the 
name of the person who excluded the record. 

Use either of the following multi-select methods to 
exclude several records at one time: 

• Press and hold the Ctrl key on your computer 
keyboard while selecting each record you want 
to exclude. Then click  Exclude. 

–or–

• To multi-select records in sequential order, press 
and hold the Shift key, click the first record and 
then the last record. Click  Exclude. 

 Exclude: Clicking this button excludes selected 
survey measurement records from the telluric 
compensation calculation. 

Table 14-2.  Description of Stationary Survey Maintenance Window (continued)

Item Description
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Survey Measurement Records  Include: To include one or more survey 
measurement records in the telluric 
compensation calculation that have previously 
been excluded, select the excluded record(s) and 

then click  Include. 

Filter the Data View: Click any of the 
following buttons to filter the data view in the 
survey measurement records grid: 

 Show Errors: Click this button to only view 
records with errors. 

 Show Warnings: Click this button to only view 
records with warnings. 

 Show Errors And Warning: Click this button 
to view only records with errors and warnings. 

 Show All: Click this button to view all records 
in the grid; this includes records with and without 
errors and warnings. 

Table 14-2.  Description of Stationary Survey Maintenance Window (continued)

Item Description
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Delete a Stationary Survey
You can delete a stationary survey with associated survey measurement records if it has 
not been used in telluric compensation. When a stationary survey has been used in telluric 
compensation, the  Delete button is disabled to prevent accidental deletion. 

To delete a stationary, follow these steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window (Figure 14-3, page 616).

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select the stationary survey in the Stationary Surveys grid you want to delete. 
Then click  Delete. 

5 When the Delete Stationary Survey message displays, click  Yes to delete the 
stationary survey or  No to cancel the operation (Figure 14-4). 

Figure 14-4.  Delete Stationary Survey
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View Telluric Summary Information
A telluric summary is available for each stationary survey listed in Stationary Survey 
Maintenance. Use this feature to quickly determine if telluric current effects are present.

To view a telluric summary for a stationary survey, follow these steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window (Figure 14-3, page 616).

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid and then click  Info to 
open the Stationary Telluric Info window (Figure 14-5). 

See Table 14-3 (page 623) for a description of the Stationary Telluric Info window. 

Figure 14-5.  Stationary Telluric Info
622 Working with Telluric Compensation



PCS Axis User and Administrator Guide
The next table provides a description of the type of summary information available in the 
Stationary Telluric Info window (Table 14-3). 

Table 14-3.  Stationary Telluric Info 

Field Name Description

Survey Stationary survey file name. 

Telluric Effects Identifies if the stationary survey shows 
telluric effects. Result for this field is either 
True or False. 

On Avg (V) Average ON voltage measurement. 

On Min (V) Lowest ON voltage measurement. 

On Max (V) Highest ON voltage measurement. 

Off Avg (V) Average OFF voltage measurement. 

Off Min (V) Lowest OFF voltage measurement.

Off Max (V) Highest OFF voltage measurement.

Threshold (V) +/– System default telluric threshold set in 
system Options (Tools > Options > 
Criteria).

On Max – On Avg (V) Highest ON voltage measurement minus the 
average ON voltage measurement. 

On Min – On Avg (V) Lowest ON voltage measurement minus the 
average ON voltage measurement. 

Off Max – Off Avg (V) Highest OFF voltage measurement minus the 
average OFF voltage measurement.

Off Min – Off Avg (V) Lowest OFF voltage measurement minus the 
average OFF voltage measurement. 
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View a Stationary Survey Graph
To view a graph of voltage measurements associated with a stationary survey, follow these 
steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window.

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid. A graph of survey 
measurements associated with the selected stationary survey display in the top-
right panel of the window (Figure 14-3, page 616). 

The stationary survey graph supports the following functions: 

• Tooltips with ON/OFF Measurements: Placing the mouse over a point in the 
graph displays tooltips with corresponding ON/OFF voltage measurements 
(Figure 14-6). 

• Selection Mode: Select this check box to hide or show the ON/OFF tooltips 
that display when hovering the mouse over a point in the graph. 

• Show Legend: Select this check box to show or hide the graph legend. You 
can also click one or more check boxes in the graph legend to hide or show 
the selected graph element. 

• Stroke Thickness: Click the up/down arrows to adjust the thickness of the 
graph line. You can also type a value in this field to adjust the thickness. 

Figure 14-6.  Tooltips with ON/OFF Measurements
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• Zoom In: If the Selection Mode check box includes a check mark, click the 
check box to clear the check mark. Then click and hold the mouse while 
dragging a selection over the graph to zoom in on the selected area of the 
graph. Double-click anywhere inside the graph to return to normal graph view 
(Figure 14-7). 

Figure 14-7.  Zoom In On Graph

• Survey Record Selection: Click anywhere on a graph line to highlight the 
corresponding survey record in the survey record grid in the bottom panel. A 
survey record with an  arrow denotes a selection in the grid. For example, the 
survey record with an On Time of 9/4/2014 2:16:11 PM is selected in the 
following example (Figure 14-8). 

Figure 14-8.  Select Survey Record in Grid
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View Compensation Runs
Use the Show Runs link in the top grid of Stationary Survey Maintenance to view 
information about a telluric compensation run for a selected stationary survey and if 
required, uncompensate or reverse (undo) the compensation run. 

To view information or reverse a compensation run for a selected stationary survey, follow 
these steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window.

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid and then click 
 Compensation Run(s) to open the Compensation Runs dialog box 

(Figure 14-9). 

5 If you want to reverse (undo) the compensation run, click the check box associated 
with the compensation run you want to reverse. Then click  Save to reverse the 
selected compensation run. 

Figure 14-9.  Compensation Runs
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View a Survey Record Waveform
When one or more survey records in a stationary survey include an associated 
waveform, click the  Show Waveform button to open the WaveForm window and 
view survey measurements in both a graph and a grid. 

To view a survey record waveform, follow these steps: 

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window.

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid and then click 
 Show Waveform to open the Waveform window (Figure 14-10). 

Figure 14-10.  WaveForm

The waveform supports the following functions: 

• Tooltips with ON/OFF Measurements: Placing the mouse over a point in the 
waveform displays tooltips with corresponding ON/OFF voltage 
measurements (Figure 14-11). 

• Show Legend: Select this check box to show or hide the graph legend. You 
can also click one or more check boxes in the graph legend to hide or show 
the selected graph element. 
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• Stroke Thickness: Click the up/down arrows to adjust the thickness of the 
graph line. You can also type a value in this field to adjust the thickness. 

Figure 14-11.  Tooltips with ON/OFF Measurements

• Zoom In: Click and hold the mouse while dragging a selection over the graph 
to zoom in on the selected area of the graph. Double-click anywhere inside the 
graph to return to normal graph view (Figure 14-12). 

Figure 14-12.  Zoom In On Graph
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Match a Stationary Survey to an Existing Milepost Location
When a stationary survey includes milepost locations that do not match existing milepost 
locations already established in PCS Axis, these mileposts are identified as Unregistered 
Milepost. Unregistered mileposts relate only to the associated stationary survey and are 
not considered as facilities in PCS Axis. 

To ensure telluric compensation calculations are accurate, use Snap To Facility to match 
milepost locations in a stationary survey to existing milepost locations already established 
in PCS Axis (Figure 14-13). 

To match milepost locations in a stationary survey to existing milepost locations in PCS 
Axis, follow these steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window.

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid and then click 
the  Snap To Facility button to open the Snap To Facility window 
(Figure 14-13). 

Figure 14-13.  Snap To Facility
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5 Click Existing Facilities to enable the grid for use. 

PCS Axis automatically selects the closest existing milepost location as indicated by 
the highlighted record labeled LG123-A, 1.243 shown in the following example 
(Figure 14-14). You can however change the selection if needed. 

6 To snap the stationary survey to an existing milepost location, select a milepost 
record in the grid and then click  OK. 

7 When the Snap To Facility window closes, click  Save in the Stationary Survey 
Maintenance window to save changes. 

Figure 14-14.  Snap To Facility
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Exclude Survey Records in a Stationary Survey
When a stationary survey includes one or more survey records with problems, the survey 
records are identified with an  error or  warning icon. A survey record with one or 
more errors must be resolved prior to running telluric compensation. A survey record with 
a warning does not require resolution, however problems may occur during telluric 
compensation.

Information in this section explains how to exclude survey records in the compensation 
calculation. A stationary survey with any of the following characteristics that include an 
error or warning are eligible for exclusion: 

• Missing ON and/or OFF voltage measurement.

• Missing survey date and time.

• Same voltage measurement for both the ON and OFF reading. 

To exclude one or more survey records in the compensation calculation, follow these steps:

1 Select the pipeline segment(s) you want to work with in the Select ROWs window 
(Figure 14-2, page 615). 

2 Click Data Entry > Stationary Survey Maintenance to open the Stationary 
Survey Maintenance window.

3 Click the down arrow in the Date range field and select an option in the selection 
list to filter the data view in the Stationary Surveys grid. Then click  Refresh. 

4 Select a stationary survey in the Stationary Surveys grid. 

5 If you want to filter data in the survey record grid, complete one of the following 
steps:

a Click  Show Errors to only display survey records with errors. 

b Click  Show Warnings to only display survey records with warnings. 

c Click  Show Errors and Warnings to only display survey records with 
errors and warnings. 

NOTE: Clicking  Show All displays all survey records related to the selected 
stationary survey including those with and without errors and warnings. 
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6 Use any of the methods in the following list to exclude one or more survey records. 
PCS Axis highlights excluded survey records in red as shown in the following 
example (Figure 14-15). The fields labeled Exclusion Change User and Exclusion 
Change Date also identify who excluded the survey record and when it was 
excluded.

• Double-click the survey record. 

• Select a survey record and then right-click the mouse and choose Exclude 
Selected in the shortcut menu that opens.

• To select multiple survey records in consecutive order, click the first survey 
record, press and hold the Shift key, then click the last survey record. Right-
click the mouse and choose Exclude Selected in the shortcut menu. 

• To select multiple survey records in non-consecutive order, press and hold the 
Ctrl key, then click each survey record you want to exclude. Right-click the 
mouse and choose Exclude Selected in the shortcut menu. 

Figure 14-15.  Exclude Survey Record(s) in Telluric Compensation

7 To include a survey record in telluric compensation that has previously been 
excluded, select the excluded survey record and then click  Include. 

NOTE: Use the  Chart Exclusions button to show or hide excluded survey 
records in the graph. 
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Running Telluric Compensation
After receiving Allegro survey files in PCS Axis and importing, evaluating, and modifying 
stationary data logger (SDL) survey files in Stationary Survey Maintenance, use the 
information in this section to run telluric compensation and related functionality using 
features available in the CPDM and ISM modules. 

Topics in this section include those in the following list:

• Using Telluric Compensation in CPDM

• Using Telluric Compensation in ISM (page 643)

Using Telluric Compensation in CPDM
When working with test point inspections in a periodic or annual survey that require 
telluric compensation, use the Telluric workspace in the CPDM Test Point Inspection grid 
to perform compensation and other related functions. 

Test point records associated with the selected pipeline segment display in the Test Point 
Inspection grid and the Test Point Inspection Detail mini-grid. Test point inspections 
eligible for telluric compensation display in the Telluric workspace based on your selection 
of SDL survey files (upstream/downstream data set). 

Topics in this section include those in the following list:

• Viewing Test Point Inspections Eligible for Compensation (page 634)

• Changing the Compensation Requirement (page 635)

• Running Telluric Compensation (page 636)

• Reversing a Compensation Run for a Selected Survey Date (page 640)

• Uncompensating Test Point Inspections (page 641)
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Viewing Test Point Inspections Eligible for Compensation
Complete the following steps to view test point inspections eligible for telluric 
compensation in CPDM: 

1 Select one or more pipeline segments to work with in the Select ROWs window. 
Click  Save to close the window (Figure 14-16). 

Choose pipeline segments with the option labeled Telluric Compensation 
Required enabled in Edit ROW Detail. See Adding a Pipeline Information 
Record (page 139) for more information if needed. 

Figure 14-16.  Select ROWs

2 Click Data Entry > Edit CPDM Data to open the Edit CPDM Data window. 

3 Click Test Point  and then the Inspection tab  to open the 
Inspection grid. Test points eligible for compensation include voltage 
measurements in the fields labeled Uncompensated On and Uncompensated Off 
in the Test Point Detail Inspection mini-grid as shown in the following figure 
(Figure 14-17). 

Figure 14-17.  Edit CPDM Data
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Changing the Compensation Requirement
If you need to change the compensation requirement for a pipeline segment and related 
test point inspections, use the Maintenance window available in the Telluric workspace to 
apply the features labeled Add Requirement or Remove Requirement as needed. 

IMPORTANT: Changing the compensation requirement must occur prior to running 
telluric compensation for the pipeline survey. The compensation requirement cannot be 
changed once telluric compensation has completed and results have been applied to the 
PCS Axis database. 

To change the compensation requirement for a pipeline segment, follow these steps:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window (Figure 14-16, page 634). 

2 Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > 
Test Point > Inspection > Telluric tab. 

3 Locate the upstream and downstream SDL survey files associated with the selected 
pipeline segment by clicking the down arrow in the Survey Date field and 
selecting a survey date using a calendar. You can also type a survey date in the 
field using the format MM/DD/YYYY to indicate the month, day, and year. Then 
click  Find. 

4 Click  Maintenance to open the Maintenance window and then click the 
Compensation Requirements tab (Figure 14-18). 

5 Click the down arrow in the ROW Code and Pipe field and select a pipeline 
segment in the selection list to view related test point inspections in the grid. 

Figure 14-18.  Maintenance
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6 Complete one of the following steps:

a To add the compensation requirement to the selected pipeline segment, click 
 Add Requirement. 

b To remove the compensation requirement from the selected pipeline segment, 
click  Remove Requirement. 

After adding or removing the compensation requirement, PCS Axis closes the 
Maintenance window and returns to the Telluric workspace. 

c If you want to close the window without changing the current compensation 
requirement, click  Cancel to return to the Telluric workspace. 

Running Telluric Compensation
Running telluric compensation takes place in the Telluric workspace of the Test Point 
Inspection grid. After receiving Allegro survey files and importing and evaluating SDL 
survey files, use the information in this section to run telluric compensation for test point 
inspections in a periodic or annual survey that include telluric effects and require 
compensation. 

Complete the following steps:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window (Figure 14-16, page 634). 

2 Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > 
Test Point > Inspection > Telluric tab (Figure 14-19). 

Figure 14-19.  Telluric Workspace
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3 Locate the upstream and downstream SDL survey files associated with the selected 
pipeline segment by clicking the down arrow in the Survey Date field and 
selecting a survey date using a calendar. You can also type a survey date in the 
field using the format MM/DD/YYYY to indicate the month, day, and year. Then 
click  Find (Figure 14-20). 

A list of SDL survey files related to the entered survey date display in the 
Stationary Surveys group box of the Telluric workspace. 

4 If you want to view a telluric summary of an SDL survey listed in the Stationary 
Surveys group box, click the Info link to open the Stationary Telluric Info 
window. For a description of this window, see View Telluric Summary 
Information (page 622). 

5 If you want to view voltage measurements associated with an SDL survey listed in 
the Stationary Surveys group box, click the Edit link to open the Stationary 
Survey Maintenance window. A description of this window is available in the 
section entitled Using Stationary Survey Maintenance (page 614). 

Figure 14-20.  Telluric Workspace
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6 To run telluric compensation, follow these steps: 

a Select the SDL upstream/downstream data set pair to use in the compensation 
run. Click the check box associated with the upstream and downstream SDL 
survey files (Figure 14-21). 

Figure 14-21.  Telluric Workspace

b Click  Run to begin the compensation process and open the 
Compensation Results window (Figure 14-22). 

Figure 14-22.  Compensation Results
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c If an error occurs during the compensation run, a  warning icon displays in 
the Compensation Results window. A description of the error and how to 
resolve it also display. 

In the following example, the survey measurement must be changed to zero to 
apply no telluric correction and successfully run compensation. See 
Uncompensating Test Point Inspections (page 641) for information about 
how to apply ForceZero and Exclude to survey measurements. 

Figure 14-23.  Warning in Compensation Results

d When the compensation process completes, click  Preview to view a graph 
of compensation results (Figure 14-24). 

Figure 14-24.  Compensation Run Preview
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e When you finish viewing the graph, click the  Windows close button to 
close the graph and return to the Compensation Results window. 

f If you want to apply compensation results to the PCS Axis database, click 
 Save in the Compensation Results window. 

Clicking  Cancel cancels the compensation process. PCS Axis closes the 
window and returns to the Telluric workspace. Compensation results are also 
not applied to the PCS Axis database. 

Reversing a Compensation Run for a Selected Survey Date
If you need to reverse (undo) one or more compensation runs for a selected survey date, 
use the Maintenance window available in the Telluric workspace to view a list of 
completed compensation runs available for uncompensation. After reversing a 
compensation run, the Test Point Inspection grid and associated Detail mini-grid update 
with uncompensated test point inspection readings for the selected pipeline segment. 

Complete the following steps to reverse a compensation run for a selected survey date:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window. 

2 Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > 
Test Point > Inspection > Telluric tab. 

3 Locate the upstream and downstream SDL survey files associated with the selected 
pipeline segment by clicking the down arrow in the Survey Date field and 
selecting a survey date using a calendar. You can also type a survey date in the 
field using the format MM/DD/YYYY to indicate the month, day, and year. Then 
click  Find (Figure 14-20, page 637). 

A list of SDL survey files related to the entered survey date display in the 
Stationary Surveys group box of the Telluric workspace. 

4 Click  Maintenance to open the Maintenance window (Figure 14-25, 
page 641). 

5 If the Compensation Run(s) grid is not visible, click the Compensation Run(s) 
tab to view a list of compensation runs. 

6 Click the check box associated with the compensation run you want to reverse. 
Then click  Save to reverse (undo) the selected compensation run. 
640 Working with Telluric Compensation



PCS Axis User and Administrator Guide
Figure 14-25.  Maintenance

Uncompensating Test Point Inspections
If you want to exclude one or more test point inspections in a compensation run, or want 
to change the inspection reading to zero (0) for one or more test points, use the Un-
Compensated Inspections window in the Telluric workspace to apply ForceZero or 
Exclude as needed. 

ForceZero applies no telluric correction to the selected test point inspection(s). Exclude 
removes the selected test point inspection(s) from the compensation run. 

Complete the following steps to uncompensate one or more test point inspections in a 
compensation run: 

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window. 

2 Open the Telluric workspace in CPDM. Click Data Entry > Edit CPDM Data > 
Test Point > Inspection > Telluric tab. 
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3 Locate the upstream and downstream SDL survey files associated with the selected 
pipeline segment by clicking the down arrow in the Survey Date field and 
selecting a survey date using a calendar. You can also type a survey date in the 
field using the format MM/DD/YYYY to indicate the month, day, and year. Then 
click  Find (Figure 14-20, page 637). 

4 Click  Un-Compensated Inspections to open the Un-Compensated 
Inspections window. Then click the down arrow in the Action field and select 
ForceZero or Exclude (Figure 14-26). 

5 Click the check box for each test point you want to uncompensate. Click  Save 
to begin the uncompensate process or  Cancel to close the window and return 
to the Telluric workspace. 

Figure 14-26.  Un-Compensated Inspections
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Using Telluric Compensation in ISM
When working with inspections in a close interval (CI) continuous survey that require 
telluric compensation, use the Telluric workspace in Edit ISM Data to perform 
compensation and other related functions. 

After selecting a CI continuous survey to work with, inspection records associated with the 
selected CI survey and pipeline segment display in the data grid of Edit ISM Data. 
Inspection records eligible for telluric compensation display in the Telluric workspace 
based on your selection of SDL survey files (upstream/downstream data set) associated 
with the selected CI survey. 

Topics in this section include those in the following list:

• Viewing CI Inspections Eligible for Compensation (page 644)

• Changing the Compensation Requirement (page 646)

• Running Telluric Compensation (page 648)

• Reversing a Compensation Run in ISM (page 652)

• Uncompensating CI Test Point Inspections (page 653)

NOTE: Several options are available for customizing a grid layout and sorting order, as 
well as applying data filters that allow you to work with a subset of CI inspection records. 
For information about how to apply data filters, refer to Viewing Records in a Grid 
(page 238). See Working with Themes and Filter Groups (page 295) for information 
about customizing the grid layout and sorting order. 
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Viewing CI Inspections Eligible for Compensation
Complete the following steps to view close interval (CI) inspections eligible for telluric 
compensation in ISM:

1 Select one or more pipeline segments to work with in the Select ROWs window. 
Click  Save to close the window (Figure 14-27). 

Choose pipeline segments with the option labeled Telluric Compensation 
Required enabled in Edit ROW Detail. See Adding a Pipeline Information 
Record (page 139) for more information if needed. 

Figure 14-27.  Select ROWs

2 If the ISM module is not open, click Modules > Indirect Survey Manager 
(ISM). 

3 Open the ISM data grid. Click Data Entry > Edit ISM Data (Figure 14-28). 

Figure 14-28.  Edit ISM Data
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4 Click the CIS button  to work with close interval survey data. 

5 Select a survey folder with CI inspection readings you want to run telluric 
compensation. Click the down arrow in the field Selected Continuous Survey 
and select a survey folder in the selection list (Figure 14-29). 

Inspection records eligible for compensation include voltage measurements in the 
fields labeled CIS Structure P/S Uncompensated and CIS Structure IRF 
Uncompensated (Figure 14-29). 

Figure 14-29.  Edit ISM Data
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Changing the Compensation Requirement
If you want to change the compensation requirement for a pipeline segment and related 
close interval (CI) inspections, use the Maintenance window available in the Telluric 
workspace to apply Add Requirement or Remove Requirement as needed. 

IMPORTANT: Changing the compensation requirement must occur prior to running 
telluric compensation for a pipeline segment and associated CI inspections. The 
compensation requirement cannot be changed once telluric compensation has completed 
and results have been applied to the PCS Axis database. 

To change the compensation requirement for a pipeline segment and associated CI 
inspections, follow these steps:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window (Figure 14-27, page 644). 

2 Open the CIS data grid in Edit ISM Data. Click Data Entry > Edit ISM Data > 
CIS button . 

3 Select a survey folder with survey readings you want to change the compensation 
requirement. Click the down arrow in the field Selected Continuous Survey and 
select a survey folder in the selection list (Figure 14-29, page 645).

4 Click the Telluric tab  to open the Telluric workspace (Figure 14-30). 

Figure 14-30.  ISM Telluric Workspace
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5 Click  Maintenance to open the Maintenance window and then click the 
Compensation Requirements tab (Figure 14-31). 

6 Click the down arrow in the field ROW Code and Pipe and select a pipeline 
segment in the selection list to view related CI inspections in the grid. 

7 Complete one of the following steps:

a To add the compensation requirement to the selected pipeline segment, click 
 Add Requirement. 

b To remove the compensation requirement from the selected pipeline segment, 
click  Remove Requirement. 

After adding or removing the compensation requirement, PCS Axis closes the 
Maintenance window and returns to the Telluric workspace. 

c If you want to close the window without changing the current compensation 
requirement, click  Cancel to return to the Telluric workspace. 

Figure 14-31.  Maintenance
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Running Telluric Compensation
Running telluric compensation takes place in the Telluric workspace of the Edit ISM Data 
grid. After receiving Allegro survey files and importing and evaluating SDL survey files, use 
the information in this section to run telluric compensation for inspections in a close 
interval (CI) survey that include telluric effects and require compensation. 

Complete the following steps:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window (Figure 14-27, page 644). 

2 Open the CIS data grid in Edit ISM Data. Click Data Entry > Edit ISM Data > 
CIS button . 

3 Select a survey folder with CI inspections that you want to run compensation. Click 
the down arrow in the field Selected Continuous Survey and select a CI survey 
folder in the selection list (Figure 14-29, page 645). 

4 Click the Telluric tab  to open the Telluric workspace (Figure 14-32, 
page 649). 

A list of stationary data logger (SDL) survey files related to the selected pipeline 
segment and CI survey display in the Stationary Surveys group box of the Telluric 
workspace (Figure 14-32, page 649). 

5 If you want to view a telluric summary of an SDL survey listed in the Stationary 
Surveys group box, click the Info link to open the Stationary Telluric Info 
window. For a description of this window, see View Telluric Summary 
Information (page 622). 

6 If you want to view voltage measurements associated with an SDL survey listed in 
the Stationary Surveys group box, click the Edit link to open the Stationary 
Survey Maintenance window. A description of this window is available in the 
section entitled Using Stationary Survey Maintenance (page 614). 
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Figure 14-32.  Telluric Workspace

7 To run telluric compensation, follow these steps: 

a Select the SDL upstream/downstream data set pair to use in the compensation 
run. Click the check box associated with the upstream and downstream SDL 
survey files (Figure 14-33). 

Figure 14-33.  Telluric Workspace
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b Click  Run to begin the compensation process and open the 
Compensation Results window (Figure 14-34). 

Figure 14-34.  Compensation Results

c If an error occurs during the compensation run, a  warning icon displays in 
the Compensation Results window. A description of the error and how to 
resolve it also display. 

In the following example, the survey measurement must be changed to zero to 
apply no telluric correction and successfully run compensation (Figure 14-35). 
See Uncompensating Test Point Inspections (page 641) for information 
about how to apply ForceZero and Exclude to survey measurements. 

Figure 14-35.  Warning in Compensation Results
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d When the compensation process completes, click  Preview to view a graph 
of compensation results (Figure 14-36). 

Figure 14-36.  Compensation Run Preview

e When you finish viewing the graph, click the  Windows close button to 
close the graph and return to the Compensation Results window. 

f If you want to apply compensation results to the PCS Axis database, click 
 Save in the Compensation Results window. 

Clicking  Cancel cancels the compensation process. PCS Axis closes the 
window and returns to the Telluric workspace. Compensation results are not 
applied to the PCS Axis database. 
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Reversing a Compensation Run in ISM
If you want to reverse (undo) one or more compensation runs in ISM, use the 
Maintenance window available in the Telluric workspace to view a list of completed 
compensation runs available for uncompensation. After reversing a compensation run, the 
data grid in Edit ISM Data updates with uncompensated close interval (CI) inspections. 

Complete the following steps to reverse a compensation run in ISM:

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window. 

2 Open the CIS data grid in Edit ISM Data. Click Data Entry > Edit ISM Data > 
CIS button . 

3 Select a survey folder with CI inspections you want to reverse (undo) a 
compensation run. Click the down arrow in the Selected Continuous Survey 
field and select a survey folder in the selection list (Figure 14-29, page 645).

4 Click the Telluric tab  to open the Telluric workspace (Figure 14-30, 
page 646). 

5 Click  Maintenance to open the Maintenance window (Figure 14-37, 
page 652). 

6 If the Compensation Run(s) grid is not visible, click the Compensation Run(s) 
tab to view a list of compensation runs. 

7 Click the check box associated with the compensation run you want to reverse. 
Then click  Save to reverse (undo) the selected compensation run. 

Figure 14-37.  Maintenance
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Uncompensating CI Test Point Inspections
If you want to exclude one or more close interval (CI) inspections in a compensation run, 
or want to change the telluric compensation to zero (0) for one or more CI inspections, 
use the Un-Compensated Inspections window in the Telluric workspace to apply 
ForceZero or Exclude as needed. 

ForceZero applies no telluric correction to the selected CI inspection(s). Exclude removes 
the selected CI inspection(s) from the compensation run. 

Complete the following steps to uncompensate one or more CI inspections in a 
compensation run: 

1 Select the pipeline segment you want to work with in the Select ROWs window. 
Then click  Save to close the window. 

2 Open the CIS data grid in Edit ISM Data. Click Data Entry > Edit ISM Data > 
CIS button . 

3 Select a survey folder with CI inspections you want to reverse (undo) a 
compensation run. Click the down arrow in the Selected Continuous Survey 
field and select a survey folder in the selection list (Figure 14-29, page 645).

4 Click the Telluric tab  to open the Telluric workspace (Figure 14-30, 
page 646). 

5 Click  Un-Compensated Inspections to open the Un-Compensated 
Inspections window. Then click the down arrow in the Action field and select 
ForceZero or Exclude (Figure 14-38, page 654). 

6 Click the check box for each CI inspection you want to uncompensate. Click 
 Save to begin the uncompensate process or  Cancel to close the 

window and return to the Telluric workspace. 
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Figure 14-38.  Un-Compensated Inspections
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Managing Themes

Information in this chapter explains how to work with facility type themes in Facility Type 
Themes Management and how to manage all themes in the system using Themes 
Management. The information is intended for users with SysAdmin user permissions 
unless noted otherwise. 

Topics in this chapter include those in the following list: 

• Working with a Facility Type Theme

• Managing Themes (page 663)

Working with a Facility Type Theme
A facility type theme is a named set of one or more facility types, such as test point, 
rectifier, valve, and atmospheric facility types. Certain features in PCS Axis require you to 
select a facility type theme to complete an operation, such as selecting a facility type 
theme when working in Define Routes (Data Entry > Define Routes) or Field Computer 
Send (Field Computer > Send). 

Two types of facility type themes are available for use. They include installed and addition 
facility type themes. An installed facility type theme is one that has been installed during 
the PCS Axis software installation. A facility type theme addition is one that you create. 

Information in this section explains how to work with a facility type theme in Facility Type 
Themes Management. Topics include those in the following list: 

• Editing an Installed Facility Type Theme (page 658)

• Adding a Facility Type Theme Addition (page 659)

• Editing a Facility Type Theme Addition (page 662)
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Editing an Installed Facility Type Theme
An installed facility type theme includes [PCS] in the name of the theme, such as  [PCS] 
Rectifier Survey. The procedure in this section explains how to complete the following 
tasks to edit an installed facility type theme:

• add a facility type

• remove a facility type

• revert an installed facility type theme

To edit an installed facility type theme, follow these steps: 

1 Click Tools > Facility Type Themes to open the Facility Type Themes window 
(Figure 15-1). 

2 Click the down arrow in Select Facility Type Theme and select a PCS Axis 
installed theme, such as  [PCS] P/S Survey. 

Figure 15-1.  Facility Type Themes

3 To add one or more facility types in an installed theme:

• Click the check box for each facility type you want to add, then click  Save. 
A check mark inside a check box indicates a selection (Figure 15-1). 
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4 To remove one or more facility types in an installed theme:

• Click the check box to clear the check mark for each facility type you want to 
remove. Click  Save to save changes. 

5 To revert a facility type theme and restore settings prior to editing:

• Click  Revert, then click  Yes when the Confirm Revert message 
displays (Figure 15-2). 

Figure 15-2.  Confirm Revert

Adding a Facility Type Theme Addition
To add a facility type theme addition, follow these steps: 

1 If the Facility Type Themes window is not open, click Tools > Facility Type 
Themes (Figure 15-3). 

Figure 15-3.  Facility Type Themes Management
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2 Click  Add to open the New Facility Type Theme dialog box (Figure 15-4, 
page 660). 

3 Type a name for the new theme in the field Enter Theme Name. 

Figure 15-4.  New Facility Type Theme

4 Select the Public check box if you want the new theme available to all PCS Axis 
users. 

When a theme is not public, it is a private theme. A public theme is available for 
use by all PCS Axis users. A private theme is available only to the user who creates 
it. 

5 Click the down arrow in Copy Facility Types From and select an existing facility 
type theme with facility types you want to copy to the new theme. 

6 Click  Save to save changes and close the dialog box. 

7 To add one or more facility types in the new theme:

• Click the check box for each facility type you want to add. 

Clicking  Select All adds all facility types in the new theme. A check mark 
inside a check box indicates a selection (Figure 15-5, page 661). 
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8 To remove one or more facility types from the new theme:

• Click the check box to clear the check mark for each facility type you want to 
remove. 

Clicking  Clear All removes all facility types in the new theme. 

9 Click  Save to save changes. 

The facility type theme is now available for selection in Define Routes (page 349) 
and Field Computer Send (page 559). 

Figure 15-5.  Facility Types
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Editing a Facility Type Theme Addition
The following procedure describes how to add and remove facility types in a facility type 
theme addition and how to delete a facility type theme addition. 

Complete the following steps:

1 If the Facility Type Themes window is not open, click Tools > Facility Type 
Themes (Figure 15-6). 

2 Click the down arrow in Select Facility Type Theme and select a facility type 
theme addition. 

Figure 15-6.  Facility Type Themes Management

3 To add one or more facility types:

• Click the check box for each facility type you want to add. Clicking  Select 
All adds all facility types. A check mark inside a check box indicates a selection. 
Click  Save to save changes. 

4 To remove one or more facility types:

• Click the check box to clear the check mark for each facility type you want to 
remove. Clicking  Clear All clears all selections. Click  Save to save 
changes. 
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5 To revert a facility type theme and restore settings prior to editing:

• Click  Revert, then click  Yes when the Confirm Revert message 
displays. 

6 To delete a facility type theme addition:

• Click  Delete and then click Yes when the Confirm Delete message opens. 

Managing Themes
Themes Management allows you to perform the following tasks for any PCS Axis installed 
and user-created theme in the system:

• change the Based On method for working with facility records

• rename a theme

• change a theme from Public to Private and vice versa

• assign a Private theme to a user

• delete a theme

To manage themes in the system, follow these steps:

1 Click Tools > Themes Management to open the Themes Management window 
(Figure 15-7, page 664).

2 Open a grid with the theme you want to edit. For example, to edit a grid layout 
theme, click the Editing tab and then the Grid Column Themes tab. 

3 To edit the Based On method for a theme: 

a Select a theme in the grid. In the following example, a Test Point Inspections 
theme addition is selected (Figure 15-7, page 664). 

b Select a mode for displaying facility records in a data entry grid, report, or 
survey file sent to the Allegro Field PC. Click the Based On field and then 
select one of the following options in the selection list: Selected ROWs, Route, 
Schedule, or Exported.

4 To rename a theme: 

• Select a theme in the grid and then type a name in the Theme field. 
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5 To change a theme from Public to Private: 

a Select a theme in the grid and then click the check box Is Public to remove 
the check mark. 

b Assign the Private theme to a user. Click the Assigned To field and select a 
user name in the selection list. 

6 To change a theme from Private to Public: 

• Select a theme in the grid and then click the check box Is Public to place a 
check mark inside the check box. PCS Axis automatically removes the user 
name associated with the private theme in the Assigned To field. 

7 To delete a theme, select a theme in the grid and then click  Delete. When the 
Confirm Delete message opens, click Yes. 

Figure 15-7.  Themes Management
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Using Reports and Graphs

Information in this chapter explains how to generate and use PCS Axis reports and graphs. 
The information is intended for PCS Axis users with SysAdmin, User, and Read Only user 
permissions unless noted otherwise. Topics in this chapter include those in the following 
list: 

• Considering the Value of PCS Axis Reports

• Overview of Reports (page 669)

• Quick Start (page 690)

• Adding a Custom Report (page 700)

• Working with Report Themes and Filter Groups (page 704)

Considering the Value of PCS Axis Reports
PCS Axis reporting supports a variety of business applications. A few of these include 
managing data collection and data entry; reviewing the quality of cathodic protection (CP) 
data; providing information for an audit; and examining the effectiveness of a maintenance 
program. 

The following list describes how you can use PCS Axis reporting in your business:

• Manage data collection and data entry.

Provide a printed copy of the Survey Report or Data Collection Report to 
technicians and vendors for recording CP data in the field. Update the PCS Axis 
database using completed reports submitted by technicians and vendors. Using 
PCS Axis reports in this manner allows you to verify consistent data collection and 
data entry in PCS Axis.
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• Review data quality.

Use PCS Axis reporting to check the quality of survey data submitted by vendors. 
The quickest method is to view the Survey Report to determine which facilities 
have not been surveyed. Blank report fields indicate no survey data. If a vendor is 
using the Allegro Field PC to collect survey data, view the Field Computer Log to 
determine which facilities have not been surveyed.

Another method for checking the quality of survey data is to generate an 
Exceptions or Comparisons report. The Exceptions report allows you to compare 
surveys from previous years. Look for dramatic changes between surveys. You can 
also use the Exceptions report to check for data entry mistakes. This is helpful 
when range checking is not used or when personnel enter data using survey data 
recorded in a printed form. The Comparisons report compares multiple years of 
survey data. Use the Comparisons report to review changes in data and check for 
mistakes that might have been made during data entry. 

• Provide information for an audit. 

The Survey Report and facility Inspections Graph contain most of the information 
needed for an audit. When an audit requires more specific information, create a 
custom facility report using a columnar, summary, or graph report style. 

To prepare for an audit, generate a Delinquency Report to help with creating a 
plan for bringing a pipeline system into compliance. Another method for preparing 
for an audit is to generate a Survey Report or any custom summary report to 
provide data for an audit. All other PCS Axis reports are also beneficial in providing 
information for an audit. 

• Determine the effectiveness of a maintenance program. 

PCS Axis reporting provides several reports and graphs that help with determining 
the effectiveness of a maintenance program. For example, use the CPDM Rectifier 
Output History Report to review the output of a rectifier over time. Look for 
changes in the rectifier output and any survey remarks or permanent comments 
that identify reasons for the change. Another method for determining a 
maintenance program’s effectiveness is to generate the Survey Report and review 
the number of inspection readings for a particular survey period. Also look for 
changes among facilities. 
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Overview of Reports
Information in this section provides an overview of the report types and styles available in 
PCS Axis, including a description of each PCS Axis report. Topics include those in the 
following list: 

• Types of PCS Axis Reports

• Description of PCS Axis Reports (page 670)

• Report Styles (page 686)

• Understanding the Summary Drilldown Report (page 689)

Types of PCS Axis Reports
The types of reports available in PCS Axis include those in the following list. 

• Compliance: This type of report includes statistics, such as: number of test points; 
number of test points surveyed; missing test points; delinquent test points; and 
test points below criteria. Each one provides a concise data summary. Compliance 
reports are a key report typically used for auditing purposes. 

• Delinquency: A delinquency report includes information about facilities that are 
currently delinquent or have been delinquent based on regulatory survey intervals. 
This type of report includes both interval violations and calendar year violations. 

• Exceptions:  Report includes survey data and other related information only for 
facilities that fail to meet certain criteria. For example, based on filter options 
selected in Exception Filters, the report can include facilities with missing structure 
readings; structure readings less negative than –0.85; or structure readings more 
negative than –2.0. This type of report is helpful when trying to quickly locate a 
problem in the maintenance of a pipeline. 

• Facility Schedules: A list of facilities (such as test points, rectifiers, bonds, and 
galvanic anodes) that need to be surveyed based on the last survey date and target 
survey month.

• Survey: All data collected for each facility for a specific survey period.
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Description of PCS Axis Reports
PCS Axis organizes reports in categories, such as PCS Axis reports, module survey reports, 
facility type reports, pipeline reports, and continuous survey reports. Most reports in each 
of these categories are available for set up as a columnar, summary, or graph report style. 
If you frequently use one or more reports, you can designate these reports as a “favorite” 
to have them listed in the Favorite Reports menu for quicker access. 

For a description and an example of the different types of PCS Axis reports, continue with 
the topics in the following list: 

• PCS Axis Reports (page 670)

• Module Survey Report (page 674)

• Facility Type Reports (page 676)

• ROW Reports (page 680)

• Continuous Survey Reports (page 682)

PCS Axis Reports
Reports available for selection include those in the following list: 

• PCS Axis Schedule Report (page 671)

• PCS Axis Delinquency Report (page 672)

• PCS Axis Inspections Graph (page 673)
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PCS Axis Schedule Report
The PCS Axis Schedule Report lists facilities that require inspection using the schedule 
definition selected for the report. The schedule definition and a calculation based on the 
last inspection date and target survey month determine which facilities the report 
includes. Information is presented in a columnar report style in two formats; as a monthly 
calendar overview and as a detailed list (Figure 16-1). 

Figure 16-1.  Example of PCS Axis Schedule Report
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PCS Axis Delinquency Report
The PCS Axis Delinquency Report is a compliance report that identifies delinquent 
facilities based on a survey schedule. Information is presented in a columnar style with a 
list of delinquent facilities; missing and surveyed facilities; facilities not included in a 
survey; and facilities below criteria (Figure 16-2). 

When the report is customized using the Summary report style, it is a statistical status 
report with a concise summary of the cathodic protection system. It includes the number 
of delinquent facilities, missing and surveyed facilities, and facilities below criteria. As an 
option, the report also provides drilldown functionality for further analysis of delinquent 
facilities. 

The following example provides a description of how a facility is identified as delinquent 
and included in the report. 

Example: A facility with a 12-month inspection cycle was initially inspected 1/15/2013. 
The facility became delinquent on 4/15/2014; this includes the 12-month inspection cycle 
plus the grace period. An inspection was recorded for the facility on 4/27/2014. If the 
report option labeled Include only delinquent facilities is not set, the facility is included 
in the Delinquency Report because it was delinquent from 4/15 to 4/26. 

Figure 16-2.  Example of PCS Axis Delinquency Report
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PCS Axis Inspections Graph
This report is a graph of inspection readings in a facility survey or survey readings in a 
continuous survey based on property settings in the Graph tab. Property settings include 
selection of one or more band fields, survey folders, and graph options. Band fields are 
equivalent to data fields in a data entry grid, such as Structure P/S in the Edit CPDM 
Data grid and CIS Structure P/S in the Edit ISM Data grid. 

Areas of the graph with spikes indicate areas where survey data should be reviewed closely 
(Figure 16-3). Locations in the graph marked with the letter “C” indicate Casing P/S. Those 
marked with the letter “F” indicate Foreign Bond. Hovering the mouse over either of these 
captions displays a yellow tooltip with measurement data as shown in the next example. To 
toggle these and other captions on or off when viewing the graph, click Options and then 
click a check box labeled with the caption you want to toggle on or off, such as Show 
Casing P/S. 

Figure 16-3.  Example of PCS Axis Inspections Graph
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Module Reports
Reports available for selection include those in the following list: 

• Module Survey Report (page 674)

• Module Data Collection Report (page 675)

Module Survey Report
The survey report includes survey information by module, such as the CPDM Survey 
Report. It is available in a columnar, summary, or graph report style. The report includes all 
facility data in the survey period selected for the report, such as facility data in a survey 
period for the CPDM Survey Report (Figure 16-4). 

Figure 16-4.  Example of CPDM Survey Report
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Module Data Collection Report 
The data collection report is a blank report used by technicians and vendors to record 
survey readings in the field. It is available for selection in all modules except ISM. The 
report uses a columnar report style and includes survey information by module, such as 
the CPDM Data Collection Report. Based on the survey type selected when setting up 
the report, it includes a list of facilities and other optional data, such as previous survey 
readings (Figure 16-5).

Figure 16-5.  Example of CPDM Data Collection Report
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Facility Type Reports
Reports available for selection in any module except ISM include those in the following list: 

• Facility Type Information Report

• Facility Type Inspections Report (page 677)

• Facility Type Maintenance Report (page 678)

• Facility Type Exceptions Report (page 679)

Facility Type Information Report
A report based on the columnar report style that includes information entered in the 
Information data entry grid for a facility type, such as the Test Point Information report. 
Depending on how the report is set up, it can include information for user-selected fields 
such as ROW Name and Code, Milepost number, Effective Date, Active/Inactive status, 
Protection Criteria, and so on. The report does not include survey readings (Figure 16-6). 

Figure 16-6.  Example of CPDM Test Point Information Report
676 Using Reports and Graphs



PCS Axis User and Administrator Guide
Facility Type Inspections Report
The inspections report includes information entered in the Inspection data entry grid for a 
particular facility type. It is available as a columnar, summary, or graph report. For example, 
the Test Points Inspection report includes all survey data collected at a test point but 
does not include other facility types such as rectifiers and bonds. Rectifier and bonds are 
included in a report specific to these facility types (Figure 16-7). 

Figure 16-7.  Example of CPDM Test Point Inspections Report
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Facility Type Maintenance Report
A report based on the columnar report style that includes information entered in the 
Maintenance data entry grid for a facility type. For example, the Test Points Maintenance 
report includes a detail listing of all current, pending, and completed repairs for test points 
(Figure 16-8). 

Figure 16-8.  Example of CPDM Test Point Maintenance Report
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Facility Type Exceptions Report
A report based on the columnar report style that includes survey data and other related 
information only for facilities that fail to meet certain criteria. For example, based on filter 
options selected in Exception Filters, the report can include facilities with missing 
structure readings; structure readings less negative than –0.85; or structure readings more 
negative than –2.0. This type of report is helpful when trying to quickly locate a problem in 
the maintenance of a pipeline (Figure 16-9). 

Figure 16-9.  Example of CPDM Test Point Exceptions Report
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ROW Reports
Reports available for selection in any module except ISM include those in the following list: 

• ROW Information Report

• ROW Maintenance Report (page 681)

ROW Information Report
A report based on the columnar report style that includes pipeline system information 
entered in the Edit ROW Detail Information grid. Depending on how the report is set up, 
it includes information for user-selected fields such as pipeline name and size, total 
footage, default location format, surface area, and so on (Figure 16-10). 

Figure 16-10.  Example of ROW Information Report
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ROW Maintenance Report
A report based on the columnar report style that includes pipeline system information 
entered in the Edit ROW Detail Maintenance grid. It includes a detail listing of all current, 
pending, and completed repairs (Figure 16-11). 

Figure 16-11.  Example of ROW Maintenance Report
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Continuous Survey Reports
Reports available for selection include those in the following list: 

• PCS Axis Inspections Graph (page 673)

• Continuous Survey Report (page 682)

• Continuous Survey Folders Report (page 684)

• CIS Criteria Report (Continuous Survey) (page 685)

Continuous Survey Report
A report based on the columnar or graph report style that includes station numbers with 
associated survey readings for a selected survey folder and pipeline segment(s) selected in 
the Select ROW window. See Figure 16-12 and Figure 16-13, page 683. 

Figure 16-12.  Example of Continuous Survey Report (Columnar Report Style)
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The next figure shows an example of the Continuous Survey Report using the graph 
report style (Figure 16-13). 

Figure 16-13.  Example of Continuous Survey Report (Graph Report Style)
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Continuous Survey Folders Report
A report based on the columnar report style that lists all survey folders associated with the 
currently selected pipeline segment in the Select ROWs window. The report includes the 
survey folder name, start date, and total number of survey readings for each survey folder 
included in the report (Figure 16-14). 

Figure 16-14.  Example of Continuous Survey Folders Report
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CIS Criteria Report (Continuous Survey)
A report based on the columnar report style that lists survey data for on/off and native 
state surveys. 

The CIS Criteria Report allows you to include or exclude survey readings based on the 
following fields: native (no cathodic protection); on potential (cathodic protection system 
on); and instant off (regular timed interruptions from the current source). If other report 
information is required, you can create a custom criteria report that meets those 
requirements. Report information also allows you to quickly determine if survey readings 
are out of specification or were recorded incorrectly (Figure 16-15). 

Figure 16-15.  Example of CIS Criteria Report (Continuous Survey)
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Report Styles
Available PCS Axis report styles include columnar, summary, and graph. Information in this 
section describes reporting characteristics for each of these styles. Topics include those in 
the following list: 

• Columnar Report Style

• Summary Report Style (page 687)

• Graph Report Style (page 688)

Columnar Report Style
The columnar report style is similar to a spreadsheet with report data organized in 
columns and rows (Figure 16-16). There are as many rows of data as there are records 
returned from the PCS Axis database. You can set up the columnar report style with a 
layout, sorting, and filtering theme, as well as setting paper and print options. 

Figure 16-16.  Example of Columnar Report Style
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Summary Report Style
The summary report allows you to analyze large amounts of pipeline data easily in a 
familiar spreadsheet format. The report provides a summary of totals, subtotals, and 
aggregated numeric data (counts, sums, and percentages) for facilities on a pipeline. For 
example, you can use the report to easily determine the total number of facilities on a 
pipeline; total number and percentage of surveyed facilities; and total number and 
percentage of surveyed facilities above criteria (Figure 16-17). 

Figure 16-17.  Example of Summary Report Style

The summary report style provides an optional Drilldown feature for viewing summary 
data in a pivot table. You can add, remove, and arrange data columns in the pivot table to 
obtain a desired report of summary data. Double-clicking a field in the grid opens a 
window with drilldown information as shown in the following example (Figure 16-18). 

Figure 16-18.  Summary Drilldown Report
Using Reports and Graphs 687



PCS Axis User and Administrator Guide
Graph Report Style
A graph report presents data in a line graph format. The report shows survey data versus 
distance or time. As an option you can set up the report to graph several bands of survey 
data. Each band includes an X-axis, Y-axis, and survey readings. 

Figure 16-19.  Example of Graph Report Style
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Understanding the Summary Drilldown Report
The Summary report includes the Drilldown option for displaying data in an interactive 
pivot table format (Figure 16-20). This feature allows you to display different 
representations of the same summary data. You can add, remove, and rearrange filters to 
display a subset of summary data for easier analysis of large amounts of data. Double-
clicking a field opens a window with detailed drilldown information for the selected 
summation type (Figure 16-18). Percentage drill downs are currently unavailable. The 
following list describes operations you can perform in a pivot table:

• Arranging Column Fields in the Grid: The arrangement of filter buttons 
correspond to the arrangement of column fields in the grid. Dragging a filter 
button to a different position within the group of buttons subsequently rearranges 
column fields in the grid. Hovering the mouse over a filter button displays a tooltip 
with the filter name. 

• Removing Column Fields in the Grid: Dragging a filter button to the area of the 
pivot table labeled “Drop Column Fields Here” removes the selected column from 
the grid. 

• Removing Filters from Calculations: Dragging a filter button to the area of the 
pivot table labeled “Drop Filter Fields Here” removes the selected filter from 
calculations. 

• Double-click a total or sub-total to view or print details in a drilldown table.

Figure 16-20.  Summary Drilldown
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Quick Start
Information in this section includes procedures for setting up and printing a report based 
on the Columnar and Summary report styles. Report set up includes selecting a report 
layout and sorting method, as well as selecting optional filters for filtering data. 

Topics in this section include those in the following list: 

• Working with a Report Based on the Columnar Report Style

• Working with a Report Based on the Summary Report Style (page 694)

• Working with a Report Based on the Graph Style (page 698)

Working with a Report Based on the Columnar Report Style
Complete the following steps to set up and print or export a report based on the 
Columnar report style: 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window.

Figure 16-21.  Select ROWs
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2 Click Reports/Graphs and then select a report in the menu to open a window 
with report property settings. If the Columnar property settings window is not 
visible, click the Columnar tab  to open the window (Figure 16-22, 
page 692). 

The following figure shows an example of the Columnar property settings window 
for the Test Point Inspection Report (Figure 16-22, page 692). 

3 Select one of the following options to choose which facility records to include in 
the report:

a Click the option Selected ROWs to include facilities associated with the 
pipeline selection(s) in the Select ROWs window. 

b Click the Route option and then select a route to include facilities associated 
with the selected route. 

4 Click the down arrow in the field Select Layout Theme and choose a layout 
theme in the selection list. The layout theme determines which fields are included 
in the report; paper and font settings; and additional print options such as 
including a signature line in the report. 

5 Click the down arrow in the field Select Sort Theme and choose a sorting theme 
in the selection list. The sorting theme determines how PCS Axis sorts report data. 

6 Choose a method for sorting inspection dates. Click Oldest First or Newest First 
in Sort Dates to sort records with the oldest or newest inspection dates first. 

7 Choose an option for inserting a line between different groups of report data. Click 
the down arrow in the field Insert Lines Between Groups and choose an option 
in the selection list. 

8 Choose an option that determines where a page break occurs in the report. Click 
the down arrow in the Page Breaks field and select an option in the selection list.
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Figure 16-22.  Test Point Inspection Report

9 Select one or more of the following options as needed in the Options group box. 
Date range in filter criteria is determined by considering all time frame filters, such 
as inspection date, survey, and periodic survey filters. 

• Only include facilities with inspections during the reporting time period:
When time frame filters are not selected in the Filters group box, such as 
inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period. 

If one or more time frame filters are selected in the Filters group box, the 
report only includes inspections for the selected time frame filter(s). 

• All inspections that meet the filter criteria: Report includes all 
inspections that meet filter criteria based on selections in the Filter group box.

• Apply other filters to the most recent inspection found within report 
timeframe: This option finds the latest inspection within the reporting time 
frame first, and then applies all other filters selected in the Filter group box. 
The report only includes inspections for facilities when the latest record within 
the date range meets other filters. 

• The most recent inspection after the filter criteria has been met: This 
option applies all filter criteria first based on selections in the Filter group box, 
and then finds the latest inspection. 

• Indicate missing inspection readings: This option includes an empty box 
in the report for each missing inspection reading. 
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10 Select one or more options in the Filters group box to filter report data according 
to your filter selection(s). For example, click Active Facilities Only to only include 
active facilities in the report. 

NOTE: PCS Axis disables the option Only show facilities with inspection records 
when the Columnar report includes any of the following filter settings: Inspection 
Date is between, Survey is equal to, Periodic Survey is equal to, or Periodic Survey 
Year is equal to. 

When adding a date filter, such as Inspection Date is between, set a date range 
using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

11 If you want to add the report in Favorite Reports (Reports/Graphs > Favorite 
Reports), click  Add Favorite. 

NOTE: If you want to remove a favorite report listed in Favorite Reports, open the 
report and then click  Remove Favorite in the report options window. 

12 To export the report:

a Click  Export to open the Export File dialog box.

b Choose an export file type. Click the down arrow in the Save as type field and 
select one of the following file types:

• Excel files (*.xlsx)

• Text files (*.txt, *.csv)

• XML files (*.xml)
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13 To print the report:

a Click  Print to open the report in a preview window. 

b To print the report using the default printer set up in Windows, click the  
Quick Print button. To select a printer other than the default printer, click the 

 Print button.

Working with a Report Based on the Summary Report Style
The following procedure explains how to set up and print or export a report based on the 
Summary report style. Also included are instructions for using the optional Drilldown 
feature. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window (Figure 16-21, page 690). 

2 Click Reports/Graphs and then select a report in the menu to open a window 
with report property settings. If the Summary property settings window is not 
visible, click the Summary tab  to open the window. 

The following figure shows an example of the Summary property settings window 
for the Test Point Inspection Report (Figure 16-23, page 695). 

3 Select an option to choose which facility records to include in the report. Click 
Selected ROWs to include facilities associated with the pipeline selection(s) in the 
Select ROWs window. Or, click Route and then select a route to include facilities 
associated with the selected route. 

4 Click the down arrow in the field Select Layout Theme and choose a layout 
theme in the selection list. The layout theme determines which fields are included 
in the report. 

5 Complete the following steps in the Sort Options group box:

a Click the down arrow in the field Select Sort Theme and choose a sorting 
theme in the selection list. The sorting theme determines how PCS Axis sorts 
report data. 

b Choose a method for sorting inspection dates. Click Oldest First or Newest 
First in Sort Dates to sort records with the oldest or newest inspection dates 
first. 
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c Choose an option for inserting a line between different groups of report data. 
Click the down arrow in the field Insert Lines Between Groups and choose 
an option in the selection list. 

d Choose an option that determines where a page break occurs in the report. 
Click the down arrow in the Page Breaks field and select an option in the 
selection list.

Figure 16-23.  Test Point Inspection Report (Summary)

6 Select one or more of the following options as needed in the Options group box. 
Date range in filter criteria is determined by considering all time frame filters, such 
as inspection date, survey, and periodic survey filters. 

• Only include facilities with inspections during the reporting time period:
When time frame filters are not selected in the Filters group box, such as 
inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period. 

If one or more time frame filters are selected in the Filters group box, the 
report only includes inspections for the selected time frame filter(s). 

• All inspections that meet the filter criteria: Report includes all inspections 
that meet filter criteria based on selections in the Filter group box.
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• Apply other filters to the most recent inspection found within report 
timeframe: This option finds the latest inspection within the reporting time 
frame first, and then applies all other filters selected in the Filter group box. 
The report only includes inspections for facilities when the latest record within 
the date range meets other filters. 

• The most recent inspection after the filter criteria has been met: This 
option applies all filter criteria first based on selections in the Filter group box, 
and then finds the latest inspection. 

7 Select one or more of the following survey filters in the Filters group box. The 
Summary report requires at least one of these filter settings (Figure 16-24): 

• Survey is equal to

• Periodic Survey is equal to

• Periodic Survey Year is equal to

NOTE: PCS Axis disables the option Only show facilities with inspection records 
when the Summary report includes any of the following filter settings: Inspection 
Date is between, Survey is equal to, Periodic Survey is equal to, or Periodic Survey 
Year is equal to. 

Figure 16-24.  Test Point Inspection Report (Summary)
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8 Select additional filters in the Filters group box as required. For example, click 
Active Facilities Only to only include active facilities in the report. 

When adding a date filter, such as Inspection Date is between, set a date range 
using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

9 If you want to add the report in Favorite Reports, click  Add Favorite. 

NOTE: Once a report has been added as a favorite, you can remove the favorite 
report by opening the report and clicking  Remove Favorite in the report 
options window. 

10 If you want to work with report data in an interactive pivot table, click  
Drilldown to open the report in a new window. 

See Understanding the Summary Drilldown Report (page 689) for a description 
of operations you can perform in the pivot table. 

11 To print the report:

a Click  Print to open the report in a preview window. 

b To print the report using the default printer set up in Windows, click the  
Quick Print button. To select a printer other than the default printer, click the 

 Print button. 
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Working with a Report Based on the Graph Style
Complete the following steps to set up and print or export a report based on the Graph 
report style: 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the graph. Click  
Save to close the window.

Figure 16-25.  Select ROWs

2 Click Reports/Graphs and select a report in the menu. 

3 Click the Graph tab  to open a property settings window. For example, 
the next figure shows the property settings window for the Test Point Inspection 
graph (Figure 16-26, page 699). 

4 Click the down arrow in the field Select Layout Theme and choose a layout 
theme in the selection list. 

5 In the Band Fields group box, click the check box for more or more types of 
survey data you want to include in the graph. 

6 Select one or more Facility Surveys in the Survey Selections group box. To 
select facility surveys in sequential order, press Shift and then click each survey. To 
select facility survey in non-sequential order, press Ctrl and then click each survey. 
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7 To include all parallel pipelines on one page, click the check box Include all 
parallel pipes on one page. 

A check mark inside the check box indicates a selection. To clear the selection, click 
the check box again to remove the check mark. 

8 To combine all selected pipelines on one page, click the check box Combine all 
selected ROWs on one page. 

9 Select one or more options in the Filters group box to filter graph data according 
to your filter selection(s). For example, click Active Facilities Only to only include 
active facilities in the graph.

Figure 16-26.  Test Point Inspection Graph Report

10 If you want to add the graph in Favorite Reports, click  Add Favorite. 

NOTE: If you want to remove a favorite report listed in Favorite Reports, open the 
report and then click  Remove Favorite in the report options window. 

11 To view the graph, click  Graph to open the graph in a preview window. Then 
click the  Print button to print the graph. 
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Adding a Custom Report
The following procedure explains how to add a custom report and set up report options. 
For information about deleting a custom report or changing a custom report from Public 
to Private and vice versa, refer to the instructions in Managing Themes (page 657). 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window (Figure 16-27). 

Figure 16-27.  Select ROWs

2 Click Reports/Graphs, navigate to a report in the list, then click  Add Report 
to open the Add Custom Report dialog box (Figure 16-28, page 701). 

For example, click Reports/Graphs > Test Point Inspection > Add Report. 

3 Type a name for the report in the Name field. 

4 If you want to add information about the report, type the information in the 
Description field. 

5 Select the Public check box if you want the report available to all PCS Axis users. 
When a report is not public, it is a private report available only to the user who 
creates it.

6 Click  Save. 
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Figure 16-28.  Add Custom Report

7 When the report options window opens, select one of the following options to 
choose which facility records to include in the report (Figure 16-29):

a Click the option Selected ROWs to include facilities associated with the 
pipeline selection(s) in the Select ROWs window. 

b Click the Route option and then select a route to include facilities associated 
with the selected route. 

Figure 16-29.  Report Options
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8 Click the down arrow in the field Select Layout Theme and choose a layout 
theme in the selection list. The layout theme determines which fields are included 
in the report.

NOTE:  For information about adding new report themes, such as a report layout 
theme, sorting theme, and filter theme, refer to Working with Report Themes 
and Filter Groups (page 704). 

9 Complete the following steps in the Sort Options group box (Figure 16-29, 
page 701): 

a Click the down arrow in the field Select Sort Theme and choose a sorting 
theme in the selection list. The sorting theme determines how PCS Axis sorts 
report data. 

b Choose a method for sorting inspection dates. Click Oldest First or Newest 
First in Sort Dates to sort records with the oldest or newest inspection dates 
first. 

c Choose an option for inserting a line between different groups of report data. 
Click the down arrow in the field Insert Lines Between Groups and choose 
an option in the selection list. 

d  Choose an option that determines where a page break occurs in the report. 
Click the down arrow in the Page Breaks field and select an option in the 
selection list. 

10 Select one or more of the following options as needed in the Options group box. 
Date range in filter criteria is determined by considering all time frame filters, such 
as inspection date, survey, and periodic survey filters (Figure 16-29, page 701).

• Only include facilities with inspections during the reporting time period:
When time frame filters are not selected in the Filters group box, such as 
inspection date, survey, or periodic survey filters, the report includes all 
inspections using the inspection date and time as the reporting time period. 

If one or more time frame filters are selected in the Filters group box, the 
report only includes inspections for the selected time frame filter(s). 

• All inspections that meet the filter criteria: Report includes all inspections 
that meet filter criteria based on selections in the Filter group box.
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• Apply other filters to the most recent inspection found within report 
timeframe: This option finds the latest inspection within the reporting time 
frame first, and then applies all other filters selected in the Filter group box. 
The report only includes inspections for facilities when the latest record within 
the date range meets other filters. 

• The most recent inspection after the filter criteria has been met: This 
option applies all filter criteria first based on selections in the Filter group box, 
and then finds the latest inspection. 

• Indicate missing inspection readings: This option includes an empty box in 
the report for each missing inspection reading. 

11 Select optional filters in the Filters group box as required. For example, click 
Active Facilities Only to only include active facilities in the report. 

When adding a date filter, such as Inspection Date is between, set a date range 
using a calendar or dynamic dates in the following manner: 

• To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

• To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

12 If you want to add the report in Favorite Reports, click  Add Favorite. 

NOTE: If you want to remove a favorite report listed in Favorite Reports, open the 
report and then click  Remove Favorite in the report options window. 

13 To print the report:

a Click  Print to open the report in a preview window. 

b To print the report using the default printer set up in Windows, click the  
Quick Print button. To select a printer other than the default printer, click the 

 Print button.
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Working with Report Themes and Filter Groups
A theme is a group of named settings saved for later use, such as a report layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] Test Point 
Inspections. 

A filter group is a named set of one or more filters that affect the data output of a report. 
PCS Axis provides two types of filter groups you can define and include in the property 
settings of a report. These include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in a report. Adding an AND filter group produces a subset of records 
that meet all filter conditions. Adding an OR filter group produces a subset of records that 
meet any filter condition. When you generate the report, PCS Axis processes filters in 
descending order beginning with the filter at the top of the filter group. 

The following sections describe how to add a report layout theme, sort theme, and an 
optional filter group. Topics include those in the following list: 

• Adding a Columnar Report Layout Theme (page 705)

• Adding a Summary Report Layout Theme (page 708)

• Adding a Report Sort Theme (page 713)

• Adding an AND Filter Group (page 718)

• Adding an OR Filter Group (page 721)

• Editing and Arranging Filter Groups (page 724)
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Adding a Columnar Report Layout Theme
A columnar report layout theme is a group of report settings saved in a theme for later 
use. Settings include choosing which fields to include in the report, paper settings, and 
print options. The following procedure applies to a columnar report layout theme for any 
columnar report in PCS Axis. 

Complete the following steps:

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Report/Graphs and then select a report in the list. 

For example, click Reports/Graphs > Test Point Inspection Report. 

3 Click the Customize tab  then the Columnar Layouts button 
 to open the Layouts page (Figure 16-30). 

Figure 16-30.  Layouts

NOTE: Setting up a Graph Layouts theme is unavailable in the current release of 
the PCS Axis software. 
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4 Click  Add to open the New Layout Theme dialog box (Figure 16-31). 

Figure 16-31.  New Layout Theme

5 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it.

6 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

7 Click  OK to save changes and return to the Layouts page. 

8 Complete the following steps to add and remove fields in the report layout theme 
as needed (Figure 16-32, page 707):

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field in the left pane to move it to the right pane. Repeat this 
step as needed. The report layout theme includes all fields in the right pane of 
the Layouts page. 

c To remove a field in the layout theme, double-click a field in the right pane to 
move it to the left pane. Repeat this step as needed. 
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d To change the order of fields in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then 
click the up  or down  button. 

9 Click the Wrap check box in Report Paper Size Estimate for each field you want 
text to wrap, such as Inspection Remarks. 

10 Click  Paper Settings to open the property settings panel (Figure 16-32). 

11 Set options as needed in the Paper Settings and Print Options group boxes. 
Adjusting the Min and Max settings in the Font group box allows you to increase 
or decrease the font size. 

12 To adjust the width of report columns, follow these steps:

a Place the mouse over a column boundary to change the cursor to a horizontal 
resize cursor  (Figure 16-32). 

b Click and drag a column boundary to adjust the width of the report column. 

c If the adjustment extends report columns outside of the page, a red “out of 
bounds” message displays as shown in the following example. Click and drag 
the column boundary to make adjustments as needed to clear the message. 

13 Click the Wrap check box in the group box labeled Report Paper Size Estimate 
for each field you want text to wrap, such as Inspection Remarks. 

Figure 16-32.  Columnar Layouts
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14 Click  Save and Close to save changes and return to the report options 
window. 

15 To apply the layout theme to the report, click the down arrow in Select Layout 
Theme and select the new layout theme in the selection list. 

Adding a Summary Report Layout Theme
A layout theme is a group of named settings saved for later use. You can define a 
Summary layout theme with report settings that define the table row, column, and data 
fields as well as the aggregate functions (average, sum, count, and percentage) used to 
calculate data fields in a Summary report. Summation fields, field operators, filters, 
drilldown fields, drilldown sorting fields, horizontal and vertical field groupings, as well as 
paper settings can all be saved in a Summary layout theme. 

A Summary report presents data in a cross tab table view. It provides a “big picture” of 
pipeline and facility data by summarizing and analyzing the data. You can control how PCS 
Axis summarizes the data, for example by sum, average, count, or percentage. Using a 
Summary report can help with analyzing data, making comparisons, and detecting 
patterns in the pipeline system. 

To add a Summary layout theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Report/Graphs and then select a report, such as the Test Point Inspection 
Report. 

3 Click the Summary tab , then the Customize tab .

4 Click the Summary Layouts button  to open the Summaries 
page (Figure 16-33, page 709). 
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Figure 16-33.  Summary Layouts

5 Click  Add to open the New Summary dialog box (Figure 16-34). 

Figure 16-34.  New Summary
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6 Type a name for the Summary layout theme in the field Enter Theme Name. If 
you want to create a public theme, click the Public check box to place a check 
mark inside the check box. When the check box is empty, the summary theme 
saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it.

7 If you want to copy fields from another Summary layout theme, click the Copy 
Content check box and then click the down arrow in Copy Fields From Theme 
and select a theme in the selection list. 

8 Click  OK to save changes and return to the Summaries page. 

9 Complete the following steps to select one or more PCS Axis fields to be used as 
horizontal table rows in the report. Field selections display in the Horizontal 
Groups panel. In a Summary report, these fields display horizontally on the left 
side of the report. 

a Click the toggle arrow  for a field category in the Search For Field panel to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field in the Search For Field Panel to move it to the 
Horizontal Groups panel. Repeat this step as needed. 

As an example, when selecting System and ROW Code, each time a System 
table row is included in the report, a ROW Code table row is also included. 

c If you want the data collapsed for a table row when you first open the 
Summary report, click the Collapsed check box for that table row in the 
Horizontal Groups panel. An expand/collapse button is available when 
viewing the report to expand and collapse data as needed. 

d If you want to rename the caption of a table row, type a name in the Caption 
field for that table row. When this field is empty, the caption of the table row 
uses the default PCS Axis description. 

NOTE: Clicking the  information button in the Horizontal Groups, Vertical 
Grouping, or Field Operations panel opens a window with information 
related to current property settings. 

e To change the order of fields in the Horizontal Groups panel and subsequently 
in the Summary report, click and drag a field to a new position in the grid. Or, 
select a field and then click the up  or down  button. 
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10 Vertical Grouping is an optional setting. It allows you to group horizontal table 
rows by a vertical column. For example, selecting Inspection Date displays data by 
Month, Quarter, or Year based on the Data Group Interval option you select. 

To group horizontal table rows by a vertical column, complete the following steps 
in the Vertical Grouping panel:

a Choose a PCS Axis field you want to use as the vertical column. Click the down 
arrow in Field and select a field in the selection list.

b If you want to use a different caption other than the name of the selected PCS 
Axis field, type a name in the Caption field. 

11 Click  Full View to hide the field selection, Horizontal Groups, and Vertical 
Grouping panels. Clicking Full View again displays these panels. 

12 Identify how you want data calculated. Set up one or more summations in the 
following manner: 

a Click  Add Summation. 

b Choose an aggregate function used to calculate data fields (average, sum, 
count, or percentage). Click an option in any of the following group boxes: 
Single, Composite, or Sum Of Total Facilities. 

c If you selected an option in the group box labeled Single or Sum Of Total 
Facilities, click the down arrow in Field and select the PCS Axis field you want 
to use in the calculation. 

d If you want to compare two summations, select Percentage or Difference in 
the Compare Summations group box. Then click the down arrow in the field 
First Summation and select a summation. Click the down arrow in the field 
Second Summation and select the second summation. 

e Repeat steps "a" through "d" as needed to add additional summations. 

NOTE: To delete a summation, select a summation tab and then click  
Delete. Click Yes when the Delete message displays. 
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13 If you want to filter the data output in the report, click the down arrow in the field 
Optional Required Runtime Filter and select a PCS Axis field in the selection 
list. Or, click Edit to set up an AND or OR filter group. See Working with Report 
Themes and Filter Groups (page 704) for related information. 

14 Click Edit in the Drilldown Fields group box and select one or more fields you 
want to use as drilldown fields. When viewing the report in PCS Axis, clicking a 
drilldown field displays another data view with more information about the field. 

15 Click Edit in the Drilldown Sorts group box and select one or more fields that 
determine how data sorts. Click ASC  to sort data in ascending order or 
DESC  to sort in descending order. 

16 Click  Paper Settings and set paper, font, and print options as needed. 

17 Click  Save. 
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Adding a Report Sort Theme
A sort theme determines how PCS Axis sorts and groups records in the report. Adding a 
sort theme allows you to choose which field(s) to sort and group records by, such as 
sorting by name or ROW code. A sort theme also allows you to set options for sorting 
records alphanumerically in either ascending or descending order. Including a group filter 
in the sorting theme allows you to organize records in a group for easier analysis. 

To add a report sort theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Choose 
pipeline segment(s) with facilities you want to include in the report. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Reports/Graphs and then select a report to open the report options window 
(Figure 16-35). 

For example, click Reports/Graphs > Test Point Inspection Report to open a 
report options window similar to the following example. 

Figure 16-35.  Report Options
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3 Click the Customize tab  then the Sorts button  to open 
the Sorts page (Figure 16-36). 

Figure 16-36.  Sorts

4  Click  Add to open the New Sort Layout dialog box (Figure 16-37). 

Figure 16-37.  New Sort Layout
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5 Type a name for the sorting theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

6 Select a theme with fields you want to copy to the new theme. Click the Copy 
Content check box and then click the down arrow in Copy Fields From Theme 
and select a theme in the selection list. 

7 Click  OK to save changes and return to the Sorts page. 

8 To choose one or more fields for sorting records in the report, follow these steps: 

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The sorting theme includes all fields listed in the right 
pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. Repeat this step as needed. 

9 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

10 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 
Using Reports and Graphs 715



PCS Axis User and Administrator Guide
11 Complete the following steps to add a new group with one or more fields that 
determine how records sort in the report: 

a Click  Add group to add a new group (Figure 16-38, page 717).

NOTE: Clicking the  edit icon for an existing group (such as City) opens a 
group box with current settings you can edit if needed. 

b Select which PCS Axis field starts the new group when that field’s value 
changes. Click the down arrow in the field Start a new group when this 
value changes and select a field in the list. 

c If you want to add another field in the group, click  Add Additional Field. 
Then click the down arrow and select a field in the selection list. The title bar of 
group includes the name of each field (Figure 16-38, page 717). 

d Choose a sorting method for the new group. To sort the group in ascending 
order, click the toggle button to select ASC . To sort in descending 
order, click the toggle button to select DESC .

e To change the position of the new group within the set of other groups in the 
theme, click the up  or down  button. PCS Axis processes groups in 
descending order beginning with the group at the top of the set. 

f To apply optional settings to the new group, click the check box for the 
following options as needed: 

• Click the check box Print group field in group header to have the 
group name print as a heading at the beginning of each group. 

• Click the check box New page for each group to have each group print 
on a new page. 

• Click the check box Print sums in group footer to have the total 
number of records in a group print at the end of each group. 
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g Choose which fields to include in the new group. Click the toggle arrow  for a 
field category in the left pane of the window to view fields available for 
selection. For example, click  All Fields. 

h Double-click a field listed in the left pane to move it to the right pane, such as 
Facility ID shown in the next figure. Repeat this step as needed. The theme 
includes all fields listed in the right pane.

i Choose a sorting method for each field added in the new group. To sort fields 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

j To change the position of fields in the new group, click the up  or down  
button. 

12 Click  Save and Close to save changes and return to the report options 
window. 

13 To apply the sorting theme to a report, click the down arrow in Select Sort 
Theme and select the sorting theme in the selection list. 

Figure 16-38.  Sort Theme Groups
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Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output of a 
report. Adding an AND filter group produces a subset of records that meet all filter 
conditions. PCS Axis processes filters in a filter group in descending order beginning with 
the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Report/Graphs and then select a report to open the report options window 
(Figure 16-39). 

For example, click Reports/Graphs > Test Point Inspection Report to open a 
report options window similar to the following example. 

Figure 16-39.  Report Options
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3 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 16-40). 

Figure 16-40.  Filters

4 Click  New ‘And’ Group to open the filter properties group box (Figure 16-41). 

Figure 16-41.  New ‘And’ Filter Group
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5 Type a name for the filter group in the field Filter Group Caption. 

6 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

7 When adding a date filter, such as Inspection Date Is Between, set a date range 
using a calendar or dynamic dates in the following manner (Figure 16-41, 
page 719): 

a To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

b To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

8 If you want the filter to remain on for all sessions of the report, select the check 
box Filter is Always On. When this check box is not selected, toggle the filter on 
and off in the report options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box.

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps 5 through 9 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save and Close to return to the report options window. 
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Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output of a 
report. Adding an OR filter group produces a subset of records that meet any filter 
condition. PCS Axis processes filters in a filter group in descending order beginning with 
the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Report/Graphs and then select a report to open the report options window 
(Figure 16-42). 

For example, click Reports/Graphs > Test Point Inspection Report to open a 
report options window similar to the following example. 

Figure 16-42.  Report Options
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3 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 16-43). 

Figure 16-43.  Filters

4 Click  New ‘Or’ Group to open a filter properties group box (Figure 16-44). 

Figure 16-44.  New ‘Or’ Filter Group
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5 Type a name for the filter group in the field Include records that match any of 
these conditions. 

6 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

7 When adding a date filter, such as Inspection Date Is Between, set a date range 
using a calendar or dynamic dates in the following manner (Figure 16-44, 
page 722): 

a To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

b To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 

8 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box.

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat steps 5 through 9 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save and Close to return to the report options window. 
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Editing and Arranging Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Information in this section explains how to edit filter property 
settings and also how to arrange filters in a group of filters. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 16-27, page 700). 

2 Choose the report you want to work with in the Reports/Graphs menu. Click 
Report/Graphs and then select a report to open the report options window 
(Figure 16-45). 

For example, click Reports/Graphs > Test Point Inspection Report to open a 
report options window similar to the following example. 

Figure 16-45.  Report Options
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3 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 16-46). 

Figure 16-46.  Filters

4 Click the edit icon  to display a filter’s property settings. In the following 
example, property settings for Inspection Data Is between are visible (Figure 16-
47, page 726). 

5 To delete a filter in a filter group, click the  delete button. 

6 To rename the filter, type a description in the field Enter Custom Filter Caption.

7 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. When adding a date filter, such as 
Inspection Date Is Between, set a date range using a calendar or dynamic dates in 
the following manner: 

a To set a date range using a calendar, click the down arrow in the start date 
field to open a calendar and select a date. Repeat this step for the end date 
field. 

b To set a date range using dynamic start and end dates, click the  calculator 
button in the start date field and set up dynamic date properties. Repeat this 
step for the end date field. Clicking the calculator button opens and closes 
dynamic date property fields. 
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8 To enable the filter for all sessions of the report, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the report options page using the filter’s 
check box. 

9 Click the  close button to close the filter’s property settings group box. 

10 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

11 Click  Save and Close to return to the report options window. 

Figure 16-47.  Inspection Date Is Between
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Using Synchronization

Information in this chapter explains how to set up and work with PCS Axis synchronization. 
The information is intended for your company’s Database System Administrator and PCS 
Axis users with SysAdmin, User, and Read Only permissions. 

Topics in this chapter include those in the following list: 

• About Synchronization (page 730)

• PCS Axis Features Unavailable in a Subscription (page 731)

• Creating the Publication (page 732)

• Adding Subscribers (page 735)

• Configuring a Subscription (page 737)

• Synchronizing a Subscription (page 739)

• Reinitializing a Subscription (page 740)

• Switching Database Connections (page 743)

NOTE: For information about how PCS Axis activates a Bridge license for a subscription 
(remote client), see Activating Bridge Import for Operation (page 15). 
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About Synchronization
Synchronization uses a Microsoft SQL Server publisher/subscriber database model. The 
publisher database is the primary database on a network server or host computer (central 
database server). Each subscription database is a copy of the publication database. Remote 
users who do not have access to the publication database can update data in a 
subscription database on their local computer. Frequent synchronization between the 
publication and subscription databases ensures all PCS Axis users are working with the 
same data (Figure 17-1). 

Synchronization supports one publisher with multiple subscribers running in a client-
server network. Synchronizing data between the publisher and subscribers is achieved 
using merge/pull replication. Merge replication is used with the publisher database. Pull 
replication is used with subscriber databases. After the initial snapshot of the publisher 
database is replicated, subsequent synchronizations only replicate data that has changed 
since the last synchronization. 

IMPORTANT: To avoid data conflicts, it is important to synchronize data between the 
publisher and each subscriber at frequent intervals. The subscriber must establish a 
reliable high-speed connection to the publisher to successfully synchronize data. 

Figure 17-1.  Typical Publisher/Subscriber Configuration

NOTE: Hierarchy Rights set up for a user in User Management determines which 
pipeline segments the user has access. This also applies to remote users with a 
subscription database on their local computer. See Setting Up User Management 
(page 175) for more information. 
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PCS Axis Features Unavailable in a Subscription
Items in the following table identify PCS Axis features unavailable to a remote user with a 
subscription database (Table 17-1):

Table 17-1.  PCS Axis Features Unavailable in a Subscription 

Select ROWs window:

• Add hierarchy levels

• Add, delete, and rename ROWs 

Modules menu:

Custom Module Management

NOTE: Creating a custom module is disabled at the subscription 
level. A custom module created on the publisher is available to 
synchronized subscriptions however. 

Data Entry menu: 

• Define Routes 

• Define Schedules

• Edit Schedule Settings

• Edit ROW Detail

• Survey Folder Maintenance

Tools menu:

• Bullhorn Bridge

• Fields and UDF Customizations

• Email Notification

• Themes Management

• Facility Type Themes

• User Management

• Options
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Creating the Publication
PCS Axis supports one publication with multiple subscriptions for data replication and 
synchronization. Creating a publication is a function performed by your company’s 
Database System Administrator. Adding subscription users is a function performed by 
the PCS Axis System Administrator or a user with PCS Axis SysAdmin permissions. 

Information in this section explains how to complete the following tasks:

• Confirming Share Folder Access

• Creating the Publication (page 733)

Confirming Share Folder Access
Before creating the publication, verify the items in the following list are available to ensure 
successful creation of the publication and subscription databases: 

• Share Folder : Confirm with your company’s database administrator (DBA) or IT 
group that a share folder has been added on the server for the publication 
snapshot files. These files are a “snapshot” of the PCS Axis database and are 
created at the time you create the publication. They are also updated when 
changes in the database structure are detected by the Snapshot Agent. 

• Share Folder Access and Permissions: Confirm with your company’s DBA or IT 
group that the share folder is accessible to any Windows domain user who will be 
configuring a subscription. These users require read/write permissions set up for 
the share folder on the server.

NOTE: The path and name of the server and share folder are needed later when 
creating the publication. The format for this information appears as: 
\\ServerName\SnapshotShareFolder
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• Snapshot Agent Security: Confirm with your company’s DBA or IT group that the 
Snapshot Agent is set up on the publication to run as a process under a Windows 
domain account. This requirement is set in the Agent Security page when using 
SQL Server Management Studio (SSMS). It allows PCS Axis to re-initialize a 
subscription that has expired. 

IMPORTANT: An expired subscription occurs when a subscriber does not 
synchronize within the publication retention period, also referred to as subscription 
expiration period. The publication retention period is set in the field Subscription 
expiration in the General page when using SQL Server Management Studio. When 
choosing the Subscription expiration interval, valid options for selection are 
Days, Weeks, or Months. 

Creating the Publication
Information in this section explains how to create the publication on the server (central 
database server). The information is intended for your company’s Database System 
Administrator. 

IMPORTANT: Microsoft SQL Server must be installed on the computer you plan to create 
and configure the publication. For more information, refer to the AI document entitled 
PCS Axis Client/Server New Installation with Replication. This document is available for 
download in the section entitled Installation & Best Practice Guides (page 2) of PCS Axis 
Help. 

To create the publication, follow these steps: 

1 Click Tools > Synchronization > Create Publication to open the Create 
Publisher dialog box (Figure 17-2). 

2 Type the server path to the share folder in the field Enter Snapshot Path using 
the format \\ServerName\SnapshotShareFolder. 

3 Click  OK to create the publication and add snapshot files in the share folder. 

NOTE: During the process of creating the publication and adding snapshot files, 
status messages and a percentage completed display in the dialog box. 
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Figure 17-2.  Create Publisher

4 Click  OK when the message Publisher Creation Complete displays (Figure 17-
3, page 734). 

Figure 17-3.  Publisher Creation Complete

To view information for the current server and database connection, as well as the 
PCS Axis software version, click Help > About PCS Axis. For more information, see 
Viewing Information About PCS Axis (page 24). 
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Adding Subscribers
The following information explains how to add one or more subscribers (remote users) 
who will set up and use a subscription database on their local computer. Information in 
this section is intended for the PCS Axis System Administrator or a PCS Axis user with 
SysAdmin permissions. 

To add one or more subscribers, follow these steps: 

1 Click Tools > Synchronization > Synchronization Configuration to open the 
Sync Configuration window (Figure 17-4). 

NOTE: A list of users previously added as a subscriber display in the Subscribers 
panel of the Sync Configuration window. Information in the Subscription Name 
field identifies whether or not a subscription has been set up on a subscriber’s 
local computer. When a subscription has been set up, the name of the subscriber’s 
computer and subscription display in the field. Otherwise, Unconfigured displays 
as shown in the next figure Figure 17-4. 

Figure 17-4.  Synchronization Configuration

2 Click  Add to open the Add Subscription dialog box (Figure 17-5, page 736). 

The dialog box includes a list of PCS Axis users available for set up as a Subscriber. 
Users are also set up as an Active user in User Management (Tools > User 
Management). 
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3 Select the user you want to add as a subscriber. Then click OK  to close 
the dialog box. 

4 Repeat steps "2" and "3" to add additional subscribers as needed. When you finish, 
click the  close button to close the Sync Configuration window. 

Subscribers can now configure a subscription on their local computer. See 
Configuring a Subscription (page 737) for more information. 

Figure 17-5.  Add Subscription
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Configuring a Subscription
Information in this section explains how to set up a subscription on the local computer of 
a PCS Axis user who has previously been added as a subscriber in Sync Configuration 
(page 732). The information is intended for PCS Axis users with User or SysAdmin 
permissions. 

IMPORTANT: Because the configuration process transfers a full copy of the publication 
snapshot to the subscriber’s computer, it’s recommended that a high-speed reliable 
connection to the server be available when configuring the subscription. Subsequent 
synchronizations only update data that has changed between the publication and 
subscription databases. 

To configure a subscription on a subscriber’s computer, follow these steps: 

1 Log on to the computer using the subscriber’s login credentials. Then start the PCS 
Axis software (Start > American Innovations > PCS Axis). 

IMPORTANT: Microsoft SQL Server must be installed on the computer you plan to 
create and configure a subscription. For more information, refer to the AI 
document entitled PCS Axis Client/Server New Installation with Replication. 
This document is available for download in the section entitled Installation & Best 
Practice Guides (page 2)of PCS Axis Help. 

2 Click Tools > Configure Subscription to open the Configure Subscriber dialog 
box (Figure 17-6, page 738). 

3 PCS Axis provides the name of the subscriber’s computer in the field Enter 
Instance Name. Include the name of the local SQL server instance in this field 
using the following format: 

ComputerName\LocalSQLServerInstanceName

NOTE: To view the name of the local SQL server instance using Microsoft SQL 
Server Management Studio (SSMS):  
(1) Start SSMS and connect to the server.  
(2) Right-click the server instance in Object Explorer and select Properties.  
(3) On the General page, view the SQL server instance name in the Name field. 
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4 If you want to use a different subscription database name than the default name 
set up previously in system Options (Tools > Options > General), type a name in 
the field Enter Subscription Database Path. 

5 Click  OK to create the subscription database. 

Figure 17-6.  Configure Subscriber

6 Click  OK when the message Subscription Complete Restart displays 
(Figure 17-7). 

When the process completes, the PCS Axis software automatically restarts and then 
connects the user to the subscription database on the local computer. In SQL 
Server Management Studio, the name of the subscription database is added in the 
Replication/Local Subscriptions folder in Object Explorer. 

Figure 17-7.  Subscription Complete Restart

NOTE: To view information for the current server and database connection, as well 
as the software version of PCS Axis, click Help > About PCS Axis. The About 
dialog box displays the current server and database connection in the Connection 
field. The Version field identifies the current database and software version. See 
Viewing Information About PCS Axis (page 24). 
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Synchronizing a Subscription
Information in this section explains how a subscriber (remote user) can synchronize the 
subscription database on their local computer with the publication database on the 
network server. When a subscription database is about to expire, PCS Axis displays a 
message to notify the subscriber (Figure 17-8). 

Figure 17-8.  Pending Subscription Expiration

IMPORTANT: To avoid data conflicts, it is important to synchronize data between the 
publisher and each subscriber at frequent intervals. The subscriber must establish a 
reliable high-speed connection to the publisher to successfully synchronize data. 

To synchronize a subscription, follow these steps: 

1 Click Tools > Synchronize Now to open the Synchronize Now dialog box. Then 
click Start (Figure 17-9). 

Figure 17-9.  Synchronize Now

2 Click  OK when the message Synchronization Complete displays to complete 
the process (Figure 17-10). 

Figure 17-10.  Synchronization Complete
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Reinitializing a Subscription
When a subscription database has expired, PCS Axis displays a message on the local 
computer of the subscriber informing the user their subscription has expired (Figure 17-
11). 

Figure 17-11.  Expired Subscription (Subscriber)

When the PCS Axis SysAdmin is connected to the publication database on the central 
database server, the message Subscription Has Expired displays in the Expiration Status 
field for the subscriber selected in the Sync Configuration window (Tools > 
Synchronization > Subscription Configuration). In the following example, the 
subscription for the selected subscriber John Smith has expired (Figure 17-12). 

Figure 17-12.  Expired Subscription (Publisher)
740 Using Synchronization



PCS Axis User and Administrator Guide
The procedure in this section explains how to re-initialize an expired subscription. The 
information is intended for the PCS Axis SysAdmin and requires a connection to the 
publication database on the central database server. 

IMPORTANT:  Because the re-initialization process transfers a full copy of the publication 
snapshot to the subscriber’s computer, it’s recommended that the subscriber have a high-
speed reliable connection to the publication server when re-initializing the subscription.  
 
Unsynchronized data is lost when re-initializing a subscription. To avoid losing 
unsynchronized data, first use Bridge to export data on the subscription. Then use Bridge 
again to import data after re-initialization is complete. See Using Bridge (page 453) for 
more information.

Complete the following steps to re-initialize an expired subscription: 

1 Click Tools > Synchronization > Synchronization Configuration to open the 
Sync Configuration window (Figure 17-13). 

2 Select the name of the subscriber with the expired subscription in the Subscribers 
panel. 

Figure 17-13.  Sync Configuration
Using Synchronization 741



PCS Axis User and Administrator Guide
3 Complete one of the following steps:

a If the subscription database has updated records that have not been 
synchronized with the publication database, click  Reinitialize 
Subscription And Allow Synchronize First. 

–or–

b If the subscription database does not need to be synchronized with the 
publication database, click  Reinitialize Subscription. 

4 Click  Yes when the message Reinitialize Subscription displays (Figure 17-14). 

The message includes the following information for the subscription: name of the 
server, primary database, and publication. This is shown in the following figure as 
ServerName:DatabaseName:PublicationName. 

Figure 17-14.  Reinitialize Subscription

5 Click  OK when the message Subscription Reinitialized displays to close the 
dialog box. 

Figure 17-15.  Subscription Reinitialized
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Switching Database Connections
Subscribers have the option of switching database connections when logging into the PCS 
Axis software. This feature allows a subscriber to connect either to the subscription 
database on their local computer or the publication database on the company network 
server. It is intended for subscribers working from the company main office instead of a 
remote field office. 

IMPORTANT: Before switching database connections, the subscriber must first 
synchronize data between the publication and subscription databases. 

To switch database connections, follow these steps:

1 Synchronize data between the subscription and publication databases. 
Click Tools > Synchronize Now (Figure 17-16). 

Figure 17-16.  Synchronize Now

2 Click  OK when the message Synchronization Complete displays to complete 
the process (Figure 17-17). 

Figure 17-17.  Synchronization Complete
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3 Click  Log Out in the main menu. Then click  Yes when the Logout message 
displays. 

4 When the Login window displays, type your Windows password in the Password 
field and then complete one of the following steps to switch database connections 
(Figure 17-18): 

a To switch to the publication, click the check box Use Subscription to clear the 
check mark. 

–or–

b To switch to your subscription, click the check box Use Subscription to place 
a check mark inside the check box. 

5 Click the login button  to start PCS Axis. 

Figure 17-18.  PCS Axis Login
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Managing the Database

Information in this chapter explains how to manage the PCS Axis database. The 
information is intended for the PCS Axis Administrator or a user with SysAdmin 
permissions. Topics in this chapter include those in the following list: 

• Running Database Integrity Check

• Running Reindex Database (page 749)

Running Database Integrity Check
In the unlikely event data becomes corrupted in the database, use Database Integrity 
Check to identify and resolve instances of data inconsistencies. The process performs an 
audit of the database searching for issues that may prevent PCS Axis from loading or 
performing basic functions. Its purpose is to clean up data issues that may cause problems 
for users. For example, database issues the auditing process detects and corrects include:

• Orphan records.

• Invalid hierarchy nodes.

• Outdated or incorrect derived fields. See Working with Derived Fields (page 214) 
for information about derived fields. 

• Invalid field characters, hierarchy nodes, or folders outside hierarchy levels.

• Duplicate or missing right-of-ways (ROWs) and pipes. 

• Blank hierarchy level names and empty or missing hierarchy folders.

• Missing base effective dates (facilities and pipelines).

• Invalid foreign keys in database tables. (A foreign key is a field in a database table 
that refers to a record in another database table.) 

To run Database Integrity Check :
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• Click File > Database Integrity Check to open the Data Auditor window 
(Figure 18-1). Then click  Run. 

The message Running displays during the database audit process. 

Figure 18-1.  Data Auditor

When the process completes, the results of the database audit display in the Data 
Auditor window (Figure 18-2). You can select and then copy text in the window to 
the Windows clipboard. The copied text can then be pasted in another software 
program such as Microsoft Excel or Word. 

Figure 18-2.  Database Integrity Check Completed
748 Managing the Database



PCS Axis User and Administrator Guide
Running Reindex Database 
The PCS Axis database uses indexes to accelerate the process of locating records in the 
database. As you add and delete records, these indexes become fragmented which in turn 
slow down database performance. The Reindex Database process restores database 
efficiency by updating the indexes. 

IMPORTANT: Before running Reindex Database, it is recommended that you make a 
backup of the PCS Axis database using Microsoft SQL Server Management Studio (SSMS). 
For more information about SSMS, see the AI document entitled PCS Axis Database 
Backup and Restore. 

To run Reindex Database:

1 Click Tools > Job Service Viewer to open the Job Service Console window 
(Figure 18-3). 

2 Click  Reindex Database. 

Figure 18-3.  Job Service Console
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3 When a warning message opens, click  Yes to continue the reindexing process 
(Figure 18-4). 

Figure 18-4.  Warning Message

Status information displays in the queue while running Reindex Database 
(Figure 18-5). When the process completes, status information then displays in the 
Job History panel. 

Figure 18-5.  Reindex Database Running
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System Field Descriptions

Information in this chapter includes a description of PCS Axis fields. Fields that include Activate in the field 
name share the same description as their counterpart, such as Activate AC Power and AC Power. The 
Activate AC Power field must be added in the Information grid to enter data in the AC Power field in the 
Inspections grid. 

NOTE: The menu path included in some field descriptions may include the placeholder text <module>, 
such as Data Entry > Edit <module> Data. The placeholder text indicates the field description applies to 
more than one module, such as CPDM, VM, ACM, ICM, or LSM. 

Table A-1.  System Field Descriptions 

Name Description

AC Input Alternating Current Input. Voltage coming into the 
rectifier from a power source. See CPDM module, Data 
Entry > Edit CPDM Data > Rectifier Information grid 
> Customize > Layouts. 

AC P/S (Volts) Alternating Current Pipe-to-Soil. Potential measurement 
in volts. AC measurements are recorded using a 
voltmeter when conducting an AC CIS survey to 
determine AC interference from sources such as 
overhead power transmission lines near the pipeline. 
Also see AC CIS definition in Appendix B (page 781). 

See ISM, Data Entry > Edit ISM Data > AC CIS. 
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AC Power Alternating Current Power. Power consumed by a 
rectifier from a power source (watts). This value is 
system-supplied and calculated as follows: 

AC Power = 3600 x Kh Factor x Revolutions
Seconds

If the value for Kh Factor, Revolutions, or Seconds is 
unknown, the value for AC Power can be entered. The 
value can be up to six digits of resolution. Meter Kh 
carries to Kh Factor field when a reading is created. Add 
and enable Activate AC Power in the Rectifier 
Information grid to allow data entry in the Inspections 
grid. See CPDM module, Data Entry > Edit CPDM Data 
> Rectifier Information and Inspections grid > 
Customize > Layouts. 

AC Service Alternating Current Service. History information field 
that identifies the complete source of incoming AC 
power; such as data for AC voltage, AC current, number 
of phases and so on. See CPDM module Data Entry > 
Edit CPDM Data > Rectifier Inspections grid > 
Customize > Layouts. 

Account Power company account number. Can also be the 
customer’s account number for gas service. See CPDM 
module, Data Entry > Edit CPDM Data > Rectifier 
Inspections grid > Customize > Layouts. 

Activate Cardinal Points Add this field in the Tank Information grid, then enable 
the field’s check box to allow data entry in the Tank 
Inspection grid for the following fields: North P/S, South 
P/S, East P/S, and West P/S. See CPDM, Data Entry > 
Edit CPDM Data > Tank > Information and Inspection 
grids > Customize > Layouts. 

Activate Center P/S Activate Center Pipe-to-Soil Add this field in the Tank 
Information grid, then enable the field’s check box to 
allow data entry in the field Center P/S in the Tank 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Tank > Information and Inspection grids > 
Customize > Layouts. 

Activate Intercardinal 
Points

Add this field in the Tank Information grid, then enable 
the field’s check box to allow data entry in the Tank 
Inspection grid for the following fields: NE P/S, SE P/S, 
NW P/S, and SW P/S. See CPDM, Data Entry > Edit 
CPDM Data > Tank > Information and Inspection 
grids > Customize > Layouts. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Activate Mid P/S Activate Mid Pipe-to-Soil. Add this field in the Tank 
Information grid, then enable the field’s check box to 
allow data entry in the field Mid P/S in the Tank 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Tank > Information and Inspection grids > 
Customize > Layouts. 

Activate Secondary 
Intercardinal Points

Add this field in the Tank Information grid, then enable 
the field’s check box to allow data entry in the Tank 
Inspection grid for the following fields: ENE P/S, ESE P/S, 
NNE P/S, NNW P/S, SSE P/S, WNW P/S, and WSW P/S. 
See CPDM, Data Entry > Edit CPDM Data > Tank > 
Information and Inspection grids > Customize > 
Layouts. 

Address System calculated field based on information entered in 
the following fields: Address Post-Direction; Address 
Pre-Direction; Address Street; Address Street Number; 
and Address Suffix. This field is available for use in all 
modules and can be added in the Information grid. See 
Data Entry > Edit <module> Data > Information grid 
> Customize > Layouts. 

Address Pre-Direction Tag at the beginning of a street name used to indicate 
direction, such as 125 E Grand Bluff St. NW, where E is 
the pre-direction. This field is available for use in all 
modules and can be added in the Information grid. See 
Data Entry > Edit <module> Data > Information grid 
> Customize > Layouts. 

Alignment Sheet Number Record number assigned to an alignment sheet for a 
pipeline right-of-way. Add this field in either the Rectifier 
Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information or 
Inspection grids > Customize > Layout. 

Allegro Survey 
Information

System-generated field showing properties in a close 
interval survey file transferred from the Allegro. 
Properties include configuration settings, ROW code, 
survey date, surveyor, type of survey, and so on. 

Anomaly Direction If survey readings were taken at regular intervals during 
an ACVG survey, use this field to indicate if the anomaly 
is in front of or behind the surveyor. This field does not 
apply to ACVG surveys that only record an ACVG point at 
the anomaly. Typical entries for this field are Forward or 
Reverse. 

See ISM, Data Entry > Edit Indirect Survey Data > 
ACVG grid. 

Table A-1.  System Field Descriptions (continued)

Name Description
System Field Descriptions 755



PCS Axis User and Administrator Guide
APB (Ppm) Acid Reducing Bacteria parts-per-million. Measurement 
of APB in parts-per-million (Ppm). Add Activate APB 
(Ppm) in the Information grid to allow data entry in the 
Inspections grid. See ICM, Data Entry > Edit ICM Data 
> Samples > Information and Inspection grids > 
Customize > Layouts.

Apparent Leak Location Leak location. See LSM, Data Entry > Edit LSM Data > 
Maintenance grid > Customize > Layouts. 

Attached Documents Use this field to attach or link a document to a record in 
the grid. This field is available in all modules. See 
Attaching a Document to a Grid Record (page 317). 

Average P/S Average Pipe-to-Soil. Reading measured in volts. Add 
the field Activate Average P/S in the Test Point 
Information grid to enable data entry in the Average P/S 
field in the Test Point Inspection grid. See CPDM, Data 
Entry > Edit CPDM Data > Test Point Information and 
Inspection grid > Customize > Layouts. 

Bond Current Adjusted Click the check box to indicate a change was made to the 
bond current. This field works in conjunction with the 
fields Bond Current Found and Bond Current Left when 
the Activate field for both of these fields has been added 
in the Information grid. 

When adjusting the bond current (1) click the Bond 
Current Adjusted check box; (2) enter the pre-adjusted 
value (in amps) in the field Bond Current Found; and 
then (3) enter the adjusted value (in amps) in the field 
Bond Current Left. See CPDM, Data Entry > Edit 
CPDM Data > Foreign Bond Information and 
Inspection grid > Customize > Layouts. 

Bond Current Found Bond current measured during an inspection (in Amps). 
This field works in conjunction with the fields Bond 
Current Adjusted and Bond Current Left when the 
Activate field for both of these fields has been added in 
the Foreign Bond Information grid. See CPDM, Data 
Entry > Edit CPDM Data > Foreign Bond Information 
and Inspection grid > Customize > Layouts. 

Bond Current Left Bond current measured after an inspection (in Amps). 
This field works in conjunction with the fields Bond 
Current Adjusted and Bond Current Found when the 
Activate field for both of these fields has been added in 
the Foreign Bond Information grid. See CPDM, Data 
Entry > Edit CPDM Data > Foreign Bond Information 
and Inspection grid > Customize > Layouts. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Bond Shunt Factor Multiplying factor measured in Amps. Used in converting 
the voltage drop across the shunt to current. Voltage 
drop and shunt resistance are used to calculate the 
current. Add the Bond Shunt Factor field in either the 
Foreign Bond Information or Inspection grid. See CPDM, 
Data Entry > Edit CPDM Data > Foreign Bond 
Information and Inspection grid > Customize > 
Layouts.

Bond Shunt Rating Shunt size measured in millivolts and Amps (mV/A). Add 
the field in either the Foreign Bond Information or 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Foreign Bond Information and Inspection grid 
> Customize > Layouts. 

Bond Shunt Resistance Shunt resistance measured in Ohms. Add the field in 
either the Foreign Bond Information or Inspection grid. 
See CPDM, Data Entry > Edit CPDM Data > Foreign 
Bond Information and Inspection grid > Customize > 
Layouts.

Bond Type Type of bond, such as resistance or direct. Add the field 
in either the Bond Information or Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Foreign Bond 
Information and Inspection grid > Customize > 
Layouts.

Casing IRF Casing IR free (IRF) reading. Voltage measurement 
indicating the potential of the casing relative to the soil 
with interrupted rectifier current. Add the field Activate 
Casing IRF in the Test Point Information grid to enable 
data entry in the Casing IRF field in the Test Point 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Information and Inspection grid > 
Customize > Layouts. 

Casing IRF Minimum and 
Maximum

Minimum and maximum value allowed for data entry in 
the Casing IRF field. Add the fields Casing IRF Minimum 
and Casing IRF Maximum in either the Test Point 
Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Test Point Information or 
Inspection grid > Customize > Layouts. 

Casing P/S Casing Pipe-to-Soil. Voltage measurement indicating the 
potential of the casing relative to the soil. Add the field 
Activate Casing P/S in the Information grid to enable 
data entry in the Casing P/S field in the Inspection grid. 
See CPDM, Data Entry > Edit CPDM Data > Test Point 
Information and Inspection grid > Customize > 
Layouts. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Casing P/S Minimum and 
Maximum

Minimum and maximum value allowed for data entry in 
the Casing P/S field. Add the fields Casing P/S Minimum 
and Casing P/S Maximum in either the Test Point 
Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Test Point Information or 
Inspection grid > Customize > Layouts. 

Casing Status Status of the casing, such as short, not short, electrolytic, 
or metallic. Add the field Activate Casing Status in the 
Information grid to enable data entry in the Casing 
Status field in the Inspection grid. See CPDM, Data 
Entry > Edit CPDM Data > Test Point Information and 
Inspection grid > Customize > Layouts. 

Center P/S Center Pipe-to-Soil. Structure reading in volts when a 
half-cell is under the center of the tank. Add the field 
Activate Casing P/S in the Information grid to enable 
data entry in the Casing P/S field in the Inspection grid. 
See CPDM, Data Entry > Edit CPDM Data > Tank 
Information and Inspection grid > Customize > 
Layouts. 

Center P/S Minimum and 
Maximum

Minimum and maximum value (voltage reading) allowed 
for data entry in the Center P/S field. Add the fields 
Center P/S Minimum and Center P/S Maximum in either 
the Tank Information or Inspection grid. See CPDM, 
Data Entry > Edit CPDM Data > Tank Information or 
Inspection grid > Customize > Layouts. 

City City where a facility is located. This field is available for 
use in all modules; add the field in either the Information 
or Inspection grid. See Data Entry > Edit <module> 
Data > Information or Inspection grid > Customize > 
Layouts. 

Close Direction Direction the valve wheel turns to close the valve. Enter 
data such as CW for clockwise or CCW for counter 
clockwise. See VM, Data Entry > Edit VM Data > 
Information or Inspection grid > Customize > 
Layouts. 

Coating Type of coating applied to the pipeline, such as tape or 
epoxy. Add this field in either the Information or 
Inspection grid. See ACM, Data Entry > Edit ACM Data 
> Information or Inspection grid > Customize > 
Layouts. 

Coating Condition Description of coating condition. See ACM, Data Entry 
> Edit ACM Data > Inspection grid > Customize > 
Layouts. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Coke Breeze Type Type of coke breeze, such as metallurgical and 
petroleum-based. See CPDM, Data Entry > Edit CPDM 
Data > Rectifier Information, Inspection, or 
Maintenance grid > Customize > Layouts. 

Coke Breeze Type Type of coke breeze such as metallurgical and 
petroleum-based. Add this field in either the Rectifier 
Information or Inspection grid. 

See CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Information or Inspection grids > Customize > 
Layout. 

Completed Maintenance Total number of maintenance records for a facility that 
have the field Completed Date populated. This is a read-
only, facility level calculated field. Add this field in the 
Rectifier Information, Inspection, or Maintenance grid. 

See CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Information, Inspection, or Maintenance grids > 
Customize > Layouts. 

Conductivity Numeric field supporting decimal numbers with up to 7 
digits resolution, including two numbers after the 
decimal. Use this field to record conductivity 
measurements as measured by the inspection tool 
during a Soil Resistivity survey. Measurements are in 
microSiemens (µS), a metric unit of measurement for 
conductivity. 

See ISM module, Data Entry > Edit ISM Data > Soil 
Resistivity.

Connection Type Type of connection used to secure a valve to the 
pipeline. 

See VM, Data Entry > Edit VM Data > Information or 
Inspection grid > Customize > Layouts.

Contact Name of a contact person at the company responsible 
for the foreign bond. 

See CPDM, Data Entry > Edit CPDM Data > Foreign 
Bond Information grid > Customize > Layouts.

Creation Date Date a facility record was created in a grid. Add this field 
in either the Rectifier Information or Inspection grid. 

See CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Information or Inspection grids > Customize > 
Layouts. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Critical Bond Check box for indicating if a bond is critical based on 
location and connection. Critical bond is used in 
scheduling. Click to place a check mark inside the check 
box if the bond is considered a critical bond. 

See CPDM, Data Entry > Edit CPDM Data > Foreign 
Bond Information, Inspection, or Maintenance grid > 
Customize > Layouts. 

Days Since First Bad 
Reading

Derived field showing the number of days since the first 
bad reading (reading does not meet criteria). Field 
available in all modules in the Information or 
Inspection data entry grid. See Working with Derived 
Fields (page 214). 

Days Since Last Good 
Reading

Derived field showing the number of days since the last 
good reading (reading meets criteria). Field available in 
all modules in the Information or Inspection data entry 
grid. See Working with Derived Fields (page 214). 

Days Until Delinquent Read-only, system calculated field. Number of days until 
a facility inspection becomes delinquent. Field is 
available in all modules. 

See Data Entry > Edit <module> Data > Information 
or Inspection grid > Customize > Layouts. 

Decibel Reading (dB) Decibel reading measured in millibels (mB, decibel 
microvolts) by the inspection tool using the A-Frame 
method during an ACVG survey. 

See ISM, Data Entry > Edit ISM Data > ACVG. 

Default Location Format Read-only field showing the format used in numbering 
facilities on a pipeline segment. Default Location Format 
is set up before adding or linking facilities to a pipeline 
segment. Valid entries are: Metric Milepost, Milepost (4 
decimals), Location ID, Milepost (3 decimals), Miles/
Station Number, Reading Number, and Station 
Number. 

Default Location Format is available in all modules. See 
Data Entry > Edit <module> Data > Information or 
Inspection grid > Customize > Layout. 

Delinquent Date From 
Schedule

Read-only field showing the date a facility becomes 
delinquent based on scheduling properties set up in Edit 
Schedule Settings (Data Entry > Edit Schedule 
Settings). This field is available in all modules. See Data 
Entry > Edit <module> Data > Information or 
Inspection grid > Customize > Layout. 

Table A-1.  System Field Descriptions (continued)

Name Description
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Depth Numeric field supporting decimal numbers with up to 6 
digits resolution, including two numbers after the 
decimal. Use this field to enter the pipeline depth 
reading in inches as measured by the PCM inspection 
tool during an ACCA survey. 

See ISM, Data Entry > Edit ISM Data > ACCA. 

Diameter Distance from wall to wall across a tank. See CPDM, 
Data Entry > Edit CPDM Data > Tank Information, 
Inspection or Maintenance grid > Customize > 
Layouts.

Diode Rating Amperage rating of the diode in the rectifier. See CPDM, 
Data Entry > Edit CPDM Data > Information or 
Inspection grid > Customize > Layout. 

Due Date From Schedule Date a facility is scheduled for survey based on settings 
in Edit Schedule Settings (Data Entry >Edit Schedule 
Settings). This field is available for use in all modules; 
add the field in either the Information or Inspection grid. 

See Data Entry > Edit <module> Data > Information 
or Inspection grid > Customize > Layouts.

Due Date From Schedule Read-only field showing the date a facility is due for 
inspection based on scheduling properties set up in Edit 
Schedule Settings (Data Entry > Edit Schedule 
Settings). This field is available in all modules. See Data 
Entry > Edit <module> Data > Information or 
Inspection grid > Customize > Layout. 

East P/S East Pipe-to-Soil. Structure reading in volts when a half-
cell is placed near the east side of a tank. Add and 
enable Activate Cardinal Points in the Information grid to 
allow data entry in the Inspections grid. See CPDM, Data 
Entry > Edit CPDM Data > Tank > Information and 
Inspection grids > Customize > Layouts. 

East P/S Maximum/
Minimum

Maximum and minimum voltage value allowed for data 
entry in the field East P/S in the Tank Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Tank > 
Information or Inspection grid > Customize > 
Layouts. 
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Effective Date Required system field automatically present in all grids. 
Effective Date is the date a history record becomes 
effective. New history records are created with an 
Effective Date when important permanent information 
changes. For example, changes to important permanent 
information include changing the protection criteria 
value for a test point; changing the operational status 
from active to inactive or vice versa; and when a pipeline 
becomes inactive or is taken out of service.

For more information, see Creating History Records 
Using an Effective Date (page 233). 

Efficiency System-provided value that is calculated using the 
formula shown below. A value can be manually entered, 
but is not recommended. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier > Information or Inspection 
grid > Customize > Layouts. 

Rectifier Output Volts Left x Rectifier Output Current Left x 100
AC Power (Watts)

Efficiency Filter Check box for indicating whether or not a rectifier is 
using an efficiency filter. Click to place a check mark 
inside the check box when an efficiency filter is present. 
See CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Information or Inspection grid > Customize > 
Layouts. 

Elevation Elevation in feet for a facility, survey point, or anomaly 
on a pipeline as reported by a GPS device. This field is 
available for use in all modules. 

See Data Entry > Edit <module> Data > Information 
or Inspection grid > Customize > Layouts.

End Date Last day of a start and end date range, such as a start 
date of 05/04/2012 and an end date of 08/06/2012. A 
date range is typically used when generating a schedule 
or when defining a survey folder. This field is available in 
all modules. 

See Data Entry > Edit <module> Data > Information 
or Inspection grid > Customize > Layout. 
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Existing Facilities An existing facility is a milepost in an imported 
stationary survey that matches an existing milepost in 
PCS Axis for the currently selected ROW (pipeline 
segment). Existing facilities are used in telluric 
compensation. Also refer to Unregistered Milepost. See 
CPDM, Data Entry > Stationary Survey Maintenance > 
Snap To Facility. 

Facility Active Check box to indicate whether or not a facility is active or 
inactive according to survey status. Add this field in 
either the Information or Inspection grid. 

See CPDM, Data Entry > Edit CPDM Data > 
Information or Inspection grid > Customize > 
Layouts. 

Facility and ROW 
Currently Active

Read-only system field showing the status of linked 
facilities on a ROW. Check box indicates whether or not a 
facility and ROW are active or inactive based on survey 
status. Add this field in either the Information or 
Inspection grid. 

See CPDM, Data Entry > Edit CPDM Data > 
Information or Inspection grid > Customize > 
Layouts.

Facility Attached 
Document

Field for attaching a file (document or image) or Internet 
link to a facility or ROW. File attachment or link can be 
previewed or edited in PCS Axis with the appropriate 
viewer or file editor if installed locally on the computer. 

Use this field to link or embed a file attachment and 
detach an attached file. This field is available in all 
modules and can be added in the Information, 
Inspection, and Maintenance grids. See any module, 
Data Entry > Edit <module> Data > Information, 
Inspection, or Maintenance grid > Customize > 
Layout. 

Facility Delinquent Date Date a facility is considered to be past due for 
inspection. This is a PCS Axis calculated field based on 
schedule settings set up in Edit Schedule Settings (Data 
Entry > Edit Schedule Settings). Available for use in all 
modules; add the field in either the Information or 
Inspection grid. See Data Entry > Edit <module> Data 
> Information or Inspection grid > Customize > 
Layouts. 
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Facility ID Identification code that identifies a facility. This field is 
available for use in all modules; add the field in either 
the Information or Inspection grid. See Data Entry > 
Edit <module> Data > Information or Inspection grid 
> Customize > Layouts. 

Foreign IRF Foreign IR free reading. Voltage measurement indicating 
the potential of a foreign line at a foreign line crossing 
relative to the soil with interrupted rectifier current. 

Add and enable Activate Foreign IRF in the Test Point 
Information grid to allow data entry in the Inspections 
grid. See CPDM, Data Entry > Edit CPDM Data > Test 
Point > Information and Inspection grids > Customize 
> Layouts. 

Foreign P/S Foreign Pipe-to-Soil. Potential reading of foreign line at a 
foreign line crossing relative to the soil. Use this field to 
enter pipe-to-soil “on” measurements taken at a site with 
all DC sources operational. 

Add and enable Activate Foreign P/S in the Test Point 
Information grid to allow data entry in the Inspections 
grid. See CPDM, Data Entry > Edit CPDM Data > Test 
Point > Information and Inspection grids > Customize 
> Layouts. 

Galvanic Anode Initial 
Current

Initial current output at install. Additional readings 
should be recorded in the field Galvanic Current in the 
Galvanic Anode Inspection grid. 

To record data in the Galvanic Current field in the 
Inspection grid: (1) add Activate Galvanic Current in the 
Information grid, then enable the field’s check box, (2) 
add the field Galvanic Current in the Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Galvanic 
Anode > Information and Inspection grids > 
Customize > Layouts. 

Galvanic Anode Shunt 
Factor

Amperage value of the galvanic anode shunt factor. 
Shunt factor includes the value in this field and the 
millivolt/amperage (mV/A) value entered in the Galvanic 
Anode Shunt Rating field. 

Add the fields Galvanic Anode Shunt Factor and Galvanic 
Anode Shunt Rating in either the Information or 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Galvanic Anode > Information or Inspection 
grids > Customize > Layouts. 
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Galvanic Anode Size Weight in pounds (lbs) of sacrificial anode. Add this field 
in either the Information or Inspection grid. See CPDM, 
Data Entry > Edit CPDM Data > Galvanic Anode > 
Information or Inspection grids > Customize > 
Layouts. 

Galvanic Anode To Soil Driving potential of the anode relative to the soil. Value 
entered in volts. Add this field in either the Information 
or Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Galvanic Anode > Information or Inspection 
grids > Customize > Layouts. 

Galvanic Anode Type Type of anode such as magnesium, aluminum, or zinc. 
Add this field in the Information or Inspection grid. See 
CPDM, Data Entry > Edit CPDM Data > Galvanic 
Anode > Information or Inspection grids > Customize 
> Layouts. 

Galvanic Current 
Maximum/Minimum

Maximum and minimum current output. See CPDM, 
Data Entry > Edit CPDM Data > Galvanic Anode > 
Information or Inspection grids > Customize > 
Layouts. 

Galvanic Number of 
Anodes

Rectifier facilities: Number of impressed current anodes 
at a rectifier/ground bed installation. If there are multiple 
ground beds at a rectifier, this will be the total number of 
anodes associated with that rectifier. 

Galvanic Anodes: Number of sacrificial anodes at a 
galvanic anode installation. 

See CPDM, Data Entry > Edit CPDM Data > Galvanic 
Anode > Information or Inspection grids > Customize 
> Layouts.

Gas Indicator Leak Test Remark field in the LSM module for describing the 
condition of the valve coating at inspection. 

To record data in the field Gas Indicator Leak Test in the 
Inspection grid: (1) add the field Activate Gas Indicator 
Leak Test in the Information grid, then enable the field’s 
check box, (2) add the field Gas Indicator Leak Test in the 
Inspection grid. See LSM, Data Entry > Edit LSM Data 
> Information and Inspection grids > Customize > 
Layouts. 
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Holiday Use this field to indicate a survey location with a pipeline 
coating anomaly (hole) as detected by the inspection 
tool during an ACVG survey. A check mark inside the 
check box indicates a survey location with a holiday. To 
remove the check mark, click the check box again. 

See ISM module, Data Entry > Edit ISM Data > ACVG. 

Indication Classification Use this field to classify or prioritize the severity of an 
indication. For example, classifications such as minor, 
moderate, severe, immediate, scheduled, or monitored 
might be used to prioritize the severity of indications. 
Typical indications include coating faults, holidays, 
corrosion activity, electrical shorts, interference, geologic 
current shielding, and other types of anomalies that have 
been discovered during an above ground, indirect 
survey. 

If your company uses a coding system for describing the 
severity of indications, you can type the code in the field; 
select the code and its description from a drop-down list 
if a picklist has previously been setup in Field and UDF 
Customizations (page 61); or import the code in PCS 
Axis using Bridge (page 453). 

Indication Score Alphanumeric field that accepts up to two characters, 
numbers, or a combination of both. Use this field to 
rank, prioritize, quantify the actual size, or grade the 
severity of an indication classification. 

Inspection Remarks Survey comment associated with a facility, anomaly, or 
landmark. Field is available for use in all modules. See 
any module, Data Entry > Edit <module> Data > 
Inspection > Customize > Layouts. 

Insulator IRF Insulator IR Free. Voltage measurement indicating the 
potential of an insulated flange relative to the soil with 
interrupted rectifier current. 

Add and enable Activate Insulator IRF in the Test Point 
Information grid to allow data entry in the Inspections 
grid. See CPDM, Data Entry > Edit CPDM Data > Test 
Point > Information and Inspection grids > Customize 
> Layouts.
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Insulator P/S Insulator Pipe-to-Soil. Potential reading for the other 
side of an insulated flange, relative to the soil. Also 
referred to as an “insulator-to-soil” potential reading. 

Add and enable Activate Insulator P/S in the Test Point 
Information grid to allow data entry in the Inspections 
grid. See CPDM, Data Entry > Edit CPDM Data > Test 
Point > Information and Inspection grids > Customize 
> Layouts.

Insulator Shunt Factor Amperage value of the insulator shunt factor. Shunt 
factor consists of the value in this field and the value 
(mV/A) in the field Insulator Shunt Rating. 

See CPDM, Data Entry > Edit CPDM Data > Test Point 
> Information or Inspection grid > Customize > 
Layouts.

IR (percentage) Numeric field supporting a 5 digit decimal number, 
including two numbers after the decimal. Use this field 
to enter a value that represents the estimated size or 
severity of a holiday as a percentage. The value you enter 
is the difference between the over-the-line (OTL) to 
remote earth (RE) readings divided by the signal 
strength (SS) of the voltage gradient at the anomaly. 

IR (percentage) = (OTL – RE or RE – OTL) ÷ SS at anomaly 

See ISM, Data Entry > Edit ISM Data > DCVG.

Is Gps Time Read-only field indicating whether or not the P/S and 
IRF (ON/OFF) inspection date and time is GPS time. See 
CPDM, Data Entry > Edit CPDM Data > Test Point 
Detail Inspection mini-grid. 

KWH Meter Kilowatt hours (KWH) recorded from a power meter for 
rectifier power usage. Add and enable Activate KWH 
Meter in the Rectifier Information grid to allow data 
entry in the Inspections grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information and 
Inspection grid > Customize > Layouts. 

Latitude Numeric field that accepts up to twelve digits. Use this 
field to enter data that identifies the GPS latitude 
coordinate (north/south) for a test point, rectifier, bond, 
anomaly, or other location type on a pipeline. Field is 
available in all modules. 

Level 1 Name through 
Level 5 Name

User setting for the names of the system hierarchy levels. 
PCS Axis supports up to five hierarchy levels. See Tools > 
Customize > Hierarchy. 
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Locate Current (mA) Use this field to enter a current reading in milliamps 
(mA) as measured by the PCM inspection tool for survey 
points located directly over the pipeline during an ACCA 
survey. 

See ISM, Data Entry > Edit ISM Data > ACCA. 

Location Code Alphanumeric code assigned to a pipeline segment. The 
field accepts up to five alphanumeric characters. 

Location Code is available for use in all modules and can 
be added in either the Information or Inspection grid. 
See Data Entry > Edit <module> Data > Information 
or Inspection grid > Customize > Layouts. 

Log Number Numeric field that supports up to 6 digits. This field is 
typically used for sequential log numbers generated by a 
PCM (pipeline current mapper) data logger for survey 
readings taken during an ACCA survey. 

See ISM, Data Entry > Edit ISM Data > ACCA. 

Longitude Numeric field that accepts up to twelve digits. Use this 
field to enter data that identifies the GPS longitude 
coordinate (east/west) for a test point, rectifier, bond, 
anomaly, or other location type on a pipeline. Field is 
available in all modules. 

Loss per Distance (dB/Ft) Numeric field supporting positive or negative decimal 
numbers with up to 5 digits resolution, including 2 
numbers after the decimal. Use this field to enter the “dB 
loss per foot” value as calculated by the PCM inspection 
tool during an ACCA survey. The calculated value 
indicates the “current loss per distance ratio”. 

See ISM, Data Entry > Edit ISM Data > ACCA.

Manufacturer Manufacturer of the rectifier being installed. See CPDM 
module, Data Entry > Edit CPDM Data > Rectifier 
Inspections grid > Customize > Layouts. 

Milepost Number representing a testing or facility location on a 
pipeline such as 23+123. May also be referred to as 
station number, milepost marker, or station marker. 

See Tools > Customize > General > User Location 
Name. 

Native P/S Native Pipe-to-Soil. Voltage reading taken prior to any 
current placed on the pipeline. Also referred to as 
depolarized or static potential. 
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Negative Shunt Factor Amperage value of the negative shunt factor. This field is 
available in the Rectifier Negative Inspections mini-grid. 
See CPDM, Data Entry > Edit CPDM Data > Rectifier 
Inspections grid > Rectifier Negative Inspections 
mini-grid. 

Number of Crossings PCS Axis calculated field showing the total number of 
crossings, such as road crossings, railroad crossings, 
foreign pipeline crossings, and fence lines. See CPDM, 
Data Entry > Edit CPDM Data > Test Point > 
Information or Inspection grid > Customize > 
Layouts. 

Number of Leaks Numeric field for entering the number of leaks. Add the 
field Activate Number of Leaks in the Information grid to 
allow data entry in the Inspection grid. See LSM, Data 
Entry > Edit LSM Data > Information and Inspection 
grid > Customize > Layouts. 

Number of Negatives PCS Axis calculated field in either the Rectifier 
Information or Inspection grid. This field shows the 
number of negatives in the Rectifier Negative 
Information mini-grid. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier > Information or Inspection 
grid > Customize > Layouts. 

Number of Readings in 
Survey

A derived field showing the total number of survey 
readings in a continuous survey. See continuous survey 
types CIS, AC CIS, DCVG and so on in Indirect Survey 
Manager (ISM). Also see Working with Derived Fields 
(page 214). 

Number of Turns Number of turns to open a valve. Add the field Activate 
Number of Turns in the Information grid to allow data 
entry in the Inspection grid. See VM, Data Entry > Edit 
VM Data > Information and Inspection grid > 
Customize > Layouts. 

Off Delta A value showing the difference between the 
uncompensated and compensated OFF values.

On Delta A value showing the difference between the 
uncompensated and compensated ON values. 

Original Station Number The initial or original station number before re-aligning 
station numbers using the Rubber Banding feature in 
Survey Maintenance. 

See ISM, Data Entry > Edit ISM Data > Survey 
Maintenance. 
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OTL to Remote Earth (mV) Over-the-Line to Remote Earth. Use this field to enter a 
value in millivolts (mV) that represents the sum of all side 
drain measurements taken during a DCVG survey for a 
survey point on the pipeline. 

See ISM, Data Entry > Edit ISM Data > DCVG. 

P/S Offset Pipe-to-Soil Offset.l Offset added to a pipe-to-soil (P/S) 
reading collected on the Allegro field computer. Use this 
field when using a permanent reference cell other than 
copper-copper sulfate. PCS Axis uses the value to 
convert the reading to the equivalent copper-copper 
sulfate reading. See CPDM, Data Entry > Edit CPDM 
Data > Test Point > Information or Inspection grid > 
Customize > Layouts. 

Parallel Line Two (2) pipelines within the same ROW (right-of way) 
and parallel to each other. Use the fields Pipeline Code 
and Pipeline Name in Select ROWs to identify a parallel 
pipeline. Also see Pipe, Pipeline Code, and Pipeline 
Name. 

PBN Dial Reading Measurement reading taken at inspection. Add the field 
Activate PBN Dial Reading in the Information grid to 
allow data entry in the Inspection grid. See ICM, Data 
Entry > Edit ICM Data > Probe > Information and 
Inspection grid > Customize > Layouts. 

PCM Current (dB) Numeric field that supports decimal numbers with up to 
6 digits resolution, including two numbers after the 
decimal point. Use this field to enter the PCM current 
reading as measured in mA and dB by the PCM 
inspection tool during an ACCA survey. 

See ISM, Data Entry > Edit ISM Data > ACCA.

PCS Field Name Selection list that allows you to choose the type of 
potential reading associated with a test lead record in 
the Test Point Detail Information and Inspection mini-
grid. The test lead inspection record controls which ON/
OFF values copy to the Inspection grid P/S and IRF fields 
for compliance reporting. See CPDM, Data Entry > Edit 
CPDM Data > Test Point Detail Information and 
Inspection mini-grids. 
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Pearson Continuous (indirect) survey that uses an electrical 
method for locating holidays in the pipeline coating by 
applying an AC signal on the pipeline and the reception 
of the signal by two surveyors wearing metal cleats and 
connected to a Pearson receiver. 

See ISM, Data Entry > Edit ISM Data > Pearson. 

Periodic Survey A survey conducted more often than every 12 months, 
such as monthly or bi-monthly rectifier surveys. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Inspection grid > Customize > Layouts. 

Periodic Survey Year Year a periodic survey is performed. See CPDM, Data 
Entry > Edit CPDM Data > Rectifier > Inspection grid 
> Customize > Layouts. 

Permanent Comments Comments permanently associated with a facility. This 
type of comment does not typically change during each 
survey year. This field is available for use in all modules 
and can be added in the Information grid. See Data 
Entry > Edit <module> Data > Information grid > 
Customize > Layouts. 

NOTE: Comments that apply to a particular survey 
should be entered in the Survey Remarks field. 

Phone Number Phone number of the person to contact at another 
company about a foreign bond. See CPDM, Data Entry 
> Edit CPDM Data > Foreign Bond > Information or 
Inspection grid > Customize > Layouts. 

Pipe Two digit alphanumeric code used to identify a parallel 
pipeline in a common ROW with an existing pipeline. 
Also see Pipeline Code, Pipeline Name, and Parallel 
Line. 

Pipeline Code Two digit alphanumeric code used to identify a parallel 
pipeline in a common ROW with an existing pipeline. 
Also see Pipe, Pipeline Name, and Parallel Line. 

Pipeline Name Name of a parallel pipeline in a common ROW with an 
existing pipeline. Also see Pipe, Pipeline Code, and 
Parallel Line. 
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Plot This Point Use this field to include or exclude continuous survey 
readings in reports and graphs. To include a survey 
reading, click the check box to place a check mark in the 
check box. To exclude a survey reading, clear the check 
mark by clicking the check box. This field is enabled by 
default with all survey readings included in reports and 
graphs. 

See ISM, Data Entry > Edit ISM Data > any survey type. 

Polarity Direction of current flow at a foreign bond. Add the field 
Activate Polarity in the Information grid to allow data 
entry in the Inspection grid. 

See CPDM, Data Entry > Edit CPDM Data > Foreign 
Bond > Information and Inspection grid > Customize 
> Layouts. 

Power Company Phone 
Number 

Phone number of the power company for a rectifier 
installation site. See CPDM, Data Entry > Edit CPDM 
Data > Rectifier > Information or Inspection grid > 
Customize > Layouts. 

Pre-Install P/S Pipe-to-soil reading taken before installation of galvanic 
anodes. See CPDM, Data Entry > Edit CPDM Data > 
Galvanic Anode > Information or Inspection grid > 
Customize > Layouts. 

Property Rights Code that identifies any property rights that might 
impact inspection or access to a pipeline. The field 
supports up to 10 alphanumeric characters including 
spaces, such as B #1234567. See LSM, Data Entry > Edit 
LSM Data > Maintenance grid > Customize > 
Layouts. 

Rectifier Anode Size Dimensions of impressed current anodes such as 3 x 60. 
Add the field in either the Rectifier Information or 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Rectifier > Information or Inspection grids > 
Customize > Layouts. 

Rectifier Anode Type Type of anode such as graphite or high silicon material. 
Add the field in either the Rectifier Information or 
Inspection grid. See CPDM, Data Entry > Edit CPDM 
Data > Rectifier > Information or Inspection grids > 
Customize > Layouts. 
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Rectifier Current Adjusted Check box for indicating a change was made to the 
rectifier current at inspection. When a change is made 
(1) click to add a check mark in the Rectifier Current 
Adjusted check box, (2) enter the adjusted reading in the 
fields Rectifier Output Volts Left and Rectifier Output 
Current Left. See CPDM, Data Entry > Edit CPDM Data 
> Rectifier > Inspection grids > Customize > Layouts. 

Rectifier Current Density A calculated report field indicating the amount of 
current required per square foot to change a structure’s 
potential to –0.85 volts. 

Rectifier Current 
Distributions

Number of pipelines receiving current from a rectifier. 
This field is generated by PCS Axis as current 
distributions are added. See CPDM module, Reports/
Graphs > Survey Report. 

Rectifier Output Current 
Found

Initial rectifier reading at inspection measured in Amps. 
Add the field Activate Rectifier Output Current Found in 
the Information grid to allow data entry in the Inspection 
grid. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Information and Inspection grids > 
Customize > Layouts. 

NOTE: PCS Axis multiplies the initial rectifier reading by 
the rectifier shunt factor when the fields Rated Rectifier 
Output Volts and Rated Rectifier Output Current are 
populated in the Rectifiers Information grid. 

Rectifier Output Current 
Found Maximum/
Minimum

Maximum and minimum value (measured in Amps) 
allowed for data entry in the field Rectifier Output 
Current Found. Add the fields in either the Rectifier 
Information or Inspection grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information or 
Inspection grids > Customize > Layouts. 

Rectifier Output Current 
Left

Rectifier reading after making adjustments to the 
rectifier output current at inspection (measured in 
Amps). Also see description for Rectifier Output Current 
Found. See CPDM, Data Entry > Edit CPDM Data > 
Rectifier > Inspection grids > Customize > Layouts. 

Rectifier Output Shunt 
Factor

Amperage value of the anode shunt factor. Refers to the 
shunt used to measure the output current of each anode 
in a positive junction box. Shunt factor includes the value 
in this field and the value entered in the field Rectifier 
Output Shunt Rating. See CPDM, Data Entry > Edit 
CPDM Data > Rectifier > Information or Inspection 
grids > Customize > Layouts. 
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Rectifier Output Volts 
Found

Initial rectifier reading at inspection measured in volts. 
Add and enable the field Activate Rectifier Output Volts 
Found in the Rectifier Information grid to allow data 
entry in the Inspections grid. Also refer to the 
description Rectifier Current Adjusted. See CPDM, Data 
Entry > Edit CPDM Data > Rectifier > Information 
and Inspection grids > Customize > Layout. 

Rectifier Output Volts 
Found Maximum/
Minimum

Maximum and minimum voltage value allowed for data 
entry in the field Rectifier Output Volts Found. See 
CPDM, Data Entry > Edit CPDM Data > Rectifier > 
Information or Inspection grids > Customize > 
Layouts.

Rectifier Output Volts Left See description for Rectifier Current Adjusted. 

Repair Priority Code number for identifying how soon repair work 
should begin. The field accepts up to five alphanumeric 
characters including spaces, such as A #123. This field is 
available for use in all modules. See Data Entry > Edit 
<module> Data > Maintenance grid > Customize > 
Layouts. 

Revolutions Number of times a power meter wheel has rotated in a 
specific time period. This field is used to calculate the 
value in the Efficiency field. Add and enable the field 
Activate Revolutions in the Rectifier Information grid to 
allow data entry in the Inspections grid. See CPDM, Data 
Entry > Edit CPDM Data > Rectifier > Information 
and Inspection grids > Customize > Layout.

RFID Radio-frequency identification number populated either 
by transferring an Allegro Periodic Survey (PS) to PCS 
Axis or manual entry in a grid. This field is available for 
use in all modules. See Data Entry > Edit <module> 
Data > Information, Inspection, or Maintenance grid 
> Customize > Layouts. 

ROW Currently Active Check box for indicating when a pipeline is active or 
inactive according to survey status. Field is available for 
use in all modules. See Data Entry > Edit <module> 
Data > Information grid. 

Seconds Amount of time in seconds that has elapsed for the 
number of Revolutions. This field is used to calculate the 
value in the Efficiency field. Add and enable the field 
Activate Seconds in the Rectifier Information grid to 
allow data entry in the Inspections grid. See CPDM, Data 
Entry > Edit CPDM Data > Rectifier > Information 
and Inspection grids > Customize > Layout. 
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Series Use Series to adjust or shift milepost numbers for a 
pipeline when adding a pipeline extension, re-routing a 
pipeline, or designating two pipelines as parallel lines. 
The calculated milepost number resulting from a Series 
is referred to as Relative Milepost. See CPDM module 
Data Entry > Pipeline Series. 

Signal Strength Signal strength of the voltage gradient (IR drop) at 
survey points along the pipeline as measured in 
millivolts (mV) by a voltmeter during a DCVG survey. 

See ISM, Data Entry > Edit ISM Data > DCVG. 

Soil Resistivity (Ohm/cm) Use this field to record soil resistivity measurements 
along the pipeline. Measurements are in Ohm-
centimeters (Ohm/cm). 

See ISM, Data Entry > Edit ISM Data > Soil Resistivity. 

South P/S Structure reading in volts when a half-cell is placed near 
the east side of a tank. Add and enable Activate Cardinal 
Points in the Tank Information grid to allow data entry in 
the Inspections grid. 

See CPDM, Data Entry > Edit CPDM Data > Tank > 
Information and Inspection grids > Customize > 
Layouts. 

South P/S Maximum/
Minimum

Maximum and minimum voltage value allowed for data 
entry when entering a structure reading in the South P/S 
field. 

SRB Amount of sulfate-reducing bacteria (SRB) measured as 
parts per million (Ppm). Add and enable Activate SRB in 
the Samples Information grid to allow data entry in the 
Inspections grid. See ICM, Data Entry > Edit CPDM 
Data > Samples > Information and Inspection grids > 
Customize > Layouts. 

Start Date First day of a start and end date range, such as a start 
date of 05/04/2012 and an end date of 08/06/2012. A 
date range is typically used when generating a schedule 
or when defining a survey folder. This field is available in 
all modules. See Data Entry > Edit <module> Data > 
Information or Inspection grid.

Station Marker See description for Milepost. 
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Station Number Use this field to enter testing or facility location numbers 
on a pipeline (such as 23+124). Station numbers are also 
referred to as milepost, milepost marker, or station 
marker. 

Station Number 
Maximum

A derived field showing the highest station number from 
survey readings in a continuous survey. See continuous 
survey types CIS, AC CIS, DCVG and so on in Indirect 
Survey Manager (ISM). Also see Working with Derived 
Fields (page 214). 

Station Number 
Minimum

A derived field showing the lowest station number from 
survey readings in a continuous survey. 

Structure IRF and 
Structure IRF-CIS

Potential of the pipe, relative to the soil, with interrupted 
rectifier current (measured in volts). Use this field to 
enter pipe-to-soil “off” measurements taken at a site with 
all DC sources interrupted. 

See ISM, Data Entry > Edit ISM Data > CIS. 

In CPDM, add and enable Activate Structure IRF in the 
Test Point Information grid to allow data entry in the 
Inspections grid. 

Structure P/S and 
Structure P/S-CIS

Potential of the pipe relative to the soil measured in 
volts. Use this field to enter pipe-to-soil “on” 
measurements taken at a site with all DC sources 
operational. 

See ISM, Data Entry > Edit ISM Data > CIS. 

In CPDM, add and enable the field Activate Structure 
P/S in the Test Point Information grid to allow data 
entry in the Inspections grid. 

Surface Area Total length and width of the pipeline expressed in feet. 
This field is used to determine Efficiency in the Current 
Density report. See any module > Data Entry > Edit 
ROW Detail. 

Surface Condition Surface condition of the pipeline. The field accepts up to 
five alphanumeric characters. See LSM, Data Entry > 
Edit LSM Data > Maintenance grid > Customize > 
Layouts. 

Surface Covering Type of coating or covering on the pipeline. See LSM, 
Data Entry > Edit LSM Data > Maintenance grid > 
Customize > Layouts. 

Survey Date Date an inspection or survey reading was taken. 

Table A-1.  System Field Descriptions (continued)
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Survey Interval Potential measurements taken at regular intervals for 
assessing the level of cathodic protection (CP). The 
system default is 2.5 feet for DC and AC close interval 
surveys (CIS and AC CIS) in ISM. 

Survey Name Identifies the survey folder a survey reading is assigned 
to. Field is available for use in all modules. See Data 
Entry > Edit <module> Data > Inspection grid > 
Customize > Layouts. For periodic survey readings in 
CPDM, use the fields Periodic Survey and Periodic 
Survey Year instead. 

Survey Remarks Remark or comment associated with a test point, 
rectifier, bond, anomaly, or landmark for a particular 
survey.

Surveyor Name of person conducting a survey. 

Tap Settings Coarse or fine tap settings for rectifier output 
adjustment, such as C2F3. Add and enable Activate Tap 
Settings in the Rectifier Information grid to allow data 
entry in the Inspections grid. See CPDM, Data Entry > 
Edit CPDM Data > Rectifier > Information and 
Inspection grids > Customize > Layouts. 

Total Footage Total number of feet for pipeline segment. 

Uncompensated Off Pipe-to-soil “OFF” (P/S) value received from the Allegro 
Field Computer. This is the raw reading without telluric 
compensation. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Detail Inspection mini-grid. 

Uncompensated On Pipe-to-soil “On” (P/S) value received from the Allegro 
Field Computer. This is the raw reading without telluric 
compensation. See CPDM, Data Entry > Edit CPDM 
Data > Test Point Detail Inspection mini-grid. 

Unregistered Milepost An unregistered milepost is a milepost in an imported 
stationary survey that does not match an existing 
milepost in PCS Axis for the currently selected ROW 
(pipeline segment). Unregistered mileposts relate only to 
the associated stationary survey and are not considered 
as facilities in PCS Axis. Unregistered mileposts are 
however used in telluric compensation. Also refer to 
Existing Facilities. See CPDM, Data Entry > Stationary 
Survey Maintenance > Snap To Facility. 
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User IR Correction When a value is entered in User IR Correction, PCS Axis 
uses the value to calculate Target P/S instead of using 
the absolute difference between Structure P/S and 
Structure IRF. See CPDM, Data Entry > Edit CPDM Data 
> Test Point > Inspection grid > Customize > Layouts. 

Valve Coating Condition of valve coating at inspection. Add and enable 
Activate Valve Coating in the Information grid to allow 
data entry in the Inspections grid. See VM, Data Entry > 
Edit VM Data > Information and Inspection grids > 
Customize > Layouts. 

Valve Condition General condition of valve at inspection. Add and enable 
Activate Valve Condition in the Information grid to allow 
data entry in the Inspections grid. See VM, Data Entry > 
Edit VM Data > Information and Inspection grids > 
Customize > Layouts. 

Valve Operated Check box for indicating if the valve was manually 
operated. Add and enable Activate Valve Operated in the 
Information grid to allow use of the field in the 
Inspections grid. See VM, Data Entry > Edit VM Data > 
Information and Inspection grids > Customize > 
Layouts. 

Valve Pass/Fail Status of the valve after inspection. Add and enable 
Activate Valve Pass/Fail in the Information grid to allow 
data entry in the Inspections grid. See VM, Data Entry > 
Edit VM Data > Information and Inspection grids > 
Customize > Layouts. 

Valve Secured Check box for indicating if the value was left secured. 
Add and enable Activate Valve Secured in the 
Information grid to allow use of the field in the 
Inspections grid. See VM, Data Entry > Edit VM Data > 
Information and Inspection grids > Customize > 
Layouts. 

Valve Type Type of valve such as block or plug. See VM, Data Entry 
> Edit VM Data > Information or Inspection grid > 
Customize > Layouts. 

Vendor Name of the company providing a service. 
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Glossary

The following information provides a description of terms commonly used in the PCS Axis software.

Table B-2.  Glossary 

Name Description

AC Alternating Current (AC). Type of current that reverses 
direction. Current flows in a positive direction for 1/120 
second, then in a negative direction for 1/120 second, 
and so on. A/C current completes 60 cycles per second.

AC CIS Alternating Current Close Interval Survey. An above 
ground, indirect inspection method conducted using an 
AC voltmeter to measure the influence of AC voltages at 
regular intervals along the pipeline. The survey identifies 
areas of inadequate cathodic protection and possible 
shock hazards to personnel due to excessive AC 
potentials typically induced by an AC power system near 
the pipeline, such as overhead power transmission lines. 
Typical voltage measurements are in a range of 0-15V 
with 15V indicating a shock hazard. 

ACCA AC Current Attenuation (ACCA). An above ground, 
indirect inspection method used to determine the 
condition of the pipeline coating. This survey method 
detects coating holidays and other anomalies by 
measuring changes in the magnetic field in the soil 
above and around the pipeline. Changes in the magnetic 
field are caused by coating defects. 
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ACVG Alternating Current Voltage Gradient (ACVG). An above 
ground, indirect inspection method that measures AC 
voltage gradients (changes in leakage current) in the soil 
above and around the pipeline in an effort to locate and 
estimate the size of coating holidays and identify 
corrosion activity.

Addition Item An addition item is a user-created item, such as a layout 
theme addition for a data entry grid. 

Amp Ampere (Amp). Basic unit of electric current. 

Anode The point in an electrochemical cell where the energy 
level is higher than its cathodic counter part, causing 
current to leave and take metal with it. This is the point 
where corrosion occurs. 

Application Scheme An application scheme is a group of named property 
settings that change the overall appearance of the PCS 
Axis interface. Currently PCS Axis only provides a default 
application scheme which cannot be customized. 

Baud Unit of speed in data transmission equal to one bit per 
second. 

Bond A wire that connects a cathodically protected pipeline to 
a foreign pipeline to allow current to travel from one 
pipeline to the another in a controlled manner, without 
causing corrosion. Without the bond, current can travel 
from one pipeline to another (in an interference 
situation) creating anodic areas and causing pipeline 
corrosion. 

Bullhorn Token Bullhorn Token is the unique Key generated by the BAT 
website when setting up an Extract to be used in a 
Bullhorn Bridge definition. See Adding a Bullhorn 
Bridge Definition (page 505) for more information.

Cathodic Protection Cathodic Protection (CP). Process of making an entire 
metallic structure the cathode and a separate 
expendable material the anodes in a carefully designed 
electrochemical cell. 
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CIS or CIPS Close Interval Survey (CIS) or Close Interval Potential 
Survey (CIPS). An above ground, indirect inspection 
method that measures pipe-to-soil (P/S) potential 
readings taken at closely spaced intervals along the 
pipeline. This type of survey is used to evaluate the 
effectiveness of a cathodic protection system; it locates 
areas between test points that are below (less negative 
than) a certain voltage level (usually –.85V) considered 
necessary for effective cathodic protection. 

Continuous Survey Above ground survey method used to identify pipeline 
coating damage (such as coating anomalies and 
holidays) and determine effectiveness of a CP system. 
Also referred to as an indirect survey. Survey methods 
include CIS (on, on/off, and static); AC CIS; DCVG; ACCA 
(electromagnetic); ACVG; Soil Resistivity; and Pearson. 

Criterion Standard for assessment of the effectiveness of a CP 
system. 

Current Quantity of flow of electricity, similar to gallons per 
minute in a water pipe. Current (I) is measured in 
amperes (Amps). 

DC Direct Current (DC). Type of current that flows steadily in 
one direction. 

DCVG Direct Current Voltage Gradient (DCVG). An above 
ground indirect inspection method that measures DC 
voltage gradients in the soil above and around the 
pipeline to locate and estimate the size of coating 
holidays and identify corrosion activity.

Depolarized Close 
Interval Potential Survey

A close interval survey (CIS) performed after influencing 
cathodic protection (CP) current sources have been 
turned off for a sufficient duration of time for 
depolarization to have occurred. This is often called a 
native-state CIS if it is performed prior to the initial 
application of CP. 
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Derived Field A derived field is a field with a value that is derived from 
values in dependent fields. See Working with Derived 
Fields (page 214) for more information. 

Digital Meter A digital device that measures electrical voltage and 
current. Device displays measurements on a screen. 

Facility Key A user defined field (UDF) set up in PCS Axis that is 
associated with an external system ID when setting up a 
Bridge definition to be used with an external system. See 
Using a Facility Key in Bridge (page 454) for more 
information. 

GGA GPS NEMA message format that provides information 
about output time, position, and fix data for a GPS 
receiver. 

GPS Global Positioning System (GPS). A navigational system 
involving satellites and computers (such as the Allegro 
Field PC and Bullhorn devices) that determines the 
latitude and longitude of a receiver on earth by 
computing the time difference for signals from different 
satellites to reach the receiver. 

Holiday A discontinuity in a protective coating that exposes the 
unprotected surface to the environment. 

Interrupted Survey See On/Off Survey.

IRF IR free (IRF) reading. 

MAOP Maximum Allowable Operating Pressure (MAOP). Based 
on the design of the pipe, this is the highest operating 
pressure a pipe can theoretically operate under. 

Merge Replication A process where updated records on the subscriber are 
copied to the publisher and vice versa during 
synchronization. 

MOP Maximum Operating Pressure (MOP). Highest pressure a 
pipe has actually operated under. 

Table B-2.  Glossary (continued)
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Ohm A unit of electrical resistance equal to that of a 
conductor in which a current of one ampere is produced 
by a potential of one volt across its terminals. 

On/Off Survey Also referred to as Interrupted Survey. A close interval 
survey conducted with regular, timed interruptions 
between the current source and the cathodic protection 
system. On readings are compared later with the Off 
readings to gauge the effectiveness of the cathodic 
protection system. 

P/S Pipe-to-Soil (P/S). Voltage potential generated between 
a buried pipe and its surrounding soil, the result of 
electrolytic action and a cause of electrolytic corrosion of 
the pipe. 

PCS Axis Installed Item An item installed during the PCS Axis software 
installation, such as themes and routes. Installed items 
are identified with [PCS] in brackets and a globe icon, 
such as the grid layout theme labeled  [PCS] Test 
Point Inspections. 

Pearson Survey An above ground survey technique used to locate 
coating holidays in buried pipelines. The survey 
compares potential gradients along the pipeline as 
measured between two movable electrical ground 
contacts. The potential gradients result from an applied 
AC signal leaking to earth at coating holidays. This 
survey is also called a DCVG survey. 

Picklist A list of acceptable choices for a field in a data entry grid 
that a user selects from when entering data (formerly 
called “validation table”). 

Pipeline A collection of segments that generally carry the same 
product and are interconnected (either end to end or as 
a lateral). Segments generally start and end at isolation 
points (for example, stations or valves), whereas a 
pipeline generally starts and ends at change of custody 
points. 
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Publication (Publisher) Primary database on a network server used in merge 
replication and synchronization with subscription 
databases. 

Publication Retention 
Period

Expiration period for subscriptions. A subscription 
becomes expired (obsolete) when the subscriber does 
not synchronize the subscription with the publication 
database within the publication retention period. An 
expired subscription must be re-initialized. See 
Reinitializing a Subscription (page 740).

Range Checking An acceptable range of values allowed for data entry in 
an inspection field. When a value is entered that falls 
outside the acceptable range of values, PCS Axis displays 
a warning message and allows the user to correct the 
invalid entry.

Remote Earth A location on the earth far enough from the affected 
structure that the soil potential gradients associated with 
currents entering the earth from the affected structure 
are insignificant. 

Replication See Merge Replication.

Resistance Resistance (R) limits current flow in a given circuit; similar 
to friction in water pipe. 

ROW Right-of-Way (ROW). Section of land designated for use 
by a pipeline. The NPMS (National Pipeline Mapping 
System) refers to ROWs as pipeline corridors. 

Segment User-defined length of pipe over which risk calculations 
are performed. Sections are specified as a uniform 
length of pipe (such as 1000 feet, 1 mile, or 1 kilometer) 
or for certain event changes such as pipe design, class 
change, or environmentally sensitive areas. 

Shunt A resistor inserted (usually permanently) in a circuit to 
assist measurement of current. Resistance is very small 
and does not affect intended operation of the circuit. 
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SMTP Simple Mail Transfer Protocol. A data transmission 
format used to send email. 

Soil Resistivity Above ground indirect inspection method. 

SSL Secure socket layer (SSL). SSL is a communication 
protocol used by an email server to transmit information 
over the Internet in an encrypted form for security 
purposes. To determine if your email client software 
supports SSL, contact your company’s IT System 
Administrator. 

SSMS SQL Server Management Studio. A Microsoft software 
application for working with components of SQL Server 
and publication and subscription databases when using 
PCS Axis Synchronization. 

Stationary Data Logger 
(SDL)

Survey equipment used to detect telluric current on a 
pipeline under survey. Two or more SDLs install at a fixed 
location on the pipeline under survey for a period of 
time. During this time period, SDLs measure and record 
ON/OFF values for an interrupted survey with GPS 
synchronization. 

Stationary Survey Type of cathodic protection (CP) survey that uses two or 
more GPS synchronized stationary data loggers (SDLs). 
The SDLs measure and record ON/OFF values for an 
interrupted survey with GPS synchronization. Stationary 
survey data is used in telluric current correction of 
periodic and close interval test point surveys. 

Subscription (Subscriber) Database instance on a remote computer used in merge 
replication when synchronizing data between the 
publisher and subscriber databases. 

Subscription Expiration 
Period

See Publication Retention Period. 
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Survey Direction The direction a close interval survey (CIS) is conducted 
along a pipeline, usually expressed as upstream 
(upstation) or downstream (downstation). CIS may be 
performed in either the upstation or downstation 
direction. The data shall clearly indicate which direction 
the survey was conducted. 

Survey Interval Distance between measurements along the pipeline in a 
close interval survey (CIS). 

Synchronization The process of replicating data between the publisher 
and subscriber databases. Only data that has changed 
since the last synchronization is replicated. 

Telluric Current Telluric current is low voltage electrical current that 
occurs naturally in the Earth's crust. It is a result of 
fluctuations in the Earth's magnetic field due to 
ionospheric disturbances typically caused by sun spot 
activity. Movement of the Earth’s magnetic field can 
induce telluric current to flow on pipelines. Telluric 
effects are more evident in the northern and southern 
latitudes on pipelines that run in a north and south 
direction. Telluric current activity varies with the time of 
day, latitude, and solar activity; it can cause significant 
fluctuation in the structure-to-electrolyte potential. 

User Defined Field A user defined field (UDF) is a user-created field. UDFs 
are created when PCS Axis does not provide a field for 
data entry. 

Vac Volts Alternating Current (Vac). 

Vdc Volts Direct Current (Vdc).

Volt Unit of measure for voltage (V). Electrical force or 
pressure. Voltage causes current to flow similar to 
pressure in a water pipe. 

Volt Meter Analog or digital device that measures electrical voltage 
or electrical force. Volt meter measurements help 
identify the potential (like water pressure) at one point 
relative to another point. 
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VTG GPS NEMA message format that provides information 
about heading and speed (course over ground). 

ZDA GPS NEMA message format that provides UTC and local 
date/time data. Provides current universal coordinated 
time and day, month, and year. ZDA is used when 
performing GPS-synchronized on/off readings. 
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C

System Security

PCS Axis security is based on a user role method. A user role is a collection of permissions that tell the 
system which features a user has access to and whether or not the user is allowed to add, edit, or delete 
data. The system supports the following PCS Axis installed user roles: 

• SysAdmin

• User

• Read Only

The SysAdmin user role has full control of all PCS Axis features and functions. The SysAdmin assigns the 
SysAdmin, User, or Read Only user role to all other users of the PCS Axis system. User role assignments are 
set up in User Management (Tools > User Management). 

The following table identifies system permissions included with the User and Read Only user roles. 
Information is organized based on PCS Axis menu and menu functions, then by permission level and user 
role. 

Table C-3.  Permissions for PCS Axis Installed User Roles 

Menu Function Permission User Read Only

File File Menu Access Yes Yes

File Select ROWs Access Yes Yes

File Select ROWs Edit (move, rename), 
Add, Delete

Yes No

File Select ROWs Find, Change, Make 
Selections, Clear

Yes Yes

File Database Integrity Check Access No No
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Modules Modules Menu Access Yes Yes

Modules CPDM, VM, ACM, ICM, LSM, 
ISM, CMM

Access Yes Yes

Data Entry Data Entry Menu Access Yes Yes

Data Entry Edit Module Data Access Yes Yes

Data Entry Edit Module Data Edit, Add, Delete Yes No

Data Entry Edit Module Data > Build 
Survey

Access Yes No

Data Entry Edit Module Data > Mini-grid Access Yes Yes

Data Entry Edit Module Data > Options Access Yes Yes

Data Entry Edit Module Data > Public 
Layout Themes

Access Yes Yes

Data Entry Edit Module Data > Public 
Layout Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private 
Layout Themes

Access, Edit, Add,  
Delete

Yes Yes

Data Entry Edit Module Data > Public Sort 
Themes

Access Yes Yes

Data Entry Edit Module Data > Public Sort 
Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private Sort 
Themes

Access, Edit, Add,  
Delete

Yes Yes

Data Entry Edit Module Data > Public 
Filter Themes

Access Yes Yes

Data Entry Edit Module Data > Public 
Filter Themes

Edit, Add, Delete No No

Data Entry Edit Module Data > Private 
Filter Themes

Access, Edit, Add,  
Delete

Yes Yes

Data Entry Edit Module Data > Ad Hoc 
Filters

Edit, Add, Delete Yes Yes

Table C-3.  Permissions for PCS Axis Installed User Roles (continued)
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Data Entry Define Routes Menu Access Yes Yes

Data Entry Define Routes Edit, Add, Delete, 
Undelete

Yes No

Data Entry Define Schedules Menu Access Yes Yes

Data Entry Define Schedules Edit No No

Data Entry Edit Schedule Settings Menu Access Yes Yes

Data Entry Edit Schedule Settings Edit No No

Data Entry Edit ROW Detail Menu Access Yes Yes

Data Entry Edit ROW Detail Edit, Add, Delete, 
Undelete

Yes No

Data Entry Pipeline Series Access Yes Yes

Data Entry Pipeline Series Edit/Add/Delete/
Undelete

No No

Data Entry Survey Folder Maintenance Access Yes Yes

Data Entry Survey Folder Maintenance Edit, Add, Delete, 
Undelete

No No

Reports/Graphs Reports/Graphs Menu, Reports, 
Graphs, Custom Reports

Access Yes Yes

Tools Tools Menu Access Yes Yes

Tools Synchronization Access Yes Yes

Tools Synchronization > Create 
Publication

Access No No

Tools Synchronization > Subscription 
Configuration (Publisher)

Access No No

Tools Synchronization > 
Synchronization Configuration 
(Publisher)

Access No No

Tools Synchronization > Configure 
Subscription (Subscriber)

Access Yes Yes

Tools Synchronization > Synchronize 
Now (Subscriber)

Access Yes Yes

Tools Synchronization > Subscription 
Configuration (Subscriber)

Access Yes Yes

Table C-3.  Permissions for PCS Axis Installed User Roles (continued)
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Tools • Bridge Menu

• Bridge

Access, Edit Yes No

Tools Field and UDF Customization 
Menu

Access Yes No

Tools Field and UDF Customization Edit, Add, Delete No No

Tools Email Notification Access No No

Tools Themes Management Menu Access Yes Yes

Tools Themes Management Edit No No

Tools Activation Key Access Yes Yes

Tools Facility Type Themes 
Management Menu

Access Yes Yes

Facility Type Themes 
Management

Edit No No

Tools User Management Menu Access No No

Tools User Management Edit No No

Tools Application Schemes Menu Access Yes No

Tools Application Schemes Edit Yes No

Tools Options Menu Access Yes No

Tools • Options > Bullhorn

• Options > Criteria

• Options > Editing

• Options > Field Computer

• Options > General

• Options >Hierarchy

• Options > Reports

• Options > Security

Edit No No

Table C-3.  Permissions for PCS Axis Installed User Roles (continued)
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Field Computer • Field Computer Menu

• Send

• Receive

• Log

Access Yes No

Help • Help Menu

• About PCS

• Technical Support

Access Yes Yes

Table C-3.  Permissions for PCS Axis Installed User Roles (continued)
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